source: projects/specs/trunk/p/parole/parole-vl.spec @ 8057

Revision 8057, 6.9 KB checked in by kudoh, 10 years ago (diff)

--force-log

Line 
1# by default don't build the browser plugin
2# use bcond_without to change the default
3#%bcond_with mozilla
4%define PAROLE_BIN %{_libexecdir}/%{name}
5
6Name:           parole
7Version:        0.5.0
8Release:        1%{?_dist_release}
9Summary:        Media player for the Xfce desktop
10Summary(ja):    Xfce デスクトップのメディアプレーヤー
11
12Group:          Applications/Multimedia
13License:        GPLv2+
14URL:            http://goodies.xfce.org/projects/applications/parole
15Source0:        http://archive.xfce.org/src/apps/parole/0.3/%{name}-%{version}.tar.bz2
16Source10:       parole.sh
17#Patch1:                parole-0.2.0.6-dsofix.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  desktop-file-utils
22BuildRequires:  gettext
23BuildRequires:  gtk-doc
24BuildRequires:  gtk2-devel >= 2.20.0
25BuildRequires:  glib2-devel >= 2.32.0
26BuildRequires:  gstreamer-devel
27BuildRequires:  gstreamer-plugins-base-devel >= 0.10.24
28BuildRequires:  dbus-devel >= 0.60
29BuildRequires:  dbus-glib-devel >= 0.70
30BuildRequires:  intltool
31BuildRequires:  libnotify-devel >= 0.4.1
32BuildRequires:  libxfcegui4-devel >= 4.8.0
33BuildRequires:  libxfce4util-devel >= 4.8.0
34BuildRequires:  libxfce4ui-devel >= 4.8.0
35BuildRequires:  xfce4-dev-tools
36BuildRequires:  taglib-devel >= 1.4
37
38#%if %{with mozilla}
39#BuildRequires:  xulrunner-devel
40#%endif
41Requires:       gstreamer-plugins-good
42
43Obsoletes: %{name}-mozplugin
44
45%description
46Parole is a modern simple media player based on the GStreamer framework and
47written to fit well in the Xfce desktop. Parole features playback of local
48media files, DVD/CD and live streams. Parole is extensible via plugins.
49
50The project still in its early developments stage, but already contains the
51following features:
52* Audio playback
53* Video playback with optional subtitle
54* Playback of live sources
55
56%description -l ja
57Parole は GStreamer フレームワークに基づき Xfce デスクトップに
58馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
59Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
60特色とします。
61Parole はプラグインを介して拡張が可能です。
62
63このプロジェクトはまだ開発の初期段階ですが、
64既に以下の機能がふくまれています。
65* オーディオの再生
66* 任意のサブタイトルがあるビデオの再生
67* ライブストリームの再生
68
69
70%package        devel
71Summary:        Development files for %{name}
72Summary(ja):    %{name} の開発ファイル
73Group:          Development/Libraries
74Requires:       %{name} = %{version}-%{release}
75Requires:       gtk-doc
76
77%description    devel
78The %{name}-devel package contains header files for developing plugins for
79%{name}.
80
81%description    devel -l ja
82%{name}-devel パッケージ は %{name} のプラグインを開発するための
83ヘッダファイルを含みます。
84
85#%if %{with mozilla}
86#%package mozplugin
87#Summary:       Browser plugin for %{name}
88#Group:         Application/Internet
89#Requires:      %{name} = %{version}-%{release}
90
91#%description    mozplugin
92#Parole is a modern simple media player based on the GStreamer framework and
93#written to fit well in the Xfce desktop. This plugin allows it to be embedded
94#in a web browser.
95#%endif
96
97%prep
98%setup -q
99#%patch1 -p1
100
101%build
102./autogen.sh
103%configure --disable-static --enable-gtk-doc
104#%if %{with mozilla}
105# --enable-browser-plugin
106#%else
107# --disable-browser-plugin
108#%endif
109make %{?_smp_mflags} V=1
110
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make install DESTDIR=$RPM_BUILD_ROOT
115find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
116
117## wrapper install
118%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
119%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{PAROLE_BIN}
120%{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
121
122
123%find_lang %{name}
124
125desktop-file-install                                    \
126  --delete-original                                     \
127  --dir=%{buildroot}%{_datadir}/applications            \
128  %{buildroot}/%{_datadir}/applications/%{name}.desktop
129
130
131%clean
132rm -rf $RPM_BUILD_ROOT
133
134
135%post
136touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
137update-mime-database %{_datadir}/mime &> /dev/null || :
138
139
140%postun
141if [ $1 -eq 0 ] ; then
142  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
143  gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
144fi
145update-mime-database %{_datadir}/mime &> /dev/null || :
146
147
148%posttrans
149gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
150
151
152%files -f %{name}.lang
153%defattr(-,root,root,-)
154%doc AUTHORS COPYING README TODO THANKS
155%{PAROLE_BIN}
156%{_bindir}/%{name}
157%dir %{_libdir}/%{name}-0/
158%{_libdir}/%{name}-0/*.so
159%{_datadir}/applications/%{name}.desktop
160%{_datadir}/icons/hicolor/*
161%{_datadir}/%{name}/
162
163
164%files devel
165%defattr(-,root,root,-)
166%doc %{_datadir}/gtk-doc/html/Parole-Plugins/
167%{_includedir}/%{name}/
168
169
170#%if %{with mozilla}
171#%files mozplugin
172#%defattr(-,root,root,-)
173#%{_libexecdir}/%{name}-media-plugin
174#%{_libdir}/mozilla/plugins/%{name}-player.so
175#%endif
176
177%changelog
178* Mon Dec 23 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
179- new upstream release
180
181* Fri Aug 24 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.3.0.3-1
182- new upstream release
183- deleted Patch1
184- added BuildRequires: xfce4-dev-tools, libxfce4ui-devel >= 4.8.0
185- changed BuildRequires
186   - gtk2-devel >= 2.16.0 to 2.20.0
187   - glib2-devel >= 2.16.0  to 2.32.0
188   - gstreamer-plugins-base-devel >= 0.10.11 to 0.10.24
189   - libxfcegui4-devel >= 4.6.0 to 4.8.0
190   - libxfce4util-devel >= 4.6.0 to 4.8.0
191
192* Fri Jun 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-3
193- rebuilt with new libxfce4util
194
195* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-2
196- added Obsoletes tag: %%{name}-mozplugin
197- added wrapper script to detect nonfree package installed
198
199* Fri Sep 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-1
200- new upstream release
201- obsoleted -mozplugin package
202
203* Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
204- new upstream release
205
206* Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
207- new upstream release
208
209* Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
210- new upstream release
211- added BuildRequires:  glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
212
213* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
214- new upstream release
215- added BuildRequires: gstreamer-devel
216- splitted mozplugin package
217
218* Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
219- new upstream release
220- dropt all pathces
221
222* Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
223- initial build for VineSeed
224
225* Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
226- BuildRequire taglib-devel and fix libnotify requirement
227
228* Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
229- Update to 0.1.90
230- Loads of additional translations
231
232* Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
233- Initial package
Note: See TracBrowser for help on using the repository browser.