source: projects/specs/trunk/p/parole/parole-vl.spec @ 6294

Revision 6294, 6.3 KB checked in by kudoh, 12 years ago (diff)
Line 
1# by default don't build the browser plugin
2# use bcond_without to change the default
3#%bcond_with mozilla
4%define PAROLE_BIN %{_libexecdir}/%{name}
5
6Name:           parole
7Version:        0.2.0.6
8Release:        3%{?_dist_release}
9Summary:        Media player for the Xfce desktop
10Summary(ja):    Xfce デスクトップのメディアプレーヤー
11
12Group:          Applications/Multimedia
13License:        GPLv2+
14URL:            http://goodies.xfce.org/projects/applications/parole
15Source0:        http://archive.xfce.org/src/apps/parole/0.2/%{name}-%{version}.tar.bz2
16Source10:       parole.sh
17Patch1:         parole-0.2.0.6-dsofix.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  gtk2-devel >= 2.16.0
22BuildRequires:  glib2-devel >= 2.16.0
23BuildRequires:  gstreamer-devel
24BuildRequires:  gstreamer-plugins-base-devel >= 0.10.11
25BuildRequires:  dbus-devel >= 0.60
26BuildRequires:  dbus-glib-devel >= 0.70
27BuildRequires:  libxfcegui4-devel >= 4.6.0
28BuildRequires:  libxfce4util-devel >= 4.6.0
29BuildRequires:  libnotify-devel >= 0.4.1
30BuildRequires:  taglib-devel >= 1.4
31BuildRequires:  desktop-file-utils
32BuildRequires:  gettext
33BuildRequires:  intltool
34
35#%if %{with mozilla}
36#BuildRequires:  xulrunner-devel
37#%endif
38
39BuildRequires:  gtk-doc
40Requires:       gstreamer-plugins-good
41
42Obsoletes: %{name}-mozplugin
43
44%description
45Parole is a modern simple media player based on the GStreamer framework and
46written to fit well in the Xfce desktop. Parole features playback of local
47media files, DVD/CD and live streams. Parole is extensible via plugins.
48
49The project still in its early developments stage, but already contains the
50following features:
51* Audio playback
52* Video playback with optional subtitle
53* Playback of live sources
54
55%description -l ja
56Parole は GStreamer フレームワークに基づき Xfce デスクトップに
57馴染むよう書かれたモダンでシンプルなメディアプレーヤーです。
58Parole はローカルメディアファイル、DVD/CD、ライブストリームの再生を
59特色とします。
60Parole はプラグインを介して拡張が可能です。
61
62このプロジェクトはまだ開発の初期段階ですが、
63既に以下の機能がふくまれています。
64* オーディオの再生
65* 任意のサブタイトルがあるビデオの再生
66* ライブストリームの再生
67
68
69%package        devel
70Summary:        Development files for %{name}
71Summary(ja):    %{name} の開発ファイル
72Group:          Development/Libraries
73Requires:       %{name} = %{version}-%{release}
74Requires:       gtk-doc
75
76%description    devel
77The %{name}-devel package contains header files for developing plugins for
78%{name}.
79
80%description    devel -l ja
81%{name}-devel パッケージ は %{name} のプラグインを開発するための
82ヘッダファイルを含みます。
83
84#%if %{with mozilla}
85#%package mozplugin
86#Summary:       Browser plugin for %{name}
87#Group:         Application/Internet
88#Requires:      %{name} = %{version}-%{release}
89
90#%description    mozplugin
91#Parole is a modern simple media player based on the GStreamer framework and
92#written to fit well in the Xfce desktop. This plugin allows it to be embedded
93#in a web browser.
94#%endif
95
96%prep
97%setup -q
98%patch1 -p1
99
100%build
101%configure --disable-static --enable-gtk-doc \
102#%if %{with mozilla}
103# --enable-browser-plugin
104#%else
105# --disable-browser-plugin
106#%endif
107make %{?_smp_mflags}
108
109
110%install
111rm -rf $RPM_BUILD_ROOT
112make install DESTDIR=$RPM_BUILD_ROOT
113find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
114
115## wrapper install
116%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
117%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{PAROLE_BIN}
118%{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
119
120
121%find_lang %{name}
122
123desktop-file-install                                    \
124  --delete-original                                     \
125  --dir=%{buildroot}%{_datadir}/applications            \
126  %{buildroot}/%{_datadir}/applications/%{name}.desktop
127
128
129%clean
130rm -rf $RPM_BUILD_ROOT
131
132
133%post
134touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
135update-mime-database %{_datadir}/mime &> /dev/null || :
136
137
138%postun
139if [ $1 -eq 0 ] ; then
140  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
141  gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
142fi
143update-mime-database %{_datadir}/mime &> /dev/null || :
144
145
146%posttrans
147gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
148
149
150%files -f %{name}.lang
151%defattr(-,root,root,-)
152%doc AUTHORS COPYING README TODO THANKS
153%{PAROLE_BIN}
154%{_bindir}/%{name}
155%dir %{_libdir}/%{name}-0/
156%{_libdir}/%{name}-0/*.so
157%{_datadir}/applications/%{name}.desktop
158%{_datadir}/icons/hicolor/*
159%{_datadir}/%{name}/
160
161
162%files devel
163%defattr(-,root,root,-)
164%doc %{_datadir}/gtk-doc/html/Parole-Plugins/
165%{_includedir}/%{name}/
166
167
168#%if %{with mozilla}
169#%files mozplugin
170#%defattr(-,root,root,-)
171#%{_libexecdir}/%{name}-media-plugin
172#%{_libdir}/mozilla/plugins/%{name}-player.so
173#%endif
174
175%changelog
176* Fri Jun 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-3
177- rebuilt with new libxfce4util
178
179* Sat May 26 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-2
180- added Obsoletes tag: %%{name}-mozplugin
181- added wrapper script to detect nonfree package installed
182
183* Fri Sep 30 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.6-1
184- new upstream release
185- obsoleted -mozplugin package
186
187* Tue Jan 26 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.2-1
188- new upstream release
189
190* Sun Jan 17 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0.1-2
191- new upstream release
192
193* Tue Jan 5 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.0-1
194- new upstream release
195- added BuildRequires:  glib2-devel >= 2.16.0, libxfce4util-devel >= 4.6.0
196
197* Wed Dec 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.99-1
198- new upstream release
199- added BuildRequires: gstreamer-devel
200- splitted mozplugin package
201
202* Sun Nov 1 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.91-1
203- new upstream release
204- dropt all pathces
205
206* Thu Oct 15 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.1.90-1
207- initial build for VineSeed
208
209* Thu Oct 08 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-2
210- BuildRequire taglib-devel and fix libnotify requirement
211
212* Wed Oct 07 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1.90-1
213- Update to 0.1.90
214- Loads of additional translations
215
216* Fri Sep 18 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.1-0.1
217- Initial package
Note: See TracBrowser for help on using the repository browser.