source: projects/specs/trunk/p/pango/pango-vl.spec @ 805

Revision 805, 16.6 KB checked in by Takemikaduchi, 14 years ago (diff)

change spec file of gnome-2.30

Line 
1%define glib2_version 2.24.0
2%define pkgconfig_version 0.12
3%define freetype2_version 2.3.9
4%define cairo_version 1.8.8
5
6# biarch support
7%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
8%define _querymodules_suffix %{nil}
9%if %{build_compat32}
10%define _querymodules_suffix -32
11%endif
12
13Summary: System for layout and rendering of internationalized text.
14Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
15Name: pango
16Version: 1.28.0
17Release: 1%{?_dist_release}
18License: LGPL
19Group: System Environment/Libraries
20Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.26/pango-%{version}.tar.bz2
21URL: http://www.pango.org
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23
24# We need to prereq this so we can run pango-querymodules
25Requires: glib2 >= %{glib2_version}
26Requires: freetype2 >= %{freetype2_version}
27BuildRequires: libtool >= 1.4.2
28BuildRequires: glib2-devel >= %{glib2_version}
29BuildRequires: pkgconfig >= %{pkgconfig_version}
30BuildRequires: freetype2-devel >= %{freetype2_version}
31BuildRequires: fontconfig-devel
32BuildRequires: libX11-devel, libXft-devel, libXrender
33BuildRequires: cairo-devel >= %{cairo_version}
34Obsoletes: pango-gtkbeta, fribidi-gtkbeta
35
36# Look for pango.modules in an arch-specific directory
37Patch0: pango-1.2.5-lib64.patch
38# biarch support (mdk)
39#Patch5: pango-1.2.5-lib64.patch.bz2
40
41
42%description
43Pango is a system for layout and rendering of internationalized text.
44
45%description -l ja
46Pango は国際化テキストのレイアウト・レンダリングシステムです。
47
48
49%package devel
50Summary: System for layout and rendering of internationalized text.
51Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
52Group: Development/Libraries
53Requires: pango = %{version}
54Requires: glib2-devel >= %{glib2_version}
55Requires: freetype2-devel >= %{freetype2_version}
56Requires: cairo-devel >= %{cairo_version}
57Requires: libX11-devel, libXft-devel, libXrender
58Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
59
60%description devel
61The pango-devel package includes the static libraries, header files,
62and developer docs for the pango package.
63
64Install pango-devel if you want to develop programs which will use
65pango.
66
67#####################################################################
68# compat32
69%package -n compat32-%{name}
70Summary: System for layout and rendering of internationalized text.
71Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
72Group: Development/Libraries
73%description -n compat32-%{name}
74Pango is a system for layout and rendering of internationalized text.
75%description -n compat32-%{name} -l ja
76Pango は国際化テキストのレイアウト・レンダリングシステムです。
77
78%package -n compat32-%{name}-devel
79Summary: Development files for pango
80Summary(ja): pango 用の開発ファイル
81Group: Development/Libraries
82Requires: compat32-%{name} = %{version}
83Requires: %{name}-devel = %{version}
84%description -n compat32-%{name}-devel
85The pango-devel package includes the static libraries, header files,
86and developer docs for the pango package.
87
88
89%prep
90%setup -q -n pango-%{version}
91%patch0 -p1 -b .lib64
92
93%build
94%configure --with-included-modules=basic-fc
95make %{?_smp_mflags}
96
97%install
98rm -rf $RPM_BUILD_ROOT
99make DESTDIR=$RPM_BUILD_ROOT install
100
101# biarch support
102mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}
103touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}/pango.modules
104
105%if %{build_compat32}
106cp $RPM_BUILD_ROOT%{_bindir}/pango-querymodules \
107   $RPM_BUILD_ROOT%{_bindir}/pango-querymodules%{_querymodules_suffix}
108%endif
109
110# remove unpackaged files
111rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
112rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
113rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post
119/sbin/ldconfig
120%{_bindir}/pango-querymodules > %{_sysconfdir}/pango/%{_arch}/pango.modules
121
122%postun -p /sbin/ldconfig
123
124%if %{build_compat32}
125%post -n compat32-%{name}
126/sbin/ldconfig
127%{_bindir}/pango-querymodules%{_querymodules_suffix} > %{_sysconfdir}/pango/%{_arch}/pango.modules
128
129%postun -p /sbin/ldconfig -n compat32-%{name}
130%endif
131
132%files
133%defattr(-, root, root)
134%doc README AUTHORS COPYING NEWS
135%doc pango-view/HELLO.txt
136#doc README AUTHORS COPYING ChangeLog
137#doc examples/HELLO.utf8
138%{_bindir}/pango-querymodules
139%{_bindir}/pango-view
140%{_libdir}/libpango*-*.so.*
141%{_libdir}/pango
142%{_mandir}/man*/*
143%dir %{_sysconfdir}/pango
144%config %{_sysconfdir}/pango/pangox.aliases
145%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
146
147%files devel
148%defattr(-, root, root)
149%{_libdir}/libpango*.so
150%{_includedir}/*
151%{_libdir}/pkgconfig/*
152%{_datadir}/gtk-doc/*
153
154%if %{build_compat32}
155%files -n compat32-%{name}
156%defattr(-, root, root)
157%{_libdir}/libpango*-*.so.*
158%{_bindir}/pango-querymodules%{_querymodules_suffix}
159%{_libdir}/pango
160%dir %{_sysconfdir}/pango/%{_arch}
161%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
162
163%files -n compat32-%{name}-devel
164%defattr(-, root, root)
165%{_libdir}/libpango*.so
166%{_libdir}/pkgconfig/*
167%endif
168
169%changelog
170* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
171- new upstream release
172
173* Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
174- changed %%makeinstall to make install with DESTDIR option
175
176* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
177- new upstream release
178
179* Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
180- new upstream release
181
182* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
183- new upstream release
184
185* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
186- new upstream release
187
188* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
189- new upstream release
190
191* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
192- new upstream release
193
194* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
195- removed %%if !%%{build_compat32} case condition
196
197* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
198- new upstream release
199
200* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
201- new upstream release
202
203* Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
204- new upstream release
205
206* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
207- new upstream release
208
209* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
210- new upstream release
211
212* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
213- new upstream release
214
215* Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
216- new upstream release
217
218* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
219- spec in UTF-8 actually
220
221* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
222- new upstream release
223- rebuilt with xorg-x11 7.3
224
225* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
226- new upstream release
227
228* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
229- used %{?_dist_release}
230
231* Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
232- new upstream release
233
234* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
235- new upstream release
236
237* Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
238- new upstream release
239- added Patch0 instead of Patch5
240
241* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
242- replace build with new environment
243
244* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
245- rebuild with new environment
246
247* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
248- new upstream release
249
250* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
251- new upstream release
252
253* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
254- new upstream release
255
256* Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
257- new upstream release
258
259* Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
260- new upstream release
261
262* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
263- new upstream release
264
265* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
266- rebuild with cairo-1.2.0
267
268* Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
269- add Patch10 to create fake style(italic/bold) for all fonts.
270  http://bugzilla.gnome.org/show_bug.cgi?id=319808
271  - This patch is not applied in upstream, but it seems usefull
272    for us.
273
274* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
275- new upstream release
276
277* Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
278- new upstream release
279
280* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
281- new upstream release
282
283* Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
284- fix broken dependancy
285
286* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
287- new upstream release
288
289* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
290- new upstream release
291- add compat32 package for x86_64 arch support
292- add Patch5 for biarch support
293
294* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
295- new upstream release
296
297* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
298- new upstream release
299
300* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
301- new upstream release
302
303* Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
304- rebuild with cairo-0.9
305- add patch10 to disable building example programs
306
307* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
308- new upstream release
309
310* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
311- new upstream release
312- drop obsolete patches
313
314* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
315- new upstream release
316- import upstream patches from fedora package.
317
318* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
319- new upstream release
320
321* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
322- new upstream release
323
324* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
325- remove unneeded dependancy to freetype2-devel
326
327* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
328- add patch10 to build against freetype-2.1.7
329- rebuild with freetype-2.1.7
330
331* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
332- new upstream release
333
334* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
335- new upstream release
336
337* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
338- new upstream release
339
340* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
341- merge patch1,2 from rawhide package.
342
343* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
344- new upstream release
345
346* Thu Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
347- new upstream release
348- Build for Vine Linux, specfile are based on rawhide release
349
350* Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
351- change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
352
353* Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
354- explicitly require pangoxft to be built, so we catch situations such
355  as xft.pc moving to /usr/X11R6
356- also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
357  hack
358
359* Thu Nov  7 2002 Havoc Pennington <hp@redhat.com>
360- 1.1.3
361
362* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
363- Require the necessary freetype version, don't just
364  BuildRequires it (#74744)
365
366* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
367- Own /etc/pango (#73962, Enrico Scholz)
368- Remove .la files from the build root
369
370* Mon Oct  7 2002 Havoc Pennington <hp@redhat.com>
371- require glib 2.0.6-3, try rebuild on more arches
372
373* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
374- Version 1.1.1 (main change, fixes font selection for FT2 backend,
375  as in gdmgreeter)
376
377* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
378- Fix linked list manipulation problem that was causing hang for anaconda
379- Fix warning from loading mini-fonts with context == NULL
380
381* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
382- Fix major memory leak in the last patch
383
384* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
385- Actually use language tags at the rendering layer (should fix #68211)
386
387* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
388- Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
389- Fix bug causing hex boxes to be misrendered
390  leaving RPATH (#66005)
391- For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
392  fonts with embedded bitmaps (#67851)
393
394* Mon Jul  8 2002 Owen Taylor <otaylor@redhat.com>
395- Make basic-x shaper work with our big-5 fonts
396
397* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
398- New upstream tarball with hooks for change-on-the fly font rendering
399
400* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
401- Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
402  ABI changes for pango's OpenType code.
403
404* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
405- Add some Korean aliases that the installer wants
406
407* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
408- automated rebuild
409
410* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
411- devel package requires fontconfig/Xft devel packages
412
413* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
414- rebuild in different environment
415
416* Thu Jun  6 2002 Owen Taylor <otaylor@redhat.com>
417- Snapshot with Xft2/fontconfig support
418
419* Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
420- Version 1.0.2
421- Patch for charmaps problem
422
423* Sun May 26 2002 Tim Powers <timp@redhat.com>
424- automated rebuild
425
426* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
427- rebuild in different environment
428
429* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
430- add patch to adjust to newer version of freetype
431
432* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
433- Update to version 1.0.1, remove patch
434
435* Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
436- Patch from CVS for big speedup with FreeType-2.0.9
437
438* Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
439- Rebuild
440
441* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
442- Version 1.0.0
443
444* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
445- Update to 0.26
446
447* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
448- Bump for rebuild
449
450* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
451- Update to 0.25
452
453* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
454- add horrible buildrequires hack
455
456* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
457- 0.24.90 cvs snap
458
459* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
460- Version 0.24
461
462* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
463- automated rebuild
464
465* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
466- new snap 0.23.90
467
468* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
469- rebuild with 64-bit-fixed glib
470
471* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
472- Version 0.22
473- add explicit check for required glib2 version before we do the build,
474  so we don't end up with bad RPMs on --nodeps builds
475- PreReq the glib2_version version, instead of 1.3.8 hardcoded that
476  no one had updated recently
477
478* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
479- Version 0.21
480
481* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
482- cvs snap
483- new cvs snap with a bugfix
484
485* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
486- sync with Owen's changes, fix up dependency versions
487
488* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
489- 0.19
490
491* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
492- build CVS snap
493
494* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
495- no relinking junk
496
497* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
498- Version 0.18
499
500* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
501- Configure --disable-gtk-doc
502- BuildRequires freetype-devel, XFree86-devel
503
504* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
505- 0.17
506- libtool hackarounds
507
508* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
509- 0.16, rename back to pango from pango-gtkbeta
510
511* Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
512- Obsolete fribidi-gtkbeta
513
514* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
515- Remove that patch I just put in
516
517* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
518- Patch pangox.pc.in to include -Iincludedir
519
520* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
521- final 0.13
522
523* Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
524- New 0.13 tarball
525
526* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
527- 0.13pre1
528
529* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
530- Rename to 0.12b to avoid versioning problems
531
532* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
533- Move to a CVS snapshot
534
535* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
536- Move back to /usr
537- Version 0.12
538
539* Mon Jun 19 2000  Owen Taylor <otaylor@redhat.com>
540- Add missing %%defattr
541
542* Thu Jun 8 2000  Owen Taylor <otaylor@redhat.com>
543- Rebuild with a prefix of /opt/gtk-beta
544
545* Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
546- version 0.11
547- add --without-qt
548
549* Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
550- Make the devel package require *-gtkbeta-* not the normal packages.
551
552* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
553- GTK+ snapshot version installing in /opt/gtk-beta
554
555* Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
556- Created spec file
Note: See TracBrowser for help on using the repository browser.