source: projects/specs/trunk/p/pango/pango-vl.spec @ 8353

Revision 8353, 19.0 KB checked in by Takemikaduchi, 10 years ago (diff)

GNOME-3.12.0

Line 
1%define glib2_version 2.38.0
2%define pkgconfig_version 0.12
3%define freetype2_version 2.3.9
4%define fontconfig_version 2.10.91
5%define cairo_version 1.12.2
6
7# biarch support
8%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
9%define _querymodules_suffix %{nil}
10%if %{build_compat32}
11%define _querymodules_suffix -32
12%endif
13
14Summary: System for layout and rendering of internationalized text.
15Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
16Name: pango
17Version: 1.36.3
18Release: 1%{?_dist_release}
19License: LGPL
20Group: System Environment/Libraries
21Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.36/pango-%{version}.tar.xz
22URL: http://www.pango.org
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25# We need to prereq this so we can run pango-querymodules
26Requires: glib2 >= %{glib2_version}
27Requires: freetype2 >= %{freetype2_version}
28BuildRequires: libtool >= 1.4.2
29BuildRequires: glib2-devel >= %{glib2_version}
30BuildRequires: pkgconfig >= %{pkgconfig_version}
31BuildRequires: freetype2-devel >= %{freetype2_version}
32BuildRequires: fontconfig-devel >= %{fontconfig_version}
33BuildRequires: libX11-devel, libXft-devel, libXrender-devel
34BuildRequires: cairo-devel >= %{cairo_version}
35BuildRequires: libSM-devel
36BuildRequires: gobject-introspection-devel
37BuildRequires: libthai-devel
38BuildRequires: harfbuzz-devel
39Obsoletes: pango-gtkbeta, fribidi-gtkbeta
40
41# Look for pango.modules in an arch-specific directory
42Patch0: pango-1.31.2-lib64.patch
43Patch1: pango-1.28.1-gobject-introspection.patch
44
45Vendor:                 Project Vine
46Distribution:   Vine Linux
47Packager:               Takemikaduchi
48
49%description
50Pango is a system for layout and rendering of internationalized text.
51
52%description -l ja
53Pango は国際化テキストのレイアウト・レンダリングシステムです。
54
55
56%package devel
57Summary: System for layout and rendering of internationalized text.
58Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
59Group: Development/Libraries
60Requires: %{name} = %{version}
61Requires: glib2-devel >= %{glib2_version}
62Requires: freetype2-devel >= %{freetype2_version}
63Requires: cairo-devel >= %{cairo_version}
64Requires: libX11-devel, libXft-devel, libXrender-devel
65Requires: harfbuzz-devel
66Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
67
68%description devel
69The pango-devel package includes the static libraries, header files,
70and developer docs for the pango package.
71
72Install pango-devel if you want to develop programs which will use
73pango.
74
75#####################################################################
76# compat32
77%package -n compat32-%{name}
78Summary: System for layout and rendering of internationalized text.
79Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
80Group: Development/Libraries
81%description -n compat32-%{name}
82Pango is a system for layout and rendering of internationalized text.
83%description -n compat32-%{name} -l ja
84Pango は国際化テキストのレイアウト・レンダリングシステムです。
85
86%package -n compat32-%{name}-devel
87Summary: Development files for pango
88Summary(ja): pango 用の開発ファイル
89Group: Development/Libraries
90Requires: compat32-%{name} = %{version}
91Requires: %{name}-devel = %{version}
92%description -n compat32-%{name}-devel
93The pango-devel package includes the static libraries, header files,
94and developer docs for the pango package.
95
96
97%prep
98%setup -q -n pango-%{version}
99%patch0 -p1 -b .lib64
100# %patch1 -p1 -b .gi
101
102%build
103###%configure --with-included-modules=basic-fc
104(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
105 %configure CONFIGFLAGS --with-included-modules=basic-fc --disable-silent-rules --enable-introspection=yes)
106
107make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111make DESTDIR=$RPM_BUILD_ROOT install
112
113# biarch support
114mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}
115touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}/pango.modules
116
117%if %{build_compat32}
118cp $RPM_BUILD_ROOT%{_bindir}/pango-querymodules \
119   $RPM_BUILD_ROOT%{_bindir}/pango-querymodules%{_querymodules_suffix}
120%endif
121
122# remove unpackaged files
123rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
124rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
125rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post
131/sbin/ldconfig
132%{_bindir}/pango-querymodules > %{_sysconfdir}/pango/%{_arch}/pango.modules
133
134%postun -p /sbin/ldconfig
135
136%if %{build_compat32}
137%post -n compat32-%{name}
138/sbin/ldconfig
139%{_bindir}/pango-querymodules%{_querymodules_suffix} > %{_sysconfdir}/pango/%{_arch}/pango.modules
140
141%postun -p /sbin/ldconfig -n compat32-%{name}
142%endif
143
144%files
145%defattr(-, root, root)
146%doc README AUTHORS COPYING NEWS
147%doc pango-view/HELLO.txt
148#doc README AUTHORS COPYING ChangeLog
149#doc examples/HELLO.utf8
150%{_bindir}/pango-querymodules
151%{_bindir}/pango-view
152%{_libdir}/libpango*-*.so.*
153%{_libdir}/pango
154%{_libdir}/girepository-1.0
155%{_mandir}/man*/*
156%dir %{_sysconfdir}/pango
157%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
158
159%files devel
160%defattr(-, root, root)
161%{_libdir}/libpango*.so
162%{_includedir}/*
163%{_libdir}/pkgconfig/*
164%{_datadir}/gtk-doc/*
165%{_datadir}/gir-1.0
166
167%if %{build_compat32}
168%files -n compat32-%{name}
169%defattr(-, root, root)
170%{_libdir}/libpango*-*.so.*
171%{_bindir}/pango-querymodules%{_querymodules_suffix}
172%{_libdir}/pango
173%dir %{_sysconfdir}/pango/%{_arch}
174%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
175
176%files -n compat32-%{name}-devel
177%defattr(-, root, root)
178%{_libdir}/libpango*.so
179%endif
180
181%changelog
182* Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.3-1
183- new upstream release
184
185* Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.2-1
186- new upstream release
187
188* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.1-1
189- new upstream release
190
191* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.0-1
192- new upstream release
193
194* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.1-1
195- new upstream release
196
197* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.0-1
198- new upstream release
199
200* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.5-1
201- new upstream release
202
203* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.2-1
204- new upstream release
205
206* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.1-1
207- new upstream release
208- update Patch0 (pango-1.31.2-lib64.patch)
209- add BuildRequires: harfbuzz-devel
210
211* Tue Jun 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
212- new upstream release
213
214* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
215- new upstream release
216
217* Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-2
218- add BuildRequires: libthai-devel
219
220* Thu Oct 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-1
221- new upstream release
222
223* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.3-1
224- new upstream release
225
226* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.28.4-1
227- new upstream release with security fixes (CVE-2011-0020, 0064)
228- add Vendor/Distri tags
229
230* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.3-1
231- add BuildRequires: libSM-devel, gobject-introspection-devel
232- add Patch1 (pango-1.28.1-gobject-introspection.patch)
233
234* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.28.1-2
235- build with rpm-4.8.1-1 for pkg-config file
236
237* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
238- new upstream release
239
240* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
241- new upstream release
242
243* Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
244- changed %%makeinstall to make install with DESTDIR option
245
246* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
247- new upstream release
248
249* Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
250- new upstream release
251
252* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
253- new upstream release
254
255* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
256- new upstream release
257
258* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
259- new upstream release
260
261* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
262- new upstream release
263
264* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
265- removed %%if !%%{build_compat32} case condition
266
267* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
268- new upstream release
269
270* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
271- new upstream release
272
273* Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
274- new upstream release
275
276* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
277- new upstream release
278
279* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
280- new upstream release
281
282* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
283- new upstream release
284
285* Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
286- new upstream release
287
288* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
289- spec in UTF-8 actually
290
291* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
292- new upstream release
293- rebuilt with xorg-x11 7.3
294
295* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
296- new upstream release
297
298* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
299- used %{?_dist_release}
300
301* Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
302- new upstream release
303
304* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
305- new upstream release
306
307* Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
308- new upstream release
309- added Patch0 instead of Patch5
310
311* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
312- replace build with new environment
313
314* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
315- rebuild with new environment
316
317* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
318- new upstream release
319
320* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
321- new upstream release
322
323* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
324- new upstream release
325
326* Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
327- new upstream release
328
329* Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
330- new upstream release
331
332* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
333- new upstream release
334
335* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
336- rebuild with cairo-1.2.0
337
338* Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
339- add Patch10 to create fake style(italic/bold) for all fonts.
340  http://bugzilla.gnome.org/show_bug.cgi?id=319808
341  - This patch is not applied in upstream, but it seems usefull
342    for us.
343
344* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
345- new upstream release
346
347* Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
348- new upstream release
349
350* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
351- new upstream release
352
353* Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
354- fix broken dependancy
355
356* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
357- new upstream release
358
359* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
360- new upstream release
361- add compat32 package for x86_64 arch support
362- add Patch5 for biarch support
363
364* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
365- new upstream release
366
367* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
368- new upstream release
369
370* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
371- new upstream release
372
373* Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
374- rebuild with cairo-0.9
375- add patch10 to disable building example programs
376
377* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
378- new upstream release
379
380* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
381- new upstream release
382- drop obsolete patches
383
384* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
385- new upstream release
386- import upstream patches from fedora package.
387
388* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
389- new upstream release
390
391* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
392- new upstream release
393
394* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
395- remove unneeded dependancy to freetype2-devel
396
397* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
398- add patch10 to build against freetype-2.1.7
399- rebuild with freetype-2.1.7
400
401* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
402- new upstream release
403
404* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
405- new upstream release
406
407* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
408- new upstream release
409
410* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
411- merge patch1,2 from rawhide package.
412
413* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
414- new upstream release
415
416* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
417- new upstream release
418- Build for Vine Linux, specfile are based on rawhide release
419
420* Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
421- change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
422
423* Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
424- explicitly require pangoxft to be built, so we catch situations such
425  as xft.pc moving to /usr/X11R6
426- also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
427  hack
428
429* Thu Nov  7 2002 Havoc Pennington <hp@redhat.com>
430- 1.1.3
431
432* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
433- Require the necessary freetype version, don't just
434  BuildRequires it (#74744)
435
436* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
437- Own /etc/pango (#73962, Enrico Scholz)
438- Remove .la files from the build root
439
440* Mon Oct  7 2002 Havoc Pennington <hp@redhat.com>
441- require glib 2.0.6-3, try rebuild on more arches
442
443* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
444- Version 1.1.1 (main change, fixes font selection for FT2 backend,
445  as in gdmgreeter)
446
447* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
448- Fix linked list manipulation problem that was causing hang for anaconda
449- Fix warning from loading mini-fonts with context == NULL
450
451* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
452- Fix major memory leak in the last patch
453
454* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
455- Actually use language tags at the rendering layer (should fix #68211)
456
457* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
458- Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
459- Fix bug causing hex boxes to be misrendered
460  leaving RPATH (#66005)
461- For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
462  fonts with embedded bitmaps (#67851)
463
464* Mon Jul  8 2002 Owen Taylor <otaylor@redhat.com>
465- Make basic-x shaper work with our big-5 fonts
466
467* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
468- New upstream tarball with hooks for change-on-the fly font rendering
469
470* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
471- Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
472  ABI changes for pango's OpenType code.
473
474* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
475- Add some Korean aliases that the installer wants
476
477* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
478- automated rebuild
479
480* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
481- devel package requires fontconfig/Xft devel packages
482
483* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
484- rebuild in different environment
485
486* Thu Jun  6 2002 Owen Taylor <otaylor@redhat.com>
487- Snapshot with Xft2/fontconfig support
488
489* Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
490- Version 1.0.2
491- Patch for charmaps problem
492
493* Sun May 26 2002 Tim Powers <timp@redhat.com>
494- automated rebuild
495
496* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
497- rebuild in different environment
498
499* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
500- add patch to adjust to newer version of freetype
501
502* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
503- Update to version 1.0.1, remove patch
504
505* Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
506- Patch from CVS for big speedup with FreeType-2.0.9
507
508* Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
509- Rebuild
510
511* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
512- Version 1.0.0
513
514* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
515- Update to 0.26
516
517* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
518- Bump for rebuild
519
520* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
521- Update to 0.25
522
523* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
524- add horrible buildrequires hack
525
526* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
527- 0.24.90 cvs snap
528
529* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
530- Version 0.24
531
532* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
533- automated rebuild
534
535* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
536- new snap 0.23.90
537
538* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
539- rebuild with 64-bit-fixed glib
540
541* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
542- Version 0.22
543- add explicit check for required glib2 version before we do the build,
544  so we don't end up with bad RPMs on --nodeps builds
545- PreReq the glib2_version version, instead of 1.3.8 hardcoded that
546  no one had updated recently
547
548* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
549- Version 0.21
550
551* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
552- cvs snap
553- new cvs snap with a bugfix
554
555* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
556- sync with Owen's changes, fix up dependency versions
557
558* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
559- 0.19
560
561* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
562- build CVS snap
563
564* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
565- no relinking junk
566
567* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
568- Version 0.18
569
570* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
571- Configure --disable-gtk-doc
572- BuildRequires freetype-devel, XFree86-devel
573
574* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
575- 0.17
576- libtool hackarounds
577
578* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
579- 0.16, rename back to pango from pango-gtkbeta
580
581* Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
582- Obsolete fribidi-gtkbeta
583
584* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
585- Remove that patch I just put in
586
587* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
588- Patch pangox.pc.in to include -Iincludedir
589
590* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
591- final 0.13
592
593* Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
594- New 0.13 tarball
595
596* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
597- 0.13pre1
598
599* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
600- Rename to 0.12b to avoid versioning problems
601
602* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
603- Move to a CVS snapshot
604
605* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
606- Move back to /usr
607- Version 0.12
608
609* Mon Jun 19 2000  Owen Taylor <otaylor@redhat.com>
610- Add missing %%defattr
611
612* Thu Jun 8 2000  Owen Taylor <otaylor@redhat.com>
613- Rebuild with a prefix of /opt/gtk-beta
614
615* Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
616- version 0.11
617- add --without-qt
618
619* Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
620- Make the devel package require *-gtkbeta-* not the normal packages.
621
622* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
623- GTK+ snapshot version installing in /opt/gtk-beta
624
625* Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
626- Created spec file
Note: See TracBrowser for help on using the repository browser.