source: projects/specs/trunk/p/pango/pango-vl.spec @ 8011

Revision 8011, 18.8 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define glib2_version 2.38.0
2%define pkgconfig_version 0.12
3%define freetype2_version 2.3.9
4%define fontconfig_version 2.10.91
5%define cairo_version 1.12.2
6
7# biarch support
8%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
9%define _querymodules_suffix %{nil}
10%if %{build_compat32}
11%define _querymodules_suffix -32
12%endif
13
14Summary: System for layout and rendering of internationalized text.
15Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
16Name: pango
17Version: 1.36.1
18Release: 1%{?_dist_release}
19License: LGPL
20Group: System Environment/Libraries
21Source: ftp://ftp.gnome.org/pub/gnome/sources/pango/1.36/pango-%{version}.tar.xz
22URL: http://www.pango.org
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24
25# We need to prereq this so we can run pango-querymodules
26Requires: glib2 >= %{glib2_version}
27Requires: freetype2 >= %{freetype2_version}
28BuildRequires: libtool >= 1.4.2
29BuildRequires: glib2-devel >= %{glib2_version}
30BuildRequires: pkgconfig >= %{pkgconfig_version}
31BuildRequires: freetype2-devel >= %{freetype2_version}
32BuildRequires: fontconfig-devel >= %{fontconfig_version}
33BuildRequires: libX11-devel, libXft-devel, libXrender-devel
34BuildRequires: cairo-devel >= %{cairo_version}
35BuildRequires: libSM-devel
36BuildRequires: gobject-introspection-devel
37BuildRequires: libthai-devel
38BuildRequires: harfbuzz-devel
39Obsoletes: pango-gtkbeta, fribidi-gtkbeta
40
41# Look for pango.modules in an arch-specific directory
42Patch0: pango-1.31.2-lib64.patch
43Patch1: pango-1.28.1-gobject-introspection.patch
44
45Vendor:                 Project Vine
46Distribution:   Vine Linux
47Packager:               Takemikaduchi
48
49%description
50Pango is a system for layout and rendering of internationalized text.
51
52%description -l ja
53Pango は国際化テキストのレイアウト・レンダリングシステムです。
54
55
56%package devel
57Summary: System for layout and rendering of internationalized text.
58Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
59Group: Development/Libraries
60Requires: %{name} = %{version}
61Requires: glib2-devel >= %{glib2_version}
62Requires: freetype2-devel >= %{freetype2_version}
63Requires: cairo-devel >= %{cairo_version}
64Requires: libX11-devel, libXft-devel, libXrender-devel
65Requires: harfbuzz-devel
66Obsoletes: fribidi-gtkbeta-devel, pango-gtkbeta-devel
67
68%description devel
69The pango-devel package includes the static libraries, header files,
70and developer docs for the pango package.
71
72Install pango-devel if you want to develop programs which will use
73pango.
74
75#####################################################################
76# compat32
77%package -n compat32-%{name}
78Summary: System for layout and rendering of internationalized text.
79Summary(ja): 国際化テキストのレイアウト・レンダリングシステム
80Group: Development/Libraries
81%description -n compat32-%{name}
82Pango is a system for layout and rendering of internationalized text.
83%description -n compat32-%{name} -l ja
84Pango は国際化テキストのレイアウト・レンダリングシステムです。
85
86%package -n compat32-%{name}-devel
87Summary: Development files for pango
88Summary(ja): pango 用の開発ファイル
89Group: Development/Libraries
90Requires: compat32-%{name} = %{version}
91Requires: %{name}-devel = %{version}
92%description -n compat32-%{name}-devel
93The pango-devel package includes the static libraries, header files,
94and developer docs for the pango package.
95
96
97%prep
98%setup -q -n pango-%{version}
99%patch0 -p1 -b .lib64
100# %patch1 -p1 -b .gi
101
102%build
103###%configure --with-included-modules=basic-fc
104(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
105 %configure CONFIGFLAGS --with-included-modules=basic-fc --disable-silent-rules --enable-introspection=yes)
106
107make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111make DESTDIR=$RPM_BUILD_ROOT install
112
113# biarch support
114mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}
115touch $RPM_BUILD_ROOT%{_sysconfdir}/pango/%{_arch}/pango.modules
116
117%if %{build_compat32}
118cp $RPM_BUILD_ROOT%{_bindir}/pango-querymodules \
119   $RPM_BUILD_ROOT%{_bindir}/pango-querymodules%{_querymodules_suffix}
120%endif
121
122# remove unpackaged files
123rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
124rm -f $RPM_BUILD_ROOT%{_libdir}/pango/*/modules/*.la
125rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pango/pango.modules
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post
131/sbin/ldconfig
132%{_bindir}/pango-querymodules > %{_sysconfdir}/pango/%{_arch}/pango.modules
133
134%postun -p /sbin/ldconfig
135
136%if %{build_compat32}
137%post -n compat32-%{name}
138/sbin/ldconfig
139%{_bindir}/pango-querymodules%{_querymodules_suffix} > %{_sysconfdir}/pango/%{_arch}/pango.modules
140
141%postun -p /sbin/ldconfig -n compat32-%{name}
142%endif
143
144%files
145%defattr(-, root, root)
146%doc README AUTHORS COPYING NEWS
147%doc pango-view/HELLO.txt
148#doc README AUTHORS COPYING ChangeLog
149#doc examples/HELLO.utf8
150%{_bindir}/pango-querymodules
151%{_bindir}/pango-view
152%{_libdir}/libpango*-*.so.*
153%{_libdir}/pango
154%{_libdir}/girepository-1.0
155%{_mandir}/man*/*
156%dir %{_sysconfdir}/pango
157%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
158
159%files devel
160%defattr(-, root, root)
161%{_libdir}/libpango*.so
162%{_includedir}/*
163%{_libdir}/pkgconfig/*
164%{_datadir}/gtk-doc/*
165%{_datadir}/gir-1.0
166
167%if %{build_compat32}
168%files -n compat32-%{name}
169%defattr(-, root, root)
170%{_libdir}/libpango*-*.so.*
171%{_bindir}/pango-querymodules%{_querymodules_suffix}
172%{_libdir}/pango
173%dir %{_sysconfdir}/pango/%{_arch}
174%ghost %{_sysconfdir}/pango/%{_arch}/pango.modules
175
176%files -n compat32-%{name}-devel
177%defattr(-, root, root)
178%{_libdir}/libpango*.so
179%endif
180
181%changelog
182* Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.1-1
183- new upstream release
184
185* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.36.0-1
186- new upstream release
187
188* Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.1-1
189- new upstream release
190
191* Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.34.0-1
192- new upstream release
193
194* Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.5-1
195- new upstream release
196
197* Wed Nov 14 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.2-1
198- new upstream release
199
200* Fri Sep 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.32.1-1
201- new upstream release
202- update Patch0 (pango-1.31.2-lib64.patch)
203- add BuildRequires: harfbuzz-devel
204
205* Tue Jun 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.1-1
206- new upstream release
207
208* Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.30.0-1
209- new upstream release
210
211* Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-2
212- add BuildRequires: libthai-devel
213
214* Thu Oct 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.4-1
215- new upstream release
216
217* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.29.3-1
218- new upstream release
219
220* Mon Apr 25 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.28.4-1
221- new upstream release with security fixes (CVE-2011-0020, 0064)
222- add Vendor/Distri tags
223
224* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.3-1
225- add BuildRequires: libSM-devel, gobject-introspection-devel
226- add Patch1 (pango-1.28.1-gobject-introspection.patch)
227
228* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.28.1-2
229- build with rpm-4.8.1-1 for pkg-config file
230
231* Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.1-1
232- new upstream release
233
234* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.28.0-1
235- new upstream release
236
237* Sun Jan 10 2010 Shu KONNO <owa@bg.wakwak.com> 1.26.2-2
238- changed %%makeinstall to make install with DESTDIR option
239
240* Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.2-1
241- new upstream release
242
243* Sun Nov 29 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.26.1-1
244- new upstream release
245
246* Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.26.0-1
247- new upstream release
248
249* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.5-1
250- new upstream release
251
252* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.4-1
253- new upstream release
254
255* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.2-1
256- new upstream release
257
258* Mon May 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.24.1-2
259- removed %%if !%%{build_compat32} case condition
260
261* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.1-1
262- new upstream release
263
264* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.24.0-1
265- new upstream release
266
267* Tue Dec 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.4-1
268- new upstream release
269
270* Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.3-1
271- new upstream release
272
273* Fri Oct 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.1-1
274- new upstream release
275
276* Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22.0-1
277- new upstream release
278
279* Thu Jul 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.5-1
280- new upstream release
281
282* Sun May 25 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.20.3-2
283- spec in UTF-8 actually
284
285* Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.3-1
286- new upstream release
287- rebuilt with xorg-x11 7.3
288
289* Wed Apr  9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.1-1vl5
290- new upstream release
291
292* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-1vl5
293- used %{?_dist_release}
294
295* Wed Mar 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.20.0-0vl1
296- new upstream release
297
298* Thu Jan 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.4-0vl1
299- new upstream release
300
301* Fri Nov 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.3-0vl1
302- new upstream release
303- added Patch0 instead of Patch5
304
305* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
306- replace build with new environment
307
308* Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl2
309- rebuild with new environment
310
311* Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.4-0vl1
312- new upstream release
313
314* Wed Apr 25 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.16.2-0vl1
315- new upstream release
316
317* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.14.9-0vl1
318- new upstream release
319
320* Sun Oct 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.7-0vl1
321- new upstream release
322
323* Sat Sep 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.4-0vl1
324- new upstream release
325
326* Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14.0-0vl1
327- new upstream release
328
329* Tue Aug 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl3
330- rebuild with cairo-1.2.0
331
332* Tue Aug 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl2
333- add Patch10 to create fake style(italic/bold) for all fonts.
334  http://bugzilla.gnome.org/show_bug.cgi?id=319808
335  - This patch is not applied in upstream, but it seems usefull
336    for us.
337
338* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.3-0vl1
339- new upstream release
340
341* Sun Apr 30 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-0vl1
342- new upstream release
343
344* Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.1-0vl1
345- new upstream release
346
347* Fri Mar 17 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl2
348- fix broken dependancy
349
350* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.0-0vl1
351- new upstream release
352
353* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.99-0vl1
354- new upstream release
355- add compat32 package for x86_64 arch support
356- add Patch5 for biarch support
357
358* Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-0vl1
359- new upstream release
360
361* Sat Oct 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.1-0vl1
362- new upstream release
363
364* Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-0vl1
365- new upstream release
366
367* Mon Aug 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl2
368- rebuild with cairo-0.9
369- add patch10 to disable building example programs
370
371* Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0vl1
372- new upstream release
373
374* Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-0vl1
375- new upstream release
376- drop obsolete patches
377
378* Sun Nov 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-0vl1
379- new upstream release
380- import upstream patches from fedora package.
381
382* Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-0vl1
383- new upstream release
384
385* Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
386- new upstream release
387
388* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
389- remove unneeded dependancy to freetype2-devel
390
391* Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl2
392- add patch10 to build against freetype-2.1.7
393- rebuild with freetype-2.1.7
394
395* Mon Sep 01 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl1
396- new upstream release
397
398* Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
399- new upstream release
400
401* Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-0vl1
402- new upstream release
403
404* Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl2
405- merge patch1,2 from rawhide package.
406
407* Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
408- new upstream release
409
410* Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.5-0vl1
411- new upstream release
412- Build for Vine Linux, specfile are based on rawhide release
413
414* Thu Nov 21 2002 Havoc Pennington <hp@redhat.com>
415- change PKG_CONFIG_PATH hack to also search /usr/X11R6/lib64/pkgconfig
416
417* Wed Nov 20 2002 Havoc Pennington <hp@redhat.com>
418- explicitly require pangoxft to be built, so we catch situations such
419  as xft.pc moving to /usr/X11R6
420- also add /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH as a temporary
421  hack
422
423* Thu Nov  7 2002 Havoc Pennington <hp@redhat.com>
424- 1.1.3
425
426* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-5
427- Require the necessary freetype version, don't just
428  BuildRequires it (#74744)
429
430* Thu Oct 31 2002 Owen Taylor <otaylor@redhat.com> 1.1.1-4
431- Own /etc/pango (#73962, Enrico Scholz)
432- Remove .la files from the build root
433
434* Mon Oct  7 2002 Havoc Pennington <hp@redhat.com>
435- require glib 2.0.6-3, try rebuild on more arches
436
437* Wed Aug 21 2002 Owen Taylor <otaylor@redhat.com>
438- Version 1.1.1 (main change, fixes font selection for FT2 backend,
439  as in gdmgreeter)
440
441* Thu Aug 15 2002 Owen Taylor <otaylor@redhat.com>
442- Fix linked list manipulation problem that was causing hang for anaconda
443- Fix warning from loading mini-fonts with context == NULL
444
445* Wed Aug 14 2002 Owen Taylor <otaylor@redhat.com>
446- Fix major memory leak in the last patch
447
448* Tue Aug 13 2002 Owen Taylor <otaylor@redhat.com>
449- Actually use language tags at the rendering layer (should fix #68211)
450
451* Mon Jul 15 2002 Owen Taylor <otaylor@redhat.com>
452- Remove fixed-ltmain.sh, relibtoolize; to fix relink problems without
453- Fix bug causing hex boxes to be misrendered
454  leaving RPATH (#66005)
455- For FT2 backend, supply FT_LOAD_NO_BITMAP to avoid problems with
456  fonts with embedded bitmaps (#67851)
457
458* Mon Jul  8 2002 Owen Taylor <otaylor@redhat.com>
459- Make basic-x shaper work with our big-5 fonts
460
461* Wed Jul  3 2002 Owen Taylor <otaylor@redhat.com>
462- New upstream tarball with hooks for change-on-the fly font rendering
463
464* Tue Jun 25 2002 Owen Taylor <otaylor@redhat.com>
465- Up FreeType version to deal with FreeType-2.0.x / 2.1.x \
466  ABI changes for pango's OpenType code.
467
468* Mon Jun 24 2002 Owen Taylor <otaylor@redhat.com>
469- Add some Korean aliases that the installer wants
470
471* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
472- automated rebuild
473
474* Sat Jun  8 2002 Havoc Pennington <hp@redhat.com>
475- devel package requires fontconfig/Xft devel packages
476
477* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
478- rebuild in different environment
479
480* Thu Jun  6 2002 Owen Taylor <otaylor@redhat.com>
481- Snapshot with Xft2/fontconfig support
482
483* Wed May 29 2002 Owen Taylor <otaylor@redhat.com>
484- Version 1.0.2
485- Patch for charmaps problem
486
487* Sun May 26 2002 Tim Powers <timp@redhat.com>
488- automated rebuild
489
490* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
491- rebuild in different environment
492
493* Wed May 22 2002 Havoc Pennington <hp@redhat.com>
494- add patch to adjust to newer version of freetype
495
496* Wed Apr  3 2002 Alex Larsson <alexl@redhat.com>
497- Update to version 1.0.1, remove patch
498
499* Tue Mar 19 2002 Owen Taylor <otaylor@redhat.com>
500- Patch from CVS for big speedup with FreeType-2.0.9
501
502* Mon Mar 11 2002 Owen Taylor <otaylor@redhat.com>
503- Rebuild
504
505* Fri Mar  8 2002 Owen Taylor <otaylor@redhat.com>
506- Version 1.0.0
507
508* Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
509- Update to 0.26
510
511* Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
512- Bump for rebuild
513
514* Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
515- Update to 0.25
516
517* Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
518- add horrible buildrequires hack
519
520* Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
521- 0.24.90 cvs snap
522
523* Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
524- Version 0.24
525
526* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
527- automated rebuild
528
529* Wed Jan  2 2002 Havoc Pennington <hp@redhat.com>
530- new snap 0.23.90
531
532* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
533- rebuild with 64-bit-fixed glib
534
535* Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
536- Version 0.22
537- add explicit check for required glib2 version before we do the build,
538  so we don't end up with bad RPMs on --nodeps builds
539- PreReq the glib2_version version, instead of 1.3.8 hardcoded that
540  no one had updated recently
541
542* Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
543- Version 0.21
544
545* Thu Oct  4 2001 Havoc Pennington <hp@redhat.com>
546- cvs snap
547- new cvs snap with a bugfix
548
549* Thu Sep 27 2001 Havoc Pennington <hp@redhat.com>
550- sync with Owen's changes, fix up dependency versions
551
552* Wed Sep 19 2001 Havoc Pennington <hp@redhat.com>
553- 0.19
554
555* Mon Sep 10 2001 Havoc Pennington <hp@redhat.com>
556- build CVS snap
557
558* Wed Sep 05 2001 Havoc Pennington <hp@redhat.com>
559- no relinking junk
560
561* Tue Sep  4 2001 root <root@dhcpd37.meridian.redhat.com>
562- Version 0.18
563
564* Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
565- Configure --disable-gtk-doc
566- BuildRequires freetype-devel, XFree86-devel
567
568* Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
569- 0.17
570- libtool hackarounds
571
572* Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
573- 0.16, rename back to pango from pango-gtkbeta
574
575* Fri Feb 16 2001 Owen Taylor <otaylor@redhat.com>
576- Obsolete fribidi-gtkbeta
577
578* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
579- Remove that patch I just put in
580
581* Mon Dec 11 2000 Havoc Pennington <hp@redhat.com>
582- Patch pangox.pc.in to include -Iincludedir
583
584* Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
585- final 0.13
586
587* Tue Nov 14 2000 Owen Taylor <otaylor@redhat.com>
588- New 0.13 tarball
589
590* Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
591- 0.13pre1
592
593* Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
594- Rename to 0.12b to avoid versioning problems
595
596* Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
597- Move to a CVS snapshot
598
599* Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
600- Move back to /usr
601- Version 0.12
602
603* Mon Jun 19 2000  Owen Taylor <otaylor@redhat.com>
604- Add missing %%defattr
605
606* Thu Jun 8 2000  Owen Taylor <otaylor@redhat.com>
607- Rebuild with a prefix of /opt/gtk-beta
608
609* Wed May 31 2000 Owen Taylor <otaylor@redhat.com>
610- version 0.11
611- add --without-qt
612
613* Wed Apr 26 2000 Owen Taylor <otaylor@redhat.com>
614- Make the devel package require *-gtkbeta-* not the normal packages.
615
616* Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
617- GTK+ snapshot version installing in /opt/gtk-beta
618
619* Fri Feb 11 2000 Owen Taylor <otaylor@redhat.com>
620- Created spec file
Note: See TracBrowser for help on using the repository browser.