source: projects/specs/trunk/p/pacemaker/pacemaker-vl.spec @ 9394

Revision 9394, 26.2 KB checked in by inagaki, 9 years ago (diff)

2015-02-28 Ryoichi INAGAKI <ryo1@…>

  • corosync, pacemaker, resoure-agents: updated
  • libqb, perl-Net-IAMP-Simple-SSL: new


Line 
1%global gname haclient
2%global uname hacluster
3%global pcmk_docdir %{_docdir}/%{name}
4
5#%global specversion 3
6#%global upstream_version Pacemaker-1.1.2
7#%global upstream_prefix Pacemaker-1-1-
8
9%global py_site %(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")
10
11# Turn off the auto compilation of python files not in the site-packages directory
12# Needed so that the -devel package is multilib compliant
13%global __os_install_post %(echo '%{__os_install_post}' | sed -e 's!/usr/lib[^[:space:]]*/brp-python-bytecompile[[:space:]].*$!!g')
14
15%global cs_major %(pkg-config corosync --modversion  | awk -F . '{print $1}')
16%global cs_minor %(pkg-config corosync --modversion  | awk -F . '{print $2}')
17
18
19# Conditionals
20# Invoke "rpmbuild --without <feature>" or "rpmbuild --with <feature>"
21# to disable or enable specific features
22
23# Legacy stonithd fencing agents
24%bcond_with stonithd
25
26# Build with/without support for profiling tools
27%bcond_with profiling
28
29# We generate docs using Publican, Asciidoc and Inkscape, but they're not available everywhere
30%bcond_without doc
31
32# Use a different versioning scheme
33%bcond_with pre_release
34
35# Ship an Upstart job file
36%bcond_with upstart_job
37
38%if %{with profiling}
39# This disables -debuginfo package creation and also the stripping binaries/libraries
40# Useful if you want sane profiling data
41%global debug_package %{nil}
42%endif
43
44# Keep around for when/if required
45#global alphatag %{upstream_version}.hg
46
47#%global pcmk_release %{?alphatag:0.}%{specversion}%{?alphatag:.%{alphatag}}%{?dist}
48
49# When downloading directly from Mercurial, it will automatically add a prefix
50# Invoking 'hg archive' wont but you can add one with:
51# hg archive -t tgz -p "$upstream_prefix-$upstream_version" -r $upstream_version $upstream_version.tar.gz
52
53Name:          pacemaker
54Summary:       Scalable High-Availability cluster resource manager
55Summary(ja):   スケーラブルかつ高可用性なクラスタリソースマネージャ
56Version:       1.1.12
57Release:       1%{?_dist_release}
58License:       GPLv2+ and LGPLv2+
59Group:         System Environment/Daemons
60URL:           http://www.clusterlabs.org
61
62Source0:       https://github.com/ClusterLabs/%{name}/archive/Pacemaker-%{version}.tar.gz
63
64BuildRoot:     %{_tmppath}/%{name}-%{version}-%{release}-root
65AutoReqProv:   on
66#Requires(pre): cluster-glue
67Requires:      resource-agents
68Requires:      %{name}-libs = %{version}-%{release}
69Requires:      %{name}-cluster-libs = %{version}-%{release}
70Requires:      %{name}-cli = %{version}-%{release}
71Requires:      python >= 2.4
72
73# Required for core functionality
74BuildRequires:  automake autoconf libtool pkgconfig libtool-ltdl-devel
75BuildRequires:  glib2-devel libxml2-devel libxslt-devel libuuid-devel
76BuildRequires:  pkgconfig python-devel gcc-c++ bzip2-devel pam-devel
77
78# Required for agent_config.h which specifies the correct scratch directory
79BuildRequires: resource-agents
80
81# We need reasonably recent versions of libqb
82BuildRequires: libqb-devel > 0.11.0
83Requires:      libqb > 0.11.0
84
85# Enables optional functionality
86BuildRequires: ncurses-devel openssl-devel docbook-style-xsl
87BuildRequires: bison byacc flex help2man dbus-devel
88
89%if %{defined _unitdir}
90BuildRequires: systemd-devel
91%endif
92
93Requires:      corosync
94BuildRequires: corosynclib-devel
95
96%if %{with stonithd}
97BuildRequires: cluster-glue-libs-devel
98%endif
99
100%if %{with doc}
101%ifarch %{ix86} x86_64
102BuildRequires: inkscape asciidoc
103#BuildRequires: publican inkscape asciidoc
104%endif
105%endif
106
107%description
108Pacemaker is an advanced, scalable High-Availability cluster resource
109manager for Corosync, CMAN and/or Linux-HA.
110
111It supports more than 16 node clusters with significant capabilities
112for managing resources and dependencies.
113
114It will run scripts at initialization, when machines go up or down,
115when related resources fail and can be configured to periodically check
116resource health.
117
118Available rpmbuild rebuild options:
119  --with(out) : stonithd doc profiling pre_release upstart_job
120
121%package cli
122License:      GPLv2+ and LGPLv2+
123Summary:      Command line tools for controlling Pacemaker clusters
124Group:        System Environment/Base
125Requires:     %{name}-libs = %{version}-%{release}
126Requires:     perl-TimeDate
127
128%description cli
129Pacemaker is an advanced, scalable High-Availability cluster resource
130manager for Corosync, CMAN and/or Linux-HA.
131
132The %{name}-cli package contains command line tools that can be used
133to query and control the cluster from machines that may, or may not,
134be part of the cluster.
135
136
137%package -n %{name}-libs
138License:      GPLv2+ and LGPLv2+
139Summary:      Core Pacemaker libraries
140Summary(ja):  Pacemaker コアライブラリ
141Group:        System Environment/Libraries
142
143%description -n pacemaker-libs
144Pacemaker is an advanced, scalable High-Availability cluster resource
145manager for Corosync, CMAN and/or Linux-HA.
146
147The %{name}-libs package contains shared libraries needed for cluster
148nodes and those just running the CLI tools.
149
150%package -n %{name}-cluster-libs
151License:      GPLv2+ and LGPLv2+
152Summary:      Cluster Libraries used by Pacemaker
153Summary(ja):  Pacemaker で用いられるクラスタライブラリ
154Group:        System Environment/Libraries
155Requires:     %{name}-libs = %{version}-%{release}
156
157%description -n %{name}-cluster-libs
158Pacemaker is an advanced, scalable High-Availability cluster resource
159manager for Corosync, CMAN and/or Linux-HA.
160
161The %{name}-cluster-libs package contains cluster-aware shared
162libraries needed for nodes that will form part of the cluster nodes.
163
164%package remote
165License:      GPLv2+ and LGPLv2+
166Summary:      Pacemaker remote daemon for non-cluster nodes
167Group:        System Environment/Daemons
168Requires:     %{name}-libs = %{version}-%{release}
169Requires:     %{name}-cli = %{version}-%{release}
170Requires:     resource-agents
171#%if %{defined systemd_requires}
172#%systemd_requires
173#%endif
174
175%description remote
176Pacemaker is an advanced, scalable High-Availability cluster resource
177manager for Corosync, CMAN and/or Linux-HA.
178
179The %{name}-remote package contains the Pacemaker Remote daemon
180which is capable of extending pacemaker functionality to remote
181nodes not running the full corosync/cluster stack.
182
183%package -n %{name}-libs-devel
184License:      GPLv2+ and LGPLv2+
185Summary:      Pacemaker development package
186Summary(ja):  Pacemaker 開発パッケージ
187Group:        Development/Libraries
188Requires:     %{name}-cts = %{version}-%{release}
189Requires:     %{name}-libs = %{version}-%{release}
190Requires:     %{name}-cluster-libs = %{version}-%{release}
191Requires:     libtool-ltdl-devel libqb-devel libuuid-devel
192Requires:     libxml2-devel libxslt-devel bzip2-devel glib2-devel
193Requires:     corosynclib-devel
194
195%description -n %{name}-libs-devel
196Pacemaker is an advanced, scalable High-Availability cluster resource
197manager for Corosync, CMAN and/or Linux-HA.
198
199The %{name}-libs-devel package contains headers and shared libraries
200for developing tools for Pacemaker.
201
202%package        cts
203License:        GPLv2+ and LGPLv2+
204Summary:        Test framework for cluster-related technologies like Pacemaker
205Group:          Development/Libraries
206Requires:       python
207
208%description    cts
209Test framework for cluster-related technologies like Pacemaker
210
211%package        doc
212License:        GPLv2+ and LGPLv2+
213Summary:        Documentation for Pacemaker
214Summary(ja):    Pacemaker のドキュメント
215Group:          Documentation
216
217%description    doc
218Documentation for Pacemaker.
219
220Pacemaker is an advanced, scalable High-Availability cluster resource
221manager for Corosync, CMAN and/or Linux-HA.
222
223%prep
224%setup -q -n %{name}-Pacemaker-%{version}
225
226%build
227./autogen.sh
228%configure \
229    %{?with_profiling: --with-profiling} \
230    --with-initdir=%{_initrddir} \
231    --docdir=%{pcmk_docdir}     \
232    --localstatedir=%{_var} \
233    --with-version=%{version}-%{release} \
234    --disable-ansi
235
236make %{_smp_mflags} V=1 docdir=%{pcmk_docdir} all
237
238%install
239rm -rf $RPM_BUILD_ROOT
240make DESTDIR=$RPM_BUILD_ROOT install
241
242mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
243mkdir -p $RPM_BUILD_ROOT%{_var}/lib/pacemaker/cores
244install -m 644 mcp/pacemaker.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/pacemaker
245
246%if %{with upstart_job}
247mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init
248install -m 644 mcp/pacemaker.upstart $RPM_BUILD_ROOT%{_sysconfdir}/init/pacemaker.conf
249install -m 644 mcp/pacemaker.combined.upstart $RPM_BUILD_ROOT%{_sysconfdir}/init/pacemaker.combined.conf
250%endif
251
252# Scripts that need should be executable
253chmod a+x $RPM_BUILD_ROOT%{_datadir}/pacemaker/tests/cts/CTSlab.py
254
255# These are not actually scripts
256find $RPM_BUILD_ROOT -name '*.xml' -type f -print0 | xargs -0 chmod a-x
257find $RPM_BUILD_ROOT -name '*.xsl' -type f -print0 | xargs -0 chmod a-x
258find $RPM_BUILD_ROOT -name '*.rng' -type f -print0 | xargs -0 chmod a-x
259find $RPM_BUILD_ROOT -name '*.dtd' -type f -print0 | xargs -0 chmod a-x
260 
261# Dont package static libs or compiled python
262find $RPM_BUILD_ROOT -name '*.a' -type f -print0 | xargs -0 rm -f
263find $RPM_BUILD_ROOT -name '*.la' -type f -print0 | xargs -0 rm -f
264
265# Don't package these either
266rm -f $RPM_BUILD_ROOT%{_libdir}/service_crm.so
267
268# Don't ship init scripts for systemd based platforms
269%if %{defined _unitdir}
270rm -f $RPM_BUILD_ROOT%{_initrddir}/pacemaker
271rm -f $RPM_BUILD_ROOT%{_initrddir}/pacemaker_remote
272%endif
273
274%if %{with profiling}
275GCOV_BASE=$RPM_BUILD_ROOT/%{_var}/lib/pacemaker/gcov
276mkdir -p $GCOV_BASE
277find . -name '*.gcno' -type f | while read F ; do
278        D=`dirname $F`
279        mkdir -p ${GCOV_BASE}/$D
280        cp $F ${GCOV_BASE}/$D
281done
282%endif
283
284%clean
285rm -rf $RPM_BUILD_ROOT
286
287%post
288%if %{defined _unitdir} && 0%{?systemd_post:1}
289%systemd_post pacemaker.service
290%else
291if [ $1 -eq 1 ]; then
292    /sbin/chkconfig --add pacemaker || :
293fi
294%endif
295
296%preun
297%if %{defined _unitdir} && 0%{?systemd_preun:1}
298%systemd_preun pacemaker.service
299%else
300if [ $1 -eq 0 ]; then
301    /sbin/service pacemaker stop &>/dev/null || :
302    /sbin/chkconfig --del pacemaker || :
303fi
304%endif
305
306%postun
307%if %{defined _unitdir} && 0%{?systemd_postun_with_restart:1}
308%systemd_postun_with_restart pacemaker.service
309%endif
310
311%post remote
312%if %{defined _unitdir} && 0%{?systemd_post:1}
313%systemd_post pacemaker_remote.service
314%else
315if [ $1 -eq 1 ]; then
316    /sbin/chkconfig --add pacemaker_remote || :
317fi
318%endif
319
320%preun remote
321%if %{defined _unitdir} && 0%{?systemd_preun:1}
322%systemd_preun pacemaker_remote.service
323%else
324if [ $1 -eq 0 ]; then
325    /sbin/service pacemaker_remote stop &>/dev/null || :
326    /sbin/chkconfig --del pacemaker_remote || :
327fi
328%endif
329
330%postun remote
331%if %{defined _unitdir} && 0%{?systemd_postun_with_restart:1}
332%systemd_postun_with_restart pacemaker_remote.service
333%endif
334
335%pre -n %{name}-libs
336getent group %{gname} >/dev/null || groupadd -r %{gname} -g 189
337getent passwd %{uname} >/dev/null || useradd -r -g %{gname} -u 189 -s /sbin/nologin -c "cluster user" %{uname}
338exit 0
339
340%post -n %{name}-libs -p /sbin/ldconfig
341
342%postun -n %{name}-libs -p /sbin/ldconfig
343
344%post -n %{name}-cluster-libs -p /sbin/ldconfig
345
346%postun -n %{name}-cluster-libs -p /sbin/ldconfig
347
348%files
349###########################################################
350%defattr(-,root,root)
351%doc AUTHORS COPYING ChangeLog
352
353%exclude %{_datadir}/pacemaker/tests
354
355%config(noreplace) %{_sysconfdir}/sysconfig/pacemaker
356%{_sbindir}/pacemakerd
357
358%if %{defined _unitdir}
359%{_unitdir}/pacemaker.service
360%else
361%{_initrddir}/pacemaker
362%endif
363
364%{_datadir}/pacemaker
365%{_datadir}/snmp/mibs/PCMK-MIB.txt
366%exclude %{_libexecdir}/pacemaker/lrmd_test
367%exclude %{_sbindir}/pacemaker_remoted
368%{_libexecdir}/pacemaker/*
369
370%{_sbindir}/crm_attribute
371%{_sbindir}/crm_master
372%{_sbindir}/crm_node
373%{_sbindir}/attrd_updater
374%{_sbindir}/fence_legacy
375%{_sbindir}/fence_pcmk
376%{_sbindir}/stonith_admin
377
378%doc %{_mandir}/man7/*
379%doc %{_mandir}/man8/attrd_updater.*
380%doc %{_mandir}/man8/crm_attribute.*
381%doc %{_mandir}/man8/crm_node.*
382%doc %{_mandir}/man8/crm_master.*
383%doc %{_mandir}/man8/fence_pcmk.*
384%doc %{_mandir}/man8/pacemakerd.*
385%doc %{_mandir}/man8/stonith_admin.*
386
387%dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker
388%dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker/cib
389%dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker/cores
390%dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker/pengine
391%dir %attr (750, %{uname}, %{gname}) %{_var}/lib/pacemaker/blackbox
392%ghost %dir %attr (750, %{uname}, %{gname}) %{_var}/run/crm
393%dir /usr/lib/ocf
394%dir /usr/lib/ocf/resource.d
395/usr/lib/ocf/resource.d/pacemaker
396
397%if 0%{?cs_major} < 2
398%if 0%{?cs_minor} < 8
399%{_libexecdir}/lcrso/pacemaker.lcrso
400%endif
401%endif
402
403%if %{with upstart_job}
404%config(noreplace) %{_sysconfdir}/init/pacemaker.conf
405%config(noreplace) %{_sysconfdir}/init/pacemaker.combined.conf
406%endif
407
408%files cli
409%defattr(-,root,root)
410%doc AUTHORS COPYING ChangeLog
411%{_sbindir}/cibadmin
412%{_sbindir}/crm_diff
413%{_sbindir}/crm_error
414%{_sbindir}/crm_failcount
415%{_sbindir}/crm_mon
416%{_sbindir}/crm_resource
417%{_sbindir}/crm_standby
418%{_sbindir}/crm_verify
419%{_sbindir}/crmadmin
420%{_sbindir}/iso8601
421%{_sbindir}/crm_shadow
422%{_sbindir}/crm_simulate
423%{_sbindir}/crm_report
424%{_sbindir}/crm_ticket
425%doc %{_mandir}/man8/*
426%exclude %{_mandir}/man8/attrd_updater.*
427%exclude %{_mandir}/man8/crm_attribute.*
428%exclude %{_mandir}/man8/crm_node.*
429%exclude %{_mandir}/man8/crm_master.*
430%exclude %{_mandir}/man8/fence_pcmk.*
431%exclude %{_mandir}/man8/pacemakerd.*
432%exclude %{_mandir}/man8/pacemaker_remoted.*
433%exclude %{_mandir}/man8/stonith_admin.*
434
435%files -n %{name}-libs
436%defattr(-,root,root)
437%doc AUTHORS COPYING.LIB
438%{_libdir}/libcib.so.*
439%{_libdir}/liblrmd.so.*
440%{_libdir}/libcrmservice.so.*
441%{_libdir}/libcrmcommon.so.*
442%{_libdir}/libpe_status.so.*
443%{_libdir}/libpe_rules.so.*
444%{_libdir}/libpengine.so.*
445%{_libdir}/libstonithd.so.*
446%{_libdir}/libtransitioner.so.*
447
448%files -n %{name}-cluster-libs
449%defattr(-,root,root)
450%{_libdir}/libcrmcluster.so.*
451%doc AUTHORS COPYING.LIB
452
453
454%files remote
455%defattr(-,root,root)
456%doc AUTHORS COPYING.LIB
457%config(noreplace) %{_sysconfdir}/logrotate.d/pacemaker
458%config(noreplace) %{_sysconfdir}/sysconfig/pacemaker
459%if %{defined _unitdir}
460%{_unitdir}/pacemaker_remote.service
461%else
462%{_initrddir}/pacemaker_remote
463%endif
464%{_sbindir}/pacemaker_remoted
465%{_mandir}/man8/pacemaker_remoted.*
466
467%files doc
468%defattr(-,root,root)
469%doc %{pcmk_docdir}
470
471%files cts
472%defattr(-,root,root)
473%doc AUTHORS COPYING.LIB
474%{py_site}/cts
475%{_datadir}/pacemaker/tests/cts
476%{_libexecdir}/pacemaker/lrmd_test
477
478%files -n %{name}-libs-devel
479%defattr(-,root,root)
480%doc AUTHORS COPYING.LIB
481%exclude %{_datadir}/pacemaker/tests/cts
482%{_datadir}/pacemaker/tests
483%{_includedir}/pacemaker
484%{_libdir}/*.so
485%if %{with profiling}
486%{_var}/lib/pacemaker
487%endif
488%{_libdir}/pkgconfig/*.pc
489
490
491%changelog
492* Sat Feb 28 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.1.12-1
493- updated to 1.1.12
494- rebuilt with gnutls 3.2.20 and corosync 2.3.4
495
496* Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-4
497- rebuild with net-snmp-5.7.1
498
499* Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-3
500- rebuild with python-2.7.2
501
502* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
503- rebuild with openssl-1.0.0d
504
505* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp>  1.1.2-1
506- initial build for Vine Linux
507
508* Mon Jun 21 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.2-3
509- publican is only available as a dependancy on i386/x86_64 machines
510
511* Fri Jun 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.2-2
512- Resolves rhbz#602239 - Added patch to documentation so that it passes validation
513- High: Core: Bug lf#2401 - Backed out changeset 6e6980376f01
514
515* Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.1.2-1.1
516- Mass rebuild with perl-5.12.0
517
518* Wed May 12 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.2-1
519- Update the tarball from the upstream 1.1.2 release
520  + High: ais: Bug lf#2340 - Force rogue child processes to terminate after waiting 2.5 minutes
521  + High: ais: Bug lf#2359 - Default expected votes to 2 inside Corosync/OpenAIS plugin
522  + High: ais: Bug lf#2359 - expected-quorum-votes not correctly updated after membership change
523  + High: ais: Bug rhbz#525552 - Move non-threadsafe calls to setenv() to after the fork()
524  + High: ais: Do not count votes from offline nodes and calculate current votes before sending quorum data
525  + High: ais: Ensure the list of active processes sent to clients is always up-to-date
526  + High: ais: Fix previous commit, actually return a result in get_process_list()
527  + High: ais: Fix two more uses of getpwnam() in non-thread-safe locations
528  + High: ais: Look for the correct conf variable for turning on file logging
529  + High: ais: Need to find a better and thread-safe way to set core_uses_pid. Disable for now.
530  + High: ais: Use the threadsafe version of getpwnam
531  + High: Core: Bug lf#2414 - Prevent use-after-free reported by valgrind when doing xpath based deletions
532  + High: Core: Bump the feature set due to the new failcount expiry feature
533  + High: Core: Fix memory leak in replace_xml_child() reported by valgrind
534  + High: Core: fix memory leaks exposed by valgrind
535  + High: crmd: Bug 2401 - Improved detection of partially active peers
536  + High: crmd: Bug bnc#578644 - Improve handling of cancelled operations caused by resource cleanup
537  + High: crmd: Bug lf#2379 - Ensure the cluster terminates when the PE is not available
538  + High: crmd: Bug lf#2414 - Prevent use-after-free of the PE connection after it dies
539  + High: crmd: Bug lf#2414 - Prevent use-after-free of the stonith-ng connection
540  + High: crmd: Do not allow the target_rc to be misused by resource agents
541  + High: crmd: Do not ignore action timeouts based on FSA state
542  + High: crmd: Ensure we dont get stuck in S_PENDING if we loose an election to someone that never talks to us again
543  + High: crmd: Fix memory leaks exposed by valgrind
544  + High: crmd: Remove race condition that could lead to multiple instances of a clone being active on a machine
545  + High: crmd: Send erase_status_tag() calls to the local CIB when the DC is fenced, since there is no DC to accept them
546  + High: crmd: Use global fencing notifications to prevent secondary fencing operations of the DC
547  + High: fencing: Account for stonith_get_info() always returning a pointer to the same static buffer
548  + High: PE: Allow startup probes to be disabled - their calculation is a major bottleneck for very large clusters
549  + High: PE: Bug lf#2317 - Avoid needless restart of primitive depending on a clone
550  + High: PE: Bug lf#2358 - Fix master-master anti-colocation
551  + High: PE: Bug lf#2361 - Ensure clones observe mandatory ordering constraints if the LHS is unrunnable
552  + High: PE: Bug lf#2383 - Combine failcounts for all instances of an anonymous clone on a host
553  + High: PE: Bug lf#2384 - Fix intra-set colocation and ordering
554  + High: PE: Bug lf#2403 - Enforce mandatory promotion (colocation) constraints
555  + High: PE: Bug lf#2412 - Correctly locate clone instances by their prefix
556  + High: PE: Correctly implement optional colocation between primitives and clone resources
557  + High: PE: Do not be so quick to pull the trigger on nodes that are coming up
558  + High: PE: Fix memory leaks exposed by valgrind
559  + High: PE: Fix memory leaks reported by valgrind
560  + High: PE: Repair handling of unordered groups in RHS ordering constraints
561  + High: PE: Rewrite native_merge_weights() to avoid Fix use-after-free
562  + High: PE: Suppress duplicate ordering constraints to achieve orders of magnitude speed increases for large clusters
563  + High: Shell: add support for xml in cli
564  + High: Shell: always reload status if working with the cluster (bnc#590035)
565  + High: Shell: check timeouts also against the default-action-timeout property
566  + High: Shell: Default to using the status section from the live CIB (bnc#592762)
567  + High: Shell: edit multiple meta_attributes sets in resource management (lf#2315)
568  + High: Shell: enable comments (lf#2221)
569  + High: Shell: implement new cibstatus interface and commands (bnc#580492)
570  + High: Shell: improve configure commit (lf#2336)
571  + High: Shell: new cibstatus import command (bnc#585471)
572  + High: Shell: new configure filter command
573  + High: Shell: restore error reporting in options
574  + High: Shell: split shell into modules
575  + High: Shell: support for the utilization element (old patch for the new structure)
576  + High: Shell: update previous node lookup procedure to include the id where necessary
577  + High: Tools: crm_mon - fix memory leaks exposed by valgrind
578
579* Thu Feb 11 2010 Andrew Beekhof <andrew@beekhof.net> - 1.1.1-0.1-60b7753f7310.hg
580- Update the tarball from upstream to version 60b7753f7310
581  + First public release of the 1.1 series
582
583* Wed Dec 9 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-5
584- Include patch of changeset 66b7bfd467f3:
585  Some clients such as gfs_controld want a cluster name, allow one to be specified in corosync.conf
586
587* Thu Oct 29 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-4
588- Include the fixes from CoroSync integration testing
589- Move the resource templates - they are not documentation
590- Ensure documentation is placed in a standard location
591- Exclude documentation that is included elsewhere in the package
592
593- Update the tarball from upstream to version ee19d8e83c2a
594  + High: cib: Correctly clean up when both plaintext and tls remote ports are requested
595  + High: PE: Bug bnc#515172 - Provide better defaults for lt(e) and gt(e) comparisions
596  + High: PE: Bug lf#2197 - Allow master instances placemaker to be influenced by colocation constraints
597  + High: PE: Make sure promote/demote pseudo actions are created correctly
598  + High: PE: Prevent target-role from promoting more than master-max instances
599  + High: ais: Bug lf#2199 - Prevent expected-quorum-votes from being populated with garbage
600  + High: ais: Prevent deadlock - dont try to release IPC message if the connection failed
601  + High: cib: For validation errors, send back the full CIB so the client can display the errors
602  + High: cib: Prevent use-after-free for remote plaintext connections
603  + High: crmd: Bug lf#2201 - Prevent use-of-NULL when running heartbeat
604  + High: Core: Bug lf#2169 - Allow dtd/schema validation to be disabled
605  + High: PE: Bug lf#2106 - Not all anonymous clone children are restarted after configuration change
606  + High: PE: Bug lf#2170 - stop-all-resources option had no effect
607  + High: PE: Bug lf#2171 - Prevent groups from starting if they depend on a complex resource which cannot
608  + High: PE: Disable resource management if stonith-enabled=true and no stonith resources are defined
609  + High: PE: Do not include master score if it would prevent allocation
610  + High: ais: Avoid excessive load by checking for dead children every 1s (instead of 100ms)
611  + High: ais: Bug rh#525589 - Prevent shutdown deadlocks when running on CoroSync
612  + High: ais: Gracefully handle changes to the AIS nodeid
613  + High: crmd: Bug bnc#527530 - Wait for the transition to complete before leaving S_TRANSITION_ENGINE
614  + High: crmd: Prevent use-after-free with LOG_DEBUG_3
615  + Medium: xml: Mask the "symmetrical" attribute on rsc_colocation constraints (bnc#540672)
616  + Medium (bnc#520707): Tools: crm: new templates ocfs2 and clvm
617  + Medium: Build: Invert the disable ais/heartbeat logic so that --without (ais|heartbeat) is available to rpmbuild
618  + Medium: PE: Bug lf#2178 - Indicate unmanaged clones
619  + Medium: PE: Bug lf#2180 - Include node information for all failed ops
620  + Medium: PE: Bug lf#2189 - Incorrect error message when unpacking simple ordering constraint
621  + Medium: PE: Correctly log resources that would like to start but cannot
622  + Medium: PE: Stop ptest from logging to syslog
623  + Medium: ais: Include version details in plugin name
624  + Medium: crmd: Requery the resource metadata after every start operation
625
626* Fri Oct  9 2009 Fabio M. Di Nitto <fdinitto@redhat.com> - 1.0.5-3
627- rebuilt with new net-snmp
628
629* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0.5-2.1
630- rebuilt with new openssl
631
632* Wed Aug 19 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-2
633- Add versioned perl dependancy as specified by
634    https://fedoraproject.org/wiki/Packaging/Perl#Packages_that_link_to_libperl
635- No longer remove RPATH data, it prevents us finding libperl.so and no other
636  libraries were being hardcoded
637- Compile in support for heartbeat
638- Conditionally add heartbeat-devel and corosynclib-devel to the -devel requirements
639  depending on which stacks are supported
640
641* Mon Aug 17 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-1
642- Add dependancy on resource-agents
643- Use the version of the configure macro that supplies --prefix, --libdir, etc
644- Update the tarball from upstream to version 462f1569a437 (Pacemaker 1.0.5 final)
645  + High: Tools: crm_resource - Advertise --move instead of --migrate
646  + Medium: Extra: New node connectivity RA that uses system ping and attrd_updater
647  + Medium: crmd: Note that dc-deadtime can be used to mask the brokeness of some switches
648
649* Tue Aug 11 2009 Ville Skyttä <ville.skytta@iki.fi> - 1.0.5-0.7.c9120a53a6ae.hg
650- Use bzipped upstream tarball.
651
652* Wed Jul  29 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-0.6.c9120a53a6ae.hg
653- Add back missing build auto* dependancies
654- Minor cleanups to the install directive
655
656* Tue Jul  28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-0.5.c9120a53a6ae.hg
657- Add a leading zero to the revision when alphatag is used
658
659* Tue Jul  28 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.5-0.4.c9120a53a6ae.hg
660- Incorporate the feedback from the cluster-glue review
661- Realistically, the version is a 1.0.5 pre-release
662- Use the global directive instead of define for variables
663- Use the haclient/hacluster group/user instead of daemon
664- Use the _configure macro
665- Fix install dependancies
666
667* Fri Jul  24 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.4-3
668- Include an AUTHORS and license file in each package
669- Change the library package name to pacemaker-libs to be more
670  Fedora compliant
671- Remove execute permissions from xml related files
672- Reference the new cluster-glue devel package name
673- Update the tarball from upstream to version c9120a53a6ae
674  + High: PE: Only prevent migration if the clone dependancy is stopping/starting on the target node
675  + High: PE: Bug 2160 - Dont shuffle clones due to colocation
676  + High: PE: New implementation of the resource migration (not stop/start) logic
677  + Medium: Tools: crm_resource - Prevent use-of-NULL by requiring a resource name for the -A and -a options
678  + Medium: PE: Prevent use-of-NULL in find_first_action()
679  + Low: Build: Include licensing files
680
681* Tue Jul 14 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.4-2
682- Reference authors from the project AUTHORS file instead of listing in description
683- Change Source0 to reference the project's Mercurial repo
684- Cleaned up the summaries and descriptions
685- Incorporate the results of Fedora package self-review
686
687* Tue Jul 14 2009 Andrew Beekhof <andrew@beekhof.net> - 1.0.4-1
688- Initial checkin
Note: See TracBrowser for help on using the repository browser.