source: projects/specs/trunk/o/os-prober/os-prober-vl.spec @ 12434

Revision 12434, 10.5 KB checked in by tomop, 4 years ago (diff)

os-prober-1.77-1

Line 
1Name:           os-prober
2Version:        1.77
3Release:        1%{?_dist_release}
4Summary:        Probes disks on the system for installed operating systems
5
6Group:          System Environment/Base
7# For more information about licensing, see copyright file.
8License:        GPLv2+ and GPL+
9URL:            http://kitenet.net/~joey/code/os-prober/
10
11Vendor:         Project Vine
12Distribution:   Vine Linux
13Packager:       tomop
14
15Source0:        http://ftp.us.debian.org/debian/pool/main/o/os-prober/%{name}_%{version}.tar.xz
16Patch0:         os-prober-no-dummy-mach-kernel.patch
17# Sent upstream
18Patch1:         os-prober-mdraidfix.patch
19Patch2:         os-prober-btrfsfix.patch
20Patch3:         os-prober-bootpart-name-fix.patch
21Patch4:         os-prober-mounted-partitions-fix.patch
22Patch5:         os-prober-factor-out-logger.patch
23# To be sent upstream
24Patch6:         os-prober-factored-logger-efi-fix.patch
25Patch7:         os-prober-umount-fix.patch
26Patch8:         os-prober-grub2-parsefix.patch
27Patch9:         os-prober-grepfix.patch
28Patch10:        os-prober-gentoo-fix.patch
29
30Requires:       udev coreutils util-linux
31Requires:       grep /bin/sed /sbin/modprobe
32Requires:       device-mapper
33
34BuildRequires:  git
35
36%description
37This package detects other OSes available on a system and outputs the results
38in a generic machine-readable format. Support for new OSes and Linux
39distributions can be added easily.
40
41%prep
42%autosetup -n %{name}-%{version} -S git
43
44find -type f -exec sed -i -e 's|usr/lib|usr/libexec|g' {} \;
45sed -i -e 's|grub-probe|grub2-probe|g' os-probes/common/50mounted-tests \
46     linux-boot-probes/common/50mounted-tests
47sed -i -e 's|grub-mount|grub2-mount|g' os-probes/common/50mounted-tests \
48     linux-boot-probes/common/50mounted-tests common.sh
49
50%build
51%make_build CFLAGS="%{optflags}" LDFLAGS="$LDFLAGS -fPIC"
52
53%install
54install -m 0755 -d %{buildroot}%{_bindir}
55install -m 0755 -d %{buildroot}%{_var}/lib/%{name}
56
57install -m 0755 -p os-prober linux-boot-prober %{buildroot}%{_bindir}
58install -m 0755 -Dp newns %{buildroot}%{_libexecdir}/os-prober/newns
59install -m 0644 -Dp common.sh %{buildroot}%{_datadir}/%{name}/common.sh
60
61%ifarch m68k
62ARCH=m68k
63%endif
64%ifarch ppc ppc64
65ARCH=powerpc
66%endif
67%ifarch sparc sparc64
68ARCH=sparc
69%endif
70%ifarch %{ix86} x86_64
71ARCH=x86
72%endif
73
74for probes in os-probes os-probes/mounted os-probes/init \
75              linux-boot-probes linux-boot-probes/mounted; do
76        install -m 755 -d %{buildroot}%{_libexecdir}/$probes
77        cp -a $probes/common/* %{buildroot}%{_libexecdir}/$probes
78        if [ -e "$probes/$ARCH" ]; then
79                cp -a $probes/$ARCH/* %{buildroot}%{_libexecdir}/$probes
80        fi
81done
82if [ "$ARCH" = x86 ]; then
83        install -m 755 -p os-probes/mounted/powerpc/20macosx \
84            %{buildroot}%{_libexecdir}/os-probes/mounted
85fi
86
87%files
88%doc README TODO debian/changelog
89%license debian/copyright
90%{_bindir}/*
91%{_libexecdir}/*
92%{_datadir}/%{name}
93%{_var}/lib/%{name}
94
95%changelog
96* Fri Sep 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.77-1
97- new upstream release.
98
99* Wed Sep 13 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.74-4
100- initial build for Vine Linux.
101
102* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.74-3
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
104
105* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.74-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
107
108* Mon Mar 27 2017 Neal Gompa <ngompa13@gmail.com> - 1.74-1
109- Update to upstream version 1.74
110- Drop merged patches
111- Rediff remaining patches
112- Move newns to /usr/libexec/os-prober (debuginfo generation works)
113- Mark copyright file as license file
114
115* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.71-2
116- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
117
118* Fri Mar 04 2016 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.71-1
119- Update to upstream version 1.71
120- Use git based autosetup for applying patches
121
122* Mon Feb 15 2016 Peter Jones <pjones@redhat.com> - 1.70-3
123- Don't keep backups with 'patch -b'; they wind up in the ouput package.
124
125* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.70-2
126- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
127
128* Fri Nov 13 2015 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.70-1
129- Update to upstream version 1.70, fixes #1275641
130- Fix bug #1236358 - os-prober duplicates grub entries for read/write btrfs
131  subvolumes, thanks to Helmut Horvath
132- Fix bug #1236649 - os-prober does not detect os on btrfs partition without
133  any subvolume
134
135* Tue Oct 20 2015 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.68-1
136- Update to upstream version 1.68, bug #1267779
137- Support a case where a kernel named vmlinuz/x is used under Gentoo, bug #1223237
138
139* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.65-3
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
141
142* Tue Dec 23 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.65-2
143- Fix using grep for searching binary files, fixes #1172405. Thanks Paul Eggert
144  for initial patch fixing grep usage in 83haiku
145
146* Sun Dec 07 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.65-1
147- Using latest upstream version tarball to be consistent with upstream
148  versioning
149
150* Sat Oct 25 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-11
151- Fix parsing grub2's initrd/linux variations, rhbz #1108344
152
153* Mon Sep 08 2014 Peter Jones <pjones@redhat.com> - 1.58-10
154- Make os-prober output include partitions for UEFI chainloads.
155  Resolves: rhbz#873207
156
157* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.58-9
158- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
159
160* Sun Jul 06 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-8
161- Fix bug in counting LVM LVs which their name contains 'btrfs' as btrfs volumes
162
163* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.58-7
164- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
165
166* Tue May 06 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-6
167- Fix separate /usr partitions for usrmove distros (bug #1044760)
168- Fix umount error when directory is temporarily busy (bug #903906)
169
170* Thu Apr 24 2014 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-5
171- Fixed bug #982009: fix btrfs support
172- Suppress some more debug messages when debug messages are disabled
173
174* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.58-4
175- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
176
177* Tue Jul 02 2013 Adam Williamson <awilliam@redhat.com> - 1.58-3
178- revert factored-logger-efi-fix.patch until grub2 is updated to match
179
180* Tue Jun 18 2013 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-2
181- Fix a bug in EFI detection because of redirecting result output
182
183* Sun May 05 2013 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.58-1
184- Update to upstream version 1.58, with UEFI support
185
186* Sat Feb 02 2013 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.57-2
187- Fix a bug in recent btrfs patch when an extended partition is examined.
188  (H.J. Lu) (bug #906847)
189- Fix naming of /boot partitions according to their fstab entry (bug #893472)
190- Don't generate .btrfsfix files which will be included in final rpm
191- Fix wrong boot partition set by linux-boot-prober when / and /boot are
192  mounted (bug #906886)
193- Factor out 'logger', so that it is run once and logs are piped to it (John
194  Reiser) (bug #875356)
195
196* Tue Jan 22 2013 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.57-1
197- Update to 1.57 (#890409)
198- Use shell string processing rather than 'basename' (#875356)
199- Make it possible to disable logging debug messages by assigning a value to
200  OS_PROBER_DISABLE_DEBUG environment variable (Gene Czarcinski) (#893997).
201- Detect multi btrfs pools/volumes (Gene Czarcinski) (#888341)
202
203* Thu Oct 11 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.56-1
204- Update to 1.56 with a bug fix and applied one of my patches
205
206* Mon Aug 27 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.55-1
207- Update to new upstream version: 1.55
208
209* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.53-4
210- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
211
212* Sat Jun 02 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.53-3
213- Consider usrmoved distribtions in fallback linux detector (bug #826754)
214- Remove patch backup files from final rpm package (by not creating a backup!)
215
216* Fri May 25 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.53-2
217- Add support for OSes installed on Linux mdraid partitions, bug #752402
218- Add Fedora's grub2 config path, fixes generating menu entries for other
219  installed Fedora's
220- Fixed bug in parsing yaboot.conf: accept spaces around '=' for append,
221  bug #825041
222
223* Fri May 11 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.53-1
224- Updated to 1.53 for a bugfix
225- Fixed directory name in upstream tarbal
226
227* Thu May 10 2012 Peter Jones <pjones@redhat.com> - 1.52-3
228- Don't detect our Mac boot blocks as OS X.
229  Resolves: rhbz#811412
230
231* Sun Apr 29 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.52-2
232- use correct directory name for setup
233
234* Sun Apr 29 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.52-1
235- Updated to 1.52, supports win 8
236
237* Wed Mar 28 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.51-1
238- Update to latest upstream version, 1.51
239
240* Sat Jan 21 2012 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.48-3
241- Remove dmraid and lvm2 dependency. bug #770393
242
243* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.48-2
244- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
245
246* Mon Jul 25 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.48-1
247- Updated to 1.48 release
248
249* Thu May 19 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.47-1
250- Updated to the new upstream version 1.47
251
252* Wed May 04 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.46-2
253- Removed obsolete parts (build tag, defattr, etc)
254- Added a patch to move newns outside of os-prober subdirectory
255- Added required utilities as package requires
256
257* Sat Apr 30 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.46-1
258- Updated to 1.46 release
259
260* Tue Feb 22 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.42-2
261- Remove executable permission from common.sh
262
263* Thu Feb 17 2011 Hedayat Vatankhah <hedayat.fwd+rpmchlog@gmail.com> - 1.42-1
264- Initial version
Note: See TracBrowser for help on using the repository browser.