source: projects/specs/trunk/o/orca/orca-vl.spec @ 10716

Revision 10716, 4.3 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%{!?python3_sitelib: %define python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
2
3Summary:        A free, open source, flexible, and extensible screen reader
4Name:           orca
5Version:        3.20.3
6Release:        1%{?_dist_release}
7
8Group:          User Interface/Desktops
9License:        LGPLv2+
10URL:            http://projects.gnome.org/orca/
11Source0:        http://ftp.gnome.org/pub/GNOME/sources/%{name}/3.20/%{name}-%{version}.tar.xz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14
15BuildRequires:  gtk3-devel >= 3.1.91
16BuildRequires:  pycairo-devel
17BuildRequires:  pygobject3-devel >= 2.90.3
18BuildRequires:  python3-pygobject
19BuildRequires:  pyxdg
20BuildRequires:  at-spi2-core-devel >= 2.1.92
21BuildRequires:  python3-brlapi
22BuildRequires:  brlapi-devel
23BuildRequires:  brltty
24BuildRequires:  python3-speech-dispatcher
25BuildRequires:  yelp-tools
26
27Requires: python3-brlapi
28Requires: python3-speech-dispatcher
29Requires: python3-pygobject
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: Takemikaduchi
34
35%description
36Orca is a free, open source, flexible, and extensible screen reader
37that provides access to the graphical desktop via user-customizable
38combinations of speech, braille, and/or magnification.
39
40Orca works with applications and toolkits that support the assistive
41technology service provider interface (AT-SPI), which is the primary
42assistive technology infrastructure for the Solaris and Linux
43operating environments.  Applications and toolkits supporting the
44AT-SPI include the GNOME GTK+ toolkit, the Java platform's Swing
45toolkit, OpenOffice, and Mozilla.  AT-SPI support for the KDE Qt
46toolkit is currently being pursued.
47
48%prep
49%setup -q
50
51%build
52%configure --disable-static
53
54make V=0
55
56%install
57rm -rf $RPM_BUILD_ROOT
58make DESTDIR=$RPM_BUILD_ROOT install INSTALL="%{__install} -p -c"
59
60find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
61
62%find_lang %{name} --all-name --with-gnome
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%post
68touch --no-create %{_datadir}/icons/hicolor
69if [ -x /usr/bin/gtk-update-icon-cache ]; then
70        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
71fi
72
73%postun
74touch --no-create %{_datadir}/icons/hicolor
75if [ -x /usr/bin/gtk-update-icon-cache ]; then
76        gtk-update-icon-cache -q %{_datadir}/icons/hicolor
77fi
78
79
80%files -f %{name}.lang
81%defattr(-,root,root,-)
82%doc ChangeLog AUTHORS COPYING NEWS README
83%{_sysconfdir}/xdg/autostart/orca-autostart.desktop
84%{_bindir}/%{name}
85%{python3_sitelib}/%{name}/*
86%{_datadir}/applications/%{name}.desktop
87%{_datadir}/icons/hicolor/*/apps/*
88%{_datadir}/%{name}
89%{_mandir}/man1/%{name}.1.gz
90
91
92%changelog
93* Sat Jul 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.20.3-1
94- new upstream release
95
96* Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.2-1
97- new upstream release
98
99* Sun Nov 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.18.1-1
100- new upstream release
101
102* Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.3-1
103- new upstream release
104
105* Sat May 16 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.2-1
106- new upstream release
107
108* Sun Apr 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.1-1
109- new upstream release
110
111* Wed Apr 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.16.0-1
112- new upstream release
113
114* Sat May 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.2-1
115- new upstream release
116
117* Sun Apr 20 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.12.1-1
118- new upstream release
119
120* Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.2-1
121- new upstream release
122
123* Sun Apr 21 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8.1-1
124- new upstream release
125
126* Thu Nov 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.3-1
127- new upstream release
128
129* Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.1-1
130- new upstream release
131
132* Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.0-1
133- new upstream release
134- change BuildRequires: yelp-tools instead of gnome-docu-utils
135
136* Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
137- new upstream release
138
139* Sat Apr 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
140- new upstream release
141- add BuildRequires: pycairo-devel, pyxdg
142
143* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
144- rebuild with python-2.7.2
145
146* Tue Nov 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-1
147- new upstream release
148
149* Fri Nov 04 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
150- initial build for Vine Linux
151
Note: See TracBrowser for help on using the repository browser.