source: projects/specs/trunk/o/orc/orc-vl.spec @ 9791

Revision 9791, 6.2 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME 3.18.1, BlueZ 5.35, ICU 56.1, Mesa 11.0.4, PulseAudio 7.1, xserver 1.17.4, etc.

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           orc
4Summary:        The Oil Run-time Compiler
5Summary(ja):    Oil ランタイムコンパイラ
6Version:        0.4.24
7Release:        1%{?_dist_release}
8
9Group:          System Environment/Libraries
10License:        BSD
11URL:            http://code.entropywave.com/orc/
12Source0:        http://gstreamer.freedesktop.org/src/orc/orc-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  gtk-doc, libtool
16
17Vendor:         Project Vine
18Distribution:   Vine Linux
19
20
21%description
22Orc is a library and set of tools for compiling and executing
23very simple programs that operate on arrays of data.  The "language"
24is a generic assembly language that represents many of the features
25available in SIMD architectures, including saturated addition and
26subtraction, and many arithmetic operations.
27
28%package doc
29Summary:        Documentation for Orc
30Summary(ja):    Orc のドキュメント
31Group:          Documentation
32Requires:       %{name} = %{version}-%{release}
33BuildArch:      noarch
34
35%description doc
36Documentation for Orc.
37
38%package devel
39Summary:        Development files and static libraries for Orc
40Summary(ja):    Orc の開発用ファイル及び静的ライブラリ
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       %{name}-compiler
44Requires:       pkgconfig
45
46%description devel
47This package contains the files needed to build packages that depend
48on orc.
49
50%package compiler
51Summary:        Orc compiler
52Summary(ja):    Orc コンパイラ
53Group:          Development/Languages
54Requires:       %{name} = %{version}-%{release}
55Requires:       pkgconfig
56
57%description compiler
58The Orc compiler, to produce optimized code.
59
60%package -n compat32-%{name}
61Summary:        The Oil Run-time Compiler
62Summary(ja):    Oil ランタイムコンパイラ
63Group:          System Environment/Libraries
64Requires:       %{name} = %{version}-%{release}
65
66%description -n compat32-%{name}
67Orc is a library and set of tools for compiling and executing
68very simple programs that operate on arrays of data.  The "language"
69is a generic assembly language that represents many of the features
70available in SIMD architectures, including saturated addition and
71subtraction, and many arithmetic operations.
72
73%package -n compat32-%{name}-devel
74Summary:        Development files and static libraries for Orc
75Summary(ja):    Orc の開発用ファイル及び静的ライブラリ
76Group:          Development/Libraries
77Requires:       compat32-%{name} = %{version}-%{release}
78Requires:       compat32-pkgconfig
79
80%description -n compat32-%{name}-devel
81This package contains the files needed to build packages that depend
82on orc.
83
84
85%prep
86%setup -q
87autoreconf -vif
88
89
90%build
91export CFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
92export CXXFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
93%configure --disable-static --enable-gtk-doc
94
95make %{?_smp_mflags}
96
97
98%install
99rm -rf %{buildroot}
100make install DESTDIR=%{buildroot} INSTALL="install -p"
101
102# Remove unneeded files.
103find %{buildroot}/%{_libdir} -name \*.a -or -name \*.la -delete
104rm -rf %{buildroot}/%{_libdir}/orc
105
106touch -r stamp-h1 %{buildroot}%{_includedir}/%{name}-0.4/orc/orc-stdint.h   
107
108%clean
109rm -rf %{buildroot}
110
111%check
112make check || true
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post -n compat32-%{name} -p /sbin/ldconfig
119
120%postun -n compat32-%{name} -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root,-)
124%doc COPYING README
125%{_bindir}/orc-bugreport
126%{_libdir}/liborc-*.so.*
127
128%files doc
129%defattr(-,root,root,-)
130%doc %{_datadir}/gtk-doc/html/orc/
131
132%files devel
133%defattr(-,root,root,-)
134%doc examples/*.c
135%{_includedir}/%{name}-0.4/
136%{_libdir}/liborc-*.so
137%{_libdir}/pkgconfig/orc-0.4.pc
138%{_datadir}/aclocal/orc.m4
139
140%files compiler
141%defattr(-,root,root,-)
142%{_bindir}/orcc
143
144%if %{build_compat32}
145%defattr(-,root,root,-)
146%files -n compat32-%{name}
147%{_libdir}/liborc-*.so.*
148
149%files -n compat32-%{name}-devel
150%defattr(-,root,root,-)
151%{_libdir}/liborc-*.so
152%endif
153
154%changelog
155* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.24-1
156- new upstream release
157
158* Tue Apr 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.23-1
159- new upstream release
160
161* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.22-1
162- new upstream release
163
164* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.19-1
165- new upstream release
166
167* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-2
168- rebuild with VineSeed environment
169
170* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-1
171- new upstream release
172
173* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-1
174- new upstream release
175- create compat32 sub packages
176
177* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.14-1
178- new upstream release
179
180* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
181- new upstream release
182
183* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.5-5
184- rebuilt with rpm-4.8.1 for pkg-config
185
186* Fri Jul 30 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.5-4
187- build with -O1 (not -O2) to fix build failure on ppc
188  (like as the Debian package does)
189
190* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.5-3
191- Initial build for Vine Linux
192
193* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-2
194- Added removed testing libraries to package.
195
196* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-1
197- Updated to 0.4.5.
198- Removed testing libraries from package.
199
200* Mon Apr 05 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-2
201- Docs as noarch.
202- Sanitize timestamps of header files.
203- orcc in -compiler subpackage.
204
205* Tue Mar 30 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-1
206- Updated to 0.4.4: Includes bugfixes for x86_64.
207
208* Wed Mar 17 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-2
209- Running autoreconf to prevent building problems.
210- Added missing files to docs.
211- Added examples to devel docs.
212
213* Thu Mar 04 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-1
214- Updated to 0.4.3
215
216* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-4
217- Removed unused libdir
218
219* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-3
220- Specfile cleanup
221- Removed tools subpackage
222- Added docs subpackage
223
224* Sat Oct 03 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-2
225- Use orc as pakage name
226- spec-file cleanup
227- Added devel requirements
228- Removed an rpath issue
229
230* Fri Oct 02 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-1
231- Initial release
232
Note: See TracBrowser for help on using the repository browser.