source: projects/specs/trunk/o/orc/orc-vl.spec @ 9073

Revision 9073, 5.7 KB checked in by Takemikaduchi, 9 years ago (diff)

GNOME 3.14.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           orc
4Summary:        The Oil Run-time Compiler
5Version:        0.4.22
6Release:        1%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        BSD
10URL:            http://code.entropywave.com/projects/orc/
11Source0:        http://gstreamer.freedesktop.org/src/orc/orc-%{version}.tar.xz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  gtk-doc, libtool
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19
20%description
21Orc is a library and set of tools for compiling and executing
22very simple programs that operate on arrays of data.  The "language"
23is a generic assembly language that represents many of the features
24available in SIMD architectures, including saturated addition and
25subtraction, and many arithmetic operations.
26
27%package doc
28Summary:        Documentation for Orc
29Group:          Development/Documentation
30Requires:       %{name} = %{version}-%{release}
31#BuildArch:     noarch
32
33%description doc
34Documentation for Orc.
35
36%package devel
37Summary:        Development files and static libraries for Orc
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40Requires:       %{name}-compiler
41Requires:       pkgconfig
42
43%description devel
44This package contains the files needed to build packages that depend
45on orc.
46
47%package compiler
48Summary:        Orc compiler
49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51Requires:       pkgconfig
52
53%description compiler
54The Orc compiler, to produce optimized code.
55
56%package -n compat32-%{name}
57Summary:        The Oil Run-time Compiler
58Group:          System Environment/Libraries
59Requires:       %{name} = %{version}-%{release}
60
61%description -n compat32-%{name}
62Orc is a library and set of tools for compiling and executing
63very simple programs that operate on arrays of data.  The "language"
64is a generic assembly language that represents many of the features
65available in SIMD architectures, including saturated addition and
66subtraction, and many arithmetic operations.
67
68%package -n compat32-%{name}-devel
69Summary:        Development files and static libraries for Orc
70Group:          Development/Libraries
71Requires:       compat32-%{name} = %{version}-%{release}
72Requires:       pkgconfig
73
74%description -n compat32-%{name}-devel
75This package contains the files needed to build packages that depend
76on orc.
77
78
79%prep
80%setup -q
81autoreconf -vif
82
83
84%build
85export CFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
86export CXXFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
87%configure --disable-static --enable-gtk-doc
88
89make %{?_smp_mflags}
90
91
92%install
93rm -rf %{buildroot}
94make install DESTDIR=%{buildroot} INSTALL="install -p"
95
96# Remove unneeded files.
97find %{buildroot}/%{_libdir} -name \*.a -or -name \*.la -delete
98rm -rf %{buildroot}/%{_libdir}/orc
99
100touch -r stamp-h1 %{buildroot}%{_includedir}/%{name}-0.4/orc/orc-stdint.h   
101
102%clean
103rm -rf %{buildroot}
104
105%check
106make check || true
107
108%post -p /sbin/ldconfig
109
110%postun -p /sbin/ldconfig
111
112%post -n compat32-%{name} -p /sbin/ldconfig
113
114%postun -n compat32-%{name} -p /sbin/ldconfig
115
116%files
117%defattr(-,root,root,-)
118%doc COPYING README
119%{_bindir}/orc-bugreport
120%{_libdir}/liborc-*.so.*
121
122%files doc
123%defattr(-,root,root,-)
124%doc %{_datadir}/gtk-doc/html/orc/
125
126%files devel
127%defattr(-,root,root,-)
128%doc examples/*.c
129%{_includedir}/%{name}-0.4/
130%{_libdir}/liborc-*.so
131%{_libdir}/pkgconfig/orc-0.4.pc
132%{_datadir}/aclocal/orc.m4
133
134%files compiler
135%defattr(-,root,root,-)
136%{_bindir}/orcc
137
138%if %{build_compat32}
139%defattr(-,root,root,-)
140%files -n compat32-%{name}
141%{_libdir}/liborc-*.so.*
142
143%files -n compat32-%{name}-devel
144%defattr(-,root,root,-)
145%{_libdir}/liborc-*.so
146%endif
147
148%changelog
149* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.22-1
150- new upstream release
151
152* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.19-1
153- new upstream release
154
155* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-2
156- rebuild with VineSeed environment
157
158* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-1
159- new upstream release
160
161* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-1
162- new upstream release
163- create compat32 sub packages
164
165* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.14-1
166- new upstream release
167
168* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
169- new upstream release
170
171* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.5-5
172- rebuilt with rpm-4.8.1 for pkg-config
173
174* Fri Jul 30 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.5-4
175- build with -O1 (not -O2) to fix build failure on ppc
176  (like as the Debian package does)
177
178* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.5-3
179- Initial build for Vine Linux
180
181* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-2
182- Added removed testing libraries to package.
183
184* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-1
185- Updated to 0.4.5.
186- Removed testing libraries from package.
187
188* Mon Apr 05 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-2
189- Docs as noarch.
190- Sanitize timestamps of header files.
191- orcc in -compiler subpackage.
192
193* Tue Mar 30 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-1
194- Updated to 0.4.4: Includes bugfixes for x86_64.
195
196* Wed Mar 17 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-2
197- Running autoreconf to prevent building problems.
198- Added missing files to docs.
199- Added examples to devel docs.
200
201* Thu Mar 04 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-1
202- Updated to 0.4.3
203
204* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-4
205- Removed unused libdir
206
207* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-3
208- Specfile cleanup
209- Removed tools subpackage
210- Added docs subpackage
211
212* Sat Oct 03 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-2
213- Use orc as pakage name
214- spec-file cleanup
215- Added devel requirements
216- Removed an rpath issue
217
218* Fri Oct 02 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-1
219- Initial release
220
Note: See TracBrowser for help on using the repository browser.