source: projects/specs/trunk/o/orc/orc-vl.spec @ 8084

Revision 8084, 5.6 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           orc
4Summary:        The Oil Run-time Compiler
5Version:        0.4.18
6Release:        2%{?_dist_release}
7
8Group:          System Environment/Libraries
9License:        BSD
10URL:            http://code.entropywave.com/projects/orc/
11Source0:        http://code.entropywave.com/download/orc/orc-%{version}.tar.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildRequires:  gtk-doc, libtool
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19
20%description
21Orc is a library and set of tools for compiling and executing
22very simple programs that operate on arrays of data.  The "language"
23is a generic assembly language that represents many of the features
24available in SIMD architectures, including saturated addition and
25subtraction, and many arithmetic operations.
26
27%package doc
28Summary:        Documentation for Orc
29Group:          Development/Documentation
30Requires:       %{name} = %{version}-%{release}
31#BuildArch:     noarch
32
33%description doc
34Documentation for Orc.
35
36%package devel
37Summary:        Development files and static libraries for Orc
38Group:          Development/Libraries
39Requires:       %{name} = %{version}-%{release}
40Requires:       %{name}-compiler
41Requires:       pkgconfig
42
43%description devel
44This package contains the files needed to build packages that depend
45on orc.
46
47%package compiler
48Summary:        Orc compiler
49Group:          Development/Libraries
50Requires:       %{name} = %{version}-%{release}
51Requires:       pkgconfig
52
53%description compiler
54The Orc compiler, to produce optimized code.
55
56%package -n compat32-%{name}
57Summary:        The Oil Run-time Compiler
58Group:          System Environment/Libraries
59Requires:       %{name} = %{version}-%{release}
60
61%description -n compat32-%{name}
62Orc is a library and set of tools for compiling and executing
63very simple programs that operate on arrays of data.  The "language"
64is a generic assembly language that represents many of the features
65available in SIMD architectures, including saturated addition and
66subtraction, and many arithmetic operations.
67
68%package -n compat32-%{name}-devel
69Summary:        Development files and static libraries for Orc
70Group:          Development/Libraries
71Requires:       compat32-%{name} = %{version}-%{release}
72Requires:       pkgconfig
73
74%description -n compat32-%{name}-devel
75This package contains the files needed to build packages that depend
76on orc.
77
78
79%prep
80%setup -q
81autoreconf -vif
82
83
84%build
85export CFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
86export CXXFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
87%configure --disable-static --enable-gtk-doc
88
89make %{?_smp_mflags}
90
91
92%install
93rm -rf %{buildroot}
94make install DESTDIR=%{buildroot} INSTALL="install -p"
95
96# Remove unneeded files.
97find %{buildroot}/%{_libdir} -name \*.a -or -name \*.la -delete
98rm -rf %{buildroot}/%{_libdir}/orc
99
100touch -r stamp-h1 %{buildroot}%{_includedir}/%{name}-0.4/orc/orc-stdint.h   
101
102%clean
103rm -rf %{buildroot}
104
105%check
106make check || true
107
108%post -p /sbin/ldconfig
109
110%postun -p /sbin/ldconfig
111
112%post -n compat32-%{name} -p /sbin/ldconfig
113
114%postun -n compat32-%{name} -p /sbin/ldconfig
115
116%files
117%defattr(-,root,root,-)
118%doc COPYING README
119%{_bindir}/orc-bugreport
120%{_libdir}/liborc-*.so.*
121
122%files doc
123%defattr(-,root,root,-)
124%doc %{_datadir}/gtk-doc/html/orc/
125
126%files devel
127%defattr(-,root,root,-)
128%doc examples/*.c
129%{_includedir}/%{name}-0.4/
130%{_libdir}/liborc-*.so
131%{_libdir}/pkgconfig/orc-0.4.pc
132%{_datadir}/aclocal/orc.m4
133
134%files compiler
135%defattr(-,root,root,-)
136%{_bindir}/orcc
137
138%if %{build_compat32}
139%defattr(-,root,root,-)
140%files -n compat32-%{name}
141%{_libdir}/liborc-*.so.*
142
143%files -n compat32-%{name}-devel
144%defattr(-,root,root,-)
145%{_libdir}/liborc-*.so
146%endif
147
148%changelog
149* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-2
150- rebuild with VineSeed environment
151
152* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-1
153- new upstream release
154
155* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-1
156- new upstream release
157- create compat32 sub packages
158
159* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.14-1
160- new upstream release
161
162* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
163- new upstream release
164
165* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.5-5
166- rebuilt with rpm-4.8.1 for pkg-config
167
168* Fri Jul 30 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.5-4
169- build with -O1 (not -O2) to fix build failure on ppc
170  (like as the Debian package does)
171
172* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.5-3
173- Initial build for Vine Linux
174
175* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-2
176- Added removed testing libraries to package.
177
178* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-1
179- Updated to 0.4.5.
180- Removed testing libraries from package.
181
182* Mon Apr 05 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-2
183- Docs as noarch.
184- Sanitize timestamps of header files.
185- orcc in -compiler subpackage.
186
187* Tue Mar 30 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-1
188- Updated to 0.4.4: Includes bugfixes for x86_64.
189
190* Wed Mar 17 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-2
191- Running autoreconf to prevent building problems.
192- Added missing files to docs.
193- Added examples to devel docs.
194
195* Thu Mar 04 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-1
196- Updated to 0.4.3
197
198* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-4
199- Removed unused libdir
200
201* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-3
202- Specfile cleanup
203- Removed tools subpackage
204- Added docs subpackage
205
206* Sat Oct 03 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-2
207- Use orc as pakage name
208- spec-file cleanup
209- Added devel requirements
210- Removed an rpath issue
211
212* Fri Oct 02 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-1
213- Initial release
214
Note: See TracBrowser for help on using the repository browser.