source: projects/specs/trunk/o/orc/orc-vl.spec @ 4616

Revision 4616, 4.1 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1Name:           orc
2Summary:        The Oil Run-time Compiler
3Version:        0.4.14
4Release:        1%{?_dist_release}
5
6Group:          System Environment/Libraries
7License:        BSD
8URL:            http://code.entropywave.com/projects/orc/
9Source0:        http://code.entropywave.com/download/orc/orc-%{version}.tar.gz
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildRequires:  gtk-doc, libtool
13
14Vendor: Project Vine
15Distribution: Vine Linux
16
17
18%description
19Orc is a library and set of tools for compiling and executing
20very simple programs that operate on arrays of data.  The "language"
21is a generic assembly language that represents many of the features
22available in SIMD architectures, including saturated addition and
23subtraction, and many arithmetic operations.
24
25%package doc
26Summary:        Documentation for Orc
27Group:          Development/Documentation
28Requires:       %{name} = %{version}-%{release}
29#BuildArch:     noarch
30
31%description doc
32Documentation for Orc.
33
34%package devel
35Summary:        Development files and static libraries for Orc
36Group:          Development/Libraries
37Requires:       %{name} = %{version}-%{release}
38Requires:       %{name}-compiler
39Requires:       pkgconfig
40
41%description devel
42This package contains the files needed to build packages that depend
43on orc.
44
45%package compiler
46Summary:        Orc compiler
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49Requires:       pkgconfig
50
51%description compiler
52The Orc compiler, to produce optimized code.
53
54
55%prep
56%setup -q
57autoreconf -vif
58
59
60%build
61export CFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
62export CXXFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
63%configure --disable-static --enable-gtk-doc
64
65make %{?_smp_mflags}
66
67
68%install
69rm -rf %{buildroot}
70make install DESTDIR=%{buildroot} INSTALL="install -p"
71
72# Remove unneeded files.
73find %{buildroot}/%{_libdir} -name \*.a -or -name \*.la -delete
74rm -rf %{buildroot}/%{_libdir}/orc
75
76touch -r stamp-h1 %{buildroot}%{_includedir}/%{name}-0.4/orc/orc-stdint.h   
77
78%clean
79rm -rf %{buildroot}
80
81%check
82make check || true
83
84%post -p /sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(-,root,root,-)
90%doc COPYING README
91%{_bindir}/orc-bugreport
92%{_libdir}/liborc-*.so.*
93
94%files doc
95%defattr(-,root,root,-)
96%doc %{_datadir}/gtk-doc/html/orc/
97
98%files devel
99%defattr(-,root,root,-)
100%doc examples/*.c
101%{_includedir}/%{name}-0.4/
102%{_libdir}/liborc-*.so
103%{_libdir}/pkgconfig/orc-0.4.pc
104
105%files compiler
106%defattr(-,root,root,-)
107%{_bindir}/orcc
108
109
110%changelog
111* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.14-1
112- new upstream release
113
114* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
115- new upstream release
116
117* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.5-5
118- rebuilt with rpm-4.8.1 for pkg-config
119
120* Fri Jul 30 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.5-4
121- build with -O1 (not -O2) to fix build failure on ppc
122  (like as the Debian package does)
123
124* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.5-3
125- Initial build for Vine Linux
126
127* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-2
128- Added removed testing libraries to package.
129
130* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-1
131- Updated to 0.4.5.
132- Removed testing libraries from package.
133
134* Mon Apr 05 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-2
135- Docs as noarch.
136- Sanitize timestamps of header files.
137- orcc in -compiler subpackage.
138
139* Tue Mar 30 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-1
140- Updated to 0.4.4: Includes bugfixes for x86_64.
141
142* Wed Mar 17 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-2
143- Running autoreconf to prevent building problems.
144- Added missing files to docs.
145- Added examples to devel docs.
146
147* Thu Mar 04 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-1
148- Updated to 0.4.3
149
150* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-4
151- Removed unused libdir
152
153* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-3
154- Specfile cleanup
155- Removed tools subpackage
156- Added docs subpackage
157
158* Sat Oct 03 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-2
159- Use orc as pakage name
160- spec-file cleanup
161- Added devel requirements
162- Removed an rpath issue
163
164* Fri Oct 02 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-1
165- Initial release
166
Note: See TracBrowser for help on using the repository browser.