source: projects/specs/trunk/o/orc/orc-vl.spec @ 1942

Revision 1942, 3.9 KB checked in by owa, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1Name:           orc
2Summary:        The Oil Run-time Compiler
3Version:        0.4.5
4Release:        5%{?_dist_release}
5
6Group:          System Environment/Libraries
7License:        BSD
8URL:            http://code.entropywave.com/projects/orc/
9Source0:        http://code.entropywave.com/download/orc/orc-%{version}.tar.gz
10
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildRequires:  gtk-doc, libtool
13
14
15%description
16Orc is a library and set of tools for compiling and executing
17very simple programs that operate on arrays of data.  The "language"
18is a generic assembly language that represents many of the features
19available in SIMD architectures, including saturated addition and
20subtraction, and many arithmetic operations.
21
22%package doc
23Summary:        Documentation for Orc
24Group:          Development/Documentation
25Requires:       %{name} = %{version}-%{release}
26#BuildArch:     noarch
27
28%description doc
29Documentation for Orc.
30
31%package devel
32Summary:        Development files and static libraries for Orc
33Group:          Development/Libraries
34Requires:       %{name} = %{version}-%{release}
35Requires:       %{name}-compiler
36Requires:       pkgconfig
37
38%description devel
39This package contains the files needed to build packages that depend
40on orc.
41
42%package compiler
43Summary:        Orc compiler
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46Requires:       pkgconfig
47
48%description compiler
49The Orc compiler, to produce optimized code.
50
51
52%prep
53%setup -q
54autoreconf -vif
55
56
57%build
58export CFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
59export CXXFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
60%configure --disable-static --enable-gtk-doc
61
62make %{?_smp_mflags}
63
64
65%install
66rm -rf %{buildroot}
67make install DESTDIR=%{buildroot} INSTALL="install -p"
68
69# Remove unneeded files.
70find %{buildroot}/%{_libdir} -name \*.a -or -name \*.la -delete
71rm -rf %{buildroot}/%{_libdir}/orc
72
73touch -r stamp-h1 %{buildroot}%{_includedir}/%{name}-0.4/orc/orc-stdint.h   
74
75%clean
76rm -rf %{buildroot}
77
78%check
79make check
80
81%post -p /sbin/ldconfig
82
83%postun -p /sbin/ldconfig
84
85
86%files
87%defattr(-,root,root,-)
88%doc COPYING README
89%{_libdir}/liborc-*.so.*
90
91%files doc
92%defattr(-,root,root,-)
93%doc %{_datadir}/gtk-doc/html/orc/
94
95%files devel
96%defattr(-,root,root,-)
97%doc examples/*.c
98%{_includedir}/%{name}-0.4/
99%{_libdir}/liborc-*.so
100%{_libdir}/pkgconfig/orc-0.4.pc
101
102%files compiler
103%defattr(-,root,root,-)
104%{_bindir}/orcc
105
106
107%changelog
108* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.5-5
109- rebuilt with rpm-4.8.1 for pkg-config
110
111* Fri Jul 30 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.5-4
112- build with -O1 (not -O2) to fix build failure on ppc
113  (like as the Debian package does)
114
115* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.5-3
116- Initial build for Vine Linux
117
118* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-2
119- Added removed testing libraries to package.
120
121* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-1
122- Updated to 0.4.5.
123- Removed testing libraries from package.
124
125* Mon Apr 05 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-2
126- Docs as noarch.
127- Sanitize timestamps of header files.
128- orcc in -compiler subpackage.
129
130* Tue Mar 30 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-1
131- Updated to 0.4.4: Includes bugfixes for x86_64.
132
133* Wed Mar 17 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-2
134- Running autoreconf to prevent building problems.
135- Added missing files to docs.
136- Added examples to devel docs.
137
138* Thu Mar 04 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-1
139- Updated to 0.4.3
140
141* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-4
142- Removed unused libdir
143
144* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-3
145- Specfile cleanup
146- Removed tools subpackage
147- Added docs subpackage
148
149* Sat Oct 03 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-2
150- Use orc as pakage name
151- spec-file cleanup
152- Added devel requirements
153- Removed an rpath issue
154
155* Fri Oct 02 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-1
156- Initial release
157
Note: See TracBrowser for help on using the repository browser.