source: projects/specs/trunk/o/orc/orc-vl.spec @ 11511

Revision 11511, 6.3 KB checked in by tomop, 6 years ago (diff)

orc-0.4.28-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           orc
4Summary:        The Oil Run-time Compiler
5Summary(ja):    Oil ランタイムコンパイラ
6Version:        0.4.28
7Release:        1%{?_dist_release}
8
9Group:          System Environment/Libraries
10License:        BSD
11URL:            http://code.entropywave.com/orc/
12Source0:        http://gstreamer.freedesktop.org/src/orc/orc-%{version}.tar.xz
13
14BuildRoot:      %{_tmppath}/%{name}-%{version}-root
15BuildRequires:  gtk-doc, libtool
16
17Vendor:         Project Vine
18Distribution:   Vine Linux
19
20
21%description
22Orc is a library and set of tools for compiling and executing
23very simple programs that operate on arrays of data.  The "language"
24is a generic assembly language that represents many of the features
25available in SIMD architectures, including saturated addition and
26subtraction, and many arithmetic operations.
27
28%package doc
29Summary:        Documentation for Orc
30Summary(ja):    Orc のドキュメント
31Group:          Documentation
32Requires:       %{name} = %{version}-%{release}
33BuildArch:      noarch
34
35%description doc
36Documentation for Orc.
37
38%package devel
39Summary:        Development files and static libraries for Orc
40Summary(ja):    Orc の開発用ファイル及び静的ライブラリ
41Group:          Development/Libraries
42Requires:       %{name} = %{version}-%{release}
43Requires:       %{name}-compiler
44Requires:       pkgconfig
45
46%description devel
47This package contains the files needed to build packages that depend
48on orc.
49
50%package compiler
51Summary:        Orc compiler
52Summary(ja):    Orc コンパイラ
53Group:          Development/Languages
54Requires:       %{name} = %{version}-%{release}
55Requires:       pkgconfig
56
57%description compiler
58The Orc compiler, to produce optimized code.
59
60%package -n compat32-%{name}
61Summary:        The Oil Run-time Compiler
62Summary(ja):    Oil ランタイムコンパイラ
63Group:          System Environment/Libraries
64Requires:       %{name} = %{version}-%{release}
65
66%description -n compat32-%{name}
67Orc is a library and set of tools for compiling and executing
68very simple programs that operate on arrays of data.  The "language"
69is a generic assembly language that represents many of the features
70available in SIMD architectures, including saturated addition and
71subtraction, and many arithmetic operations.
72
73%package -n compat32-%{name}-devel
74Summary:        Development files and static libraries for Orc
75Summary(ja):    Orc の開発用ファイル及び静的ライブラリ
76Group:          Development/Libraries
77Requires:       compat32-%{name} = %{version}-%{release}
78Requires:       compat32-pkgconfig
79
80%description -n compat32-%{name}-devel
81This package contains the files needed to build packages that depend
82on orc.
83
84
85%prep
86%setup -q
87autoreconf -vif
88
89
90%build
91export CFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
92export CXXFLAGS=`echo $RPM_OPT_FLAGS | sed 's/-O2/-O1/g'`
93%configure --disable-static --enable-gtk-doc
94
95make %{?_smp_mflags}
96
97
98%install
99rm -rf %{buildroot}
100make install DESTDIR=%{buildroot} INSTALL="install -p"
101
102# Remove unneeded files.
103find %{buildroot}/%{_libdir} -name \*.a -or -name \*.la -delete
104rm -rf %{buildroot}/%{_libdir}/orc
105
106touch -r stamp-h1 %{buildroot}%{_includedir}/%{name}-0.4/orc/orc-stdint.h   
107
108%clean
109rm -rf %{buildroot}
110
111%check
112make check || true
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%post -n compat32-%{name} -p /sbin/ldconfig
119
120%postun -n compat32-%{name} -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root,-)
124%doc COPYING README
125%{_bindir}/orc-bugreport
126%{_libdir}/liborc-*.so.*
127
128%files doc
129%defattr(-,root,root,-)
130%doc %{_datadir}/gtk-doc/html/orc/
131
132%files devel
133%defattr(-,root,root,-)
134%doc examples/*.c
135%{_includedir}/%{name}-0.4/
136%{_libdir}/liborc-*.so
137%{_libdir}/pkgconfig/orc-0.4.pc
138%{_datadir}/aclocal/orc.m4
139
140%files compiler
141%defattr(-,root,root,-)
142%{_bindir}/orcc
143
144%if %{build_compat32}
145%defattr(-,root,root,-)
146%files -n compat32-%{name}
147%{_libdir}/liborc-*.so.*
148
149%files -n compat32-%{name}-devel
150%defattr(-,root,root,-)
151%{_libdir}/liborc-*.so
152%endif
153
154%changelog
155* Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.4.28-1
156- new upstream release.
157
158* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.24-1
159- new upstream release
160
161* Tue Apr 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.23-1
162- new upstream release
163
164* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.22-1
165- new upstream release
166
167* Sat Apr 19 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.19-1
168- new upstream release
169
170* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-2
171- rebuild with VineSeed environment
172
173* Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.18-1
174- new upstream release
175
176* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.16-1
177- new upstream release
178- create compat32 sub packages
179
180* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.14-1
181- new upstream release
182
183* Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4.11-1
184- new upstream release
185
186* Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 0.4.5-5
187- rebuilt with rpm-4.8.1 for pkg-config
188
189* Fri Jul 30 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.5-4
190- build with -O1 (not -O2) to fix build failure on ppc
191  (like as the Debian package does)
192
193* Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.4.5-3
194- Initial build for Vine Linux
195
196* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-2
197- Added removed testing libraries to package.
198
199* Sun Jun 13 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.5-1
200- Updated to 0.4.5.
201- Removed testing libraries from package.
202
203* Mon Apr 05 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-2
204- Docs as noarch.
205- Sanitize timestamps of header files.
206- orcc in -compiler subpackage.
207
208* Tue Mar 30 2010 Fabian Deutsch <fabiand@fedoraproject.org> - 0.4.4-1
209- Updated to 0.4.4: Includes bugfixes for x86_64.
210
211* Wed Mar 17 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-2
212- Running autoreconf to prevent building problems.
213- Added missing files to docs.
214- Added examples to devel docs.
215
216* Thu Mar 04 2010 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.3-1
217- Updated to 0.4.3
218
219* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-4
220- Removed unused libdir
221
222* Sun Oct 18 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-3
223- Specfile cleanup
224- Removed tools subpackage
225- Added docs subpackage
226
227* Sat Oct 03 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-2
228- Use orc as pakage name
229- spec-file cleanup
230- Added devel requirements
231- Removed an rpath issue
232
233* Fri Oct 02 2009 Fabian Deutsch <fabian.deutsch@gmx.de> - 0.4.2-1
234- Initial release
235
Note: See TracBrowser for help on using the repository browser.