source: projects/specs/trunk/o/openssl102/openssl102-vl.spec @ 11830

Revision 11830, 26.9 KB checked in by tomop, 5 years ago (diff)

openssl-1.1.1-1

Line 
1%bcond_with devel
2%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
3%define soversion 10
4%define version 1.0.2p
5%define release 1%{_dist_release}
6
7Summary: Secure Sockets Layer Toolkit
8Name: openssl102
9Version: %{version}
10Release: %{release}
11Source: ftp://ftp.openssl.org/source/openssl-%{version}.tar.gz
12Source2: Makefile.certificate
13Source6: make-dummy-cert
14Source7: renew-dummy-cert
15
16# Patch0: openssl-1.0.2-soversion.patch
17# Patch2: openssl-1.0.1-rpm_opt.patch
18Patch0: openssl-1.0.2g-rpmbuild.patch
19Patch4: openssl-1.0.2g-enginesdir.patch
20Patch5: openssl-1.0.2a-version-add-engines.patch
21Patch8: openssl-1.0.1c-perlfind.patch
22
23# security fix
24# nothing ;-)
25
26License: BSDish
27Group: System Environment/Libraries
28URL: http://www.openssl.org/
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: perl, sed
32BuildRequires: zlib-devel, krb5-devel
33
34Requires: mktemp
35Requires: ca-certificates
36%if %{with devel}
37Requires: openssl >= 1.1.1
38%endif
39
40Vendor: Project Vine
41Distribution: Vine Linux
42Packager: daisuke, iwamoto
43
44%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
45
46%description
47The OpenSSL certificate management tool and the shared libraries that
48provide various cryptographic algorithms and protocols.
49
50%if %{with devel}
51%package devel
52Summary: OpenSSL libraries and development headers.
53Group: Development/Libraries
54Requires: %{name} = %{version}-%{release}
55Requires: krb5-devel
56
57%description devel
58The static libraries and include files needed to compile apps
59with support for various the cryptographic algorithms and protocols
60supported by OpenSSL.
61
62Patches for many networking apps can be found at:
63ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
64
65%package static
66Summary:  Libraries for static linking of applications which will use OpenSSL
67Group: Development/Libraries
68Requires: %{name}-devel = %{version}-%{release}
69
70%description static
71OpenSSL is a toolkit for supporting cryptography. The openssl-static
72package contains static libraries needed for static linking of
73applications which support various cryptographic algorithms and
74protocols.
75
76%package perl
77Summary: OpenSSL scripts which require Perl.
78Group: Applications/Internet
79Requires: perl
80Requires: %{name} = %{version}-%{release}
81
82%description perl
83Perl scripts provided with OpenSSL for converting certificates and keys
84from other formats to those used by OpenSSL.
85%endif
86
87## to build compat32 for x86_64 architecture support
88%package -n compat32-%{name}
89Summary: Secure Sockets Layer Toolkit
90Group: System Environment/Libraries
91Requires: %{name} = %{version}-%{release}
92%description -n compat32-%{name}
93The OpenSSL certificate management tool and the shared libraries that
94provide various cryptographic algorithms and protocols.
95
96%if %{with devel}
97%package -n compat32-%{name}-devel
98Summary: OpenSSL libraries and development headers.
99Group: Development/Libraries
100Requires: compat32-%{name} = %{version}-%{release}
101Requires: compat32-krb5-devel
102%description -n compat32-%{name}-devel
103The static libraries and include files needed to compile apps
104with support for various the cryptographic algorithms and protocols
105supported by OpenSSL.
106
107%endif
108
109%prep
110%setup -q -n openssl-%{version}
111
112%patch0 -p1 -b .soversion
113%patch4 -p1 -b .enginesdir
114%patch5 -p1 -b .version-add-engines
115%patch8 -p1 -b .perlfind
116
117# security fix
118# nothing ;-)
119
120chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
121chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
122# chmod 644 doc/openssl_button.html doc/openssl_button.gif
123chmod 644 doc/ssleay.txt
124
125%build
126PATH=${PATH}:${PWD}/bin
127TOPDIR=${PWD}
128LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
129
130# Modify the various perl scripts to reference perl in the right location.
131perl util/perlpath.pl `dirname %{__perl}`
132
133# Generate a table with the compile settings for my perusal.
134touch Makefile
135make TABLE PERL=%{__perl}
136
137# Figure out which flags we want to use.
138# default
139sslarch=%{_os}-%{_target_cpu}
140#
141%ifarch %ix86
142sslarch=linux-elf
143if ! echo %{_target} | grep -q i686 ; then
144   sslflags="no-asm 386"
145fi
146%endif
147%ifarch sparcv9
148sslarch=linux-sparcv9
149sslflags=no-asm
150%endif
151%ifarch sparc64
152sslarch=linux64-sparcv9
153sslflags=no-asm
154%endif
155%ifarch alpha alphaev56 alphaev6 alphaev67
156sslarch=linux-alpha-gcc
157%endif
158%ifarch s390 sh3eb sh4eb
159sslarch="linux-generic32 -DB_ENDIAN"
160%endif
161%ifarch s390x
162sslarch="linux64-s390x"
163%endif
164%ifarch %{arm} sh3 sh4
165sslarch=linux-generic32
166%endif
167# ia64/x86_64/ppc\ppc64 are OK by default.
168
169# Configure the build tree.  Override OpenSSL defaults with known-good defaults
170# usable on all platforms.  The Configure script already knows to use -fPIC and
171# RPM_OPT_FLAGS, so we can skip specifiying them here.
172./Configure  \
173         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
174         zlib-dynamic enable-camellia enable-seed enable-tlsext \
175         enable-rfc3779 enable-cms enable-md2 \
176         --enginesdir=%{_libdir}/%{name}/engines \
177         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
178         shared ${sslarch}
179
180# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
181# marked as not requiring an executable stack.
182RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
183make depend
184make all build-shared
185
186# Generate hashes for the included certs.
187LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
188export LD_LIBRARY_PATH
189make rehash build-shared
190
191# Verify that what was compiled actually works.
192make -C test apps tests
193
194# Relink the main binary to get it dynamically linked.
195rm apps/openssl
196make all build-shared
197
198%install
199[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
200# Install OpenSSL.
201install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/%{name}}
202make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
203install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
204# added for lib64
205# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
206mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/%{name}
207# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
208mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
209mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
210rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
211rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
212for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
213        chmod 755 ${lib}
214        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
215        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
216done
217# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
218
219# Install a makefile for generating keys and self-signed certs, and a script
220# for generating them on the fly.
221mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
222install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
223install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
224install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
225
226# Make sure we actually include the headers we built against.
227for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
228        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
229                install -m644 include/openssl/`basename ${header}` ${header}
230        fi
231done
232
233# Rename man pages so that they don't conflict with system man pages.  We used
234# to change the file extensions, but that only prevents file conflicts.  The
235# man viewer still can't select either of the two unless we physically change
236# the directory.
237for section in 1 2 3 4 5 6 7 8 ; do
238        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
239                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
240                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
241        fi
242done
243
244# Pick a CA script.
245pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
246mv CA.sh CA
247popd
248
249mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
250mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
251mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
252mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
253mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
254
255# Ensure the openssl.cnf timestamp is identical across builds to avoid
256# mulitlib conflicts and unnecessary renames on upgrade
257touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
258
259%clean
260[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
261
262%files
263%defattr(-,root,root)
264%doc FAQ LICENSE CHANGES NEWS INSTALL README
265%doc doc/README doc/c-indentation.el doc/openssl.txt
266%doc doc/openssl_button.html doc/openssl_button.gif
267%doc doc/ssleay.txt
268
269%if %{with devel}
270%{_sysconfdir}/pki/tls/certs/make-dummy-cert
271%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
272%{_sysconfdir}/pki/tls/certs/Makefile
273%{_sysconfdir}/pki/tls/misc/CA
274%dir %{_sysconfdir}/pki/CA
275%dir %{_sysconfdir}/pki/CA/private
276%dir %{_sysconfdir}/pki/CA/certs
277%dir %{_sysconfdir}/pki/CA/crl
278%dir %{_sysconfdir}/pki/CA/newcerts
279%{_sysconfdir}/pki/tls/misc/c_*
280%dir %{_sysconfdir}/pki/tls
281%dir %{_sysconfdir}/pki/tls/certs
282%dir %{_sysconfdir}/pki/tls/misc
283%dir %{_sysconfdir}/pki/tls/private
284%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
285
286%attr(0755,root,root) %{_bindir}/openssl
287%endif
288%attr(0755,root,root) /%{_lib}/*.so.*
289%attr(0755,root,root) %{_libdir}/%{name}/engines/*.so
290%if %{with devel}
291%attr(0755,root,root) %dir %{_mandir}/man1*
292%attr(0644,root,root) %{_mandir}/man1*/*
293%attr(0755,root,root) %dir %{_mandir}/man5*
294%attr(0644,root,root) %{_mandir}/man5*/*
295%attr(0755,root,root) %dir %{_mandir}/man7*
296%attr(0644,root,root) %{_mandir}/man7*/*
297%endif
298
299%if %{with devel}
300%files devel
301%defattr(-,root,root)
302%{_prefix}/include/openssl
303%exclude %{_libdir}/lib*.a
304%attr(0755,root,root) %{_libdir}/*.so
305%attr(0755,root,root) %dir %{_mandir}/man3*
306%attr(0644,root,root) %{_mandir}/man3*/*
307%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
308
309%files static
310%defattr(-,root,root)
311%attr(0644,root,root) %{_libdir}/*.a
312
313%files perl
314%defattr(-,root,root)
315%attr(0755,root,root) %{_bindir}/c_rehash
316%attr(0755,root,root) %dir %{_mandir}/man1*
317%attr(0644,root,root) %{_mandir}/man1*/*.pl*
318%{_sysconfdir}/pki/tls/misc/*.pl
319#%{_sysconfdir}/pki/tls/misc/tsget
320%doc apps/tsget
321%endif
322
323## to build compat32 for x86_64 architecture support
324%if %{build_compat32}
325%files -n compat32-%{name}
326%defattr(-,root,root)
327%attr(0755,root,root) /%{_lib}/*.so.*
328
329%if %{with devel}
330%files -n compat32-%{name}-devel
331%defattr(-,root,root)
332%exclude %{_libdir}/lib*.a
333%attr(0755,root,root) %{_libdir}/*.so
334%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
335%endif
336%endif
337
338%post -p /sbin/ldconfig
339
340%postun -p /sbin/ldconfig
341
342%post -n compat32-%{name} -p /sbin/ldconfig
343
344%postun -n compat32-%{name} -p /sbin/ldconfig
345
346%changelog
347* Wed Oct 31 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.2p-1
348- new upstream release.
349- renamed for compatibility.
350
351* Sun Apr  1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
352- new upstream release with security fixes
353
354* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
355- new upstream release with security fixes
356
357* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
358- new upstream release with security fixes
359
360* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
361- new upstream release with security fixes
362
363* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
364- new upstream release with security fixes
365
366* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
367- new upstream release 1.0.2 with security fixes
368- Patch2 is merged into Patch0
369
370* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
371- new upstream release with security fixes
372
373* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
374- new upstream release with security fixes
375
376* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
377- new upstream release
378
379* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
380- merged into Vine6
381  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
382  - new upstream release with security fixes 
383  - update Patch2,5
384
385* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
386- new upstream release with security fixes 
387
388* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
389- new upstream release with security fixes
390- add patch8 from fc21 (fix perl find.pl)
391
392* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
393- new upstream release with security fixes.
394
395* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
396- new upstream release with security fixes
397
398* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
399- new upstream release with security fixes
400
401* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
402- move root CA bundle to ca-certificates package
403
404* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
405- update to 1.0.1e
406  - 1.0.1d has major regressions from 1.0.1c
407
408* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
409- remove tsget script to delete dependency perl(WWW::Curl::Easy)
410 - openssl-perl package contains it in docdir
411
412* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
413- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
414- fixed %%files
415
416* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
417- update to 1.0.1c
418- enable configure options:
419  enable-camellia enable-seed enable-tlsext enable-rfc3779
420  enable-cms enable-md2
421- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
422- generate a table with the compile settings before configure
423
424* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
425- new upstream release with security fix (CVE-2012-0050)
426
427* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
428- new upstream release with security fix
429  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
430
431* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
432- new upstream release with security fix (CVE-2011-3207, 3210)
433
434* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
435- rebuild with krb5-libs 1.8
436
437* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
438- new upstream release with security fix
439
440* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
441- use upstream openssl.pc instead of vine original one (SOURCE6)
442
443* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
444- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
445
446* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
447- add R: krb5-devel into devel pkg
448- add R: compat32-krb5-devel into compat32-devel pkg
449
450* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
451- new upstream release 1.0.0x
452- separate static libs into static package
453- change configure options
454- change so version 10
455- add tsget into perl package
456- update all patches
457
458* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
459- fix changelog typo...
460
461* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
462- new upstream release with security fix (CVE-2010-4180)
463
464* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
465- new upstream release with security fix (CVE-2010-3864)
466- drop patches included in new release
467- update patch4
468
469* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
470- add patch12 for fix CVE-2009-3555 (renegotiation)
471
472* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
473- add patch11 for fix CVE-2009-4355 (memory leak)
474
475* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
476- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
477
478* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
479- removed unnecessary %%if %{build_compat32} statements
480- removed lib*.a from devel package
481
482* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
483- new upstream release with security fix (CVE-2000-0590,0591,0789)
484
485* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
486- new upstream release with security fix (CVE-2008-5077)
487
488* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
489- new upstream release
490
491* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
492- new upstream release
493- new versioning policy
494
495* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
496- new upstream release
497- drop patch10,20 which is merged in upstream
498
499* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
500- add security patch in advance for CVE-2007-5135
501  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
502  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
503
504* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
505- add security patch for CVE-2007-3108
506  (http://openssl.org/news/patch-CVE-2007-3108.txt)
507
508* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
509- new upstream release
510
511* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
512- update (fix) openssl.pc <BTS:437>
513
514* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
515- new upstream release (with security fix)
516
517* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
518- new upstream release
519- add patch2 to use RPM_OPT macro
520
521* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
522- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
523
524* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
525- added compat32-* packages for x86_64 architecture support
526- added openssl-0.9.7i.Configure-compat32.patch
527- changed '/lib' to '/%{_lib}'
528
529* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
530- new upstream release
531
532* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
533- rebuild on VineSeed
534
535* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
536- added a security patch from Gentoo.
537  - Patch1: openssl-0.9.7c-tempfile.patch
538
539* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
540- sslarch for ppc was missing... added.
541
542* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
543- use sslarch=linux-alpha-gcc instead of alpha-gcc
544
545* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
546- new upstream version
547- clean up of spec file
548        -- removed old patches
549
550* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
551- new upstream release
552- SECURITY fix.
553  - http://www.openssl.org/news/secadv_20040317.txt
554
555* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
556- new upstream release
557- [Security fix]
558  - Vulnerabilities in ASN.1 parsing
559    http://www.openssl.org/news/secadv_20030930.txt
560- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
561
562* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
563- add openssl.pc for pkgconfig
564
565* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
566- New upstream version
567- dropped patch10, 11
568        -- merged upstream version
569
570* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
571- rebuild for VineSeed
572
573* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
574- [Security Fix]
575  - Timing-based attacks on RSA keys
576    http://www.openssl.org/news/secadv_20030317.txt
577  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
578    http://www.openssl.org/news/secadv_20030317.txt
579
580* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
581- new upstream release 0.9.6i
582- [Security Fix]
583- build for Vine Linux 2.6 errata
584
585* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
586- new upstream release 0.9.6h
587
588* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
589- new upstream release 0.9.6g
590
591* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
592- SECURITY: CAN-2002-0659 fixed
593  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
594    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
595    - update asn patch to fix accidental reversal of a logic check
596    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
597    - update asn patch to reduce chance that compiler optimization will remove
598      one of the added tests
599    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
600    - rebuild
601    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
602    - add patch to fix ASN.1 vulnerabilities
603
604* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
605- rename spec file name
606- SECURITY: CA-2002-23 fixed
607  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
608    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
609    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
610
611* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
612- added ${PATH} in LD_LIBRARY_PATH
613- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
614 
615* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
616- remove --no-<cipher>
617
618* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
619- add Patch10 for mipsel shared ( Configure )
620
621* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
622- build for Vine Linux
623- use openssl-engine-0.9.6b.tar.gz
624
625* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
626- update to 0.9.6b
627
628* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
629- move .so symlinks back to %%{_libdir}
630
631* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
632- move shared libraries to /lib (#38410)
633
634* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
635- switch to engine code base
636
637* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
638- add a script for creating dummy certificates
639- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
640
641* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
642- add s390x support
643
644* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
645- change two memcpy() calls to memmove()
646- don't define L_ENDIAN on alpha
647
648* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
649- make subpackages depend on the main package
650
651* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
652- adjust the hobble script to not disturb symlinks in include/ (fix from
653  Joe Orton)
654
655* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
656- drop the m2crypo patch we weren't using
657
658* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
659- configure using "shared" as well
660
661* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
662- update to 0.9.6a
663- use the build-shared target to build shared libraries
664- bump the soversion to 2 because we're no longer compatible with
665  our 0.9.5a packages or our 0.9.6 packages
666- drop the patch for making rsatest a no-op when rsa null support is used
667- put all man pages into <section>ssl instead of <section>
668- break the m2crypto modules into a separate package
669
670* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
671- use BN_LLONG on s390
672
673* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
674- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
675
676* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
677- move c_rehash to the perl subpackage, because it's a perl script now
678
679* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
680- update to 0.9.6
681- enable MD2
682- use the libcrypto.so and libssl.so targets to build shared libs with
683- bump the soversion to 1 because we're no longer compatible with any of
684  the various 0.9.5a packages circulating around, which provide lib*.so.0
685
686* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
687- change hobble-openssl for disabling MD2 again
688
689* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
690- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
691  bytes or so, causing EVP_DigestInit() to zero out stack variables in
692  apps built against a version of the library without it
693
694* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
695- disable some inline assembly, which on x86 is Pentium-specific
696- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
697
698* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
699- fix s390 patch
700
701* Fri Dec 8 2000 Than Ngo <than@redhat.com>
702- added support s390
703
704* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
705- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
706- add the CA.pl man page to the perl subpackage
707
708* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
709- always build with -mcpu=ev5 on alpha
710
711* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
712- add a symlink from cert.pem to ca-bundle.crt
713
714* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
715- add a ca-bundle file for packages like Samba to reference for CA certificates
716
717* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
718- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
719
720* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
721- add unzip as a buildprereq (#17662)
722- update m2crypto to 0.05-snap4
723
724* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
725- fix some issues in building when it's not installed
726
727* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
728- make sure the headers we include are the ones we built with (aaaaarrgh!)
729
730* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
731- add Richard Henderson's patch for BN on ia64
732- clean up the changelog
733
734* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
735- fix the building of python modules without openssl-devel already installed
736
737* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
738- byte-compile python extensions without the build-root
739- adjust the makefile to not remove temporary files (like .key files when
740  building .csr files) by marking them as .PRECIOUS
741
742* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
743- break out python extensions into a subpackage
744
745* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
746- tweak the makefile some more
747
748* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
749- disable MD2 support
750
751* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
752- disable MDC2 support
753
754* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
755- tweak the disabling of RC5, IDEA support
756- tweak the makefile
757
758* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
759- strip binaries and libraries
760- rework certificate makefile to have the right parts for Apache
761
762* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
763- use %%{_perl} instead of /usr/bin/perl
764- disable alpha until it passes its own test suite
765
766* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
767- move the passwd.1 man page out of the passwd package's way
768
769* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
770- update to 0.9.5a, modified for U.S.
771- add perl as a build-time requirement
772- move certificate makefile to another package
773- disable RC5, IDEA, RSA support
774- remove optimizations for now
775
776* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
777- Bero told me to move the Makefile into this package
778
779* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
780- add lib*.so symlinks to link dynamically against shared libs
781
782* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
783- update to 0.9.5
784- run ldconfig directly in post/postun
785- add FAQ
786
787* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
788- Fix build on non-x86 platforms
789
790* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
791- move /usr/share/ssl/* from -devel to main package
792
793* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
794- inital packaging
795- changes from base:
796  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
797  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.