source: projects/specs/trunk/o/openssl098/openssl098-vl.spec @ 9499

Revision 9499, 20.9 KB checked in by Takemikaduchi, 9 years ago (diff)

merge into Vine6

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 6
3%define version 0.9.8zf
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl098
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14# Source6: openssl-%{version}.pc
15Patch0: openssl-0.9.8b-soversion.patch
16Patch2: openssl-0.9.8e-rpm_opt.patch
17Patch4: openssl-0.9.8p-enginesdir.patch
18Patch8: openssl-0.9.8zf-perlfind.patch
19
20# security fix
21# nothing ;-)
22
23License: BSDish
24Group: System Environment/Libraries
25URL: http://www.openssl.org/
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: perl, sed
28Requires: mktemp
29Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
34
35%description
36The OpenSSL certificate management tool and the shared libraries that
37provide various cryptographic algorithms and protocols.
38
39## to build compat32 for x86_64 architecture support
40%package -n compat32-%{name}
41Summary: Secure Sockets Layer Toolkit
42Group: System Environment/Libraries
43Requires: %{name} = %{version}-%{release}
44%description -n compat32-%{name}
45The OpenSSL certificate management tool and the shared libraries that
46provide various cryptographic algorithms and protocols.
47
48%prep
49%setup -q -n openssl-%{version}
50%patch0 -p1 -b .soversion
51%patch2 -p1 -b .rpm_opt
52%patch4 -p1 -b .enginesdir
53%patch8 -p1 -b .perlfind
54
55# security fix
56# nothing ;-)
57
58chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
59chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
60chmod 644 doc/openssl_button.html doc/openssl_button.gif
61chmod 644 doc/ssleay.txt
62
63# Link the configuration header to the one we're going to make.
64ln -sf ../../crypto/opensslconf.h include/openssl/
65
66%build
67PATH=${PATH}:${PWD}/bin
68TOPDIR=${PWD}
69LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
70
71# Figure out which flags we want to use.  Can't use assembler because it's
72# not lowest-common-denominator in most cases.
73perl util/perlpath.pl `dirname %{__perl}`
74%ifarch %ix86
75sslarch=linux-elf
76sslflags="no-asm 386"
77%endif
78%ifarch ppc
79sslarch=linux-ppc
80sslflags=no-asm
81%endif
82%ifarch sparc
83sslarch=linux-sparcv9
84sslflags=no-asm
85%endif
86%ifarch ia64
87sslarch=linux-ia64
88sslflags=no-asm
89%endif
90%ifarch alpha
91sslarch=linux-alpha-gcc
92sslflags=no-asm
93%endif
94%ifarch s390
95sslarch=linux-s390
96%endif
97%ifarch s390x
98sslarch=linux-s390x
99%endif
100%ifarch mipsel
101sslarch=linux-mips
102sslflags=no-asm
103%endif
104## to build for x86_64 architecture support
105%ifarch x86_64
106sslarch=linux-x86_64
107sslflags=no-asm
108%endif
109
110# Configure the build tree.  Override OpenSSL defaults with known-good defaults
111# usable on all platforms.  The Configure script already knows to use -fPIC and
112# RPM_OPT_FLAGS, so we can skip specifiying them here.
113./Configure  \
114         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
115         --enginesdir=%{_libdir}/openssl/engines \
116         shared ${sslarch}
117
118# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
119# marked as not requiring an executable stack.
120RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
121make depend
122make all build-shared
123
124# Generate hashes for the included certs.
125LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
126export LD_LIBRARY_PATH
127make rehash build-shared
128
129# Verify that what was compiled actually works.
130make -C test apps tests
131
132# Relink the main binary to get it dynamically linked.
133rm apps/openssl
134make all build-shared
135
136%install
137[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
138# Install OpenSSL.
139install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
140make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
141install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
142# added for lib64
143mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
144mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
145mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
146mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
147rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
148rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
149for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
150        chmod 755 ${lib}
151        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
152        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
153done
154# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
155
156# Install a makefile for generating keys and self-signed certs, and a script
157# for generating them on the fly.
158mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
159install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
160install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
161
162# Make sure we actually include the headers we built against.
163for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
164        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
165                install -m644 include/openssl/`basename ${header}` ${header}
166        fi
167done
168
169# Rename man pages so that they don't conflict with system man pages.  We used
170# to change the file extensions, but that only prevents file conflicts.  The
171# man viewer still can't select either of the two unless we physically change
172# the directory.
173for section in 1 2 3 4 5 6 7 8 ; do
174        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
175                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
176                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
177        fi
178done
179
180# Pick a CA script.
181pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
182mv CA.sh CA
183popd
184
185# Install root CA stuffs.
186cat %{SOURCE3} > ca-bundle.crt
187install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
188ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
189
190# Fix libdir.
191#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
192# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
193#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
194#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
195# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
196#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
197# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
198
199%clean
200[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
201
202%files
203%defattr(-,root,root)
204%doc FAQ LICENSE CHANGES NEWS INSTALL README
205%doc doc/README doc/c-indentation.el doc/openssl.txt
206%doc doc/openssl_button.html doc/openssl_button.gif
207%doc doc/ssleay.txt
208# %dir %{_datadir}/ssl
209# %{_datadir}/ssl/certs
210# %{_datadir}/ssl/cert.pem
211# %{_datadir}/ssl/misc/CA
212# %{_datadir}/ssl/misc/c_*
213# %{_datadir}/ssl/private
214# %config(noreplace) %{_datadir}/ssl/openssl.cnf
215
216# %attr(0755,root,root) %{_bindir}/openssl
217%attr(0755,root,root) /%{_lib}/*.so.*
218# %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
219# %attr(0755,root,root) %dir %{_mandir}/man1*
220# %attr(0644,root,root) %{_mandir}/man1*/*
221# %attr(0755,root,root) %dir %{_mandir}/man5*
222# %attr(0644,root,root) %{_mandir}/man5*/*
223# %attr(0755,root,root) %dir %{_mandir}/man7*
224# %attr(0644,root,root) %{_mandir}/man7*/*
225
226## to build compat32 for x86_64 architecture support
227%if %{build_compat32}
228%files -n compat32-%{name}
229%defattr(-,root,root)
230%attr(0755,root,root) /%{_lib}/*.so.*
231%endif
232
233%post -p /sbin/ldconfig
234
235%postun -p /sbin/ldconfig
236
237%post -n compat32-%{name} -p /sbin/ldconfig
238
239%postun -n compat32-%{name} -p /sbin/ldconfig
240
241%changelog
242* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9.8zf-1
243- merge into Vine6
244  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zf-1
245  - new upstream release with security fix
246  * Sat Jan 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zd-1
247  - new upstream release with security fix
248  * Thu Oct 23 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zc-1
249  - new upstream release with security fix
250  * Thu Aug  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8zb-1
251  - new upstream release with security fix   
252  * Sat Jun  7 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8za-1
253  - new upstream release with security fix 
254- add Patch8: openssl-0.9.8zf-perlfind.patch
255
256* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8r-1
257- new upstream release with security fix
258
259* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
260- new upstream release with security fix
261- update patch4
262
263* Wed Mar 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-2
264- fix files list (unneeded files were included in package)
265
266* Tue Mar 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8n-1
267- new compatible package openssl 0.9.8n for upgrade openssl 1.0.0
268
269* Thu Mar 18 2010 IWAI, Masaharu <iwai@alib.jp> 0.9.8m-1
270- new upstream release
271- update enginsdir patch (Patch4)
272- drop unnecessary patch: upstream fixed
273  - dtls dos patch (Patch10)
274  - CVE-2009-4355 (memory leak) patch (Patch11)
275  - CVE-2009-3555 (renegotiation) patch (Patch12)
276- update SOURCE6 for pkgconfig
277- replace BuildPreReq to BuildRequires
278
279* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
280- add patch12 for fix CVE-2009-3555 (renegotiation)
281
282* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
283- add patch11 for fix CVE-2009-4355 (memory leak)
284
285* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
286- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
287
288* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
289- removed unnecessary %%if %{build_compat32} statements
290- removed lib*.a from devel package
291
292* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
293- new upstream release with security fix (CVE-2000-0590,0591,0789)
294
295* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
296- new upstream release with security fix (CVE-2008-5077)
297
298* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
299- new upstream release
300
301* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
302- new upstream release
303- new versioning policy
304
305* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
306- new upstream release
307- drop patch10,20 which is merged in upstream
308
309* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
310- add security patch in advance for CVE-2007-5135
311  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
312  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
313
314* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
315- add security patch for CVE-2007-3108
316  (http://openssl.org/news/patch-CVE-2007-3108.txt)
317
318* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
319- new upstream release
320
321* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
322- update (fix) openssl.pc <BTS:437>
323
324* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
325- new upstream release (with security fix)
326
327* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
328- new upstream release
329- add patch2 to use RPM_OPT macro
330
331* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
332- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
333
334* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
335- added compat32-* packages for x86_64 architecture support
336- added openssl-0.9.7i.Configure-compat32.patch
337- changed '/lib' to '/%{_lib}'
338
339* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
340- new upstream release
341
342* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
343- rebuild on VineSeed
344
345* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
346- added a security patch from Gentoo.
347  - Patch1: openssl-0.9.7c-tempfile.patch
348
349* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
350- sslarch for ppc was missing... added.
351
352* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
353- use sslarch=linux-alpha-gcc instead of alpha-gcc
354
355* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
356- new upstream version
357- clean up of spec file
358        -- removed old patches
359
360* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
361- new upstream release
362- SECURITY fix.
363  - http://www.openssl.org/news/secadv_20040317.txt
364
365* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
366- new upstream release
367- [Security fix]
368  - Vulnerabilities in ASN.1 parsing
369    http://www.openssl.org/news/secadv_20030930.txt
370- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
371
372* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
373- add openssl.pc for pkgconfig
374
375* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
376- New upstream version
377- dropped patch10, 11
378        -- merged upstream version
379
380* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
381- rebuild for VineSeed
382
383* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
384- [Security Fix]
385  - Timing-based attacks on RSA keys
386    http://www.openssl.org/news/secadv_20030317.txt
387  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
388    http://www.openssl.org/news/secadv_20030317.txt
389
390* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
391- new upstream release 0.9.6i
392- [Security Fix]
393- build for Vine Linux 2.6 errata
394
395* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
396- new upstream release 0.9.6h
397
398* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
399- new upstream release 0.9.6g
400
401* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
402- SECURITY: CAN-2002-0659 fixed
403  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
404    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
405    - update asn patch to fix accidental reversal of a logic check
406    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
407    - update asn patch to reduce chance that compiler optimization will remove
408      one of the added tests
409    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
410    - rebuild
411    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
412    - add patch to fix ASN.1 vulnerabilities
413
414* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
415- rename spec file name
416- SECURITY: CA-2002-23 fixed
417  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
418    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
419    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
420
421* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
422- added ${PATH} in LD_LIBRARY_PATH
423- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
424 
425* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
426- remove --no-<cipher>
427
428* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
429- add Patch10 for mipsel shared ( Configure )
430
431* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
432- build for Vine Linux
433- use openssl-engine-0.9.6b.tar.gz
434
435* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
436- update to 0.9.6b
437
438* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
439- move .so symlinks back to %%{_libdir}
440
441* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
442- move shared libraries to /lib (#38410)
443
444* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
445- switch to engine code base
446
447* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
448- add a script for creating dummy certificates
449- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
450
451* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
452- add s390x support
453
454* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
455- change two memcpy() calls to memmove()
456- don't define L_ENDIAN on alpha
457
458* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
459- make subpackages depend on the main package
460
461* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
462- adjust the hobble script to not disturb symlinks in include/ (fix from
463  Joe Orton)
464
465* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
466- drop the m2crypo patch we weren't using
467
468* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
469- configure using "shared" as well
470
471* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
472- update to 0.9.6a
473- use the build-shared target to build shared libraries
474- bump the soversion to 2 because we're no longer compatible with
475  our 0.9.5a packages or our 0.9.6 packages
476- drop the patch for making rsatest a no-op when rsa null support is used
477- put all man pages into <section>ssl instead of <section>
478- break the m2crypto modules into a separate package
479
480* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
481- use BN_LLONG on s390
482
483* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
484- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
485
486* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
487- move c_rehash to the perl subpackage, because it's a perl script now
488
489* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
490- update to 0.9.6
491- enable MD2
492- use the libcrypto.so and libssl.so targets to build shared libs with
493- bump the soversion to 1 because we're no longer compatible with any of
494  the various 0.9.5a packages circulating around, which provide lib*.so.0
495
496* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
497- change hobble-openssl for disabling MD2 again
498
499* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
500- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
501  bytes or so, causing EVP_DigestInit() to zero out stack variables in
502  apps built against a version of the library without it
503
504* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
505- disable some inline assembly, which on x86 is Pentium-specific
506- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
507
508* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
509- fix s390 patch
510
511* Fri Dec 8 2000 Than Ngo <than@redhat.com>
512- added support s390
513
514* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
515- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
516- add the CA.pl man page to the perl subpackage
517
518* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
519- always build with -mcpu=ev5 on alpha
520
521* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
522- add a symlink from cert.pem to ca-bundle.crt
523
524* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
525- add a ca-bundle file for packages like Samba to reference for CA certificates
526
527* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
528- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
529
530* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
531- add unzip as a buildprereq (#17662)
532- update m2crypto to 0.05-snap4
533
534* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
535- fix some issues in building when it's not installed
536
537* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
538- make sure the headers we include are the ones we built with (aaaaarrgh!)
539
540* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
541- add Richard Henderson's patch for BN on ia64
542- clean up the changelog
543
544* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
545- fix the building of python modules without openssl-devel already installed
546
547* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
548- byte-compile python extensions without the build-root
549- adjust the makefile to not remove temporary files (like .key files when
550  building .csr files) by marking them as .PRECIOUS
551
552* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
553- break out python extensions into a subpackage
554
555* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
556- tweak the makefile some more
557
558* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
559- disable MD2 support
560
561* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
562- disable MDC2 support
563
564* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
565- tweak the disabling of RC5, IDEA support
566- tweak the makefile
567
568* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
569- strip binaries and libraries
570- rework certificate makefile to have the right parts for Apache
571
572* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
573- use %%{_perl} instead of /usr/bin/perl
574- disable alpha until it passes its own test suite
575
576* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
577- move the passwd.1 man page out of the passwd package's way
578
579* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
580- update to 0.9.5a, modified for U.S.
581- add perl as a build-time requirement
582- move certificate makefile to another package
583- disable RC5, IDEA, RSA support
584- remove optimizations for now
585
586* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
587- Bero told me to move the Makefile into this package
588
589* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
590- add lib*.so symlinks to link dynamically against shared libs
591
592* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
593- update to 0.9.5
594- run ldconfig directly in post/postun
595- add FAQ
596
597* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
598- Fix build on non-x86 platforms
599
600* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
601- move /usr/share/ssl/* from -devel to main package
602
603* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
604- inital packaging
605- changes from base:
606  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
607  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.