source: projects/specs/trunk/o/openssl097/openssl097-vl.spec @ 521

Revision 521, 19.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 4
3%define version 0.9.7m
4%define release 1%{?_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl097
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14Source6: openssl-%{version}.pc
15Patch0: openssl-0.9.7h-soversion.patch
16Patch2: openssl-0.9.7m-rpm_opt.patch
17
18# security patch
19Patch10: http://openssl.org/news/patch-CVE-2007-3108.txt
20Patch20: openssl-0.9.7l_CVE-2007-5135.patch
21
22License: BSDish
23Group: System Environment/Libraries
24URL: http://www.openssl.org/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildPreReq: perl, sed
27Requires: mktemp
28Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
33
34%description
35The OpenSSL certificate management tool and the shared libraries that
36provide various cryptographic algorithms and protocols.
37
38%package devel
39Summary: OpenSSL libraries and development headers.
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44The static libraries and include files needed to compile apps
45with support for various the cryptographic algorithms and protocols
46supported by OpenSSL.
47
48Patches for many networking apps can be found at:
49ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
50
51%package perl
52Summary: OpenSSL scripts which require Perl.
53Group: Applications/Internet
54Requires: perl
55Requires: %{name} = %{version}-%{release}
56
57%description perl
58Perl scripts provided with OpenSSL for converting certificates and keys
59from other formats to those used by OpenSSL.
60
61## to build compat32 for x86_64 architecture support
62%package -n compat32-%{name}
63Summary: Secure Sockets Layer Toolkit
64Group: System Environment/Libraries
65Requires: mktemp
66%description -n compat32-%{name}
67The OpenSSL certificate management tool and the shared libraries that
68provide various cryptographic algorithms and protocols.
69
70%package -n compat32-%{name}-devel
71Summary: OpenSSL libraries and development headers.
72Group: Development/Libraries
73Requires: compat32-%{name} = %{version}-%{release}
74%description -n compat32-%{name}-devel
75The static libraries and include files needed to compile apps
76with support for various the cryptographic algorithms and protocols
77supported by OpenSSL.
78
79%prep
80%setup -q -n openssl-%{version}
81%patch0 -p1 -b .soversion
82%patch2 -p1 -b .rpm_opt
83
84%patch10 -p1 -b CVE-2007-3108
85%patch20 -p1 -b CVE-2007-5135
86
87chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
88chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
89chmod 644 doc/openssl_button.html doc/openssl_button.gif
90chmod 644 doc/ssleay.txt
91
92# Link the configuration header to the one we're going to make.
93ln -sf ../../crypto/opensslconf.h include/openssl/
94
95%build
96PATH=${PATH}:${PWD}/bin
97TOPDIR=${PWD}
98LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
99
100# Figure out which flags we want to use.  Can't use assembler because it's
101# not lowest-common-denominator in most cases.
102perl util/perlpath.pl `dirname %{__perl}`
103%ifarch %ix86
104sslarch=linux-elf
105sslflags="no-asm 386"
106%endif
107%ifarch ppc
108sslarch=linux-ppc
109sslflags=no-asm
110%endif
111%ifarch sparc
112sslarch=linux-sparcv9
113sslflags=no-asm
114%endif
115%ifarch ia64
116sslarch=linux-ia64
117sslflags=no-asm
118%endif
119%ifarch alpha
120sslarch=linux-alpha-gcc
121sslflags=no-asm
122%endif
123%ifarch s390
124sslarch=linux-s390
125%endif
126%ifarch s390x
127sslarch=linux-s390x
128%endif
129%ifarch mipsel
130sslarch=linux-mips
131sslflags=no-asm
132%endif
133## to build for x86_64 architecture support
134%ifarch x86_64
135sslarch=linux-x86_64
136sslflags=no-asm
137%endif
138
139# Configure the build tree.  Override OpenSSL defaults with known-good defaults
140# usable on all platforms.  The Configure script already knows to use -fPIC and
141# RPM_OPT_FLAGS, so we can skip specifiying them here.
142./Configure  \
143         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
144         shared ${sslarch}
145
146# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
147# marked as not requiring an executable stack.
148RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
149make depend
150make all build-shared
151
152# Generate hashes for the included certs.
153LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
154export LD_LIBRARY_PATH
155make rehash build-shared
156
157# Verify that what was compiled actually works.
158make -C test apps tests
159
160# Relink the main binary to get it dynamically linked.
161rm apps/openssl
162make all build-shared
163
164%install
165[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
166# Install OpenSSL.
167#install -d $RPM_BUILD_ROOT{/lib,%{_bindir},%{_includedir},%{_libdir},%{_mandir}}
168install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir}}
169make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
170install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
171# added for lib64
172mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
173mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{solibbase} $RPM_BUILD_ROOT/%{_lib}/
174mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
175rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
176rename so.%{solibbase} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{solibbase}
177#for lib in $RPM_BUILD_ROOT/lib/*.so.%{version} ; do
178for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
179        chmod 755 ${lib}
180        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
181        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`.%{soversion}
182done
183# install -m644 -D $RPM_SOURCE_DIR/openssl.pc $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
184install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
185
186# Install a makefile for generating keys and self-signed certs, and a script
187# for generating them on the fly.
188mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
189install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
190install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
191
192# Make sure we actually include the headers we built against.
193for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
194        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
195                install -m644 include/openssl/`basename ${header}` ${header}
196        fi
197done
198
199# Rename man pages so that they don't conflict with system man pages.  We used
200# to change the file extensions, but that only prevents file conflicts.  The
201# man viewer still can't select either of the two unless we physically change
202# the directory.
203for section in 1 2 3 4 5 6 7 8 ; do
204        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
205                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
206                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
207        fi
208done
209
210# Pick a CA script.
211pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
212mv CA.sh CA
213popd
214
215# Install root CA stuffs.
216cat %{SOURCE3} > ca-bundle.crt
217install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
218ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
219
220# Fix libdir.
221#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
222sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
223        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
224        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
225cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
226        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
227rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
228
229%clean
230[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
231
232%files
233%defattr(-,root,root)
234%doc FAQ LICENSE CHANGES NEWS INSTALL README
235%doc doc/README doc/c-indentation.el doc/openssl.txt
236%doc doc/openssl_button.html doc/openssl_button.gif
237%doc doc/ssleay.txt
238%dir %{_datadir}/ssl
239%attr(0755,root,root) /%{_lib}/*.so.%{version}
240
241## to build compat32 for x86_64 architecture support
242%if %{build_compat32}
243%files -n compat32-%{name}
244%defattr(-,root,root)
245%attr(0755,root,root) /%{_lib}/*.so.%{version}
246%endif
247
248%post -p /sbin/ldconfig
249
250%postun -p /sbin/ldconfig
251
252%if %{build_compat32}
253%post -n compat32-%{name} -p /sbin/ldconfig
254%postun -n compat32-%{name} -p /sbin/ldconfig
255%endif
256
257%changelog
258* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.9.7m-1vl5
259- applied new versioning policy
260
261* Sun Dec 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.7m-0vl4
262- dropped Patch1: openssl-0.9.7i.Configure-compat32.patch
263- removed %%if !%%{build_compat32} case condition
264
265* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7m-0vl3
266- add security patch in advance for CVE-2007-5135
267  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
268  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
269
270* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7m-0vl2
271- added security patch for CVE-2007-3108
272  (http://openssl.org/news/patch-CVE-2007-3108.txt)
273
274* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7m-0vl1
275- new upstream release
276- build as compat library pacakge
277
278* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
279- update (fix) openssl.pc <BTS:437>
280
281* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
282- new upstream release (with security fix)
283
284* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
285- new upstream release
286- add patch2 to use RPM_OPT macro
287
288* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
289- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
290
291* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
292- added compat32-* packages for x86_64 architecture support
293- added openssl-0.9.7i.Configure-compat32.patch
294- changed '/lib' to '/%{_lib}'
295
296* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
297- new upstream release
298
299* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
300- rebuild on VineSeed
301
302* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
303- added a security patch from Gentoo.
304  - Patch1: openssl-0.9.7c-tempfile.patch
305
306* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
307- sslarch for ppc was missing... added.
308
309* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
310- use sslarch=linux-alpha-gcc instead of alpha-gcc
311
312* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
313- new upstream version
314- clean up of spec file
315        -- removed old patches
316
317* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
318- new upstream release
319- SECURITY fix.
320  - http://www.openssl.org/news/secadv_20040317.txt
321
322* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
323- new upstream release
324- [Security fix]
325  - Vulnerabilities in ASN.1 parsing
326    http://www.openssl.org/news/secadv_20030930.txt
327- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
328
329* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
330- add openssl.pc for pkgconfig
331
332* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
333- New upstream version
334- dropped patch10, 11
335        -- merged upstream version
336
337* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
338- rebuild for VineSeed
339
340* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
341- [Security Fix]
342  - Timing-based attacks on RSA keys
343    http://www.openssl.org/news/secadv_20030317.txt
344  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
345    http://www.openssl.org/news/secadv_20030317.txt
346
347* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
348- new upstream release 0.9.6i
349- [Security Fix]
350- build for Vine Linux 2.6 errata
351
352* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
353- new upstream release 0.9.6h
354
355* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
356- new upstream release 0.9.6g
357
358* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
359- SECURITY: CAN-2002-0659 fixed
360  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
361    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
362    - update asn patch to fix accidental reversal of a logic check
363    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
364    - update asn patch to reduce chance that compiler optimization will remove
365      one of the added tests
366    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
367    - rebuild
368    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
369    - add patch to fix ASN.1 vulnerabilities
370
371* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
372- rename spec file name
373- SECURITY: CA-2002-23 fixed
374  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
375    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
376    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
377
378* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
379- added ${PATH} in LD_LIBRARY_PATH
380- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
381 
382* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
383- remove --no-<cipher>
384
385* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
386- add Patch10 for mipsel shared ( Configure )
387
388* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
389- build for Vine Linux
390- use openssl-engine-0.9.6b.tar.gz
391
392* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
393- update to 0.9.6b
394
395* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
396- move .so symlinks back to %%{_libdir}
397
398* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
399- move shared libraries to /lib (#38410)
400
401* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
402- switch to engine code base
403
404* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
405- add a script for creating dummy certificates
406- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
407
408* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
409- add s390x support
410
411* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
412- change two memcpy() calls to memmove()
413- don't define L_ENDIAN on alpha
414
415* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
416- make subpackages depend on the main package
417
418* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
419- adjust the hobble script to not disturb symlinks in include/ (fix from
420  Joe Orton)
421
422* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
423- drop the m2crypo patch we weren't using
424
425* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
426- configure using "shared" as well
427
428* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
429- update to 0.9.6a
430- use the build-shared target to build shared libraries
431- bump the soversion to 2 because we're no longer compatible with
432  our 0.9.5a packages or our 0.9.6 packages
433- drop the patch for making rsatest a no-op when rsa null support is used
434- put all man pages into <section>ssl instead of <section>
435- break the m2crypto modules into a separate package
436
437* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
438- use BN_LLONG on s390
439
440* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
441- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
442
443* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
444- move c_rehash to the perl subpackage, because it's a perl script now
445
446* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
447- update to 0.9.6
448- enable MD2
449- use the libcrypto.so and libssl.so targets to build shared libs with
450- bump the soversion to 1 because we're no longer compatible with any of
451  the various 0.9.5a packages circulating around, which provide lib*.so.0
452
453* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
454- change hobble-openssl for disabling MD2 again
455
456* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
457- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
458  bytes or so, causing EVP_DigestInit() to zero out stack variables in
459  apps built against a version of the library without it
460
461* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
462- disable some inline assembly, which on x86 is Pentium-specific
463- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
464
465* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
466- fix s390 patch
467
468* Fri Dec 8 2000 Than Ngo <than@redhat.com>
469- added support s390
470
471* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
472- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
473- add the CA.pl man page to the perl subpackage
474
475* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
476- always build with -mcpu=ev5 on alpha
477
478* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
479- add a symlink from cert.pem to ca-bundle.crt
480
481* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
482- add a ca-bundle file for packages like Samba to reference for CA certificates
483
484* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
485- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
486
487* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
488- add unzip as a buildprereq (#17662)
489- update m2crypto to 0.05-snap4
490
491* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
492- fix some issues in building when it's not installed
493
494* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
495- make sure the headers we include are the ones we built with (aaaaarrgh!)
496
497* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
498- add Richard Henderson's patch for BN on ia64
499- clean up the changelog
500
501* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
502- fix the building of python modules without openssl-devel already installed
503
504* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
505- byte-compile python extensions without the build-root
506- adjust the makefile to not remove temporary files (like .key files when
507  building .csr files) by marking them as .PRECIOUS
508
509* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
510- break out python extensions into a subpackage
511
512* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
513- tweak the makefile some more
514
515* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
516- disable MD2 support
517
518* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
519- disable MDC2 support
520
521* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
522- tweak the disabling of RC5, IDEA support
523- tweak the makefile
524
525* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
526- strip binaries and libraries
527- rework certificate makefile to have the right parts for Apache
528
529* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
530- use %%{_perl} instead of /usr/bin/perl
531- disable alpha until it passes its own test suite
532
533* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
534- move the passwd.1 man page out of the passwd package's way
535
536* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
537- update to 0.9.5a, modified for U.S.
538- add perl as a build-time requirement
539- move certificate makefile to another package
540- disable RC5, IDEA, RSA support
541- remove optimizations for now
542
543* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
544- Bero told me to move the Makefile into this package
545
546* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
547- add lib*.so symlinks to link dynamically against shared libs
548
549* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
550- update to 0.9.5
551- run ldconfig directly in post/postun
552- add FAQ
553
554* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
555- Fix build on non-x86 platforms
556
557* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
558- move /usr/share/ssl/* from -devel to main package
559
560* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
561- inital packaging
562- changes from base:
563  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
564  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.