source: projects/specs/trunk/o/openssl096/openssl096-vl.spec @ 521

Revision 521, 14.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define soversion 2
2
3Summary: Secure Sockets Layer Toolkit
4Name: openssl096
5Version: 0.9.6m
6Release: 1%{?_dist_release}
7Source: openssl-engine-%{version}.tar.gz
8Source1: hobble-openssl
9Source2: Makefile.certificate
10Source3: ca-bundle.crt
11Source4: RHNS-CA-CERT
12Source5: make-dummy-cert
13Source6: openssl.pc
14Patch0: openssl-0.9.6m-rpm.patch
15Patch1: openssl-0.9.5a-64.patch
16Patch2: openssl-0.9.5a-defaults.patch
17Patch3: openssl-0.9.5a-ia64.patch
18Patch4: openssl-0.9.6g-glibc.patch
19Patch5: openssl-0.9.6g-soversion.patch
20
21# security fix
22Patch106: openssl-CAN-2005-2969.patch
23Patch107: openssl-0.9.7d-CVE-2006-4339.patch
24Patch108: openssl-engine-0.9.6b-cve-2006-2940.patch
25Patch109: openssl-0.9.6b-cve-2006-3738.patch
26Patch110: openssl-0.9.8b-cve-2006-4343.patch
27Patch120: openssl-0.9.6m_CVE-2007-3108.patch
28Patch130: openssl-0.9.6m_CVE-2007-5135.patch
29Patch140: openssl-0.9.6m_CVE-2006-4339.patch
30
31License: BSDish
32Group: System Environment/Libraries
33URL: http://www.openssl.org/
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35BuildPreReq: perl, sed
36Requires: mktemp
37
38Distribution: Vine Linux
39Vendor: Project Vine
40Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
41
42%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
43
44%description
45The OpenSSL certificate management tool and the shared libraries that
46provide various cryptographic algorithms and protocols.
47
48%package devel
49Summary: OpenSSL libraries and development headers.
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description devel
54The static libraries and include files needed to compile apps
55with support for various the cryptographic algorithms and protocols
56supported by OpenSSL.
57
58Patches for many networking apps can be found at:
59ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
60
61%package perl
62Summary: OpenSSL scripts which require Perl.
63Group: Applications/Internet
64Requires: perl
65Requires: %{name} = %{version}-%{release}
66
67%description perl
68Perl scripts provided with OpenSSL for converting certificates and keys
69from other formats to those used by OpenSSL.
70
71%prep
72%setup -q -n openssl-engine-%{version}
73#%{SOURCE1}
74%patch0 -p1 -b .redhat
75%patch1 -p1 -b .64
76%patch2 -p1 -b .defaults
77%patch3 -p1 -b .ia64
78%patch4 -p1 -b .glibc
79%patch5 -p1 -b .soversion
80
81# security fix
82%patch106 -p0 -b .CAN-2005-2969
83%patch107 -p1 -b .CVE-2006-4339
84%patch108 -p1 -b .CVE-2006-2940
85%patch109 -p1 -b .CVE-2006-3738
86%patch110 -p0 -b .CVE-2006-4343
87%patch120 -p0 -b .CVE-2007-3108
88%patch130 -p1 -b .CVE-2007-5135
89%patch140 -p1 -b .CVE-2006-4339
90
91chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
92chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
93chmod 644 doc/openssl_button.html doc/openssl_button.gif
94chmod 644 doc/ssleay.txt
95
96# Link the configuration header to the one we're going to make.
97ln -sf ../../crypto/opensslconf.h include/openssl/
98
99%build
100PATH=${PATH}:${PWD}/bin
101TOPDIR=${PWD}
102LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
103
104# Figure out which flags we want to use.  Can't use assembler because it's
105# not lowest-common-denominator in most cases.
106perl util/perlpath.pl `dirname %{__perl}`
107%ifarch %ix86
108sslarch=linux-elf
109sslflags="no-asm 386"
110%endif
111%ifarch sparc
112sslarch=linux-sparcv9
113sslflags=no-asm
114%endif
115%ifarch ia64
116sslarch=linux-ia64
117sslflags=no-asm
118%endif
119%ifarch alpha
120sslarch=alpha-gcc
121sslflags=no-asm
122%endif
123%ifarch s390
124sslarch=linux-s390
125%endif
126%ifarch s390x
127sslarch=linux-s390x
128%endif
129%ifarch mipsel
130sslarch=linux-mips
131sslflags=no-asm
132%endif
133# Configure the build tree.  Override OpenSSL defaults with known-good defaults
134# usable on all platforms.  The Configure script already knows to use -fPIC and
135# RPM_OPT_FLAGS, so we can skip specifiying them here.
136./config --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} shared
137make all build-shared
138
139# Generate hashes for the included certs.
140make rehash build-shared
141
142# Verify that what was compiled actually works.
143make -C test apps tests
144
145# Relink the main binary to get it dynamically linked.
146rm apps/openssl
147make all build-shared
148
149%install
150[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
151# Install OpenSSL.
152install -d $RPM_BUILD_ROOT{/lib,%{_bindir},%{_includedir},%{_libdir},%{_mandir}}
153make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
154install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
155mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{solibbase} $RPM_BUILD_ROOT/lib/
156mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
157rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
158rename so.%{solibbase} so.%{version} $RPM_BUILD_ROOT/lib/*.so.%{solibbase}
159for lib in $RPM_BUILD_ROOT/lib/*.so.%{version} ; do
160        chmod 755 ${lib}
161        ln -s -f ../../lib/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
162        ln -s -f ../../lib/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`.%{soversion}
163done
164
165%clean
166[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
167
168%files
169%defattr(-,root,root)
170%doc FAQ LICENSE CHANGES NEWS INSTALL README
171%doc doc/README doc/c-indentation.el doc/openssl.txt
172%doc doc/openssl_button.html doc/openssl_button.gif
173%doc doc/ssleay.txt
174%attr(0755,root,root) /lib/*.so.%{version}
175
176%post -p /sbin/ldconfig
177
178%postun -p /sbin/ldconfig
179
180%changelog
181* Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6m-1vl5
182- applied new versioning policy
183
184* Tue Oct 23 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
185- 0.9.6m-0vl5
186- add patch120 for fix CVE-2007-3108 (Montgomery:BN_from_montgomery())
187- add patch130 for fix CVE-2007-5135
188- add patch140 for fix CVE-2006-4339 (RSA key with exponent 3)
189
190* Fri Sep 29 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
191- 0.9.6m-0vl4
192- add Patch108 for fix CVE-2006-2940
193- add Patch109 for fix CVE-2006-3738
194- add Patch110 for fix CVE-2006-4343
195- change patch No. (patch6 -> 106, patch7 -> 107)
196
197* Mon Sep 11 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
198- 0.9.6m-0vl3
199- add patch7 for fix CVE-2006-4339
200
201* Sat Jul  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.6m-0vl2
202- rebuilt for VineSeed
203
204* Thu Oct 13 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
205- 0.9.6m-0vl1.1
206- add patch6 for fix CAN-2005-2969
207
208* Fri Mar 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
209- new upstream release
210- SECURITY fix.
211  - http://www.openssl.org/news/secadv_20040317.txt
212- build as compatibility package 
213
214* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
215- new upstream release
216- [Security fix]
217  - Vulnerabilities in ASN.1 parsing
218    http://www.openssl.org/news/secadv_20030930.txt
219- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
220
221* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
222- add openssl.pc for pkgconfig
223
224* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
225- New upstream version
226- dropped patch10, 11
227        -- merged upstream version
228
229* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
230- rebuild for VineSeed
231
232* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
233- [Security Fix]
234  - Timing-based attacks on RSA keys
235    http://www.openssl.org/news/secadv_20030317.txt
236  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
237    http://www.openssl.org/news/secadv_20030317.txt
238
239* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
240- new upstream release 0.9.6i
241- [Security Fix]
242- build for Vine Linux 2.6 errata
243
244* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
245- new upstream release 0.9.6h
246
247* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
248- new upstream release 0.9.6g
249
250* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
251- SECURITY: CAN-2002-0659 fixed
252  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
253    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
254    - update asn patch to fix accidental reversal of a logic check
255    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
256    - update asn patch to reduce chance that compiler optimization will remove
257      one of the added tests
258    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
259    - rebuild
260    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
261    - add patch to fix ASN.1 vulnerabilities
262
263* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
264- rename spec file name
265- SECURITY: CA-2002-23 fixed
266  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
267    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
268    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
269
270* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
271- added ${PATH} in LD_LIBRARY_PATH
272- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
273 
274* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
275- remove --no-<cipher>
276
277* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
278- add Patch10 for mipsel shared ( Configure )
279
280* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
281- build for Vine Linux
282- use openssl-engine-0.9.6b.tar.gz
283
284* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
285- update to 0.9.6b
286
287* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
288- move .so symlinks back to %%{_libdir}
289
290* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
291- move shared libraries to /lib (#38410)
292
293* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
294- switch to engine code base
295
296* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
297- add a script for creating dummy certificates
298- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
299
300* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
301- add s390x support
302
303* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
304- change two memcpy() calls to memmove()
305- don't define L_ENDIAN on alpha
306
307* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
308- make subpackages depend on the main package
309
310* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
311- adjust the hobble script to not disturb symlinks in include/ (fix from
312  Joe Orton)
313
314* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
315- drop the m2crypo patch we weren't using
316
317* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
318- configure using "shared" as well
319
320* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
321- update to 0.9.6a
322- use the build-shared target to build shared libraries
323- bump the soversion to 2 because we're no longer compatible with
324  our 0.9.5a packages or our 0.9.6 packages
325- drop the patch for making rsatest a no-op when rsa null support is used
326- put all man pages into <section>ssl instead of <section>
327- break the m2crypto modules into a separate package
328
329* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
330- use BN_LLONG on s390
331
332* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
333- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
334
335* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
336- move c_rehash to the perl subpackage, because it's a perl script now
337
338* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
339- update to 0.9.6
340- enable MD2
341- use the libcrypto.so and libssl.so targets to build shared libs with
342- bump the soversion to 1 because we're no longer compatible with any of
343  the various 0.9.5a packages circulating around, which provide lib*.so.0
344
345* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
346- change hobble-openssl for disabling MD2 again
347
348* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
349- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
350  bytes or so, causing EVP_DigestInit() to zero out stack variables in
351  apps built against a version of the library without it
352
353* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
354- disable some inline assembly, which on x86 is Pentium-specific
355- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
356
357* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
358- fix s390 patch
359
360* Fri Dec 8 2000 Than Ngo <than@redhat.com>
361- added support s390
362
363* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
364- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
365- add the CA.pl man page to the perl subpackage
366
367* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
368- always build with -mcpu=ev5 on alpha
369
370* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
371- add a symlink from cert.pem to ca-bundle.crt
372
373* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
374- add a ca-bundle file for packages like Samba to reference for CA certificates
375
376* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
377- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
378
379* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
380- add unzip as a buildprereq (#17662)
381- update m2crypto to 0.05-snap4
382
383* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
384- fix some issues in building when it's not installed
385
386* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
387- make sure the headers we include are the ones we built with (aaaaarrgh!)
388
389* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
390- add Richard Henderson's patch for BN on ia64
391- clean up the changelog
392
393* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
394- fix the building of python modules without openssl-devel already installed
395
396* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
397- byte-compile python extensions without the build-root
398- adjust the makefile to not remove temporary files (like .key files when
399  building .csr files) by marking them as .PRECIOUS
400
401* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
402- break out python extensions into a subpackage
403
404* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
405- tweak the makefile some more
406
407* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
408- disable MD2 support
409
410* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
411- disable MDC2 support
412
413* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
414- tweak the disabling of RC5, IDEA support
415- tweak the makefile
416
417* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
418- strip binaries and libraries
419- rework certificate makefile to have the right parts for Apache
420
421* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
422- use %%{_perl} instead of /usr/bin/perl
423- disable alpha until it passes its own test suite
424
425* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
426- move the passwd.1 man page out of the passwd package's way
427
428* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
429- update to 0.9.5a, modified for U.S.
430- add perl as a build-time requirement
431- move certificate makefile to another package
432- disable RC5, IDEA, RSA support
433- remove optimizations for now
434
435* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
436- Bero told me to move the Makefile into this package
437
438* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
439- add lib*.so symlinks to link dynamically against shared libs
440
441* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
442- update to 0.9.5
443- run ldconfig directly in post/postun
444- add FAQ
445
446* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
447- Fix build on non-x86 platforms
448
449* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
450- move /usr/share/ssl/* from -devel to main package
451
452* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
453- inital packaging
454- changes from base:
455  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
456  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.