source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 9657

Revision 9657, 25.8 KB checked in by iwamoto, 9 years ago (diff)

openssl: update to 1.0.1p

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1p
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source6: make-dummy-cert
13Source7: renew-dummy-cert
14
15Patch0: openssl-1.0.0-soversion.patch
16Patch2: openssl-1.0.1-rpm_opt.patch
17Patch4: openssl-1.0.0-enginesdir.patch
18Patch5: openssl-1.0.1m-version-add-engines.patch
19Patch8: openssl-1.0.1c-perlfind.patch
20
21# security fix
22# nothing ;-)
23
24License: BSDish
25Group: System Environment/Libraries
26URL: http://www.openssl.org/
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: perl, sed
30BuildRequires: zlib-devel, krb5-devel
31
32Requires: mktemp
33Requires: ca-certificates
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: daisuke, iwamoto
38
39%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
40
41%description
42The OpenSSL certificate management tool and the shared libraries that
43provide various cryptographic algorithms and protocols.
44
45%package devel
46Summary: OpenSSL libraries and development headers.
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49Requires: krb5-devel
50
51%description devel
52The static libraries and include files needed to compile apps
53with support for various the cryptographic algorithms and protocols
54supported by OpenSSL.
55
56Patches for many networking apps can be found at:
57ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
58
59%package static
60Summary:  Libraries for static linking of applications which will use OpenSSL
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65OpenSSL is a toolkit for supporting cryptography. The openssl-static
66package contains static libraries needed for static linking of
67applications which support various cryptographic algorithms and
68protocols.
69
70%package perl
71Summary: OpenSSL scripts which require Perl.
72Group: Applications/Internet
73Requires: perl
74Requires: %{name} = %{version}-%{release}
75
76%description perl
77Perl scripts provided with OpenSSL for converting certificates and keys
78from other formats to those used by OpenSSL.
79
80## to build compat32 for x86_64 architecture support
81%package -n compat32-%{name}
82Summary: Secure Sockets Layer Toolkit
83Group: System Environment/Libraries
84Requires: %{name} = %{version}-%{release}
85%description -n compat32-%{name}
86The OpenSSL certificate management tool and the shared libraries that
87provide various cryptographic algorithms and protocols.
88
89%package -n compat32-%{name}-devel
90Summary: OpenSSL libraries and development headers.
91Group: Development/Libraries
92Requires: compat32-%{name} = %{version}-%{release}
93Requires: compat32-krb5-devel
94%description -n compat32-%{name}-devel
95The static libraries and include files needed to compile apps
96with support for various the cryptographic algorithms and protocols
97supported by OpenSSL.
98
99%prep
100%setup -q -n openssl-%{version}
101%patch0 -p1 -b .soversion
102%patch2 -p1 -b .rpm_opt
103%patch4 -p1 -b .enginesdir
104%patch5 -p1 -b .version-add-engines
105%patch8 -p1 -b .perlfind
106
107# security fix
108# nothing ;-)
109
110chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
111chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
112chmod 644 doc/openssl_button.html doc/openssl_button.gif
113chmod 644 doc/ssleay.txt
114
115# Link the configuration header to the one we're going to make.
116ln -sf ../../crypto/opensslconf.h include/openssl/
117
118%build
119PATH=${PATH}:${PWD}/bin
120TOPDIR=${PWD}
121LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
122
123# Modify the various perl scripts to reference perl in the right location.
124perl util/perlpath.pl `dirname %{__perl}`
125
126# Generate a table with the compile settings for my perusal.
127touch Makefile
128make TABLE PERL=%{__perl}
129
130# Figure out which flags we want to use.
131# default
132sslarch=%{_os}-%{_target_cpu}
133#
134%ifarch %ix86
135sslarch=linux-elf
136if ! echo %{_target} | grep -q i686 ; then
137   sslflags="no-asm 386"
138fi
139%endif
140%ifarch sparcv9
141sslarch=linux-sparcv9
142sslflags=no-asm
143%endif
144%ifarch sparc64
145sslarch=linux64-sparcv9
146sslflags=no-asm
147%endif
148%ifarch alpha alphaev56 alphaev6 alphaev67
149sslarch=linux-alpha-gcc
150%endif
151%ifarch s390 sh3eb sh4eb
152sslarch="linux-generic32 -DB_ENDIAN"
153%endif
154%ifarch s390x
155sslarch="linux64-s390x"
156%endif
157%ifarch %{arm} sh3 sh4
158sslarch=linux-generic32
159%endif
160# ia64/x86_64/ppc\ppc64 are OK by default.
161
162# Configure the build tree.  Override OpenSSL defaults with known-good defaults
163# usable on all platforms.  The Configure script already knows to use -fPIC and
164# RPM_OPT_FLAGS, so we can skip specifiying them here.
165./Configure  \
166         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
167         zlib-dynamic enable-camellia enable-seed enable-tlsext \
168         enable-rfc3779 enable-cms enable-md2 \
169         --enginesdir=%{_libdir}/openssl/engines \
170         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
171         shared ${sslarch}
172
173# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
174# marked as not requiring an executable stack.
175RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
176make depend
177make all build-shared
178
179# Generate hashes for the included certs.
180LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
181export LD_LIBRARY_PATH
182make rehash build-shared
183
184# Verify that what was compiled actually works.
185make -C test apps tests
186
187# Relink the main binary to get it dynamically linked.
188rm apps/openssl
189make all build-shared
190
191%install
192[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
193# Install OpenSSL.
194install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
195make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
196install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
197# added for lib64
198# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
199mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
200# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
201mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
202mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
203rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
204rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
205for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
206        chmod 755 ${lib}
207        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
208        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
209done
210# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
211
212# Install a makefile for generating keys and self-signed certs, and a script
213# for generating them on the fly.
214mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
215install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
216install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
217install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
218
219# Make sure we actually include the headers we built against.
220for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
221        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
222                install -m644 include/openssl/`basename ${header}` ${header}
223        fi
224done
225
226# Rename man pages so that they don't conflict with system man pages.  We used
227# to change the file extensions, but that only prevents file conflicts.  The
228# man viewer still can't select either of the two unless we physically change
229# the directory.
230for section in 1 2 3 4 5 6 7 8 ; do
231        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
232                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
233                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
234        fi
235done
236
237# Pick a CA script.
238pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
239mv CA.sh CA
240popd
241
242mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
243mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
245mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
246mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
247
248# Ensure the openssl.cnf timestamp is identical across builds to avoid
249# mulitlib conflicts and unnecessary renames on upgrade
250touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
251
252%clean
253[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
254
255%files
256%defattr(-,root,root)
257%doc FAQ LICENSE CHANGES NEWS INSTALL README
258%doc doc/README doc/c-indentation.el doc/openssl.txt
259%doc doc/openssl_button.html doc/openssl_button.gif
260%doc doc/ssleay.txt
261
262%{_sysconfdir}/pki/tls/certs/make-dummy-cert
263%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
264%{_sysconfdir}/pki/tls/certs/Makefile
265%{_sysconfdir}/pki/tls/misc/CA
266%dir %{_sysconfdir}/pki/CA
267%dir %{_sysconfdir}/pki/CA/private
268%dir %{_sysconfdir}/pki/CA/certs
269%dir %{_sysconfdir}/pki/CA/crl
270%dir %{_sysconfdir}/pki/CA/newcerts
271%{_sysconfdir}/pki/tls/misc/c_*
272%dir %{_sysconfdir}/pki/tls
273%dir %{_sysconfdir}/pki/tls/certs
274%dir %{_sysconfdir}/pki/tls/misc
275%dir %{_sysconfdir}/pki/tls/private
276%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
277
278%attr(0755,root,root) %{_bindir}/openssl
279%attr(0755,root,root) /%{_lib}/*.so.*
280%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
281%attr(0755,root,root) %dir %{_mandir}/man1*
282%attr(0644,root,root) %{_mandir}/man1*/*
283%attr(0755,root,root) %dir %{_mandir}/man5*
284%attr(0644,root,root) %{_mandir}/man5*/*
285%attr(0755,root,root) %dir %{_mandir}/man7*
286%attr(0644,root,root) %{_mandir}/man7*/*
287
288%files devel
289%defattr(-,root,root)
290%{_prefix}/include/openssl
291%exclude %{_libdir}/lib*.a
292%attr(0755,root,root) %{_libdir}/*.so
293%attr(0755,root,root) %dir %{_mandir}/man3*
294%attr(0644,root,root) %{_mandir}/man3*/*
295%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
296
297%files static
298%defattr(-,root,root)
299%attr(0644,root,root) %{_libdir}/*.a
300
301%files perl
302%defattr(-,root,root)
303%attr(0755,root,root) %{_bindir}/c_rehash
304%attr(0755,root,root) %dir %{_mandir}/man1*
305%attr(0644,root,root) %{_mandir}/man1*/*.pl*
306%{_sysconfdir}/pki/tls/misc/*.pl
307#%{_sysconfdir}/pki/tls/misc/tsget
308%doc apps/tsget
309
310## to build compat32 for x86_64 architecture support
311%if %{build_compat32}
312%files -n compat32-%{name}
313%defattr(-,root,root)
314%attr(0755,root,root) /%{_lib}/*.so.*
315
316%files -n compat32-%{name}-devel
317%defattr(-,root,root)
318%exclude %{_libdir}/lib*.a
319%attr(0755,root,root) %{_libdir}/*.so
320%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
321%endif
322
323%post -p /sbin/ldconfig
324
325%postun -p /sbin/ldconfig
326
327%post -n compat32-%{name} -p /sbin/ldconfig
328
329%postun -n compat32-%{name} -p /sbin/ldconfig
330
331%changelog
332* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
333- new upstream release with security fixes
334
335* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
336- new upstream release
337
338* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
339- merged into Vine6
340  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
341  - new upstream release with security fixes 
342  - update Patch2,5
343
344* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
345- new upstream release with security fixes 
346
347* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
348- new upstream release with security fixes
349- add patch8 from fc21 (fix perl find.pl)
350
351* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
352- new upstream release with security fixes.
353
354* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
355- new upstream release with security fixes
356
357* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
358- new upstream release with security fixes
359
360* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
361- move root CA bundle to ca-certificates package
362
363* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
364- update to 1.0.1e
365  - 1.0.1d has major regressions from 1.0.1c
366
367* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
368- remove tsget script to delete dependency perl(WWW::Curl::Easy)
369 - openssl-perl package contains it in docdir
370
371* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
372- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
373- fixed %%files
374
375* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
376- update to 1.0.1c
377- enable configure options:
378  enable-camellia enable-seed enable-tlsext enable-rfc3779
379  enable-cms enable-md2
380- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
381- generate a table with the compile settings before configure
382
383* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
384- new upstream release with security fix (CVE-2012-0050)
385
386* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
387- new upstream release with security fix
388  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
389
390* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
391- new upstream release with security fix (CVE-2011-3207, 3210)
392
393* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
394- rebuild with krb5-libs 1.8
395
396* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
397- new upstream release with security fix
398
399* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
400- use upstream openssl.pc instead of vine original one (SOURCE6)
401
402* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
403- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
404
405* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
406- add R: krb5-devel into devel pkg
407- add R: compat32-krb5-devel into compat32-devel pkg
408
409* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
410- new upstream release 1.0.0x
411- separate static libs into static package
412- change configure options
413- change so version 10
414- add tsget into perl package
415- update all patches
416
417* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
418- fix changelog typo...
419
420* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
421- new upstream release with security fix (CVE-2010-4180)
422
423* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
424- new upstream release with security fix (CVE-2010-3864)
425- drop patches included in new release
426- update patch4
427
428* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
429- add patch12 for fix CVE-2009-3555 (renegotiation)
430
431* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
432- add patch11 for fix CVE-2009-4355 (memory leak)
433
434* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
435- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
436
437* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
438- removed unnecessary %%if %{build_compat32} statements
439- removed lib*.a from devel package
440
441* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
442- new upstream release with security fix (CVE-2000-0590,0591,0789)
443
444* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
445- new upstream release with security fix (CVE-2008-5077)
446
447* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
448- new upstream release
449
450* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
451- new upstream release
452- new versioning policy
453
454* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
455- new upstream release
456- drop patch10,20 which is merged in upstream
457
458* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
459- add security patch in advance for CVE-2007-5135
460  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
461  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
462
463* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
464- add security patch for CVE-2007-3108
465  (http://openssl.org/news/patch-CVE-2007-3108.txt)
466
467* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
468- new upstream release
469
470* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
471- update (fix) openssl.pc <BTS:437>
472
473* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
474- new upstream release (with security fix)
475
476* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
477- new upstream release
478- add patch2 to use RPM_OPT macro
479
480* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
481- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
482
483* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
484- added compat32-* packages for x86_64 architecture support
485- added openssl-0.9.7i.Configure-compat32.patch
486- changed '/lib' to '/%{_lib}'
487
488* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
489- new upstream release
490
491* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
492- rebuild on VineSeed
493
494* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
495- added a security patch from Gentoo.
496  - Patch1: openssl-0.9.7c-tempfile.patch
497
498* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
499- sslarch for ppc was missing... added.
500
501* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
502- use sslarch=linux-alpha-gcc instead of alpha-gcc
503
504* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
505- new upstream version
506- clean up of spec file
507        -- removed old patches
508
509* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
510- new upstream release
511- SECURITY fix.
512  - http://www.openssl.org/news/secadv_20040317.txt
513
514* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
515- new upstream release
516- [Security fix]
517  - Vulnerabilities in ASN.1 parsing
518    http://www.openssl.org/news/secadv_20030930.txt
519- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
520
521* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
522- add openssl.pc for pkgconfig
523
524* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
525- New upstream version
526- dropped patch10, 11
527        -- merged upstream version
528
529* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
530- rebuild for VineSeed
531
532* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
533- [Security Fix]
534  - Timing-based attacks on RSA keys
535    http://www.openssl.org/news/secadv_20030317.txt
536  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
537    http://www.openssl.org/news/secadv_20030317.txt
538
539* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
540- new upstream release 0.9.6i
541- [Security Fix]
542- build for Vine Linux 2.6 errata
543
544* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
545- new upstream release 0.9.6h
546
547* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
548- new upstream release 0.9.6g
549
550* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
551- SECURITY: CAN-2002-0659 fixed
552  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
553    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
554    - update asn patch to fix accidental reversal of a logic check
555    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
556    - update asn patch to reduce chance that compiler optimization will remove
557      one of the added tests
558    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
559    - rebuild
560    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
561    - add patch to fix ASN.1 vulnerabilities
562
563* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
564- rename spec file name
565- SECURITY: CA-2002-23 fixed
566  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
567    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
568    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
569
570* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
571- added ${PATH} in LD_LIBRARY_PATH
572- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
573 
574* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
575- remove --no-<cipher>
576
577* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
578- add Patch10 for mipsel shared ( Configure )
579
580* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
581- build for Vine Linux
582- use openssl-engine-0.9.6b.tar.gz
583
584* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
585- update to 0.9.6b
586
587* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
588- move .so symlinks back to %%{_libdir}
589
590* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
591- move shared libraries to /lib (#38410)
592
593* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
594- switch to engine code base
595
596* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
597- add a script for creating dummy certificates
598- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
599
600* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
601- add s390x support
602
603* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
604- change two memcpy() calls to memmove()
605- don't define L_ENDIAN on alpha
606
607* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
608- make subpackages depend on the main package
609
610* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
611- adjust the hobble script to not disturb symlinks in include/ (fix from
612  Joe Orton)
613
614* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
615- drop the m2crypo patch we weren't using
616
617* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
618- configure using "shared" as well
619
620* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
621- update to 0.9.6a
622- use the build-shared target to build shared libraries
623- bump the soversion to 2 because we're no longer compatible with
624  our 0.9.5a packages or our 0.9.6 packages
625- drop the patch for making rsatest a no-op when rsa null support is used
626- put all man pages into <section>ssl instead of <section>
627- break the m2crypto modules into a separate package
628
629* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
630- use BN_LLONG on s390
631
632* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
633- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
634
635* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
636- move c_rehash to the perl subpackage, because it's a perl script now
637
638* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
639- update to 0.9.6
640- enable MD2
641- use the libcrypto.so and libssl.so targets to build shared libs with
642- bump the soversion to 1 because we're no longer compatible with any of
643  the various 0.9.5a packages circulating around, which provide lib*.so.0
644
645* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
646- change hobble-openssl for disabling MD2 again
647
648* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
649- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
650  bytes or so, causing EVP_DigestInit() to zero out stack variables in
651  apps built against a version of the library without it
652
653* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
654- disable some inline assembly, which on x86 is Pentium-specific
655- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
656
657* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
658- fix s390 patch
659
660* Fri Dec 8 2000 Than Ngo <than@redhat.com>
661- added support s390
662
663* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
664- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
665- add the CA.pl man page to the perl subpackage
666
667* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
668- always build with -mcpu=ev5 on alpha
669
670* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
671- add a symlink from cert.pem to ca-bundle.crt
672
673* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
674- add a ca-bundle file for packages like Samba to reference for CA certificates
675
676* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
677- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
678
679* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
680- add unzip as a buildprereq (#17662)
681- update m2crypto to 0.05-snap4
682
683* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
684- fix some issues in building when it's not installed
685
686* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
687- make sure the headers we include are the ones we built with (aaaaarrgh!)
688
689* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
690- add Richard Henderson's patch for BN on ia64
691- clean up the changelog
692
693* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
694- fix the building of python modules without openssl-devel already installed
695
696* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
697- byte-compile python extensions without the build-root
698- adjust the makefile to not remove temporary files (like .key files when
699  building .csr files) by marking them as .PRECIOUS
700
701* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
702- break out python extensions into a subpackage
703
704* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
705- tweak the makefile some more
706
707* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
708- disable MD2 support
709
710* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
711- disable MDC2 support
712
713* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
714- tweak the disabling of RC5, IDEA support
715- tweak the makefile
716
717* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
718- strip binaries and libraries
719- rework certificate makefile to have the right parts for Apache
720
721* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
722- use %%{_perl} instead of /usr/bin/perl
723- disable alpha until it passes its own test suite
724
725* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
726- move the passwd.1 man page out of the passwd package's way
727
728* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
729- update to 0.9.5a, modified for U.S.
730- add perl as a build-time requirement
731- move certificate makefile to another package
732- disable RC5, IDEA, RSA support
733- remove optimizations for now
734
735* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
736- Bero told me to move the Makefile into this package
737
738* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
739- add lib*.so symlinks to link dynamically against shared libs
740
741* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
742- update to 0.9.5
743- run ldconfig directly in post/postun
744- add FAQ
745
746* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
747- Fix build on non-x86 platforms
748
749* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
750- move /usr/share/ssl/* from -devel to main package
751
752* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
753- inital packaging
754- changes from base:
755  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
756  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.