source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 9499

Revision 9499, 25.6 KB checked in by Takemikaduchi, 9 years ago (diff)

merge into Vine6

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1m
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source6: make-dummy-cert
13Source7: renew-dummy-cert
14
15Patch0: openssl-1.0.0-soversion.patch
16Patch2: openssl-1.0.1-rpm_opt.patch
17Patch4: openssl-1.0.0-enginesdir.patch
18Patch5: openssl-1.0.1m-version-add-engines.patch
19Patch8: openssl-1.0.1c-perlfind.patch
20
21# security fix
22# nothing ;-)
23
24License: BSDish
25Group: System Environment/Libraries
26URL: http://www.openssl.org/
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-root
29BuildRequires: perl, sed
30BuildRequires: zlib-devel, krb5-devel
31
32Requires: mktemp
33Requires: ca-certificates
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: daisuke, iwamoto
38
39%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
40
41%description
42The OpenSSL certificate management tool and the shared libraries that
43provide various cryptographic algorithms and protocols.
44
45%package devel
46Summary: OpenSSL libraries and development headers.
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49Requires: krb5-devel
50
51%description devel
52The static libraries and include files needed to compile apps
53with support for various the cryptographic algorithms and protocols
54supported by OpenSSL.
55
56Patches for many networking apps can be found at:
57ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
58
59%package static
60Summary:  Libraries for static linking of applications which will use OpenSSL
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65OpenSSL is a toolkit for supporting cryptography. The openssl-static
66package contains static libraries needed for static linking of
67applications which support various cryptographic algorithms and
68protocols.
69
70%package perl
71Summary: OpenSSL scripts which require Perl.
72Group: Applications/Internet
73Requires: perl
74Requires: %{name} = %{version}-%{release}
75
76%description perl
77Perl scripts provided with OpenSSL for converting certificates and keys
78from other formats to those used by OpenSSL.
79
80## to build compat32 for x86_64 architecture support
81%package -n compat32-%{name}
82Summary: Secure Sockets Layer Toolkit
83Group: System Environment/Libraries
84Requires: %{name} = %{version}-%{release}
85%description -n compat32-%{name}
86The OpenSSL certificate management tool and the shared libraries that
87provide various cryptographic algorithms and protocols.
88
89%package -n compat32-%{name}-devel
90Summary: OpenSSL libraries and development headers.
91Group: Development/Libraries
92Requires: compat32-%{name} = %{version}-%{release}
93Requires: compat32-krb5-devel
94%description -n compat32-%{name}-devel
95The static libraries and include files needed to compile apps
96with support for various the cryptographic algorithms and protocols
97supported by OpenSSL.
98
99%prep
100%setup -q -n openssl-%{version}
101%patch0 -p1 -b .soversion
102%patch2 -p1 -b .rpm_opt
103%patch4 -p1 -b .enginesdir
104%patch5 -p1 -b .version-add-engines
105%patch8 -p1 -b .perlfind
106
107# security fix
108# nothing ;-)
109
110chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
111chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
112chmod 644 doc/openssl_button.html doc/openssl_button.gif
113chmod 644 doc/ssleay.txt
114
115# Link the configuration header to the one we're going to make.
116ln -sf ../../crypto/opensslconf.h include/openssl/
117
118%build
119PATH=${PATH}:${PWD}/bin
120TOPDIR=${PWD}
121LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
122
123# Modify the various perl scripts to reference perl in the right location.
124perl util/perlpath.pl `dirname %{__perl}`
125
126# Generate a table with the compile settings for my perusal.
127touch Makefile
128make TABLE PERL=%{__perl}
129
130# Figure out which flags we want to use.
131# default
132sslarch=%{_os}-%{_target_cpu}
133#
134%ifarch %ix86
135sslarch=linux-elf
136if ! echo %{_target} | grep -q i686 ; then
137   sslflags="no-asm 386"
138fi
139%endif
140%ifarch sparcv9
141sslarch=linux-sparcv9
142sslflags=no-asm
143%endif
144%ifarch sparc64
145sslarch=linux64-sparcv9
146sslflags=no-asm
147%endif
148%ifarch alpha alphaev56 alphaev6 alphaev67
149sslarch=linux-alpha-gcc
150%endif
151%ifarch s390 sh3eb sh4eb
152sslarch="linux-generic32 -DB_ENDIAN"
153%endif
154%ifarch s390x
155sslarch="linux64-s390x"
156%endif
157%ifarch %{arm} sh3 sh4
158sslarch=linux-generic32
159%endif
160# ia64/x86_64/ppc\ppc64 are OK by default.
161
162# Configure the build tree.  Override OpenSSL defaults with known-good defaults
163# usable on all platforms.  The Configure script already knows to use -fPIC and
164# RPM_OPT_FLAGS, so we can skip specifiying them here.
165./Configure  \
166         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
167         zlib-dynamic enable-camellia enable-seed enable-tlsext \
168         enable-rfc3779 enable-cms enable-md2 \
169         --enginesdir=%{_libdir}/openssl/engines \
170         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
171         shared ${sslarch}
172
173# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
174# marked as not requiring an executable stack.
175RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
176make depend
177make all build-shared
178
179# Generate hashes for the included certs.
180LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
181export LD_LIBRARY_PATH
182make rehash build-shared
183
184# Verify that what was compiled actually works.
185make -C test apps tests
186
187# Relink the main binary to get it dynamically linked.
188rm apps/openssl
189make all build-shared
190
191%install
192[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
193# Install OpenSSL.
194install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
195make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
196install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
197# added for lib64
198# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
199mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
200# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
201mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
202mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
203rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
204rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
205for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
206        chmod 755 ${lib}
207        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
208        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
209done
210# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
211
212# Install a makefile for generating keys and self-signed certs, and a script
213# for generating them on the fly.
214mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
215install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
216install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
217install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
218
219# Make sure we actually include the headers we built against.
220for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
221        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
222                install -m644 include/openssl/`basename ${header}` ${header}
223        fi
224done
225
226# Rename man pages so that they don't conflict with system man pages.  We used
227# to change the file extensions, but that only prevents file conflicts.  The
228# man viewer still can't select either of the two unless we physically change
229# the directory.
230for section in 1 2 3 4 5 6 7 8 ; do
231        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
232                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
233                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
234        fi
235done
236
237# Pick a CA script.
238pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
239mv CA.sh CA
240popd
241
242mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
243mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
245mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
246mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
247
248# Ensure the openssl.cnf timestamp is identical across builds to avoid
249# mulitlib conflicts and unnecessary renames on upgrade
250touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
251
252%clean
253[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
254
255%files
256%defattr(-,root,root)
257%doc FAQ LICENSE CHANGES NEWS INSTALL README
258%doc doc/README doc/c-indentation.el doc/openssl.txt
259%doc doc/openssl_button.html doc/openssl_button.gif
260%doc doc/ssleay.txt
261
262%{_sysconfdir}/pki/tls/certs/make-dummy-cert
263%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
264%{_sysconfdir}/pki/tls/certs/Makefile
265%{_sysconfdir}/pki/tls/misc/CA
266%dir %{_sysconfdir}/pki/CA
267%dir %{_sysconfdir}/pki/CA/private
268%dir %{_sysconfdir}/pki/CA/certs
269%dir %{_sysconfdir}/pki/CA/crl
270%dir %{_sysconfdir}/pki/CA/newcerts
271%{_sysconfdir}/pki/tls/misc/c_*
272%dir %{_sysconfdir}/pki/tls
273%dir %{_sysconfdir}/pki/tls/certs
274%dir %{_sysconfdir}/pki/tls/misc
275%dir %{_sysconfdir}/pki/tls/private
276%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
277
278%attr(0755,root,root) %{_bindir}/openssl
279%attr(0755,root,root) /%{_lib}/*.so.*
280%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
281%attr(0755,root,root) %dir %{_mandir}/man1*
282%attr(0644,root,root) %{_mandir}/man1*/*
283%attr(0755,root,root) %dir %{_mandir}/man5*
284%attr(0644,root,root) %{_mandir}/man5*/*
285%attr(0755,root,root) %dir %{_mandir}/man7*
286%attr(0644,root,root) %{_mandir}/man7*/*
287
288%files devel
289%defattr(-,root,root)
290%{_prefix}/include/openssl
291%exclude %{_libdir}/lib*.a
292%attr(0755,root,root) %{_libdir}/*.so
293%attr(0755,root,root) %dir %{_mandir}/man3*
294%attr(0644,root,root) %{_mandir}/man3*/*
295%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
296
297%files static
298%defattr(-,root,root)
299%attr(0644,root,root) %{_libdir}/*.a
300
301%files perl
302%defattr(-,root,root)
303%attr(0755,root,root) %{_bindir}/c_rehash
304%attr(0755,root,root) %dir %{_mandir}/man1*
305%attr(0644,root,root) %{_mandir}/man1*/*.pl*
306%{_sysconfdir}/pki/tls/misc/*.pl
307#%{_sysconfdir}/pki/tls/misc/tsget
308%doc apps/tsget
309
310## to build compat32 for x86_64 architecture support
311%if %{build_compat32}
312%files -n compat32-%{name}
313%defattr(-,root,root)
314%attr(0755,root,root) /%{_lib}/*.so.*
315
316%files -n compat32-%{name}-devel
317%defattr(-,root,root)
318%exclude %{_libdir}/lib*.a
319%attr(0755,root,root) %{_libdir}/*.so
320%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
321%endif
322
323%post -p /sbin/ldconfig
324
325%postun -p /sbin/ldconfig
326
327%post -n compat32-%{name} -p /sbin/ldconfig
328
329%postun -n compat32-%{name} -p /sbin/ldconfig
330
331%changelog
332* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
333- merged into Vine6
334  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
335  - new upstream release with security fixes 
336  - update Patch2,5
337
338* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
339- new upstream release with security fixes 
340
341* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
342- new upstream release with security fixes
343- add patch8 from fc21 (fix perl find.pl)
344
345* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
346- new upstream release with security fixes.
347
348* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
349- new upstream release with security fixes
350
351* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
352- new upstream release with security fixes
353
354* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
355- move root CA bundle to ca-certificates package
356
357* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
358- update to 1.0.1e
359  - 1.0.1d has major regressions from 1.0.1c
360
361* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
362- remove tsget script to delete dependency perl(WWW::Curl::Easy)
363 - openssl-perl package contains it in docdir
364
365* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
366- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
367- fixed %%files
368
369* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
370- update to 1.0.1c
371- enable configure options:
372  enable-camellia enable-seed enable-tlsext enable-rfc3779
373  enable-cms enable-md2
374- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
375- generate a table with the compile settings before configure
376
377* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
378- new upstream release with security fix (CVE-2012-0050)
379
380* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
381- new upstream release with security fix
382  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
383
384* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
385- new upstream release with security fix (CVE-2011-3207, 3210)
386
387* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
388- rebuild with krb5-libs 1.8
389
390* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
391- new upstream release with security fix
392
393* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
394- use upstream openssl.pc instead of vine original one (SOURCE6)
395
396* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
397- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
398
399* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
400- add R: krb5-devel into devel pkg
401- add R: compat32-krb5-devel into compat32-devel pkg
402
403* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
404- new upstream release 1.0.0x
405- separate static libs into static package
406- change configure options
407- change so version 10
408- add tsget into perl package
409- update all patches
410
411* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
412- fix changelog typo...
413
414* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
415- new upstream release with security fix (CVE-2010-4180)
416
417* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
418- new upstream release with security fix (CVE-2010-3864)
419- drop patches included in new release
420- update patch4
421
422* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
423- add patch12 for fix CVE-2009-3555 (renegotiation)
424
425* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
426- add patch11 for fix CVE-2009-4355 (memory leak)
427
428* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
429- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
430
431* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
432- removed unnecessary %%if %{build_compat32} statements
433- removed lib*.a from devel package
434
435* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
436- new upstream release with security fix (CVE-2000-0590,0591,0789)
437
438* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
439- new upstream release with security fix (CVE-2008-5077)
440
441* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
442- new upstream release
443
444* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
445- new upstream release
446- new versioning policy
447
448* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
449- new upstream release
450- drop patch10,20 which is merged in upstream
451
452* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
453- add security patch in advance for CVE-2007-5135
454  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
455  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
456
457* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
458- add security patch for CVE-2007-3108
459  (http://openssl.org/news/patch-CVE-2007-3108.txt)
460
461* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
462- new upstream release
463
464* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
465- update (fix) openssl.pc <BTS:437>
466
467* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
468- new upstream release (with security fix)
469
470* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
471- new upstream release
472- add patch2 to use RPM_OPT macro
473
474* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
475- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
476
477* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
478- added compat32-* packages for x86_64 architecture support
479- added openssl-0.9.7i.Configure-compat32.patch
480- changed '/lib' to '/%{_lib}'
481
482* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
483- new upstream release
484
485* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
486- rebuild on VineSeed
487
488* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
489- added a security patch from Gentoo.
490  - Patch1: openssl-0.9.7c-tempfile.patch
491
492* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
493- sslarch for ppc was missing... added.
494
495* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
496- use sslarch=linux-alpha-gcc instead of alpha-gcc
497
498* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
499- new upstream version
500- clean up of spec file
501        -- removed old patches
502
503* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
504- new upstream release
505- SECURITY fix.
506  - http://www.openssl.org/news/secadv_20040317.txt
507
508* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
509- new upstream release
510- [Security fix]
511  - Vulnerabilities in ASN.1 parsing
512    http://www.openssl.org/news/secadv_20030930.txt
513- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
514
515* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
516- add openssl.pc for pkgconfig
517
518* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
519- New upstream version
520- dropped patch10, 11
521        -- merged upstream version
522
523* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
524- rebuild for VineSeed
525
526* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
527- [Security Fix]
528  - Timing-based attacks on RSA keys
529    http://www.openssl.org/news/secadv_20030317.txt
530  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
531    http://www.openssl.org/news/secadv_20030317.txt
532
533* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
534- new upstream release 0.9.6i
535- [Security Fix]
536- build for Vine Linux 2.6 errata
537
538* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
539- new upstream release 0.9.6h
540
541* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
542- new upstream release 0.9.6g
543
544* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
545- SECURITY: CAN-2002-0659 fixed
546  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
547    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
548    - update asn patch to fix accidental reversal of a logic check
549    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
550    - update asn patch to reduce chance that compiler optimization will remove
551      one of the added tests
552    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
553    - rebuild
554    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
555    - add patch to fix ASN.1 vulnerabilities
556
557* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
558- rename spec file name
559- SECURITY: CA-2002-23 fixed
560  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
561    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
562    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
563
564* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
565- added ${PATH} in LD_LIBRARY_PATH
566- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
567 
568* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
569- remove --no-<cipher>
570
571* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
572- add Patch10 for mipsel shared ( Configure )
573
574* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
575- build for Vine Linux
576- use openssl-engine-0.9.6b.tar.gz
577
578* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
579- update to 0.9.6b
580
581* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
582- move .so symlinks back to %%{_libdir}
583
584* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
585- move shared libraries to /lib (#38410)
586
587* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
588- switch to engine code base
589
590* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
591- add a script for creating dummy certificates
592- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
593
594* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
595- add s390x support
596
597* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
598- change two memcpy() calls to memmove()
599- don't define L_ENDIAN on alpha
600
601* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
602- make subpackages depend on the main package
603
604* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
605- adjust the hobble script to not disturb symlinks in include/ (fix from
606  Joe Orton)
607
608* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
609- drop the m2crypo patch we weren't using
610
611* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
612- configure using "shared" as well
613
614* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
615- update to 0.9.6a
616- use the build-shared target to build shared libraries
617- bump the soversion to 2 because we're no longer compatible with
618  our 0.9.5a packages or our 0.9.6 packages
619- drop the patch for making rsatest a no-op when rsa null support is used
620- put all man pages into <section>ssl instead of <section>
621- break the m2crypto modules into a separate package
622
623* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
624- use BN_LLONG on s390
625
626* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
627- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
628
629* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
630- move c_rehash to the perl subpackage, because it's a perl script now
631
632* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
633- update to 0.9.6
634- enable MD2
635- use the libcrypto.so and libssl.so targets to build shared libs with
636- bump the soversion to 1 because we're no longer compatible with any of
637  the various 0.9.5a packages circulating around, which provide lib*.so.0
638
639* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
640- change hobble-openssl for disabling MD2 again
641
642* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
643- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
644  bytes or so, causing EVP_DigestInit() to zero out stack variables in
645  apps built against a version of the library without it
646
647* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
648- disable some inline assembly, which on x86 is Pentium-specific
649- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
650
651* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
652- fix s390 patch
653
654* Fri Dec 8 2000 Than Ngo <than@redhat.com>
655- added support s390
656
657* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
658- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
659- add the CA.pl man page to the perl subpackage
660
661* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
662- always build with -mcpu=ev5 on alpha
663
664* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
665- add a symlink from cert.pem to ca-bundle.crt
666
667* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
668- add a ca-bundle file for packages like Samba to reference for CA certificates
669
670* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
671- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
672
673* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
674- add unzip as a buildprereq (#17662)
675- update m2crypto to 0.05-snap4
676
677* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
678- fix some issues in building when it's not installed
679
680* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
681- make sure the headers we include are the ones we built with (aaaaarrgh!)
682
683* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
684- add Richard Henderson's patch for BN on ia64
685- clean up the changelog
686
687* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
688- fix the building of python modules without openssl-devel already installed
689
690* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
691- byte-compile python extensions without the build-root
692- adjust the makefile to not remove temporary files (like .key files when
693  building .csr files) by marking them as .PRECIOUS
694
695* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
696- break out python extensions into a subpackage
697
698* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
699- tweak the makefile some more
700
701* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
702- disable MD2 support
703
704* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
705- disable MDC2 support
706
707* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
708- tweak the disabling of RC5, IDEA support
709- tweak the makefile
710
711* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
712- strip binaries and libraries
713- rework certificate makefile to have the right parts for Apache
714
715* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
716- use %%{_perl} instead of /usr/bin/perl
717- disable alpha until it passes its own test suite
718
719* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
720- move the passwd.1 man page out of the passwd package's way
721
722* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
723- update to 0.9.5a, modified for U.S.
724- add perl as a build-time requirement
725- move certificate makefile to another package
726- disable RC5, IDEA, RSA support
727- remove optimizations for now
728
729* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
730- Bero told me to move the Makefile into this package
731
732* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
733- add lib*.so symlinks to link dynamically against shared libs
734
735* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
736- update to 0.9.5
737- run ldconfig directly in post/postun
738- add FAQ
739
740* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
741- Fix build on non-x86 platforms
742
743* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
744- move /usr/share/ssl/* from -devel to main package
745
746* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
747- inital packaging
748- changes from base:
749  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
750  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.