source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 7446

Revision 7446, 24.3 KB checked in by iwaim, 11 years ago (diff)

openssl 1.0.1d-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1d
4%define release 2%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14# Source6: openssl-%{version}.pc
15Patch0: openssl-1.0.0-soversion.patch
16Patch2: openssl-1.0.0-rpm_opt.patch
17Patch4: openssl-1.0.0-enginesdir.patch
18Patch5: openssl-0.9.8j-version-add-engines.patch
19
20# security fix
21# nothing ;-)
22
23License: BSDish
24Group: System Environment/Libraries
25URL: http://www.openssl.org/
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: perl, sed
28BuildRequires: zlib-devel, krb5-devel
29Requires: mktemp
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: daisuke, iwamoto
34
35%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
36
37%description
38The OpenSSL certificate management tool and the shared libraries that
39provide various cryptographic algorithms and protocols.
40
41%package devel
42Summary: OpenSSL libraries and development headers.
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: krb5-devel
46
47%description devel
48The static libraries and include files needed to compile apps
49with support for various the cryptographic algorithms and protocols
50supported by OpenSSL.
51
52Patches for many networking apps can be found at:
53ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
54
55%package static
56Summary:  Libraries for static linking of applications which will use OpenSSL
57Group: Development/Libraries
58Requires: %{name}-devel = %{version}-%{release}
59
60%description static
61OpenSSL is a toolkit for supporting cryptography. The openssl-static
62package contains static libraries needed for static linking of
63applications which support various cryptographic algorithms and
64protocols.
65
66%package perl
67Summary: OpenSSL scripts which require Perl.
68Group: Applications/Internet
69Requires: perl
70Requires: %{name} = %{version}-%{release}
71
72%description perl
73Perl scripts provided with OpenSSL for converting certificates and keys
74from other formats to those used by OpenSSL.
75
76## to build compat32 for x86_64 architecture support
77%package -n compat32-%{name}
78Summary: Secure Sockets Layer Toolkit
79Group: System Environment/Libraries
80Requires: %{name} = %{version}-%{release}
81%description -n compat32-%{name}
82The OpenSSL certificate management tool and the shared libraries that
83provide various cryptographic algorithms and protocols.
84
85%package -n compat32-%{name}-devel
86Summary: OpenSSL libraries and development headers.
87Group: Development/Libraries
88Requires: compat32-%{name} = %{version}-%{release}
89Requires: compat32-krb5-devel
90%description -n compat32-%{name}-devel
91The static libraries and include files needed to compile apps
92with support for various the cryptographic algorithms and protocols
93supported by OpenSSL.
94
95%prep
96%setup -q -n openssl-%{version}
97%patch0 -p1 -b .soversion
98%patch2 -p1 -b .rpm_opt
99%patch4 -p1 -b .enginesdir
100%patch5 -p1 -b .version-add-engines
101
102# security fix
103# nothing ;-)
104
105chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
106chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
107chmod 644 doc/openssl_button.html doc/openssl_button.gif
108chmod 644 doc/ssleay.txt
109
110# Link the configuration header to the one we're going to make.
111ln -sf ../../crypto/opensslconf.h include/openssl/
112
113%build
114PATH=${PATH}:${PWD}/bin
115TOPDIR=${PWD}
116LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
117
118# Modify the various perl scripts to reference perl in the right location.
119perl util/perlpath.pl `dirname %{__perl}`
120
121# Generate a table with the compile settings for my perusal.
122touch Makefile
123make TABLE PERL=%{__perl}
124
125# Figure out which flags we want to use.
126# default
127sslarch=%{_os}-%{_target_cpu}
128#
129%ifarch %ix86
130sslarch=linux-elf
131if ! echo %{_target} | grep -q i686 ; then
132   sslflags="no-asm 386"
133fi
134%endif
135%ifarch sparcv9
136sslarch=linux-sparcv9
137sslflags=no-asm
138%endif
139%ifarch sparc64
140sslarch=linux64-sparcv9
141sslflags=no-asm
142%endif
143%ifarch alpha alphaev56 alphaev6 alphaev67
144sslarch=linux-alpha-gcc
145%endif
146%ifarch s390 sh3eb sh4eb
147sslarch="linux-generic32 -DB_ENDIAN"
148%endif
149%ifarch s390x
150sslarch="linux64-s390x"
151%endif
152%ifarch %{arm} sh3 sh4
153sslarch=linux-generic32
154%endif
155# ia64/x86_64/ppc\ppc64 are OK by default.
156
157# Configure the build tree.  Override OpenSSL defaults with known-good defaults
158# usable on all platforms.  The Configure script already knows to use -fPIC and
159# RPM_OPT_FLAGS, so we can skip specifiying them here.
160./Configure  \
161         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
162         zlib-dynamic enable-camellia enable-seed enable-tlsext \
163         enable-rfc3779 enable-cms enable-md2 \
164         --enginesdir=%{_libdir}/openssl/engines \
165         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
166         shared ${sslarch}
167
168# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
169# marked as not requiring an executable stack.
170RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
171make depend
172make all build-shared
173
174# Generate hashes for the included certs.
175LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
176export LD_LIBRARY_PATH
177make rehash build-shared
178
179# Verify that what was compiled actually works.
180make -C test apps tests
181
182# Relink the main binary to get it dynamically linked.
183rm apps/openssl
184make all build-shared
185
186%install
187[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
188# Install OpenSSL.
189install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
190make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
191install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
192# added for lib64
193# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
194mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
195# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
196mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
197mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
198rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
199rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
200for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
201        chmod 755 ${lib}
202        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
203        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
204done
205# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
206
207# Install a makefile for generating keys and self-signed certs, and a script
208# for generating them on the fly.
209mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
210install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
211install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
212
213# Make sure we actually include the headers we built against.
214for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
215        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
216                install -m644 include/openssl/`basename ${header}` ${header}
217        fi
218done
219
220# Rename man pages so that they don't conflict with system man pages.  We used
221# to change the file extensions, but that only prevents file conflicts.  The
222# man viewer still can't select either of the two unless we physically change
223# the directory.
224for section in 1 2 3 4 5 6 7 8 ; do
225        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
226                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
227                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
228        fi
229done
230
231# Pick a CA script.
232pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
233mv CA.sh CA
234popd
235
236# Install root CA stuffs.
237cat %{SOURCE3} > ca-bundle.crt
238install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
239ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
240
241# Fix libdir.
242#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
243# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
244#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
245#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
246# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
247#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
248# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
249
250# remove file
251## moved docdir in openssl-perl sub package from 1.0.0c-3
252%__rm -f $RPM_BUILD_ROOT%{_datadir}/ssl/misc/tsget
253
254%clean
255[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
256
257%files
258%defattr(-,root,root)
259%doc FAQ LICENSE CHANGES NEWS INSTALL README
260%doc doc/README doc/c-indentation.el doc/openssl.txt
261%doc doc/openssl_button.html doc/openssl_button.gif
262%doc doc/ssleay.txt
263%dir %{_datadir}/ssl
264%{_datadir}/ssl/certs
265%{_datadir}/ssl/cert.pem
266%{_datadir}/ssl/misc/CA
267%{_datadir}/ssl/misc/c_*
268%{_datadir}/ssl/private
269
270%config(noreplace) %{_datadir}/ssl/openssl.cnf
271
272%attr(0755,root,root) %{_bindir}/openssl
273%attr(0755,root,root) /%{_lib}/*.so.*
274%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
275%attr(0755,root,root) %dir %{_mandir}/man1*
276%attr(0644,root,root) %{_mandir}/man1*/*
277%attr(0755,root,root) %dir %{_mandir}/man5*
278%attr(0644,root,root) %{_mandir}/man5*/*
279%attr(0755,root,root) %dir %{_mandir}/man7*
280%attr(0644,root,root) %{_mandir}/man7*/*
281
282%files devel
283%defattr(-,root,root)
284%{_prefix}/include/openssl
285%exclude %{_libdir}/lib*.a
286%attr(0755,root,root) %{_libdir}/*.so
287%attr(0755,root,root) %dir %{_mandir}/man3*
288%attr(0644,root,root) %{_mandir}/man3*/*
289%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
290
291%files static
292%defattr(-,root,root)
293%attr(0644,root,root) %{_libdir}/*.a
294
295%files perl
296%defattr(-,root,root)
297%attr(0755,root,root) %{_bindir}/c_rehash
298%attr(0755,root,root) %dir %{_mandir}/man1*
299%attr(0644,root,root) %{_mandir}/man1*/*.pl*
300%{_datadir}/ssl/misc/*.pl
301# %{_datadir}/ssl/misc/tsget
302%doc apps/tsget
303
304## to build compat32 for x86_64 architecture support
305%if %{build_compat32}
306%files -n compat32-%{name}
307%defattr(-,root,root)
308%attr(0755,root,root) /%{_lib}/*.so.*
309
310%files -n compat32-%{name}-devel
311%defattr(-,root,root)
312%exclude %{_libdir}/lib*.a
313%attr(0755,root,root) %{_libdir}/*.so
314%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
315%endif
316
317%post -p /sbin/ldconfig
318
319%postun -p /sbin/ldconfig
320
321%post -n compat32-%{name} -p /sbin/ldconfig
322
323%postun -n compat32-%{name} -p /sbin/ldconfig
324
325%changelog
326* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
327- remove tsget script to delete dependency perl(WWW::Curl::Easy)
328 - openssl-perl package contains it in docdir
329
330* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
331- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
332- fixed %%files
333
334* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
335- update to 1.0.1c
336- enable configure options:
337  enable-camellia enable-seed enable-tlsext enable-rfc3779
338  enable-cms enable-md2
339- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
340- generate a table with the compile settings before configure
341
342* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
343- new upstream release with security fix (CVE-2012-0050)
344
345* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
346- new upstream release with security fix
347  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
348
349* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
350- new upstream release with security fix (CVE-2011-3207, 3210)
351
352* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
353- rebuild with krb5-libs 1.8
354
355* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
356- new upstream release with security fix
357
358* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
359- use upstream openssl.pc instead of vine original one (SOURCE6)
360
361* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
362- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
363
364* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
365- add R: krb5-devel into devel pkg
366- add R: compat32-krb5-devel into compat32-devel pkg
367
368* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
369- new upstream release 1.0.0x
370- separate static libs into static package
371- change configure options
372- change so version 10
373- add tsget into perl package
374- update all patches
375
376* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
377- fix changelog typo...
378
379* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
380- new upstream release with security fix (CVE-2010-4180)
381
382* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
383- new upstream release with security fix (CVE-2010-3864)
384- drop patches included in new release
385- update patch4
386
387* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
388- add patch12 for fix CVE-2009-3555 (renegotiation)
389
390* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
391- add patch11 for fix CVE-2009-4355 (memory leak)
392
393* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
394- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
395
396* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
397- removed unnecessary %%if %{build_compat32} statements
398- removed lib*.a from devel package
399
400* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
401- new upstream release with security fix (CVE-2000-0590,0591,0789)
402
403* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
404- new upstream release with security fix (CVE-2008-5077)
405
406* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
407- new upstream release
408
409* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
410- new upstream release
411- new versioning policy
412
413* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
414- new upstream release
415- drop patch10,20 which is merged in upstream
416
417* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
418- add security patch in advance for CVE-2007-5135
419  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
420  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
421
422* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
423- add security patch for CVE-2007-3108
424  (http://openssl.org/news/patch-CVE-2007-3108.txt)
425
426* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
427- new upstream release
428
429* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
430- update (fix) openssl.pc <BTS:437>
431
432* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
433- new upstream release (with security fix)
434
435* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
436- new upstream release
437- add patch2 to use RPM_OPT macro
438
439* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
440- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
441
442* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
443- added compat32-* packages for x86_64 architecture support
444- added openssl-0.9.7i.Configure-compat32.patch
445- changed '/lib' to '/%{_lib}'
446
447* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
448- new upstream release
449
450* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
451- rebuild on VineSeed
452
453* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
454- added a security patch from Gentoo.
455  - Patch1: openssl-0.9.7c-tempfile.patch
456
457* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
458- sslarch for ppc was missing... added.
459
460* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
461- use sslarch=linux-alpha-gcc instead of alpha-gcc
462
463* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
464- new upstream version
465- clean up of spec file
466        -- removed old patches
467
468* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
469- new upstream release
470- SECURITY fix.
471  - http://www.openssl.org/news/secadv_20040317.txt
472
473* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
474- new upstream release
475- [Security fix]
476  - Vulnerabilities in ASN.1 parsing
477    http://www.openssl.org/news/secadv_20030930.txt
478- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
479
480* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
481- add openssl.pc for pkgconfig
482
483* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
484- New upstream version
485- dropped patch10, 11
486        -- merged upstream version
487
488* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
489- rebuild for VineSeed
490
491* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
492- [Security Fix]
493  - Timing-based attacks on RSA keys
494    http://www.openssl.org/news/secadv_20030317.txt
495  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
496    http://www.openssl.org/news/secadv_20030317.txt
497
498* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
499- new upstream release 0.9.6i
500- [Security Fix]
501- build for Vine Linux 2.6 errata
502
503* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
504- new upstream release 0.9.6h
505
506* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
507- new upstream release 0.9.6g
508
509* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
510- SECURITY: CAN-2002-0659 fixed
511  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
512    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
513    - update asn patch to fix accidental reversal of a logic check
514    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
515    - update asn patch to reduce chance that compiler optimization will remove
516      one of the added tests
517    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
518    - rebuild
519    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
520    - add patch to fix ASN.1 vulnerabilities
521
522* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
523- rename spec file name
524- SECURITY: CA-2002-23 fixed
525  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
526    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
527    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
528
529* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
530- added ${PATH} in LD_LIBRARY_PATH
531- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
532 
533* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
534- remove --no-<cipher>
535
536* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
537- add Patch10 for mipsel shared ( Configure )
538
539* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
540- build for Vine Linux
541- use openssl-engine-0.9.6b.tar.gz
542
543* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
544- update to 0.9.6b
545
546* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
547- move .so symlinks back to %%{_libdir}
548
549* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
550- move shared libraries to /lib (#38410)
551
552* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
553- switch to engine code base
554
555* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
556- add a script for creating dummy certificates
557- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
558
559* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
560- add s390x support
561
562* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
563- change two memcpy() calls to memmove()
564- don't define L_ENDIAN on alpha
565
566* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
567- make subpackages depend on the main package
568
569* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
570- adjust the hobble script to not disturb symlinks in include/ (fix from
571  Joe Orton)
572
573* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
574- drop the m2crypo patch we weren't using
575
576* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
577- configure using "shared" as well
578
579* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
580- update to 0.9.6a
581- use the build-shared target to build shared libraries
582- bump the soversion to 2 because we're no longer compatible with
583  our 0.9.5a packages or our 0.9.6 packages
584- drop the patch for making rsatest a no-op when rsa null support is used
585- put all man pages into <section>ssl instead of <section>
586- break the m2crypto modules into a separate package
587
588* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
589- use BN_LLONG on s390
590
591* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
592- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
593
594* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
595- move c_rehash to the perl subpackage, because it's a perl script now
596
597* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
598- update to 0.9.6
599- enable MD2
600- use the libcrypto.so and libssl.so targets to build shared libs with
601- bump the soversion to 1 because we're no longer compatible with any of
602  the various 0.9.5a packages circulating around, which provide lib*.so.0
603
604* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
605- change hobble-openssl for disabling MD2 again
606
607* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
608- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
609  bytes or so, causing EVP_DigestInit() to zero out stack variables in
610  apps built against a version of the library without it
611
612* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
613- disable some inline assembly, which on x86 is Pentium-specific
614- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
615
616* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
617- fix s390 patch
618
619* Fri Dec 8 2000 Than Ngo <than@redhat.com>
620- added support s390
621
622* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
623- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
624- add the CA.pl man page to the perl subpackage
625
626* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
627- always build with -mcpu=ev5 on alpha
628
629* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
630- add a symlink from cert.pem to ca-bundle.crt
631
632* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
633- add a ca-bundle file for packages like Samba to reference for CA certificates
634
635* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
636- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
637
638* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
639- add unzip as a buildprereq (#17662)
640- update m2crypto to 0.05-snap4
641
642* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
643- fix some issues in building when it's not installed
644
645* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
646- make sure the headers we include are the ones we built with (aaaaarrgh!)
647
648* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
649- add Richard Henderson's patch for BN on ia64
650- clean up the changelog
651
652* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
653- fix the building of python modules without openssl-devel already installed
654
655* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
656- byte-compile python extensions without the build-root
657- adjust the makefile to not remove temporary files (like .key files when
658  building .csr files) by marking them as .PRECIOUS
659
660* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
661- break out python extensions into a subpackage
662
663* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
664- tweak the makefile some more
665
666* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
667- disable MD2 support
668
669* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
670- disable MDC2 support
671
672* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
673- tweak the disabling of RC5, IDEA support
674- tweak the makefile
675
676* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
677- strip binaries and libraries
678- rework certificate makefile to have the right parts for Apache
679
680* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
681- use %%{_perl} instead of /usr/bin/perl
682- disable alpha until it passes its own test suite
683
684* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
685- move the passwd.1 man page out of the passwd package's way
686
687* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
688- update to 0.9.5a, modified for U.S.
689- add perl as a build-time requirement
690- move certificate makefile to another package
691- disable RC5, IDEA, RSA support
692- remove optimizations for now
693
694* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
695- Bero told me to move the Makefile into this package
696
697* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
698- add lib*.so symlinks to link dynamically against shared libs
699
700* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
701- update to 0.9.5
702- run ldconfig directly in post/postun
703- add FAQ
704
705* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
706- Fix build on non-x86 platforms
707
708* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
709- move /usr/share/ssl/* from -devel to main package
710
711* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
712- inital packaging
713- changes from base:
714  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
715  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.