source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 6254

Revision 6254, 23.9 KB checked in by daisuke, 12 years ago (diff)

openssl:

  • update to 1.0.1c
  • enable configure options: enable-camellia enable-seed enable-tlsext enable-rfc3779 enable-cms enable-md2
  • remove no-asm option from ai64/x86_64/ppc/ppc64/i686
  • generate a table with the compile settings before configure
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.1c
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14# Source6: openssl-%{version}.pc
15Patch0: openssl-1.0.0-soversion.patch
16Patch2: openssl-1.0.0-rpm_opt.patch
17Patch4: openssl-1.0.0-enginesdir.patch
18Patch5: openssl-0.9.8j-version-add-engines.patch
19
20# security fix
21# nothing ;-)
22
23License: BSDish
24Group: System Environment/Libraries
25URL: http://www.openssl.org/
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: perl, sed
28BuildRequires: zlib-devel, krb5-devel
29Requires: mktemp
30
31Vendor: Project Vine
32Distribution: Vine Linux
33Packager: daisuke, iwamoto
34
35%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
36
37%description
38The OpenSSL certificate management tool and the shared libraries that
39provide various cryptographic algorithms and protocols.
40
41%package devel
42Summary: OpenSSL libraries and development headers.
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: krb5-devel
46
47%description devel
48The static libraries and include files needed to compile apps
49with support for various the cryptographic algorithms and protocols
50supported by OpenSSL.
51
52Patches for many networking apps can be found at:
53ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
54
55%package static
56Summary:  Libraries for static linking of applications which will use OpenSSL
57Group: Development/Libraries
58Requires: %{name}-devel = %{version}-%{release}
59
60%description static
61OpenSSL is a toolkit for supporting cryptography. The openssl-static
62package contains static libraries needed for static linking of
63applications which support various cryptographic algorithms and
64protocols.
65
66%package perl
67Summary: OpenSSL scripts which require Perl.
68Group: Applications/Internet
69Requires: perl
70Requires: %{name} = %{version}-%{release}
71
72%description perl
73Perl scripts provided with OpenSSL for converting certificates and keys
74from other formats to those used by OpenSSL.
75
76## to build compat32 for x86_64 architecture support
77%package -n compat32-%{name}
78Summary: Secure Sockets Layer Toolkit
79Group: System Environment/Libraries
80Requires: %{name} = %{version}-%{release}
81%description -n compat32-%{name}
82The OpenSSL certificate management tool and the shared libraries that
83provide various cryptographic algorithms and protocols.
84
85%package -n compat32-%{name}-devel
86Summary: OpenSSL libraries and development headers.
87Group: Development/Libraries
88Requires: compat32-%{name} = %{version}-%{release}
89Requires: compat32-krb5-devel
90%description -n compat32-%{name}-devel
91The static libraries and include files needed to compile apps
92with support for various the cryptographic algorithms and protocols
93supported by OpenSSL.
94
95%prep
96%setup -q -n openssl-%{version}
97%patch0 -p1 -b .soversion
98%patch2 -p1 -b .rpm_opt
99%patch4 -p1 -b .enginesdir
100%patch5 -p1 -b .version-add-engines
101
102# security fix
103# nothing ;-)
104
105chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
106chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
107chmod 644 doc/openssl_button.html doc/openssl_button.gif
108chmod 644 doc/ssleay.txt
109
110# Link the configuration header to the one we're going to make.
111ln -sf ../../crypto/opensslconf.h include/openssl/
112
113%build
114PATH=${PATH}:${PWD}/bin
115TOPDIR=${PWD}
116LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
117
118# Modify the various perl scripts to reference perl in the right location.
119perl util/perlpath.pl `dirname %{__perl}`
120
121# Generate a table with the compile settings for my perusal.
122touch Makefile
123make TABLE PERL=%{__perl}
124
125# Figure out which flags we want to use.
126# default
127sslarch=%{_os}-%{_target_cpu}
128#
129%ifarch %ix86
130sslarch=linux-elf
131if ! echo %{_target} | grep -q i686 ; then
132   sslflags="no-asm 386"
133fi
134%endif
135%ifarch sparcv9
136sslarch=linux-sparcv9
137sslflags=no-asm
138%endif
139%ifarch sparc64
140sslarch=linux64-sparcv9
141sslflags=no-asm
142%endif
143%ifarch alpha alphaev56 alphaev6 alphaev67
144sslarch=linux-alpha-gcc
145%endif
146%ifarch s390 sh3eb sh4eb
147sslarch="linux-generic32 -DB_ENDIAN"
148%endif
149%ifarch s390x
150sslarch="linux64-s390x"
151%endif
152%ifarch %{arm} sh3 sh4
153sslarch=linux-generic32
154%endif
155# ia64/x86_64/ppc\ppc64 are OK by default.
156
157# Configure the build tree.  Override OpenSSL defaults with known-good defaults
158# usable on all platforms.  The Configure script already knows to use -fPIC and
159# RPM_OPT_FLAGS, so we can skip specifiying them here.
160./Configure  \
161         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
162         zlib-dynamic enable-camellia enable-seed enable-tlsext \
163         enable-rfc3779 enable-cms enable-md2 \
164         --enginesdir=%{_libdir}/openssl/engines \
165         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
166         shared ${sslarch}
167
168# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
169# marked as not requiring an executable stack.
170RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
171make depend
172make all build-shared
173
174# Generate hashes for the included certs.
175LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
176export LD_LIBRARY_PATH
177make rehash build-shared
178
179# Verify that what was compiled actually works.
180make -C test apps tests
181
182# Relink the main binary to get it dynamically linked.
183rm apps/openssl
184make all build-shared
185
186%install
187[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
188# Install OpenSSL.
189install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
190make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
191install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
192# added for lib64
193# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
194mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
195# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
196mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
197mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
198rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
199rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
200for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
201        chmod 755 ${lib}
202        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
203        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
204done
205# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
206
207# Install a makefile for generating keys and self-signed certs, and a script
208# for generating them on the fly.
209mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
210install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
211install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
212
213# Make sure we actually include the headers we built against.
214for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
215        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
216                install -m644 include/openssl/`basename ${header}` ${header}
217        fi
218done
219
220# Rename man pages so that they don't conflict with system man pages.  We used
221# to change the file extensions, but that only prevents file conflicts.  The
222# man viewer still can't select either of the two unless we physically change
223# the directory.
224for section in 1 2 3 4 5 6 7 8 ; do
225        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
226                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
227                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
228        fi
229done
230
231# Pick a CA script.
232pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
233mv CA.sh CA
234popd
235
236# Install root CA stuffs.
237cat %{SOURCE3} > ca-bundle.crt
238install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
239ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
240
241# Fix libdir.
242#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
243# sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
244#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
245#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
246# cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
247#         $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
248# rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
249
250%clean
251[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
252
253%files
254%defattr(-,root,root)
255%doc FAQ LICENSE CHANGES NEWS INSTALL README
256%doc doc/README doc/c-indentation.el doc/openssl.txt
257%doc doc/openssl_button.html doc/openssl_button.gif
258%doc doc/ssleay.txt
259%dir %{_datadir}/ssl
260%{_datadir}/ssl/certs
261%{_datadir}/ssl/cert.pem
262%{_datadir}/ssl/misc/CA
263%{_datadir}/ssl/misc/c_*
264%{_datadir}/ssl/private
265
266%config(noreplace) %{_datadir}/ssl/openssl.cnf
267
268%attr(0755,root,root) %{_bindir}/openssl
269%attr(0755,root,root) /%{_lib}/*.so.*
270%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
271%attr(0755,root,root) %dir %{_mandir}/man1*
272%attr(0644,root,root) %{_mandir}/man1*/*
273%attr(0755,root,root) %dir %{_mandir}/man5*
274%attr(0644,root,root) %{_mandir}/man5*/*
275%attr(0755,root,root) %dir %{_mandir}/man7*
276%attr(0644,root,root) %{_mandir}/man7*/*
277
278%files devel
279%defattr(-,root,root)
280%{_prefix}/include/openssl
281%exclude %{_libdir}/lib*.a
282%attr(0755,root,root) %{_libdir}/*.so
283%attr(0755,root,root) %dir %{_mandir}/man3*
284%attr(0644,root,root) %{_mandir}/man3*/*
285%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
286
287%files static
288%defattr(-,root,root)
289%attr(0644,root,root) %{_libdir}/*.a
290
291%files perl
292%defattr(-,root,root)
293%attr(0755,root,root) %{_bindir}/c_rehash
294%attr(0755,root,root) %dir %{_mandir}/man1*
295%attr(0644,root,root) %{_mandir}/man1*/*.pl*
296%{_datadir}/ssl/misc/*.pl
297# %{_datadir}/ssl/misc/tsget
298%doc apps/tsget
299
300## to build compat32 for x86_64 architecture support
301%if %{build_compat32}
302%files -n compat32-%{name}
303%defattr(-,root,root)
304%attr(0755,root,root) /%{_lib}/*.so.*
305
306%files -n compat32-%{name}-devel
307%defattr(-,root,root)
308%exclude %{_libdir}/lib*.a
309%attr(0755,root,root) %{_libdir}/*.so
310%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
311%endif
312
313%post -p /sbin/ldconfig
314
315%postun -p /sbin/ldconfig
316
317%post -n compat32-%{name} -p /sbin/ldconfig
318
319%postun -n compat32-%{name} -p /sbin/ldconfig
320
321%changelog
322* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
323- update to 1.0.1c
324- enable configure options:
325  enable-camellia enable-seed enable-tlsext enable-rfc3779
326  enable-cms enable-md2
327- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
328- generate a table with the compile settings before configure
329
330* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
331- new upstream release with security fix (CVE-2012-0050)
332
333* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
334- new upstream release with security fix
335  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
336
337* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
338- new upstream release with security fix (CVE-2011-3207, 3210)
339
340* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
341- rebuild with krb5-libs 1.8
342
343* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
344- new upstream release with security fix
345
346* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
347- use upstream openssl.pc instead of vine original one (SOURCE6)
348
349* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
350- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
351
352* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
353- add R: krb5-devel into devel pkg
354- add R: compat32-krb5-devel into compat32-devel pkg
355
356* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
357- new upstream release 1.0.0x
358- separate static libs into static package
359- change configure options
360- change so version 10
361- add tsget into perl package
362- update all patches
363
364* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
365- fix changelog typo...
366
367* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
368- new upstream release with security fix (CVE-2010-4180)
369
370* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
371- new upstream release with security fix (CVE-2010-3864)
372- drop patches included in new release
373- update patch4
374
375* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
376- add patch12 for fix CVE-2009-3555 (renegotiation)
377
378* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
379- add patch11 for fix CVE-2009-4355 (memory leak)
380
381* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
382- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
383
384* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
385- removed unnecessary %%if %{build_compat32} statements
386- removed lib*.a from devel package
387
388* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
389- new upstream release with security fix (CVE-2000-0590,0591,0789)
390
391* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
392- new upstream release with security fix (CVE-2008-5077)
393
394* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
395- new upstream release
396
397* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
398- new upstream release
399- new versioning policy
400
401* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
402- new upstream release
403- drop patch10,20 which is merged in upstream
404
405* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
406- add security patch in advance for CVE-2007-5135
407  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
408  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
409
410* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
411- add security patch for CVE-2007-3108
412  (http://openssl.org/news/patch-CVE-2007-3108.txt)
413
414* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
415- new upstream release
416
417* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
418- update (fix) openssl.pc <BTS:437>
419
420* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
421- new upstream release (with security fix)
422
423* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
424- new upstream release
425- add patch2 to use RPM_OPT macro
426
427* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
428- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
429
430* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
431- added compat32-* packages for x86_64 architecture support
432- added openssl-0.9.7i.Configure-compat32.patch
433- changed '/lib' to '/%{_lib}'
434
435* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
436- new upstream release
437
438* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
439- rebuild on VineSeed
440
441* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
442- added a security patch from Gentoo.
443  - Patch1: openssl-0.9.7c-tempfile.patch
444
445* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
446- sslarch for ppc was missing... added.
447
448* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
449- use sslarch=linux-alpha-gcc instead of alpha-gcc
450
451* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
452- new upstream version
453- clean up of spec file
454        -- removed old patches
455
456* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
457- new upstream release
458- SECURITY fix.
459  - http://www.openssl.org/news/secadv_20040317.txt
460
461* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
462- new upstream release
463- [Security fix]
464  - Vulnerabilities in ASN.1 parsing
465    http://www.openssl.org/news/secadv_20030930.txt
466- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
467
468* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
469- add openssl.pc for pkgconfig
470
471* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
472- New upstream version
473- dropped patch10, 11
474        -- merged upstream version
475
476* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
477- rebuild for VineSeed
478
479* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
480- [Security Fix]
481  - Timing-based attacks on RSA keys
482    http://www.openssl.org/news/secadv_20030317.txt
483  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
484    http://www.openssl.org/news/secadv_20030317.txt
485
486* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
487- new upstream release 0.9.6i
488- [Security Fix]
489- build for Vine Linux 2.6 errata
490
491* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
492- new upstream release 0.9.6h
493
494* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
495- new upstream release 0.9.6g
496
497* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
498- SECURITY: CAN-2002-0659 fixed
499  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
500    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
501    - update asn patch to fix accidental reversal of a logic check
502    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
503    - update asn patch to reduce chance that compiler optimization will remove
504      one of the added tests
505    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
506    - rebuild
507    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
508    - add patch to fix ASN.1 vulnerabilities
509
510* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
511- rename spec file name
512- SECURITY: CA-2002-23 fixed
513  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
514    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
515    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
516
517* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
518- added ${PATH} in LD_LIBRARY_PATH
519- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
520 
521* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
522- remove --no-<cipher>
523
524* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
525- add Patch10 for mipsel shared ( Configure )
526
527* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
528- build for Vine Linux
529- use openssl-engine-0.9.6b.tar.gz
530
531* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
532- update to 0.9.6b
533
534* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
535- move .so symlinks back to %%{_libdir}
536
537* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
538- move shared libraries to /lib (#38410)
539
540* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
541- switch to engine code base
542
543* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
544- add a script for creating dummy certificates
545- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
546
547* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
548- add s390x support
549
550* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
551- change two memcpy() calls to memmove()
552- don't define L_ENDIAN on alpha
553
554* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
555- make subpackages depend on the main package
556
557* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
558- adjust the hobble script to not disturb symlinks in include/ (fix from
559  Joe Orton)
560
561* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
562- drop the m2crypo patch we weren't using
563
564* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
565- configure using "shared" as well
566
567* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
568- update to 0.9.6a
569- use the build-shared target to build shared libraries
570- bump the soversion to 2 because we're no longer compatible with
571  our 0.9.5a packages or our 0.9.6 packages
572- drop the patch for making rsatest a no-op when rsa null support is used
573- put all man pages into <section>ssl instead of <section>
574- break the m2crypto modules into a separate package
575
576* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
577- use BN_LLONG on s390
578
579* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
580- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
581
582* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
583- move c_rehash to the perl subpackage, because it's a perl script now
584
585* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
586- update to 0.9.6
587- enable MD2
588- use the libcrypto.so and libssl.so targets to build shared libs with
589- bump the soversion to 1 because we're no longer compatible with any of
590  the various 0.9.5a packages circulating around, which provide lib*.so.0
591
592* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
593- change hobble-openssl for disabling MD2 again
594
595* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
596- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
597  bytes or so, causing EVP_DigestInit() to zero out stack variables in
598  apps built against a version of the library without it
599
600* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
601- disable some inline assembly, which on x86 is Pentium-specific
602- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
603
604* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
605- fix s390 patch
606
607* Fri Dec 8 2000 Than Ngo <than@redhat.com>
608- added support s390
609
610* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
611- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
612- add the CA.pl man page to the perl subpackage
613
614* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
615- always build with -mcpu=ev5 on alpha
616
617* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
618- add a symlink from cert.pem to ca-bundle.crt
619
620* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
621- add a ca-bundle file for packages like Samba to reference for CA certificates
622
623* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
624- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
625
626* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
627- add unzip as a buildprereq (#17662)
628- update m2crypto to 0.05-snap4
629
630* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
631- fix some issues in building when it's not installed
632
633* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
634- make sure the headers we include are the ones we built with (aaaaarrgh!)
635
636* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
637- add Richard Henderson's patch for BN on ia64
638- clean up the changelog
639
640* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
641- fix the building of python modules without openssl-devel already installed
642
643* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
644- byte-compile python extensions without the build-root
645- adjust the makefile to not remove temporary files (like .key files when
646  building .csr files) by marking them as .PRECIOUS
647
648* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
649- break out python extensions into a subpackage
650
651* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
652- tweak the makefile some more
653
654* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
655- disable MD2 support
656
657* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
658- disable MDC2 support
659
660* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
661- tweak the disabling of RC5, IDEA support
662- tweak the makefile
663
664* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
665- strip binaries and libraries
666- rework certificate makefile to have the right parts for Apache
667
668* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
669- use %%{_perl} instead of /usr/bin/perl
670- disable alpha until it passes its own test suite
671
672* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
673- move the passwd.1 man page out of the passwd package's way
674
675* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
676- update to 0.9.5a, modified for U.S.
677- add perl as a build-time requirement
678- move certificate makefile to another package
679- disable RC5, IDEA, RSA support
680- remove optimizations for now
681
682* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
683- Bero told me to move the Makefile into this package
684
685* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
686- add lib*.so symlinks to link dynamically against shared libs
687
688* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
689- update to 0.9.5
690- run ldconfig directly in post/postun
691- add FAQ
692
693* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
694- Fix build on non-x86 platforms
695
696* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
697- move /usr/share/ssl/* from -devel to main package
698
699* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
700- inital packaging
701- changes from base:
702  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
703  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.