source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 1852

Revision 1852, 21.3 KB checked in by inagaki, 14 years ago (diff)

rebuilt with rpm-4.8.1: dbus, openssl

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 6
3%define version 0.9.8m
4%define release 2%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14Source6: openssl-%{version}.pc
15Patch0: openssl-0.9.8b-soversion.patch
16Patch2: openssl-0.9.8e-rpm_opt.patch
17Patch4: openssl-0.9.8m-enginesdir.patch
18
19# security fix
20# nothing ;-)
21
22License: BSDish
23Group: System Environment/Libraries
24URL: http://www.openssl.org/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: perl, sed
27Requires: mktemp
28Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
33
34%description
35The OpenSSL certificate management tool and the shared libraries that
36provide various cryptographic algorithms and protocols.
37
38%package devel
39Summary: OpenSSL libraries and development headers.
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44The static libraries and include files needed to compile apps
45with support for various the cryptographic algorithms and protocols
46supported by OpenSSL.
47
48Patches for many networking apps can be found at:
49ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
50
51%package perl
52Summary: OpenSSL scripts which require Perl.
53Group: Applications/Internet
54Requires: perl
55Requires: %{name} = %{version}-%{release}
56
57%description perl
58Perl scripts provided with OpenSSL for converting certificates and keys
59from other formats to those used by OpenSSL.
60
61## to build compat32 for x86_64 architecture support
62%package -n compat32-%{name}
63Summary: Secure Sockets Layer Toolkit
64Group: System Environment/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description -n compat32-%{name}
68The OpenSSL certificate management tool and the shared libraries that
69provide various cryptographic algorithms and protocols.
70
71%package -n compat32-%{name}-devel
72Summary: OpenSSL libraries and development headers.
73Group: Development/Libraries
74Requires: compat32-%{name} = %{version}-%{release}
75
76%description -n compat32-%{name}-devel
77The static libraries and include files needed to compile apps
78with support for various the cryptographic algorithms and protocols
79supported by OpenSSL.
80
81%prep
82%setup -q -n openssl-%{version}
83%patch0 -p1 -b .soversion
84%patch2 -p1 -b .rpm_opt
85%patch4 -p1 -b .enginesdir
86
87# security fix
88# nothing ;-)
89
90chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
91chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
92chmod 644 doc/openssl_button.html doc/openssl_button.gif
93chmod 644 doc/ssleay.txt
94
95# Link the configuration header to the one we're going to make.
96ln -sf ../../crypto/opensslconf.h include/openssl/
97
98%build
99PATH=${PATH}:${PWD}/bin
100TOPDIR=${PWD}
101LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
102
103# Figure out which flags we want to use.  Can't use assembler because it's
104# not lowest-common-denominator in most cases.
105perl util/perlpath.pl `dirname %{__perl}`
106%ifarch %ix86
107sslarch=linux-elf
108sslflags="no-asm 386"
109%endif
110%ifarch ppc
111sslarch=linux-ppc
112sslflags=no-asm
113%endif
114%ifarch sparc
115sslarch=linux-sparcv9
116sslflags=no-asm
117%endif
118%ifarch ia64
119sslarch=linux-ia64
120sslflags=no-asm
121%endif
122%ifarch alpha
123sslarch=linux-alpha-gcc
124sslflags=no-asm
125%endif
126%ifarch s390
127sslarch=linux-s390
128%endif
129%ifarch s390x
130sslarch=linux-s390x
131%endif
132%ifarch mipsel
133sslarch=linux-mips
134sslflags=no-asm
135%endif
136## to build for x86_64 architecture support
137%ifarch x86_64
138sslarch=linux-x86_64
139sslflags=no-asm
140%endif
141
142# Configure the build tree.  Override OpenSSL defaults with known-good defaults
143# usable on all platforms.  The Configure script already knows to use -fPIC and
144# RPM_OPT_FLAGS, so we can skip specifiying them here.
145./Configure  \
146         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
147         --enginesdir=%{_libdir}/openssl/engines \
148         shared ${sslarch}
149
150# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
151# marked as not requiring an executable stack.
152RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
153make depend
154make all build-shared
155
156# Generate hashes for the included certs.
157LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
158export LD_LIBRARY_PATH
159make rehash build-shared
160
161# Verify that what was compiled actually works.
162make -C test apps tests
163
164# Relink the main binary to get it dynamically linked.
165rm apps/openssl
166make all build-shared
167
168%install
169[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
170# Install OpenSSL.
171install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
172make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
173install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
174# added for lib64
175mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
176mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
177mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
178mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
179rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
180rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
181for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
182        chmod 755 ${lib}
183        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
184        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
185done
186install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
187
188# Install a makefile for generating keys and self-signed certs, and a script
189# for generating them on the fly.
190mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
191install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
192install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
193
194# Make sure we actually include the headers we built against.
195for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
196        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
197                install -m644 include/openssl/`basename ${header}` ${header}
198        fi
199done
200
201# Rename man pages so that they don't conflict with system man pages.  We used
202# to change the file extensions, but that only prevents file conflicts.  The
203# man viewer still can't select either of the two unless we physically change
204# the directory.
205for section in 1 2 3 4 5 6 7 8 ; do
206        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
207                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
208                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
209        fi
210done
211
212# Pick a CA script.
213pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
214mv CA.sh CA
215popd
216
217# Install root CA stuffs.
218cat %{SOURCE3} > ca-bundle.crt
219install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
220ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
221
222# Fix libdir.
223#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
224sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
225        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
226        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
227cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
228        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
229rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
230
231%clean
232[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
233
234%files
235%defattr(-,root,root)
236%doc FAQ LICENSE CHANGES NEWS INSTALL README
237%doc doc/README doc/c-indentation.el doc/openssl.txt
238%doc doc/openssl_button.html doc/openssl_button.gif
239%doc doc/ssleay.txt
240%dir %{_datadir}/ssl
241%{_datadir}/ssl/certs
242%{_datadir}/ssl/cert.pem
243%{_datadir}/ssl/misc/CA
244%{_datadir}/ssl/misc/c_*
245%{_datadir}/ssl/private
246
247%config(noreplace) %{_datadir}/ssl/openssl.cnf
248
249%attr(0755,root,root) %{_bindir}/openssl
250%attr(0755,root,root) /%{_lib}/*.so.*
251%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
252%attr(0755,root,root) %dir %{_mandir}/man1*
253%attr(0644,root,root) %{_mandir}/man1*/*
254%attr(0755,root,root) %dir %{_mandir}/man5*
255%attr(0644,root,root) %{_mandir}/man5*/*
256%attr(0755,root,root) %dir %{_mandir}/man7*
257%attr(0644,root,root) %{_mandir}/man7*/*
258
259%files devel
260%defattr(-,root,root)
261%{_prefix}/include/openssl
262%exclude %{_libdir}/lib*.a
263%attr(0755,root,root) %{_libdir}/*.so
264%attr(0755,root,root) %dir %{_mandir}/man3*
265%attr(0644,root,root) %{_mandir}/man3*/*
266%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
267
268%files perl
269%defattr(-,root,root)
270%attr(0755,root,root) %{_bindir}/c_rehash
271%attr(0755,root,root) %dir %{_mandir}/man1*
272%attr(0644,root,root) %{_mandir}/man1*/*.pl*
273%{_datadir}/ssl/misc/*.pl
274
275## to build compat32 for x86_64 architecture support
276%if %{build_compat32}
277%files -n compat32-%{name}
278%defattr(-,root,root)
279%attr(0755,root,root) /%{_lib}/*.so.*
280
281%files -n compat32-%{name}-devel
282%defattr(-,root,root)
283%exclude %{_libdir}/lib*.a
284%attr(0755,root,root) %{_libdir}/*.so
285%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
286%endif
287
288%post -p /sbin/ldconfig
289
290%postun -p /sbin/ldconfig
291
292%post -n compat32-%{name} -p /sbin/ldconfig
293
294%postun -n compat32-%{name} -p /sbin/ldconfig
295
296%changelog
297* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.8m-2
298- rebuilt with rpm-4.8.1
299
300* Thu Mar 18 2010 IWAI, Masaharu <iwai@alib.jp> 0.9.8m-1
301- new upstream release
302- update enginsdir patch (Patch4)
303- drop unnecessary patch: upstream fixed
304  - dtls dos patch (Patch10)
305  - CVE-2009-4355 (memory leak) patch (Patch11)
306  - CVE-2009-3555 (renegotiation) patch (Patch12)
307- update SOURCE6 for pkgconfig
308- replace BuildPreReq to BuildRequires
309
310* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
311- add patch12 for fix CVE-2009-3555 (renegotiation)
312
313* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
314- add patch11 for fix CVE-2009-4355 (memory leak)
315
316* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
317- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
318
319* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
320- removed unnecessary %%if %{build_compat32} statements
321- removed lib*.a from devel package
322
323* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
324- new upstream release with security fix (CVE-2000-0590,0591,0789)
325
326* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
327- new upstream release with security fix (CVE-2008-5077)
328
329* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
330- new upstream release
331
332* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
333- new upstream release
334- new versioning policy
335
336* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
337- new upstream release
338- drop patch10,20 which is merged in upstream
339
340* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
341- add security patch in advance for CVE-2007-5135
342  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
343  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
344
345* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
346- add security patch for CVE-2007-3108
347  (http://openssl.org/news/patch-CVE-2007-3108.txt)
348
349* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
350- new upstream release
351
352* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
353- update (fix) openssl.pc <BTS:437>
354
355* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
356- new upstream release (with security fix)
357
358* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
359- new upstream release
360- add patch2 to use RPM_OPT macro
361
362* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
363- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
364
365* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
366- added compat32-* packages for x86_64 architecture support
367- added openssl-0.9.7i.Configure-compat32.patch
368- changed '/lib' to '/%{_lib}'
369
370* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
371- new upstream release
372
373* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
374- rebuild on VineSeed
375
376* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
377- added a security patch from Gentoo.
378  - Patch1: openssl-0.9.7c-tempfile.patch
379
380* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
381- sslarch for ppc was missing... added.
382
383* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
384- use sslarch=linux-alpha-gcc instead of alpha-gcc
385
386* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
387- new upstream version
388- clean up of spec file
389        -- removed old patches
390
391* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
392- new upstream release
393- SECURITY fix.
394  - http://www.openssl.org/news/secadv_20040317.txt
395
396* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
397- new upstream release
398- [Security fix]
399  - Vulnerabilities in ASN.1 parsing
400    http://www.openssl.org/news/secadv_20030930.txt
401- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
402
403* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
404- add openssl.pc for pkgconfig
405
406* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
407- New upstream version
408- dropped patch10, 11
409        -- merged upstream version
410
411* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
412- rebuild for VineSeed
413
414* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
415- [Security Fix]
416  - Timing-based attacks on RSA keys
417    http://www.openssl.org/news/secadv_20030317.txt
418  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
419    http://www.openssl.org/news/secadv_20030317.txt
420
421* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
422- new upstream release 0.9.6i
423- [Security Fix]
424- build for Vine Linux 2.6 errata
425
426* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
427- new upstream release 0.9.6h
428
429* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
430- new upstream release 0.9.6g
431
432* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
433- SECURITY: CAN-2002-0659 fixed
434  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
435    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
436    - update asn patch to fix accidental reversal of a logic check
437    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
438    - update asn patch to reduce chance that compiler optimization will remove
439      one of the added tests
440    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
441    - rebuild
442    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
443    - add patch to fix ASN.1 vulnerabilities
444
445* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
446- rename spec file name
447- SECURITY: CA-2002-23 fixed
448  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
449    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
450    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
451
452* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
453- added ${PATH} in LD_LIBRARY_PATH
454- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
455 
456* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
457- remove --no-<cipher>
458
459* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
460- add Patch10 for mipsel shared ( Configure )
461
462* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
463- build for Vine Linux
464- use openssl-engine-0.9.6b.tar.gz
465
466* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
467- update to 0.9.6b
468
469* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
470- move .so symlinks back to %%{_libdir}
471
472* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
473- move shared libraries to /lib (#38410)
474
475* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
476- switch to engine code base
477
478* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
479- add a script for creating dummy certificates
480- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
481
482* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
483- add s390x support
484
485* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
486- change two memcpy() calls to memmove()
487- don't define L_ENDIAN on alpha
488
489* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
490- make subpackages depend on the main package
491
492* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
493- adjust the hobble script to not disturb symlinks in include/ (fix from
494  Joe Orton)
495
496* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
497- drop the m2crypo patch we weren't using
498
499* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
500- configure using "shared" as well
501
502* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
503- update to 0.9.6a
504- use the build-shared target to build shared libraries
505- bump the soversion to 2 because we're no longer compatible with
506  our 0.9.5a packages or our 0.9.6 packages
507- drop the patch for making rsatest a no-op when rsa null support is used
508- put all man pages into <section>ssl instead of <section>
509- break the m2crypto modules into a separate package
510
511* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
512- use BN_LLONG on s390
513
514* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
515- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
516
517* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
518- move c_rehash to the perl subpackage, because it's a perl script now
519
520* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
521- update to 0.9.6
522- enable MD2
523- use the libcrypto.so and libssl.so targets to build shared libs with
524- bump the soversion to 1 because we're no longer compatible with any of
525  the various 0.9.5a packages circulating around, which provide lib*.so.0
526
527* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
528- change hobble-openssl for disabling MD2 again
529
530* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
531- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
532  bytes or so, causing EVP_DigestInit() to zero out stack variables in
533  apps built against a version of the library without it
534
535* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
536- disable some inline assembly, which on x86 is Pentium-specific
537- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
538
539* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
540- fix s390 patch
541
542* Fri Dec 8 2000 Than Ngo <than@redhat.com>
543- added support s390
544
545* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
546- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
547- add the CA.pl man page to the perl subpackage
548
549* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
550- always build with -mcpu=ev5 on alpha
551
552* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
553- add a symlink from cert.pem to ca-bundle.crt
554
555* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
556- add a ca-bundle file for packages like Samba to reference for CA certificates
557
558* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
559- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
560
561* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
562- add unzip as a buildprereq (#17662)
563- update m2crypto to 0.05-snap4
564
565* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
566- fix some issues in building when it's not installed
567
568* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
569- make sure the headers we include are the ones we built with (aaaaarrgh!)
570
571* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
572- add Richard Henderson's patch for BN on ia64
573- clean up the changelog
574
575* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
576- fix the building of python modules without openssl-devel already installed
577
578* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
579- byte-compile python extensions without the build-root
580- adjust the makefile to not remove temporary files (like .key files when
581  building .csr files) by marking them as .PRECIOUS
582
583* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
584- break out python extensions into a subpackage
585
586* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
587- tweak the makefile some more
588
589* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
590- disable MD2 support
591
592* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
593- disable MDC2 support
594
595* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
596- tweak the disabling of RC5, IDEA support
597- tweak the makefile
598
599* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
600- strip binaries and libraries
601- rework certificate makefile to have the right parts for Apache
602
603* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
604- use %%{_perl} instead of /usr/bin/perl
605- disable alpha until it passes its own test suite
606
607* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
608- move the passwd.1 man page out of the passwd package's way
609
610* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
611- update to 0.9.5a, modified for U.S.
612- add perl as a build-time requirement
613- move certificate makefile to another package
614- disable RC5, IDEA, RSA support
615- remove optimizations for now
616
617* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
618- Bero told me to move the Makefile into this package
619
620* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
621- add lib*.so symlinks to link dynamically against shared libs
622
623* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
624- update to 0.9.5
625- run ldconfig directly in post/postun
626- add FAQ
627
628* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
629- Fix build on non-x86 platforms
630
631* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
632- move /usr/share/ssl/* from -devel to main package
633
634* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
635- inital packaging
636- changes from base:
637  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
638  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.