source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 676

Revision 676, 21.2 KB checked in by iwaim, 14 years ago (diff)

update: openssl 0.9.8m-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 6
3%define version 0.9.8m
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14Source6: openssl-%{version}.pc
15Patch0: openssl-0.9.8b-soversion.patch
16Patch2: openssl-0.9.8e-rpm_opt.patch
17Patch4: openssl-0.9.8m-enginesdir.patch
18
19# security fix
20# nothing ;-)
21
22License: BSDish
23Group: System Environment/Libraries
24URL: http://www.openssl.org/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildRequires: perl, sed
27Requires: mktemp
28Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
33
34%description
35The OpenSSL certificate management tool and the shared libraries that
36provide various cryptographic algorithms and protocols.
37
38%package devel
39Summary: OpenSSL libraries and development headers.
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44The static libraries and include files needed to compile apps
45with support for various the cryptographic algorithms and protocols
46supported by OpenSSL.
47
48Patches for many networking apps can be found at:
49ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
50
51%package perl
52Summary: OpenSSL scripts which require Perl.
53Group: Applications/Internet
54Requires: perl
55Requires: %{name} = %{version}-%{release}
56
57%description perl
58Perl scripts provided with OpenSSL for converting certificates and keys
59from other formats to those used by OpenSSL.
60
61## to build compat32 for x86_64 architecture support
62%package -n compat32-%{name}
63Summary: Secure Sockets Layer Toolkit
64Group: System Environment/Libraries
65Requires: %{name} = %{version}-%{release}
66%description -n compat32-%{name}
67The OpenSSL certificate management tool and the shared libraries that
68provide various cryptographic algorithms and protocols.
69
70%package -n compat32-%{name}-devel
71Summary: OpenSSL libraries and development headers.
72Group: Development/Libraries
73Requires: compat32-%{name} = %{version}-%{release}
74%description -n compat32-%{name}-devel
75The static libraries and include files needed to compile apps
76with support for various the cryptographic algorithms and protocols
77supported by OpenSSL.
78
79%prep
80%setup -q -n openssl-%{version}
81%patch0 -p1 -b .soversion
82%patch2 -p1 -b .rpm_opt
83%patch4 -p1 -b .enginesdir
84
85# security fix
86# nothing ;-)
87
88chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
89chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
90chmod 644 doc/openssl_button.html doc/openssl_button.gif
91chmod 644 doc/ssleay.txt
92
93# Link the configuration header to the one we're going to make.
94ln -sf ../../crypto/opensslconf.h include/openssl/
95
96%build
97PATH=${PATH}:${PWD}/bin
98TOPDIR=${PWD}
99LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
100
101# Figure out which flags we want to use.  Can't use assembler because it's
102# not lowest-common-denominator in most cases.
103perl util/perlpath.pl `dirname %{__perl}`
104%ifarch %ix86
105sslarch=linux-elf
106sslflags="no-asm 386"
107%endif
108%ifarch ppc
109sslarch=linux-ppc
110sslflags=no-asm
111%endif
112%ifarch sparc
113sslarch=linux-sparcv9
114sslflags=no-asm
115%endif
116%ifarch ia64
117sslarch=linux-ia64
118sslflags=no-asm
119%endif
120%ifarch alpha
121sslarch=linux-alpha-gcc
122sslflags=no-asm
123%endif
124%ifarch s390
125sslarch=linux-s390
126%endif
127%ifarch s390x
128sslarch=linux-s390x
129%endif
130%ifarch mipsel
131sslarch=linux-mips
132sslflags=no-asm
133%endif
134## to build for x86_64 architecture support
135%ifarch x86_64
136sslarch=linux-x86_64
137sslflags=no-asm
138%endif
139
140# Configure the build tree.  Override OpenSSL defaults with known-good defaults
141# usable on all platforms.  The Configure script already knows to use -fPIC and
142# RPM_OPT_FLAGS, so we can skip specifiying them here.
143./Configure  \
144         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
145         --enginesdir=%{_libdir}/openssl/engines \
146         shared ${sslarch}
147
148# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
149# marked as not requiring an executable stack.
150RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
151make depend
152make all build-shared
153
154# Generate hashes for the included certs.
155LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
156export LD_LIBRARY_PATH
157make rehash build-shared
158
159# Verify that what was compiled actually works.
160make -C test apps tests
161
162# Relink the main binary to get it dynamically linked.
163rm apps/openssl
164make all build-shared
165
166%install
167[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
168# Install OpenSSL.
169install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
170make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
171install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
172# added for lib64
173mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
174mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
175mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
176mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
177rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
178rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
179for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
180        chmod 755 ${lib}
181        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
182        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
183done
184install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
185
186# Install a makefile for generating keys and self-signed certs, and a script
187# for generating them on the fly.
188mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
189install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
190install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
191
192# Make sure we actually include the headers we built against.
193for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
194        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
195                install -m644 include/openssl/`basename ${header}` ${header}
196        fi
197done
198
199# Rename man pages so that they don't conflict with system man pages.  We used
200# to change the file extensions, but that only prevents file conflicts.  The
201# man viewer still can't select either of the two unless we physically change
202# the directory.
203for section in 1 2 3 4 5 6 7 8 ; do
204        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
205                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
206                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
207        fi
208done
209
210# Pick a CA script.
211pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
212mv CA.sh CA
213popd
214
215# Install root CA stuffs.
216cat %{SOURCE3} > ca-bundle.crt
217install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
218ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
219
220# Fix libdir.
221#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
222sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
223        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
224        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
225cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
226        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
227rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
228
229%clean
230[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
231
232%files
233%defattr(-,root,root)
234%doc FAQ LICENSE CHANGES NEWS INSTALL README
235%doc doc/README doc/c-indentation.el doc/openssl.txt
236%doc doc/openssl_button.html doc/openssl_button.gif
237%doc doc/ssleay.txt
238%dir %{_datadir}/ssl
239%{_datadir}/ssl/certs
240%{_datadir}/ssl/cert.pem
241%{_datadir}/ssl/misc/CA
242%{_datadir}/ssl/misc/c_*
243%{_datadir}/ssl/private
244
245%config(noreplace) %{_datadir}/ssl/openssl.cnf
246
247%attr(0755,root,root) %{_bindir}/openssl
248%attr(0755,root,root) /%{_lib}/*.so.*
249%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
250%attr(0755,root,root) %dir %{_mandir}/man1*
251%attr(0644,root,root) %{_mandir}/man1*/*
252%attr(0755,root,root) %dir %{_mandir}/man5*
253%attr(0644,root,root) %{_mandir}/man5*/*
254%attr(0755,root,root) %dir %{_mandir}/man7*
255%attr(0644,root,root) %{_mandir}/man7*/*
256
257%files devel
258%defattr(-,root,root)
259%{_prefix}/include/openssl
260%exclude %{_libdir}/lib*.a
261%attr(0755,root,root) %{_libdir}/*.so
262%attr(0755,root,root) %dir %{_mandir}/man3*
263%attr(0644,root,root) %{_mandir}/man3*/*
264%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
265
266%files perl
267%defattr(-,root,root)
268%attr(0755,root,root) %{_bindir}/c_rehash
269%attr(0755,root,root) %dir %{_mandir}/man1*
270%attr(0644,root,root) %{_mandir}/man1*/*.pl*
271%{_datadir}/ssl/misc/*.pl
272
273## to build compat32 for x86_64 architecture support
274%if %{build_compat32}
275%files -n compat32-%{name}
276%defattr(-,root,root)
277%attr(0755,root,root) /%{_lib}/*.so.*
278
279%files -n compat32-%{name}-devel
280%defattr(-,root,root)
281%exclude %{_libdir}/lib*.a
282%attr(0755,root,root) %{_libdir}/*.so
283%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
284%endif
285
286%post -p /sbin/ldconfig
287
288%postun -p /sbin/ldconfig
289
290%post -n compat32-%{name} -p /sbin/ldconfig
291
292%postun -n compat32-%{name} -p /sbin/ldconfig
293
294%changelog
295* Thu Mar 18 2010 IWAI, Masaharu <iwai@alib.jp> 0.9.8m-1
296- new upstream release
297- update enginsdir patch (Patch4)
298- drop unnecessary patch: upstream fixed
299  - dtls dos patch (Patch10)
300  - CVE-2009-4355 (memory leak) patch (Patch11)
301  - CVE-2009-3555 (renegotiation) patch (Patch12)
302- update SOURCE6 for pkgconfig
303- replace BuildPreReq to BuildRequires
304
305* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
306- add patch12 for fix CVE-2009-3555 (renegotiation)
307
308* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
309- add patch11 for fix CVE-2009-4355 (memory leak)
310
311* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
312- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
313
314* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
315- removed unnecessary %%if %{build_compat32} statements
316- removed lib*.a from devel package
317
318* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
319- new upstream release with security fix (CVE-2000-0590,0591,0789)
320
321* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
322- new upstream release with security fix (CVE-2008-5077)
323
324* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
325- new upstream release
326
327* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
328- new upstream release
329- new versioning policy
330
331* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
332- new upstream release
333- drop patch10,20 which is merged in upstream
334
335* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
336- add security patch in advance for CVE-2007-5135
337  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
338  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
339
340* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
341- add security patch for CVE-2007-3108
342  (http://openssl.org/news/patch-CVE-2007-3108.txt)
343
344* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
345- new upstream release
346
347* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
348- update (fix) openssl.pc <BTS:437>
349
350* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
351- new upstream release (with security fix)
352
353* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
354- new upstream release
355- add patch2 to use RPM_OPT macro
356
357* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
358- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
359
360* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
361- added compat32-* packages for x86_64 architecture support
362- added openssl-0.9.7i.Configure-compat32.patch
363- changed '/lib' to '/%{_lib}'
364
365* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
366- new upstream release
367
368* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
369- rebuild on VineSeed
370
371* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
372- added a security patch from Gentoo.
373  - Patch1: openssl-0.9.7c-tempfile.patch
374
375* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
376- sslarch for ppc was missing... added.
377
378* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
379- use sslarch=linux-alpha-gcc instead of alpha-gcc
380
381* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
382- new upstream version
383- clean up of spec file
384        -- removed old patches
385
386* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
387- new upstream release
388- SECURITY fix.
389  - http://www.openssl.org/news/secadv_20040317.txt
390
391* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
392- new upstream release
393- [Security fix]
394  - Vulnerabilities in ASN.1 parsing
395    http://www.openssl.org/news/secadv_20030930.txt
396- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
397
398* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
399- add openssl.pc for pkgconfig
400
401* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
402- New upstream version
403- dropped patch10, 11
404        -- merged upstream version
405
406* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
407- rebuild for VineSeed
408
409* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
410- [Security Fix]
411  - Timing-based attacks on RSA keys
412    http://www.openssl.org/news/secadv_20030317.txt
413  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
414    http://www.openssl.org/news/secadv_20030317.txt
415
416* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
417- new upstream release 0.9.6i
418- [Security Fix]
419- build for Vine Linux 2.6 errata
420
421* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
422- new upstream release 0.9.6h
423
424* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
425- new upstream release 0.9.6g
426
427* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
428- SECURITY: CAN-2002-0659 fixed
429  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
430    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
431    - update asn patch to fix accidental reversal of a logic check
432    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
433    - update asn patch to reduce chance that compiler optimization will remove
434      one of the added tests
435    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
436    - rebuild
437    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
438    - add patch to fix ASN.1 vulnerabilities
439
440* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
441- rename spec file name
442- SECURITY: CA-2002-23 fixed
443  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
444    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
445    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
446
447* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
448- added ${PATH} in LD_LIBRARY_PATH
449- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
450 
451* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
452- remove --no-<cipher>
453
454* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
455- add Patch10 for mipsel shared ( Configure )
456
457* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
458- build for Vine Linux
459- use openssl-engine-0.9.6b.tar.gz
460
461* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
462- update to 0.9.6b
463
464* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
465- move .so symlinks back to %%{_libdir}
466
467* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
468- move shared libraries to /lib (#38410)
469
470* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
471- switch to engine code base
472
473* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
474- add a script for creating dummy certificates
475- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
476
477* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
478- add s390x support
479
480* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
481- change two memcpy() calls to memmove()
482- don't define L_ENDIAN on alpha
483
484* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
485- make subpackages depend on the main package
486
487* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
488- adjust the hobble script to not disturb symlinks in include/ (fix from
489  Joe Orton)
490
491* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
492- drop the m2crypo patch we weren't using
493
494* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
495- configure using "shared" as well
496
497* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
498- update to 0.9.6a
499- use the build-shared target to build shared libraries
500- bump the soversion to 2 because we're no longer compatible with
501  our 0.9.5a packages or our 0.9.6 packages
502- drop the patch for making rsatest a no-op when rsa null support is used
503- put all man pages into <section>ssl instead of <section>
504- break the m2crypto modules into a separate package
505
506* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
507- use BN_LLONG on s390
508
509* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
510- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
511
512* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
513- move c_rehash to the perl subpackage, because it's a perl script now
514
515* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
516- update to 0.9.6
517- enable MD2
518- use the libcrypto.so and libssl.so targets to build shared libs with
519- bump the soversion to 1 because we're no longer compatible with any of
520  the various 0.9.5a packages circulating around, which provide lib*.so.0
521
522* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
523- change hobble-openssl for disabling MD2 again
524
525* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
526- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
527  bytes or so, causing EVP_DigestInit() to zero out stack variables in
528  apps built against a version of the library without it
529
530* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
531- disable some inline assembly, which on x86 is Pentium-specific
532- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
533
534* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
535- fix s390 patch
536
537* Fri Dec 8 2000 Than Ngo <than@redhat.com>
538- added support s390
539
540* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
541- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
542- add the CA.pl man page to the perl subpackage
543
544* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
545- always build with -mcpu=ev5 on alpha
546
547* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
548- add a symlink from cert.pem to ca-bundle.crt
549
550* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
551- add a ca-bundle file for packages like Samba to reference for CA certificates
552
553* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
554- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
555
556* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
557- add unzip as a buildprereq (#17662)
558- update m2crypto to 0.05-snap4
559
560* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
561- fix some issues in building when it's not installed
562
563* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
564- make sure the headers we include are the ones we built with (aaaaarrgh!)
565
566* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
567- add Richard Henderson's patch for BN on ia64
568- clean up the changelog
569
570* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
571- fix the building of python modules without openssl-devel already installed
572
573* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
574- byte-compile python extensions without the build-root
575- adjust the makefile to not remove temporary files (like .key files when
576  building .csr files) by marking them as .PRECIOUS
577
578* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
579- break out python extensions into a subpackage
580
581* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
582- tweak the makefile some more
583
584* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
585- disable MD2 support
586
587* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
588- disable MDC2 support
589
590* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
591- tweak the disabling of RC5, IDEA support
592- tweak the makefile
593
594* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
595- strip binaries and libraries
596- rework certificate makefile to have the right parts for Apache
597
598* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
599- use %%{_perl} instead of /usr/bin/perl
600- disable alpha until it passes its own test suite
601
602* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
603- move the passwd.1 man page out of the passwd package's way
604
605* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
606- update to 0.9.5a, modified for U.S.
607- add perl as a build-time requirement
608- move certificate makefile to another package
609- disable RC5, IDEA, RSA support
610- remove optimizations for now
611
612* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
613- Bero told me to move the Makefile into this package
614
615* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
616- add lib*.so symlinks to link dynamically against shared libs
617
618* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
619- update to 0.9.5
620- run ldconfig directly in post/postun
621- add FAQ
622
623* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
624- Fix build on non-x86 platforms
625
626* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
627- move /usr/share/ssl/* from -devel to main package
628
629* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
630- inital packaging
631- changes from base:
632  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
633  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.