source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 12388

Revision 12388, 31.3 KB checked in by tomop, 4 years ago (diff)

updated 8 packages

avahi-0.8-1

farstream-0.2.9-1

gssdp-1.2.2-1

gupnp-igd-0.2.5-1

gupnp-1.2.2-1

libnice-0.1.16-1

openssl-1.1.1g-1

xmltoman-0.4-22

Line 
1%bcond_with fips
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}}
5# 1.0.0 soversion = 10
6# 1.1.0 soversion = 1.1 (same as upstream although presence of some symbols
7#                        depends on build configuration options)
8%define soversion 1.1
9
10Summary: Secure Sockets Layer Toolkit
11Name: openssl
12Version: 1.1.1g
13Release: 1%{_dist_release}
14Group: System Environment/Libraries
15Vendor: Project Vine
16Distribution: Vine Linux
17Packager: daisuke, iwamoto
18
19License: BSDish
20URL: http://www.openssl.org/
21# We have to remove certain patented algorithms from the openssl source
22# tarball with the hobble-openssl script which is included below.
23# The original openssl upstream tarball cannot be shipped in the .src.rpm.
24Source: openssl-%{version}-hobbled.tar.xz
25Source1: hobble-openssl
26Source2: Makefile.certificate
27Source6: make-dummy-cert
28Source7: renew-dummy-cert
29Source9: opensslconf-new.h
30Source10: opensslconf-new-warning.h
31Source11: README.FIPS
32Source12: ec_curve.c
33Source13: ectest.c
34
35# Build changes
36Patch1: openssl-1.1.1f-build.patch
37Patch2: openssl-1.1.0-defaults.patch
38Patch3: openssl-1.1.0-no-html.patch
39Patch4: openssl-1.1.1-man-rename.patch
40# Bug fixes
41Patch21: openssl-1.1.0-issuer-hash.patch
42# Functionality changes
43Patch31: openssl-1.1.1-conf-paths.patch
44Patch32: openssl-1.1.1-version-add-engines.patch
45Patch33: openssl-1.1.1-apps-dgst.patch
46Patch36: openssl-1.1.1-no-brainpool.patch
47Patch37: openssl-1.1.1-ec-curves.patch
48Patch38: openssl-1.1.1-no-weak-verify.patch
49Patch40: openssl-1.1.1-disable-ssl3.patch
50Patch41: openssl-1.1.1-system-cipherlist.patch
51Patch42: openssl-1.1.1-fips.patch
52Patch43: openssl-1.1.1-ignore-bound.patch
53Patch44: openssl-1.1.1-version-override.patch
54Patch45: openssl-1.1.1-weak-ciphers.patch
55Patch46: openssl-1.1.1-seclevel.patch
56Patch48: openssl-1.1.1-fips-post-rand.patch
57Patch49: openssl-1.1.1-evp-kdf.patch
58Patch50: openssl-1.1.1-ssh-kdf.patch
59# Backported fixes including security fixes
60Patch51: openssl-1.1.1-upstream-sync.patch
61Patch52: openssl-1.1.1-s390x-update.patch
62Patch53: openssl-1.1.1-fips-crng-test.patch
63
64# security fix
65# none
66
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68BuildRequires: perl, sed
69BuildRequires: zlib-devel, krb5-devel
70BuildRequires: lksctp-tools-devel
71
72Requires: mktemp
73Requires: ca-certificates
74
75%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
76
77%description
78The OpenSSL certificate management tool and the shared libraries that
79provide various cryptographic algorithms and protocols.
80
81%package devel
82Summary: OpenSSL libraries and development headers.
83Group: Development/Libraries
84Requires: %{name} = %{version}-%{release}
85Requires: krb5-devel
86
87%description devel
88The static libraries and include files needed to compile apps
89with support for various the cryptographic algorithms and protocols
90supported by OpenSSL.
91
92Patches for many networking apps can be found at:
93ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
94
95%package static
96Summary:  Libraries for static linking of applications which will use OpenSSL
97Group: Development/Libraries
98Requires: %{name}-devel = %{version}-%{release}
99
100%description static
101OpenSSL is a toolkit for supporting cryptography. The openssl-static
102package contains static libraries needed for static linking of
103applications which support various cryptographic algorithms and
104protocols.
105
106%package perl
107Summary: OpenSSL scripts which require Perl.
108Group: Applications/Internet
109Requires: %{name} = %{version}-%{release}
110Requires: perl
111
112%description perl
113Perl scripts provided with OpenSSL for converting certificates and keys
114from other formats to those used by OpenSSL.
115
116## to build compat32 for x86_64 architecture support
117%package -n compat32-%{name}
118Summary: Secure Sockets Layer Toolkit
119Group: System Environment/Libraries
120Requires: %{name} = %{version}-%{release}
121%description -n compat32-%{name}
122The OpenSSL certificate management tool and the shared libraries that
123provide various cryptographic algorithms and protocols.
124
125%package -n compat32-%{name}-devel
126Summary: OpenSSL libraries and development headers.
127Group: Development/Libraries
128Requires: compat32-%{name} = %{version}-%{release}
129Requires: compat32-krb5-devel
130%description -n compat32-%{name}-devel
131The static libraries and include files needed to compile apps
132with support for various the cryptographic algorithms and protocols
133supported by OpenSSL.
134
135%prep
136%setup -q -n %{name}-%{version}
137
138# The hobble_openssl is called here redundantly, just to be sure.
139# The tarball has already the sources removed.
140%{SOURCE1} > /dev/null
141
142cp %{SOURCE12} crypto/ec/
143cp %{SOURCE13} test/
144
145%patch1 -p1 -b .build   %{?_rawbuild}
146%patch2 -p1 -b .defaults
147%patch3 -p1 -b .no-html  %{?_rawbuild}
148%patch4 -p1 -b .man-rename
149
150%patch21 -p1 -b .issuer-hash
151
152%patch31 -p1 -b .conf-paths
153%patch32 -p1 -b .version-add-engines
154%patch33 -p1 -b .dgst
155%patch36 -p1 -b .no-brainpool
156%patch37 -p1 -b .curves
157%patch38 -p1 -b .no-weak-verify
158%patch40 -p1 -b .disable-ssl3
159%patch41 -p1 -b .system-cipherlist
160%if %{with fips}
161%patch42 -p1 -b .fips
162%endif
163%patch43 -p1 -b .ignore-bound
164%if %{with fips}
165%patch44 -p1 -b .version-override
166%endif
167%patch45 -p1 -b .weak-ciphers
168%if %{with fips}
169%patch46 -p1 -b .seclevel
170%patch49 -p1 -b .evp-kdf
171%patch50 -p1 -b .ssh-kdf
172%patch51 -p1 -b .upstream-sync
173%endif
174#patch52 -p1 -b .s390x-update
175%if %{with fips}
176%patch53 -p1 -b .crng-test
177%endif
178
179# security fix
180# none
181
182%build
183# Figure out which flags we want to use.
184# default
185sslarch=%{_os}-%{_target_cpu}
186#
187%ifarch %ix86
188sslarch=linux-elf
189if ! echo %{_target} | grep -q i686 ; then
190   sslflags="no-asm 386"
191fi
192%endif
193%ifarch x86_64
194sslflags=enable-ec_nistp_64_gcc_128
195%endif
196
197# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
198# marked as not requiring an executable stack.
199# Also add -DPURIFY to make using valgrind with openssl easier as we do not
200# want to depend on the uninitialized memory as a source of entropy anyway.
201RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack -DPURIFY $RPM_LD_FLAGS"
202
203export HASHBANGPERL=/usr/bin/perl
204
205perl -pi -e 's|/engines-|/%{name}/engines-|' ./Configurations/unix-Makefile.tmpl
206
207# ia64, x86_64, ppc are OK by default
208# Configure the build tree.  Override OpenSSL defaults with known-good defaults
209# usable on all platforms.  The Configure script already knows to use -fPIC and
210# RPM_OPT_FLAGS, so we can skip specifiying them here.
211./Configure \
212        --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
213        --system-ciphers-file=%{_sysconfdir}/crypto-policies/back-ends/openssl.config \
214        zlib enable-camellia enable-seed enable-rfc3779 enable-sctp \
215        enable-cms enable-md2 enable-rc5 enable-ssl3 enable-ssl3-method \
216        enable-weak-ssl-ciphers \
217        no-mdc2 no-ec2m no-sm2 no-sm4 \
218        shared  ${sslarch} $RPM_OPT_FLAGS '-DDEVRANDOM="\"/dev/urandom\""'
219
220# Do not run this in a production package the FIPS symbols must be patched-in
221#util/mkdef.pl crypto update
222
223make all
224
225%if %{with fips}
226# Overwrite FIPS README
227cp -f %{SOURCE11} .
228%endif
229
230# Clean up the .pc files
231for i in libcrypto.pc libssl.pc openssl.pc ; do
232  sed -i '/^Libs.private:/{s/-L[^ ]* //;s/-Wl[^ ]* //}' $i
233done
234
235%check
236# Verify that what was compiled actually works.
237
238# Hack - either enable SCTP AUTH chunks in kernel or disable sctp for check
239(sysctl net.sctp.addip_enable=1 && sysctl net.sctp.auth_enable=1) || \
240(echo 'Failed to enable SCTP AUTH chunks, disabling SCTP for tests...' &&
241 sed '/"zlib-dynamic" => "default",/a\ \ "sctp" => "default",' configdata.pm > configdata.pm.new && \
242 touch -r configdata.pm configdata.pm.new && \
243 mv -f configdata.pm.new configdata.pm)
244
245# We must revert patch31 before tests otherwise they will fail
246patch -p1 -R < %{PATCH31}
247
248# drop a recipe includes tests for brainpool curves (not supported by openssl-hobbled).
249rm -f test/recipes/80-test_ssl_new.t
250
251
252LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
253export LD_LIBRARY_PATH
254OPENSSL_ENABLE_MD5_VERIFY=
255export OPENSSL_ENABLE_MD5_VERIFY
256OPENSSL_SYSTEM_CIPHERS_OVERRIDE=xyz_nonexistent_file
257export OPENSSL_SYSTEM_CIPHERS_OVERRIDE
258make test
259
260
261# Add generation of HMAC checksum of the final stripped library
262%define __spec_install_post \
263    %{?__debug_package:%{__debug_install_post}} \
264    %{__arch_install_post} \
265    %{__os_install_post} \
266%{nil}
267
268%define __provides_exclude_from %{_libdir}/openssl
269
270%install
271[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
272# Install OpenSSL.
273install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl,%{_pkgdocdir}}
274make DESTDIR=$RPM_BUILD_ROOT install
275mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
276rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
277for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
278        chmod 755 ${lib}
279        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT/%{_libdir}/`basename ${lib} .%{version}`
280        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
281done
282
283# Install a makefile for generating keys and self-signed certs, and a script
284# for generating them on the fly.
285mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
286install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_pkgdocdir}/Makefile.certificate
287install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/make-dummy-cert
288install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_bindir}/renew-dummy-cert
289
290# Move runable perl scripts to bindir
291mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/*.pl $RPM_BUILD_ROOT%{_bindir}
292mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/tsget $RPM_BUILD_ROOT%{_bindir}
293
294# Rename man pages so that they don't conflict with other system man pages.
295pushd $RPM_BUILD_ROOT%{_mandir}
296ln -s -f config.5 man5/openssl.cnf.5
297for manpage in man*/* ; do
298        if [ -L ${manpage} ]; then
299                TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
300                ln -snf ${TARGET}ssl ${manpage}ssl
301                rm -f ${manpage}
302        else
303                mv ${manpage} ${manpage}ssl
304        fi
305done
306for conflict in passwd rand ; do
307        rename ${conflict} ssl${conflict} man*/${conflict}*
308# Fix dangling symlinks
309        manpage=man1/openssl-${conflict}.*
310        if [ -L ${manpage} ] ; then
311                ln -snf ssl${conflict}.1ssl ${manpage}
312        fi
313done
314popd
315
316mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
317mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
318mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
319mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
320mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
321
322# Ensure the config file timestamps are identical across builds to avoid
323# mulitlib conflicts and unnecessary renames on upgrade
324touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
325touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf
326
327rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf.dist
328rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf.dist
329
330# Determine which arch opensslconf.h is going to try to #include.
331basearch=%{_arch}
332%ifarch %{ix86}
333basearch=i386
334%endif
335
336# Next step of gradual disablement of SSL3.
337# Make SSL3 disappear to newly built dependencies.
338sed -i '/^\#ifndef OPENSSL_NO_SSL_TRACE/i\
339#ifndef OPENSSL_NO_SSL3\
340# define OPENSSL_NO_SSL3\
341#endif' $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
342
343%ifarch %{multilib_arches}
344# Do an opensslconf.h switcheroo to avoid file conflicts on systems where you
345# can have both a 32- and 64-bit version of the library, and they each need
346# their own correct-but-different versions of opensslconf.h to be usable.
347install -m644 %{SOURCE10} \
348        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
349cat $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h >> \
350        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
351install -m644 %{SOURCE9} \
352        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
353%endif
354LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
355export LD_LIBRARY_PATH
356
357
358%clean
359[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
360
361%files
362%defattr(-,root,root)
363%{!?_licensedir:%global license %%doc}
364%license LICENSE
365%doc FAQ NEWS README
366%if %{with fips}
367%doc README.FIPS
368%endif
369%{_pkgdocdir}/Makefile.certificate
370%dir %{_sysconfdir}/pki/tls
371%dir %{_sysconfdir}/pki/tls/certs
372%dir %{_sysconfdir}/pki/tls/misc
373%dir %{_sysconfdir}/pki/tls/private
374%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
375%config(noreplace) %{_sysconfdir}/pki/tls/ct_log_list.cnf
376
377%{_bindir}/make-dummy-cert
378%{_bindir}/renew-dummy-cert
379%{_bindir}/openssl
380%attr(0755,root,root) /%{_lib}/*.so.*
381%attr(0755,root,root) %{_libdir}/%{name}/engines-%{soversion}
382%dir %{_mandir}/man1*
383%{_mandir}/man1*/*
384%dir %{_mandir}/man5*
385%{_mandir}/man5*/*
386%dir %{_mandir}/man7*
387%{_mandir}/man7*/*
388
389%files devel
390%defattr(-,root,root)
391%{_prefix}/include/openssl
392%exclude %{_libdir}/lib*.a
393%attr(0755,root,root) %{_libdir}/*.so
394%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
395%dir %{_mandir}/man3*
396%{_mandir}/man3*/*
397
398%files static
399%defattr(-,root,root)
400%attr(0644,root,root) %{_libdir}/*.a
401
402%files perl
403%defattr(-,root,root)
404%{_bindir}/c_rehash
405%{_bindir}/*.pl
406%{_bindir}/tsget
407%{_mandir}/man1*/*.pl*
408%{_mandir}/man1*/c_rehash*
409%{_mandir}/man1*/tsget*
410%{_mandir}/man1*/openssl-tsget*
411%dir %{_sysconfdir}/pki/CA
412%dir %{_sysconfdir}/pki/CA/private
413%dir %{_sysconfdir}/pki/CA/certs
414%dir %{_sysconfdir}/pki/CA/crl
415%dir %{_sysconfdir}/pki/CA/newcerts
416
417## to build compat32 for x86_64 architecture support
418%if %{build_compat32}
419%files -n compat32-%{name}
420%defattr(-,root,root)
421%attr(0755,root,root) /%{_lib}/*.so.*
422
423%files -n compat32-%{name}-devel
424%defattr(-,root,root)
425%exclude %{_libdir}/lib*.a
426%attr(0755,root,root) %{_libdir}/*.so
427%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
428%endif
429
430%post -p /sbin/ldconfig
431
432%postun -p /sbin/ldconfig
433
434%post -n compat32-%{name} -p /sbin/ldconfig
435
436%postun -n compat32-%{name} -p /sbin/ldconfig
437
438%changelog
439* Sat Apr 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1g-1
440- new upstream release.
441
442* Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1f-1
443- new upstream release.
444- updated Patch1.
445- dropped Patch54: fixed in upstream.
446
447* Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1e-1
448- new upstream release.
449- dropped Patch100 and 1000: fixed in upstream.
450
451* Fri Dec 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1d-2
452- imported Patch1000 from upstream.
453
454* Fri Sep 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1d-1
455- new upstream release.
456- updated Source12 and 13.
457- updated all patches.
458- imported Patch100 from upstream.
459
460* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1c-1
461- new upstream release.
462- updated Patch37 and 41.
463- imported Patch52-54 from rawhide.
464
465* Mon May 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-2
466- fixed openssl.cnf
467
468* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-1
469- new upstream release.
470- imported Patch36 from rawhide.
471- updated Patch32.
472
473* Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1a-1
474- new upstream release.
475- updated Patch2.
476- dropped Patch36 and 46: fixed in upstream.
477
478* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-2
479- fixed symlinks.
480
481* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
482- new upstream release (newest LTS version).
483- imported fedora stuff (except FIPS).
484
485* Sun Apr  1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
486- new upstream release with security fixes
487
488* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
489- new upstream release with security fixes
490
491* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
492- new upstream release with security fixes
493
494* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
495- new upstream release with security fixes
496
497* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
498- new upstream release with security fixes
499
500* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
501- new upstream release 1.0.2 with security fixes
502- Patch2 is merged into Patch0
503
504* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
505- new upstream release with security fixes
506
507* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
508- new upstream release with security fixes
509
510* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
511- new upstream release
512
513* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
514- merged into Vine6
515  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
516  - new upstream release with security fixes 
517  - update Patch2,5
518
519* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
520- new upstream release with security fixes 
521
522* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
523- new upstream release with security fixes
524- add patch8 from fc21 (fix perl find.pl)
525
526* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
527- new upstream release with security fixes.
528
529* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
530- new upstream release with security fixes
531
532* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
533- new upstream release with security fixes
534
535* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
536- move root CA bundle to ca-certificates package
537
538* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
539- update to 1.0.1e
540  - 1.0.1d has major regressions from 1.0.1c
541
542* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
543- remove tsget script to delete dependency perl(WWW::Curl::Easy)
544 - openssl-perl package contains it in docdir
545
546* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
547- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
548- fixed %%files
549
550* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
551- update to 1.0.1c
552- enable configure options:
553  enable-camellia enable-seed enable-tlsext enable-rfc3779
554  enable-cms enable-md2
555- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
556- generate a table with the compile settings before configure
557
558* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
559- new upstream release with security fix (CVE-2012-0050)
560
561* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
562- new upstream release with security fix
563  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
564
565* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
566- new upstream release with security fix (CVE-2011-3207, 3210)
567
568* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
569- rebuild with krb5-libs 1.8
570
571* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
572- new upstream release with security fix
573
574* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
575- use upstream openssl.pc instead of vine original one (SOURCE6)
576
577* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
578- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
579
580* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
581- add R: krb5-devel into devel pkg
582- add R: compat32-krb5-devel into compat32-devel pkg
583
584* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
585- new upstream release 1.0.0x
586- separate static libs into static package
587- change configure options
588- change so version 10
589- add tsget into perl package
590- update all patches
591
592* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
593- fix changelog typo...
594
595* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
596- new upstream release with security fix (CVE-2010-4180)
597
598* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
599- new upstream release with security fix (CVE-2010-3864)
600- drop patches included in new release
601- update patch4
602
603* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
604- add patch12 for fix CVE-2009-3555 (renegotiation)
605
606* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
607- add patch11 for fix CVE-2009-4355 (memory leak)
608
609* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
610- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
611
612* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
613- removed unnecessary %%if %{build_compat32} statements
614- removed lib*.a from devel package
615
616* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
617- new upstream release with security fix (CVE-2000-0590,0591,0789)
618
619* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
620- new upstream release with security fix (CVE-2008-5077)
621
622* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
623- new upstream release
624
625* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
626- new upstream release
627- new versioning policy
628
629* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
630- new upstream release
631- drop patch10,20 which is merged in upstream
632
633* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
634- add security patch in advance for CVE-2007-5135
635  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
636  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
637
638* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
639- add security patch for CVE-2007-3108
640  (http://openssl.org/news/patch-CVE-2007-3108.txt)
641
642* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
643- new upstream release
644
645* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
646- update (fix) openssl.pc <BTS:437>
647
648* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
649- new upstream release (with security fix)
650
651* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
652- new upstream release
653- add patch2 to use RPM_OPT macro
654
655* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
656- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
657
658* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
659- added compat32-* packages for x86_64 architecture support
660- added openssl-0.9.7i.Configure-compat32.patch
661- changed '/lib' to '/%{_lib}'
662
663* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
664- new upstream release
665
666* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
667- rebuild on VineSeed
668
669* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
670- added a security patch from Gentoo.
671  - Patch1: openssl-0.9.7c-tempfile.patch
672
673* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
674- sslarch for ppc was missing... added.
675
676* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
677- use sslarch=linux-alpha-gcc instead of alpha-gcc
678
679* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
680- new upstream version
681- clean up of spec file
682        -- removed old patches
683
684* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
685- new upstream release
686- SECURITY fix.
687  - http://www.openssl.org/news/secadv_20040317.txt
688
689* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
690- new upstream release
691- [Security fix]
692  - Vulnerabilities in ASN.1 parsing
693    http://www.openssl.org/news/secadv_20030930.txt
694- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
695
696* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
697- add openssl.pc for pkgconfig
698
699* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
700- New upstream version
701- dropped patch10, 11
702        -- merged upstream version
703
704* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
705- rebuild for VineSeed
706
707* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
708- [Security Fix]
709  - Timing-based attacks on RSA keys
710    http://www.openssl.org/news/secadv_20030317.txt
711  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
712    http://www.openssl.org/news/secadv_20030317.txt
713
714* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
715- new upstream release 0.9.6i
716- [Security Fix]
717- build for Vine Linux 2.6 errata
718
719* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
720- new upstream release 0.9.6h
721
722* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
723- new upstream release 0.9.6g
724
725* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
726- SECURITY: CAN-2002-0659 fixed
727  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
728    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
729    - update asn patch to fix accidental reversal of a logic check
730    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
731    - update asn patch to reduce chance that compiler optimization will remove
732      one of the added tests
733    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
734    - rebuild
735    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
736    - add patch to fix ASN.1 vulnerabilities
737
738* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
739- rename spec file name
740- SECURITY: CA-2002-23 fixed
741  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
742    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
743    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
744
745* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
746- added ${PATH} in LD_LIBRARY_PATH
747- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
748 
749* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
750- remove --no-<cipher>
751
752* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
753- add Patch10 for mipsel shared ( Configure )
754
755* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
756- build for Vine Linux
757- use openssl-engine-0.9.6b.tar.gz
758
759* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
760- update to 0.9.6b
761
762* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
763- move .so symlinks back to %%{_libdir}
764
765* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
766- move shared libraries to /lib (#38410)
767
768* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
769- switch to engine code base
770
771* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
772- add a script for creating dummy certificates
773- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
774
775* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
776- add s390x support
777
778* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
779- change two memcpy() calls to memmove()
780- don't define L_ENDIAN on alpha
781
782* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
783- make subpackages depend on the main package
784
785* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
786- adjust the hobble script to not disturb symlinks in include/ (fix from
787  Joe Orton)
788
789* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
790- drop the m2crypo patch we weren't using
791
792* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
793- configure using "shared" as well
794
795* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
796- update to 0.9.6a
797- use the build-shared target to build shared libraries
798- bump the soversion to 2 because we're no longer compatible with
799  our 0.9.5a packages or our 0.9.6 packages
800- drop the patch for making rsatest a no-op when rsa null support is used
801- put all man pages into <section>ssl instead of <section>
802- break the m2crypto modules into a separate package
803
804* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
805- use BN_LLONG on s390
806
807* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
808- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
809
810* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
811- move c_rehash to the perl subpackage, because it's a perl script now
812
813* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
814- update to 0.9.6
815- enable MD2
816- use the libcrypto.so and libssl.so targets to build shared libs with
817- bump the soversion to 1 because we're no longer compatible with any of
818  the various 0.9.5a packages circulating around, which provide lib*.so.0
819
820* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
821- change hobble-openssl for disabling MD2 again
822
823* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
824- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
825  bytes or so, causing EVP_DigestInit() to zero out stack variables in
826  apps built against a version of the library without it
827
828* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
829- disable some inline assembly, which on x86 is Pentium-specific
830- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
831
832* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
833- fix s390 patch
834
835* Fri Dec 8 2000 Than Ngo <than@redhat.com>
836- added support s390
837
838* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
839- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
840- add the CA.pl man page to the perl subpackage
841
842* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
843- always build with -mcpu=ev5 on alpha
844
845* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
846- add a symlink from cert.pem to ca-bundle.crt
847
848* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
849- add a ca-bundle file for packages like Samba to reference for CA certificates
850
851* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
852- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
853
854* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
855- add unzip as a buildprereq (#17662)
856- update m2crypto to 0.05-snap4
857
858* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
859- fix some issues in building when it's not installed
860
861* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
862- make sure the headers we include are the ones we built with (aaaaarrgh!)
863
864* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
865- add Richard Henderson's patch for BN on ia64
866- clean up the changelog
867
868* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
869- fix the building of python modules without openssl-devel already installed
870
871* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
872- byte-compile python extensions without the build-root
873- adjust the makefile to not remove temporary files (like .key files when
874  building .csr files) by marking them as .PRECIOUS
875
876* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
877- break out python extensions into a subpackage
878
879* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
880- tweak the makefile some more
881
882* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
883- disable MD2 support
884
885* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
886- disable MDC2 support
887
888* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
889- tweak the disabling of RC5, IDEA support
890- tweak the makefile
891
892* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
893- strip binaries and libraries
894- rework certificate makefile to have the right parts for Apache
895
896* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
897- use %%{_perl} instead of /usr/bin/perl
898- disable alpha until it passes its own test suite
899
900* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
901- move the passwd.1 man page out of the passwd package's way
902
903* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
904- update to 0.9.5a, modified for U.S.
905- add perl as a build-time requirement
906- move certificate makefile to another package
907- disable RC5, IDEA, RSA support
908- remove optimizations for now
909
910* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
911- Bero told me to move the Makefile into this package
912
913* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
914- add lib*.so symlinks to link dynamically against shared libs
915
916* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
917- update to 0.9.5
918- run ldconfig directly in post/postun
919- add FAQ
920
921* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
922- Fix build on non-x86 platforms
923
924* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
925- move /usr/share/ssl/* from -devel to main package
926
927* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
928- inital packaging
929- changes from base:
930  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
931  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.