source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 12368

Revision 12368, 31.2 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

hddtemp-0.3-0.36.beta15

lshw-B.02.19.2-1

libndp-1.7-1

openssl-1.1.1f-1

smartmontools-7.1-1

Line 
1%bcond_with fips
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}}
5# 1.0.0 soversion = 10
6# 1.1.0 soversion = 1.1 (same as upstream although presence of some symbols
7#                        depends on build configuration options)
8%define soversion 1.1
9
10Summary: Secure Sockets Layer Toolkit
11Name: openssl
12Version: 1.1.1f
13Release: 1%{_dist_release}
14# We have to remove certain patented algorithms from the openssl source
15# tarball with the hobble-openssl script which is included below.
16# The original openssl upstream tarball cannot be shipped in the .src.rpm.
17Source: openssl-%{version}-hobbled.tar.xz
18Source1: hobble-openssl
19Source2: Makefile.certificate
20Source6: make-dummy-cert
21Source7: renew-dummy-cert
22Source9: opensslconf-new.h
23Source10: opensslconf-new-warning.h
24Source11: README.FIPS
25Source12: ec_curve.c
26Source13: ectest.c
27
28# Build changes
29Patch1: openssl-1.1.1f-build.patch
30Patch2: openssl-1.1.0-defaults.patch
31Patch3: openssl-1.1.0-no-html.patch
32Patch4: openssl-1.1.1-man-rename.patch
33# Bug fixes
34Patch21: openssl-1.1.0-issuer-hash.patch
35# Functionality changes
36Patch31: openssl-1.1.1-conf-paths.patch
37Patch32: openssl-1.1.1-version-add-engines.patch
38Patch33: openssl-1.1.1-apps-dgst.patch
39Patch36: openssl-1.1.1-no-brainpool.patch
40Patch37: openssl-1.1.1-ec-curves.patch
41Patch38: openssl-1.1.1-no-weak-verify.patch
42Patch40: openssl-1.1.1-disable-ssl3.patch
43Patch41: openssl-1.1.1-system-cipherlist.patch
44Patch42: openssl-1.1.1-fips.patch
45Patch43: openssl-1.1.1-ignore-bound.patch
46Patch44: openssl-1.1.1-version-override.patch
47Patch45: openssl-1.1.1-weak-ciphers.patch
48Patch46: openssl-1.1.1-seclevel.patch
49Patch48: openssl-1.1.1-fips-post-rand.patch
50Patch49: openssl-1.1.1-evp-kdf.patch
51Patch50: openssl-1.1.1-ssh-kdf.patch
52# Backported fixes including security fixes
53Patch51: openssl-1.1.1-upstream-sync.patch
54Patch52: openssl-1.1.1-s390x-update.patch
55Patch53: openssl-1.1.1-fips-crng-test.patch
56
57# security fix
58# none
59
60License: BSDish
61Group: System Environment/Libraries
62URL: http://www.openssl.org/
63
64BuildRoot: %{_tmppath}/%{name}-%{version}-root
65BuildRequires: perl, sed
66BuildRequires: zlib-devel, krb5-devel
67BuildRequires: lksctp-tools-devel
68
69Requires: mktemp
70Requires: ca-certificates
71
72Vendor: Project Vine
73Distribution: Vine Linux
74Packager: daisuke, iwamoto
75
76%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
77
78%description
79The OpenSSL certificate management tool and the shared libraries that
80provide various cryptographic algorithms and protocols.
81
82%package devel
83Summary: OpenSSL libraries and development headers.
84Group: Development/Libraries
85Requires: %{name} = %{version}-%{release}
86Requires: krb5-devel
87
88%description devel
89The static libraries and include files needed to compile apps
90with support for various the cryptographic algorithms and protocols
91supported by OpenSSL.
92
93Patches for many networking apps can be found at:
94ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
95
96%package static
97Summary:  Libraries for static linking of applications which will use OpenSSL
98Group: Development/Libraries
99Requires: %{name}-devel = %{version}-%{release}
100
101%description static
102OpenSSL is a toolkit for supporting cryptography. The openssl-static
103package contains static libraries needed for static linking of
104applications which support various cryptographic algorithms and
105protocols.
106
107%package perl
108Summary: OpenSSL scripts which require Perl.
109Group: Applications/Internet
110Requires: %{name} = %{version}-%{release}
111Requires: perl
112
113%description perl
114Perl scripts provided with OpenSSL for converting certificates and keys
115from other formats to those used by OpenSSL.
116
117## to build compat32 for x86_64 architecture support
118%package -n compat32-%{name}
119Summary: Secure Sockets Layer Toolkit
120Group: System Environment/Libraries
121Requires: %{name} = %{version}-%{release}
122%description -n compat32-%{name}
123The OpenSSL certificate management tool and the shared libraries that
124provide various cryptographic algorithms and protocols.
125
126%package -n compat32-%{name}-devel
127Summary: OpenSSL libraries and development headers.
128Group: Development/Libraries
129Requires: compat32-%{name} = %{version}-%{release}
130Requires: compat32-krb5-devel
131%description -n compat32-%{name}-devel
132The static libraries and include files needed to compile apps
133with support for various the cryptographic algorithms and protocols
134supported by OpenSSL.
135
136%prep
137%setup -q -n %{name}-%{version}
138
139# The hobble_openssl is called here redundantly, just to be sure.
140# The tarball has already the sources removed.
141%{SOURCE1} > /dev/null
142
143cp %{SOURCE12} crypto/ec/
144cp %{SOURCE13} test/
145
146%patch1 -p1 -b .build   %{?_rawbuild}
147%patch2 -p1 -b .defaults
148%patch3 -p1 -b .no-html  %{?_rawbuild}
149%patch4 -p1 -b .man-rename
150
151%patch21 -p1 -b .issuer-hash
152
153%patch31 -p1 -b .conf-paths
154%patch32 -p1 -b .version-add-engines
155%patch33 -p1 -b .dgst
156%patch36 -p1 -b .no-brainpool
157%patch37 -p1 -b .curves
158%patch38 -p1 -b .no-weak-verify
159%patch40 -p1 -b .disable-ssl3
160%patch41 -p1 -b .system-cipherlist
161%if %{with fips}
162%patch42 -p1 -b .fips
163%endif
164%patch43 -p1 -b .ignore-bound
165%if %{with fips}
166%patch44 -p1 -b .version-override
167%endif
168%patch45 -p1 -b .weak-ciphers
169%if %{with fips}
170%patch46 -p1 -b .seclevel
171%patch49 -p1 -b .evp-kdf
172%patch50 -p1 -b .ssh-kdf
173%patch51 -p1 -b .upstream-sync
174%endif
175#patch52 -p1 -b .s390x-update
176%if %{with fips}
177%patch53 -p1 -b .crng-test
178%endif
179
180# security fix
181# none
182
183%build
184# Figure out which flags we want to use.
185# default
186sslarch=%{_os}-%{_target_cpu}
187#
188%ifarch %ix86
189sslarch=linux-elf
190if ! echo %{_target} | grep -q i686 ; then
191   sslflags="no-asm 386"
192fi
193%endif
194%ifarch x86_64
195sslflags=enable-ec_nistp_64_gcc_128
196%endif
197
198# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
199# marked as not requiring an executable stack.
200# Also add -DPURIFY to make using valgrind with openssl easier as we do not
201# want to depend on the uninitialized memory as a source of entropy anyway.
202RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack -DPURIFY $RPM_LD_FLAGS"
203
204export HASHBANGPERL=/usr/bin/perl
205
206perl -pi -e 's|/engines-|/%{name}/engines-|' ./Configurations/unix-Makefile.tmpl
207
208# ia64, x86_64, ppc are OK by default
209# Configure the build tree.  Override OpenSSL defaults with known-good defaults
210# usable on all platforms.  The Configure script already knows to use -fPIC and
211# RPM_OPT_FLAGS, so we can skip specifiying them here.
212./Configure \
213        --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
214        --system-ciphers-file=%{_sysconfdir}/crypto-policies/back-ends/openssl.config \
215        zlib enable-camellia enable-seed enable-rfc3779 enable-sctp \
216        enable-cms enable-md2 enable-rc5 enable-ssl3 enable-ssl3-method \
217        enable-weak-ssl-ciphers \
218        no-mdc2 no-ec2m no-sm2 no-sm4 \
219        shared  ${sslarch} $RPM_OPT_FLAGS '-DDEVRANDOM="\"/dev/urandom\""'
220
221# Do not run this in a production package the FIPS symbols must be patched-in
222#util/mkdef.pl crypto update
223
224make all
225
226%if %{with fips}
227# Overwrite FIPS README
228cp -f %{SOURCE11} .
229%endif
230
231# Clean up the .pc files
232for i in libcrypto.pc libssl.pc openssl.pc ; do
233  sed -i '/^Libs.private:/{s/-L[^ ]* //;s/-Wl[^ ]* //}' $i
234done
235
236%check
237# Verify that what was compiled actually works.
238
239# Hack - either enable SCTP AUTH chunks in kernel or disable sctp for check
240(sysctl net.sctp.addip_enable=1 && sysctl net.sctp.auth_enable=1) || \
241(echo 'Failed to enable SCTP AUTH chunks, disabling SCTP for tests...' &&
242 sed '/"zlib-dynamic" => "default",/a\ \ "sctp" => "default",' configdata.pm > configdata.pm.new && \
243 touch -r configdata.pm configdata.pm.new && \
244 mv -f configdata.pm.new configdata.pm)
245
246# We must revert patch31 before tests otherwise they will fail
247patch -p1 -R < %{PATCH31}
248
249# drop a recipe includes tests for brainpool curves (not supported by openssl-hobbled).
250rm -f test/recipes/80-test_ssl_new.t
251
252
253LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
254export LD_LIBRARY_PATH
255OPENSSL_ENABLE_MD5_VERIFY=
256export OPENSSL_ENABLE_MD5_VERIFY
257OPENSSL_SYSTEM_CIPHERS_OVERRIDE=xyz_nonexistent_file
258export OPENSSL_SYSTEM_CIPHERS_OVERRIDE
259make test
260
261
262# Add generation of HMAC checksum of the final stripped library
263%define __spec_install_post \
264    %{?__debug_package:%{__debug_install_post}} \
265    %{__arch_install_post} \
266    %{__os_install_post} \
267%{nil}
268
269%define __provides_exclude_from %{_libdir}/openssl
270
271%install
272[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
273# Install OpenSSL.
274install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl,%{_pkgdocdir}}
275make DESTDIR=$RPM_BUILD_ROOT install
276mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
277rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
278for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
279        chmod 755 ${lib}
280        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT/%{_libdir}/`basename ${lib} .%{version}`
281        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
282done
283
284# Install a makefile for generating keys and self-signed certs, and a script
285# for generating them on the fly.
286mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
287install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_pkgdocdir}/Makefile.certificate
288install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/make-dummy-cert
289install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_bindir}/renew-dummy-cert
290
291# Move runable perl scripts to bindir
292mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/*.pl $RPM_BUILD_ROOT%{_bindir}
293mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/tsget $RPM_BUILD_ROOT%{_bindir}
294
295# Rename man pages so that they don't conflict with other system man pages.
296pushd $RPM_BUILD_ROOT%{_mandir}
297ln -s -f config.5 man5/openssl.cnf.5
298for manpage in man*/* ; do
299        if [ -L ${manpage} ]; then
300                TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
301                ln -snf ${TARGET}ssl ${manpage}ssl
302                rm -f ${manpage}
303        else
304                mv ${manpage} ${manpage}ssl
305        fi
306done
307for conflict in passwd rand ; do
308        rename ${conflict} ssl${conflict} man*/${conflict}*
309# Fix dangling symlinks
310        manpage=man1/openssl-${conflict}.*
311        if [ -L ${manpage} ] ; then
312                ln -snf ssl${conflict}.1ssl ${manpage}
313        fi
314done
315popd
316
317mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
318mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
319mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
320mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
321mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
322
323# Ensure the config file timestamps are identical across builds to avoid
324# mulitlib conflicts and unnecessary renames on upgrade
325touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
326touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf
327
328rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf.dist
329rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf.dist
330
331# Determine which arch opensslconf.h is going to try to #include.
332basearch=%{_arch}
333%ifarch %{ix86}
334basearch=i386
335%endif
336
337# Next step of gradual disablement of SSL3.
338# Make SSL3 disappear to newly built dependencies.
339sed -i '/^\#ifndef OPENSSL_NO_SSL_TRACE/i\
340#ifndef OPENSSL_NO_SSL3\
341# define OPENSSL_NO_SSL3\
342#endif' $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
343
344%ifarch %{multilib_arches}
345# Do an opensslconf.h switcheroo to avoid file conflicts on systems where you
346# can have both a 32- and 64-bit version of the library, and they each need
347# their own correct-but-different versions of opensslconf.h to be usable.
348install -m644 %{SOURCE10} \
349        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
350cat $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h >> \
351        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
352install -m644 %{SOURCE9} \
353        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
354%endif
355LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
356export LD_LIBRARY_PATH
357
358
359%clean
360[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
361
362%files
363%defattr(-,root,root)
364%{!?_licensedir:%global license %%doc}
365%license LICENSE
366%doc FAQ NEWS README
367%if %{with fips}
368%doc README.FIPS
369%endif
370%{_pkgdocdir}/Makefile.certificate
371%dir %{_sysconfdir}/pki/tls
372%dir %{_sysconfdir}/pki/tls/certs
373%dir %{_sysconfdir}/pki/tls/misc
374%dir %{_sysconfdir}/pki/tls/private
375%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
376%config(noreplace) %{_sysconfdir}/pki/tls/ct_log_list.cnf
377
378%{_bindir}/make-dummy-cert
379%{_bindir}/renew-dummy-cert
380%{_bindir}/openssl
381%attr(0755,root,root) /%{_lib}/*.so.*
382%attr(0755,root,root) %{_libdir}/%{name}/engines-%{soversion}
383%dir %{_mandir}/man1*
384%{_mandir}/man1*/*
385%dir %{_mandir}/man5*
386%{_mandir}/man5*/*
387%dir %{_mandir}/man7*
388%{_mandir}/man7*/*
389
390%files devel
391%defattr(-,root,root)
392%{_prefix}/include/openssl
393%exclude %{_libdir}/lib*.a
394%attr(0755,root,root) %{_libdir}/*.so
395%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
396%dir %{_mandir}/man3*
397%{_mandir}/man3*/*
398
399%files static
400%defattr(-,root,root)
401%attr(0644,root,root) %{_libdir}/*.a
402
403%files perl
404%defattr(-,root,root)
405%{_bindir}/c_rehash
406%{_bindir}/*.pl
407%{_bindir}/tsget
408%{_mandir}/man1*/*.pl*
409%{_mandir}/man1*/c_rehash*
410%{_mandir}/man1*/tsget*
411%{_mandir}/man1*/openssl-tsget*
412%dir %{_sysconfdir}/pki/CA
413%dir %{_sysconfdir}/pki/CA/private
414%dir %{_sysconfdir}/pki/CA/certs
415%dir %{_sysconfdir}/pki/CA/crl
416%dir %{_sysconfdir}/pki/CA/newcerts
417
418## to build compat32 for x86_64 architecture support
419%if %{build_compat32}
420%files -n compat32-%{name}
421%defattr(-,root,root)
422%attr(0755,root,root) /%{_lib}/*.so.*
423
424%files -n compat32-%{name}-devel
425%defattr(-,root,root)
426%exclude %{_libdir}/lib*.a
427%attr(0755,root,root) %{_libdir}/*.so
428%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
429%endif
430
431%post -p /sbin/ldconfig
432
433%postun -p /sbin/ldconfig
434
435%post -n compat32-%{name} -p /sbin/ldconfig
436
437%postun -n compat32-%{name} -p /sbin/ldconfig
438
439%changelog
440* Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1f-1
441- new upstream release.
442- updated Patch1.
443- dropped Patch54: fixed in upstream.
444
445* Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1e-1
446- new upstream release.
447- dropped Patch100 and 1000: fixed in upstream.
448
449* Fri Dec 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1d-2
450- imported Patch1000 from upstream.
451
452* Fri Sep 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1d-1
453- new upstream release.
454- updated Source12 and 13.
455- updated all patches.
456- imported Patch100 from upstream.
457
458* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1c-1
459- new upstream release.
460- updated Patch37 and 41.
461- imported Patch52-54 from rawhide.
462
463* Mon May 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-2
464- fixed openssl.cnf
465
466* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-1
467- new upstream release.
468- imported Patch36 from rawhide.
469- updated Patch32.
470
471* Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1a-1
472- new upstream release.
473- updated Patch2.
474- dropped Patch36 and 46: fixed in upstream.
475
476* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-2
477- fixed symlinks.
478
479* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
480- new upstream release (newest LTS version).
481- imported fedora stuff (except FIPS).
482
483* Sun Apr  1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
484- new upstream release with security fixes
485
486* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
487- new upstream release with security fixes
488
489* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
490- new upstream release with security fixes
491
492* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
493- new upstream release with security fixes
494
495* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
496- new upstream release with security fixes
497
498* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
499- new upstream release 1.0.2 with security fixes
500- Patch2 is merged into Patch0
501
502* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
503- new upstream release with security fixes
504
505* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
506- new upstream release with security fixes
507
508* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
509- new upstream release
510
511* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
512- merged into Vine6
513  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
514  - new upstream release with security fixes 
515  - update Patch2,5
516
517* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
518- new upstream release with security fixes 
519
520* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
521- new upstream release with security fixes
522- add patch8 from fc21 (fix perl find.pl)
523
524* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
525- new upstream release with security fixes.
526
527* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
528- new upstream release with security fixes
529
530* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
531- new upstream release with security fixes
532
533* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
534- move root CA bundle to ca-certificates package
535
536* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
537- update to 1.0.1e
538  - 1.0.1d has major regressions from 1.0.1c
539
540* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
541- remove tsget script to delete dependency perl(WWW::Curl::Easy)
542 - openssl-perl package contains it in docdir
543
544* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
545- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
546- fixed %%files
547
548* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
549- update to 1.0.1c
550- enable configure options:
551  enable-camellia enable-seed enable-tlsext enable-rfc3779
552  enable-cms enable-md2
553- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
554- generate a table with the compile settings before configure
555
556* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
557- new upstream release with security fix (CVE-2012-0050)
558
559* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
560- new upstream release with security fix
561  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
562
563* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
564- new upstream release with security fix (CVE-2011-3207, 3210)
565
566* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
567- rebuild with krb5-libs 1.8
568
569* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
570- new upstream release with security fix
571
572* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
573- use upstream openssl.pc instead of vine original one (SOURCE6)
574
575* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
576- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
577
578* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
579- add R: krb5-devel into devel pkg
580- add R: compat32-krb5-devel into compat32-devel pkg
581
582* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
583- new upstream release 1.0.0x
584- separate static libs into static package
585- change configure options
586- change so version 10
587- add tsget into perl package
588- update all patches
589
590* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
591- fix changelog typo...
592
593* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
594- new upstream release with security fix (CVE-2010-4180)
595
596* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
597- new upstream release with security fix (CVE-2010-3864)
598- drop patches included in new release
599- update patch4
600
601* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
602- add patch12 for fix CVE-2009-3555 (renegotiation)
603
604* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
605- add patch11 for fix CVE-2009-4355 (memory leak)
606
607* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
608- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
609
610* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
611- removed unnecessary %%if %{build_compat32} statements
612- removed lib*.a from devel package
613
614* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
615- new upstream release with security fix (CVE-2000-0590,0591,0789)
616
617* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
618- new upstream release with security fix (CVE-2008-5077)
619
620* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
621- new upstream release
622
623* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
624- new upstream release
625- new versioning policy
626
627* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
628- new upstream release
629- drop patch10,20 which is merged in upstream
630
631* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
632- add security patch in advance for CVE-2007-5135
633  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
634  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
635
636* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
637- add security patch for CVE-2007-3108
638  (http://openssl.org/news/patch-CVE-2007-3108.txt)
639
640* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
641- new upstream release
642
643* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
644- update (fix) openssl.pc <BTS:437>
645
646* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
647- new upstream release (with security fix)
648
649* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
650- new upstream release
651- add patch2 to use RPM_OPT macro
652
653* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
654- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
655
656* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
657- added compat32-* packages for x86_64 architecture support
658- added openssl-0.9.7i.Configure-compat32.patch
659- changed '/lib' to '/%{_lib}'
660
661* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
662- new upstream release
663
664* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
665- rebuild on VineSeed
666
667* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
668- added a security patch from Gentoo.
669  - Patch1: openssl-0.9.7c-tempfile.patch
670
671* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
672- sslarch for ppc was missing... added.
673
674* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
675- use sslarch=linux-alpha-gcc instead of alpha-gcc
676
677* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
678- new upstream version
679- clean up of spec file
680        -- removed old patches
681
682* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
683- new upstream release
684- SECURITY fix.
685  - http://www.openssl.org/news/secadv_20040317.txt
686
687* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
688- new upstream release
689- [Security fix]
690  - Vulnerabilities in ASN.1 parsing
691    http://www.openssl.org/news/secadv_20030930.txt
692- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
693
694* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
695- add openssl.pc for pkgconfig
696
697* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
698- New upstream version
699- dropped patch10, 11
700        -- merged upstream version
701
702* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
703- rebuild for VineSeed
704
705* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
706- [Security Fix]
707  - Timing-based attacks on RSA keys
708    http://www.openssl.org/news/secadv_20030317.txt
709  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
710    http://www.openssl.org/news/secadv_20030317.txt
711
712* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
713- new upstream release 0.9.6i
714- [Security Fix]
715- build for Vine Linux 2.6 errata
716
717* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
718- new upstream release 0.9.6h
719
720* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
721- new upstream release 0.9.6g
722
723* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
724- SECURITY: CAN-2002-0659 fixed
725  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
726    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
727    - update asn patch to fix accidental reversal of a logic check
728    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
729    - update asn patch to reduce chance that compiler optimization will remove
730      one of the added tests
731    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
732    - rebuild
733    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
734    - add patch to fix ASN.1 vulnerabilities
735
736* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
737- rename spec file name
738- SECURITY: CA-2002-23 fixed
739  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
740    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
741    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
742
743* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
744- added ${PATH} in LD_LIBRARY_PATH
745- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
746 
747* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
748- remove --no-<cipher>
749
750* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
751- add Patch10 for mipsel shared ( Configure )
752
753* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
754- build for Vine Linux
755- use openssl-engine-0.9.6b.tar.gz
756
757* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
758- update to 0.9.6b
759
760* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
761- move .so symlinks back to %%{_libdir}
762
763* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
764- move shared libraries to /lib (#38410)
765
766* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
767- switch to engine code base
768
769* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
770- add a script for creating dummy certificates
771- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
772
773* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
774- add s390x support
775
776* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
777- change two memcpy() calls to memmove()
778- don't define L_ENDIAN on alpha
779
780* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
781- make subpackages depend on the main package
782
783* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
784- adjust the hobble script to not disturb symlinks in include/ (fix from
785  Joe Orton)
786
787* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
788- drop the m2crypo patch we weren't using
789
790* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
791- configure using "shared" as well
792
793* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
794- update to 0.9.6a
795- use the build-shared target to build shared libraries
796- bump the soversion to 2 because we're no longer compatible with
797  our 0.9.5a packages or our 0.9.6 packages
798- drop the patch for making rsatest a no-op when rsa null support is used
799- put all man pages into <section>ssl instead of <section>
800- break the m2crypto modules into a separate package
801
802* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
803- use BN_LLONG on s390
804
805* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
806- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
807
808* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
809- move c_rehash to the perl subpackage, because it's a perl script now
810
811* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
812- update to 0.9.6
813- enable MD2
814- use the libcrypto.so and libssl.so targets to build shared libs with
815- bump the soversion to 1 because we're no longer compatible with any of
816  the various 0.9.5a packages circulating around, which provide lib*.so.0
817
818* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
819- change hobble-openssl for disabling MD2 again
820
821* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
822- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
823  bytes or so, causing EVP_DigestInit() to zero out stack variables in
824  apps built against a version of the library without it
825
826* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
827- disable some inline assembly, which on x86 is Pentium-specific
828- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
829
830* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
831- fix s390 patch
832
833* Fri Dec 8 2000 Than Ngo <than@redhat.com>
834- added support s390
835
836* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
837- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
838- add the CA.pl man page to the perl subpackage
839
840* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
841- always build with -mcpu=ev5 on alpha
842
843* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
844- add a symlink from cert.pem to ca-bundle.crt
845
846* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
847- add a ca-bundle file for packages like Samba to reference for CA certificates
848
849* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
850- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
851
852* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
853- add unzip as a buildprereq (#17662)
854- update m2crypto to 0.05-snap4
855
856* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
857- fix some issues in building when it's not installed
858
859* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
860- make sure the headers we include are the ones we built with (aaaaarrgh!)
861
862* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
863- add Richard Henderson's patch for BN on ia64
864- clean up the changelog
865
866* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
867- fix the building of python modules without openssl-devel already installed
868
869* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
870- byte-compile python extensions without the build-root
871- adjust the makefile to not remove temporary files (like .key files when
872  building .csr files) by marking them as .PRECIOUS
873
874* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
875- break out python extensions into a subpackage
876
877* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
878- tweak the makefile some more
879
880* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
881- disable MD2 support
882
883* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
884- disable MDC2 support
885
886* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
887- tweak the disabling of RC5, IDEA support
888- tweak the makefile
889
890* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
891- strip binaries and libraries
892- rework certificate makefile to have the right parts for Apache
893
894* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
895- use %%{_perl} instead of /usr/bin/perl
896- disable alpha until it passes its own test suite
897
898* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
899- move the passwd.1 man page out of the passwd package's way
900
901* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
902- update to 0.9.5a, modified for U.S.
903- add perl as a build-time requirement
904- move certificate makefile to another package
905- disable RC5, IDEA, RSA support
906- remove optimizations for now
907
908* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
909- Bero told me to move the Makefile into this package
910
911* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
912- add lib*.so symlinks to link dynamically against shared libs
913
914* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
915- update to 0.9.5
916- run ldconfig directly in post/postun
917- add FAQ
918
919* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
920- Fix build on non-x86 platforms
921
922* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
923- move /usr/share/ssl/* from -devel to main package
924
925* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
926- inital packaging
927- changes from base:
928  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
929  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.