source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 12317

Revision 12317, 31.2 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

dovecot-2.3.9.2-1

mariadb-10.4.11-1

openssl-1.1.1d-2

php73-7.3.13-1

spamassassin-3.4.3-1

squid-4.9-1

zabbix-4.0.15-1

Line 
1%bcond_with fips
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}}
5%define version 1.1.1d
6%define release 2%{_dist_release}
7# 1.0.0 soversion = 10
8# 1.1.0 soversion = 1.1 (same as upstream although presence of some symbols
9#                        depends on build configuration options)
10%define soversion 1.1
11
12Summary: Secure Sockets Layer Toolkit
13Name: openssl
14Version: %{version}
15Release: %{release}
16# We have to remove certain patented algorithms from the openssl source
17# tarball with the hobble-openssl script which is included below.
18# The original openssl upstream tarball cannot be shipped in the .src.rpm.
19Source: openssl-%{version}-hobbled.tar.xz
20Source1: hobble-openssl
21Source2: Makefile.certificate
22Source6: make-dummy-cert
23Source7: renew-dummy-cert
24Source9: opensslconf-new.h
25Source10: opensslconf-new-warning.h
26Source11: README.FIPS
27Source12: ec_curve.c
28Source13: ectest.c
29
30# Build changes
31Patch1: openssl-1.1.1-build.patch
32Patch2: openssl-1.1.0-defaults.patch
33Patch3: openssl-1.1.0-no-html.patch
34Patch4: openssl-1.1.1-man-rename.patch
35# Bug fixes
36Patch21: openssl-1.1.0-issuer-hash.patch
37# Functionality changes
38Patch31: openssl-1.1.1-conf-paths.patch
39Patch32: openssl-1.1.1-version-add-engines.patch
40Patch33: openssl-1.1.1-apps-dgst.patch
41Patch36: openssl-1.1.1-no-brainpool.patch
42Patch37: openssl-1.1.1-ec-curves.patch
43Patch38: openssl-1.1.1-no-weak-verify.patch
44Patch40: openssl-1.1.1-disable-ssl3.patch
45Patch41: openssl-1.1.1-system-cipherlist.patch
46Patch42: openssl-1.1.1-fips.patch
47Patch43: openssl-1.1.1-ignore-bound.patch
48Patch44: openssl-1.1.1-version-override.patch
49Patch45: openssl-1.1.1-weak-ciphers.patch
50Patch46: openssl-1.1.1-seclevel.patch
51Patch48: openssl-1.1.1-fips-post-rand.patch
52Patch49: openssl-1.1.1-evp-kdf.patch
53Patch50: openssl-1.1.1-ssh-kdf.patch
54# Backported fixes including security fixes
55Patch51: openssl-1.1.1-upstream-sync.patch
56Patch52: openssl-1.1.1-s390x-update.patch
57Patch53: openssl-1.1.1-fips-crng-test.patch
58Patch54: openssl-1.1.1-regression-fixes.patch
59Patch100: BIO_f_zlib.patch
60
61# security fix
62# https://git.openssl.org/gitweb/?p=openssl.git;a=patch;h=419102400a2811582a7a3d4a4e317d72e5ce0a8f
63Patch1000: CVE-2019-1551.patch
64
65License: BSDish
66Group: System Environment/Libraries
67URL: http://www.openssl.org/
68
69BuildRoot: %{_tmppath}/%{name}-%{version}-root
70BuildRequires: perl, sed
71BuildRequires: zlib-devel, krb5-devel
72BuildRequires: lksctp-tools-devel
73
74Requires: mktemp
75Requires: ca-certificates
76
77Vendor: Project Vine
78Distribution: Vine Linux
79Packager: daisuke, iwamoto
80
81%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
82
83%description
84The OpenSSL certificate management tool and the shared libraries that
85provide various cryptographic algorithms and protocols.
86
87%package devel
88Summary: OpenSSL libraries and development headers.
89Group: Development/Libraries
90Requires: %{name} = %{version}-%{release}
91Requires: krb5-devel
92
93%description devel
94The static libraries and include files needed to compile apps
95with support for various the cryptographic algorithms and protocols
96supported by OpenSSL.
97
98Patches for many networking apps can be found at:
99ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
100
101%package static
102Summary:  Libraries for static linking of applications which will use OpenSSL
103Group: Development/Libraries
104Requires: %{name}-devel = %{version}-%{release}
105
106%description static
107OpenSSL is a toolkit for supporting cryptography. The openssl-static
108package contains static libraries needed for static linking of
109applications which support various cryptographic algorithms and
110protocols.
111
112%package perl
113Summary: OpenSSL scripts which require Perl.
114Group: Applications/Internet
115Requires: %{name} = %{version}-%{release}
116Requires: perl
117
118%description perl
119Perl scripts provided with OpenSSL for converting certificates and keys
120from other formats to those used by OpenSSL.
121
122## to build compat32 for x86_64 architecture support
123%package -n compat32-%{name}
124Summary: Secure Sockets Layer Toolkit
125Group: System Environment/Libraries
126Requires: %{name} = %{version}-%{release}
127%description -n compat32-%{name}
128The OpenSSL certificate management tool and the shared libraries that
129provide various cryptographic algorithms and protocols.
130
131%package -n compat32-%{name}-devel
132Summary: OpenSSL libraries and development headers.
133Group: Development/Libraries
134Requires: compat32-%{name} = %{version}-%{release}
135Requires: compat32-krb5-devel
136%description -n compat32-%{name}-devel
137The static libraries and include files needed to compile apps
138with support for various the cryptographic algorithms and protocols
139supported by OpenSSL.
140
141%prep
142%setup -q -n %{name}-%{version}
143
144# The hobble_openssl is called here redundantly, just to be sure.
145# The tarball has already the sources removed.
146%{SOURCE1} > /dev/null
147
148cp %{SOURCE12} crypto/ec/
149cp %{SOURCE13} test/
150
151%patch1 -p1 -b .build   %{?_rawbuild}
152%patch2 -p1 -b .defaults
153%patch3 -p1 -b .no-html  %{?_rawbuild}
154%patch4 -p1 -b .man-rename
155
156%patch21 -p1 -b .issuer-hash
157
158%patch31 -p1 -b .conf-paths
159%patch32 -p1 -b .version-add-engines
160%patch33 -p1 -b .dgst
161%patch36 -p1 -b .no-brainpool
162%patch37 -p1 -b .curves
163%patch38 -p1 -b .no-weak-verify
164%patch40 -p1 -b .disable-ssl3
165%patch41 -p1 -b .system-cipherlist
166%if %{with fips}
167%patch42 -p1 -b .fips
168%endif
169%patch43 -p1 -b .ignore-bound
170%if %{with fips}
171%patch44 -p1 -b .version-override
172%endif
173%patch45 -p1 -b .weak-ciphers
174%if %{with fips}
175%patch46 -p1 -b .seclevel
176%patch49 -p1 -b .evp-kdf
177%patch50 -p1 -b .ssh-kdf
178%patch51 -p1 -b .upstream-sync
179%endif
180%patch52 -p1 -b .s390x-update
181%if %{with fips}
182%patch53 -p1 -b .crng-test
183%endif
184%patch54 -p1 -b .regression
185
186%patch100 -p1 -b .BIO_f_zlib
187
188# security fix
189%patch1000 -p1 -b .CVE-2019-1551
190
191%build
192# Figure out which flags we want to use.
193# default
194sslarch=%{_os}-%{_target_cpu}
195#
196%ifarch %ix86
197sslarch=linux-elf
198if ! echo %{_target} | grep -q i686 ; then
199   sslflags="no-asm 386"
200fi
201%endif
202%ifarch x86_64
203sslflags=enable-ec_nistp_64_gcc_128
204%endif
205
206# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
207# marked as not requiring an executable stack.
208# Also add -DPURIFY to make using valgrind with openssl easier as we do not
209# want to depend on the uninitialized memory as a source of entropy anyway.
210RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack -DPURIFY $RPM_LD_FLAGS"
211
212export HASHBANGPERL=/usr/bin/perl
213
214perl -pi -e 's|/engines-|/%{name}/engines-|' ./Configurations/unix-Makefile.tmpl
215
216# ia64, x86_64, ppc are OK by default
217# Configure the build tree.  Override OpenSSL defaults with known-good defaults
218# usable on all platforms.  The Configure script already knows to use -fPIC and
219# RPM_OPT_FLAGS, so we can skip specifiying them here.
220./Configure \
221        --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
222        --system-ciphers-file=%{_sysconfdir}/crypto-policies/back-ends/openssl.config \
223        zlib enable-camellia enable-seed enable-rfc3779 enable-sctp \
224        enable-cms enable-md2 enable-rc5 enable-ssl3 enable-ssl3-method \
225        enable-weak-ssl-ciphers \
226        no-mdc2 no-ec2m no-sm2 no-sm4 \
227        shared  ${sslarch} $RPM_OPT_FLAGS '-DDEVRANDOM="\"/dev/urandom\""'
228
229# Do not run this in a production package the FIPS symbols must be patched-in
230#util/mkdef.pl crypto update
231
232make all
233
234%if %{with fips}
235# Overwrite FIPS README
236cp -f %{SOURCE11} .
237%endif
238
239# Clean up the .pc files
240for i in libcrypto.pc libssl.pc openssl.pc ; do
241  sed -i '/^Libs.private:/{s/-L[^ ]* //;s/-Wl[^ ]* //}' $i
242done
243
244%check
245# Verify that what was compiled actually works.
246
247# Hack - either enable SCTP AUTH chunks in kernel or disable sctp for check
248(sysctl net.sctp.addip_enable=1 && sysctl net.sctp.auth_enable=1) || \
249(echo 'Failed to enable SCTP AUTH chunks, disabling SCTP for tests...' &&
250 sed '/"zlib-dynamic" => "default",/a\ \ "sctp" => "default",' configdata.pm > configdata.pm.new && \
251 touch -r configdata.pm configdata.pm.new && \
252 mv -f configdata.pm.new configdata.pm)
253
254# We must revert patch31 before tests otherwise they will fail
255patch -p1 -R < %{PATCH31}
256
257# drop a recipe includes tests for brainpool curves (not supported by openssl-hobbled).
258rm -f test/recipes/80-test_ssl_new.t
259
260
261LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
262export LD_LIBRARY_PATH
263OPENSSL_ENABLE_MD5_VERIFY=
264export OPENSSL_ENABLE_MD5_VERIFY
265OPENSSL_SYSTEM_CIPHERS_OVERRIDE=xyz_nonexistent_file
266export OPENSSL_SYSTEM_CIPHERS_OVERRIDE
267make test
268
269
270# Add generation of HMAC checksum of the final stripped library
271%define __spec_install_post \
272    %{?__debug_package:%{__debug_install_post}} \
273    %{__arch_install_post} \
274    %{__os_install_post} \
275%{nil}
276
277%define __provides_exclude_from %{_libdir}/openssl
278
279%install
280[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
281# Install OpenSSL.
282install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl,%{_pkgdocdir}}
283make DESTDIR=$RPM_BUILD_ROOT install
284mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
285rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
286for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
287        chmod 755 ${lib}
288        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT/%{_libdir}/`basename ${lib} .%{version}`
289        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
290done
291
292# Install a makefile for generating keys and self-signed certs, and a script
293# for generating them on the fly.
294mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
295install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_pkgdocdir}/Makefile.certificate
296install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/make-dummy-cert
297install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_bindir}/renew-dummy-cert
298
299# Move runable perl scripts to bindir
300mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/*.pl $RPM_BUILD_ROOT%{_bindir}
301mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/tsget $RPM_BUILD_ROOT%{_bindir}
302
303# Rename man pages so that they don't conflict with other system man pages.
304pushd $RPM_BUILD_ROOT%{_mandir}
305ln -s -f config.5 man5/openssl.cnf.5
306for manpage in man*/* ; do
307        if [ -L ${manpage} ]; then
308                TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
309                ln -snf ${TARGET}ssl ${manpage}ssl
310                rm -f ${manpage}
311        else
312                mv ${manpage} ${manpage}ssl
313        fi
314done
315for conflict in passwd rand ; do
316        rename ${conflict} ssl${conflict} man*/${conflict}*
317# Fix dangling symlinks
318        manpage=man1/openssl-${conflict}.*
319        if [ -L ${manpage} ] ; then
320                ln -snf ssl${conflict}.1ssl ${manpage}
321        fi
322done
323popd
324
325mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
326mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
327mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
328mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
329mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
330
331# Ensure the config file timestamps are identical across builds to avoid
332# mulitlib conflicts and unnecessary renames on upgrade
333touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
334touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf
335
336rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf.dist
337rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf.dist
338
339# Determine which arch opensslconf.h is going to try to #include.
340basearch=%{_arch}
341%ifarch %{ix86}
342basearch=i386
343%endif
344
345# Next step of gradual disablement of SSL3.
346# Make SSL3 disappear to newly built dependencies.
347sed -i '/^\#ifndef OPENSSL_NO_SSL_TRACE/i\
348#ifndef OPENSSL_NO_SSL3\
349# define OPENSSL_NO_SSL3\
350#endif' $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
351
352%ifarch %{multilib_arches}
353# Do an opensslconf.h switcheroo to avoid file conflicts on systems where you
354# can have both a 32- and 64-bit version of the library, and they each need
355# their own correct-but-different versions of opensslconf.h to be usable.
356install -m644 %{SOURCE10} \
357        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
358cat $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h >> \
359        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
360install -m644 %{SOURCE9} \
361        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
362%endif
363LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
364export LD_LIBRARY_PATH
365
366
367%clean
368[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
369
370%files
371%defattr(-,root,root)
372%{!?_licensedir:%global license %%doc}
373%license LICENSE
374%doc FAQ NEWS README
375%if %{with fips}
376%doc README.FIPS
377%endif
378%{_pkgdocdir}/Makefile.certificate
379%dir %{_sysconfdir}/pki/tls
380%dir %{_sysconfdir}/pki/tls/certs
381%dir %{_sysconfdir}/pki/tls/misc
382%dir %{_sysconfdir}/pki/tls/private
383%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
384%config(noreplace) %{_sysconfdir}/pki/tls/ct_log_list.cnf
385
386%{_bindir}/make-dummy-cert
387%{_bindir}/renew-dummy-cert
388%{_bindir}/openssl
389%attr(0755,root,root) /%{_lib}/*.so.*
390%attr(0755,root,root) %{_libdir}/%{name}/engines-%{soversion}
391%dir %{_mandir}/man1*
392%{_mandir}/man1*/*
393%dir %{_mandir}/man5*
394%{_mandir}/man5*/*
395%dir %{_mandir}/man7*
396%{_mandir}/man7*/*
397
398%files devel
399%defattr(-,root,root)
400%{_prefix}/include/openssl
401%exclude %{_libdir}/lib*.a
402%attr(0755,root,root) %{_libdir}/*.so
403%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
404%dir %{_mandir}/man3*
405%{_mandir}/man3*/*
406
407%files static
408%defattr(-,root,root)
409%attr(0644,root,root) %{_libdir}/*.a
410
411%files perl
412%defattr(-,root,root)
413%{_bindir}/c_rehash
414%{_bindir}/*.pl
415%{_bindir}/tsget
416%{_mandir}/man1*/*.pl*
417%{_mandir}/man1*/c_rehash*
418%{_mandir}/man1*/tsget*
419%{_mandir}/man1*/openssl-tsget*
420%dir %{_sysconfdir}/pki/CA
421%dir %{_sysconfdir}/pki/CA/private
422%dir %{_sysconfdir}/pki/CA/certs
423%dir %{_sysconfdir}/pki/CA/crl
424%dir %{_sysconfdir}/pki/CA/newcerts
425
426## to build compat32 for x86_64 architecture support
427%if %{build_compat32}
428%files -n compat32-%{name}
429%defattr(-,root,root)
430%attr(0755,root,root) /%{_lib}/*.so.*
431
432%files -n compat32-%{name}-devel
433%defattr(-,root,root)
434%exclude %{_libdir}/lib*.a
435%attr(0755,root,root) %{_libdir}/*.so
436%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
437%endif
438
439%post -p /sbin/ldconfig
440
441%postun -p /sbin/ldconfig
442
443%post -n compat32-%{name} -p /sbin/ldconfig
444
445%postun -n compat32-%{name} -p /sbin/ldconfig
446
447%changelog
448* Fri Dec 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1d-2
449- imported Patch1000 from upstream.
450
451* Fri Sep 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1d-1
452- new upstream release.
453- updated Source12 and 13.
454- updated all patches.
455- imported Patch100 from upstream.
456
457* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1c-1
458- new upstream release.
459- updated Patch37 and 41.
460- imported Patch52-54 from rawhide.
461
462* Mon May 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-2
463- fixed openssl.cnf
464
465* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-1
466- new upstream release.
467- imported Patch36 from rawhide.
468- updated Patch32.
469
470* Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1a-1
471- new upstream release.
472- updated Patch2.
473- dropped Patch36 and 46: fixed in upstream.
474
475* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-2
476- fixed symlinks.
477
478* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
479- new upstream release (newest LTS version).
480- imported fedora stuff (except FIPS).
481
482* Sun Apr  1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
483- new upstream release with security fixes
484
485* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
486- new upstream release with security fixes
487
488* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
489- new upstream release with security fixes
490
491* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
492- new upstream release with security fixes
493
494* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
495- new upstream release with security fixes
496
497* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
498- new upstream release 1.0.2 with security fixes
499- Patch2 is merged into Patch0
500
501* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
502- new upstream release with security fixes
503
504* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
505- new upstream release with security fixes
506
507* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
508- new upstream release
509
510* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
511- merged into Vine6
512  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
513  - new upstream release with security fixes 
514  - update Patch2,5
515
516* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
517- new upstream release with security fixes 
518
519* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
520- new upstream release with security fixes
521- add patch8 from fc21 (fix perl find.pl)
522
523* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
524- new upstream release with security fixes.
525
526* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
527- new upstream release with security fixes
528
529* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
530- new upstream release with security fixes
531
532* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
533- move root CA bundle to ca-certificates package
534
535* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
536- update to 1.0.1e
537  - 1.0.1d has major regressions from 1.0.1c
538
539* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
540- remove tsget script to delete dependency perl(WWW::Curl::Easy)
541 - openssl-perl package contains it in docdir
542
543* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
544- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
545- fixed %%files
546
547* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
548- update to 1.0.1c
549- enable configure options:
550  enable-camellia enable-seed enable-tlsext enable-rfc3779
551  enable-cms enable-md2
552- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
553- generate a table with the compile settings before configure
554
555* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
556- new upstream release with security fix (CVE-2012-0050)
557
558* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
559- new upstream release with security fix
560  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
561
562* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
563- new upstream release with security fix (CVE-2011-3207, 3210)
564
565* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
566- rebuild with krb5-libs 1.8
567
568* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
569- new upstream release with security fix
570
571* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
572- use upstream openssl.pc instead of vine original one (SOURCE6)
573
574* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
575- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
576
577* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
578- add R: krb5-devel into devel pkg
579- add R: compat32-krb5-devel into compat32-devel pkg
580
581* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
582- new upstream release 1.0.0x
583- separate static libs into static package
584- change configure options
585- change so version 10
586- add tsget into perl package
587- update all patches
588
589* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
590- fix changelog typo...
591
592* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
593- new upstream release with security fix (CVE-2010-4180)
594
595* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
596- new upstream release with security fix (CVE-2010-3864)
597- drop patches included in new release
598- update patch4
599
600* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
601- add patch12 for fix CVE-2009-3555 (renegotiation)
602
603* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
604- add patch11 for fix CVE-2009-4355 (memory leak)
605
606* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
607- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
608
609* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
610- removed unnecessary %%if %{build_compat32} statements
611- removed lib*.a from devel package
612
613* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
614- new upstream release with security fix (CVE-2000-0590,0591,0789)
615
616* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
617- new upstream release with security fix (CVE-2008-5077)
618
619* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
620- new upstream release
621
622* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
623- new upstream release
624- new versioning policy
625
626* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
627- new upstream release
628- drop patch10,20 which is merged in upstream
629
630* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
631- add security patch in advance for CVE-2007-5135
632  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
633  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
634
635* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
636- add security patch for CVE-2007-3108
637  (http://openssl.org/news/patch-CVE-2007-3108.txt)
638
639* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
640- new upstream release
641
642* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
643- update (fix) openssl.pc <BTS:437>
644
645* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
646- new upstream release (with security fix)
647
648* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
649- new upstream release
650- add patch2 to use RPM_OPT macro
651
652* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
653- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
654
655* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
656- added compat32-* packages for x86_64 architecture support
657- added openssl-0.9.7i.Configure-compat32.patch
658- changed '/lib' to '/%{_lib}'
659
660* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
661- new upstream release
662
663* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
664- rebuild on VineSeed
665
666* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
667- added a security patch from Gentoo.
668  - Patch1: openssl-0.9.7c-tempfile.patch
669
670* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
671- sslarch for ppc was missing... added.
672
673* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
674- use sslarch=linux-alpha-gcc instead of alpha-gcc
675
676* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
677- new upstream version
678- clean up of spec file
679        -- removed old patches
680
681* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
682- new upstream release
683- SECURITY fix.
684  - http://www.openssl.org/news/secadv_20040317.txt
685
686* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
687- new upstream release
688- [Security fix]
689  - Vulnerabilities in ASN.1 parsing
690    http://www.openssl.org/news/secadv_20030930.txt
691- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
692
693* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
694- add openssl.pc for pkgconfig
695
696* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
697- New upstream version
698- dropped patch10, 11
699        -- merged upstream version
700
701* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
702- rebuild for VineSeed
703
704* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
705- [Security Fix]
706  - Timing-based attacks on RSA keys
707    http://www.openssl.org/news/secadv_20030317.txt
708  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
709    http://www.openssl.org/news/secadv_20030317.txt
710
711* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
712- new upstream release 0.9.6i
713- [Security Fix]
714- build for Vine Linux 2.6 errata
715
716* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
717- new upstream release 0.9.6h
718
719* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
720- new upstream release 0.9.6g
721
722* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
723- SECURITY: CAN-2002-0659 fixed
724  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
725    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
726    - update asn patch to fix accidental reversal of a logic check
727    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
728    - update asn patch to reduce chance that compiler optimization will remove
729      one of the added tests
730    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
731    - rebuild
732    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
733    - add patch to fix ASN.1 vulnerabilities
734
735* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
736- rename spec file name
737- SECURITY: CA-2002-23 fixed
738  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
739    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
740    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
741
742* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
743- added ${PATH} in LD_LIBRARY_PATH
744- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
745 
746* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
747- remove --no-<cipher>
748
749* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
750- add Patch10 for mipsel shared ( Configure )
751
752* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
753- build for Vine Linux
754- use openssl-engine-0.9.6b.tar.gz
755
756* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
757- update to 0.9.6b
758
759* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
760- move .so symlinks back to %%{_libdir}
761
762* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
763- move shared libraries to /lib (#38410)
764
765* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
766- switch to engine code base
767
768* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
769- add a script for creating dummy certificates
770- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
771
772* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
773- add s390x support
774
775* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
776- change two memcpy() calls to memmove()
777- don't define L_ENDIAN on alpha
778
779* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
780- make subpackages depend on the main package
781
782* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
783- adjust the hobble script to not disturb symlinks in include/ (fix from
784  Joe Orton)
785
786* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
787- drop the m2crypo patch we weren't using
788
789* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
790- configure using "shared" as well
791
792* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
793- update to 0.9.6a
794- use the build-shared target to build shared libraries
795- bump the soversion to 2 because we're no longer compatible with
796  our 0.9.5a packages or our 0.9.6 packages
797- drop the patch for making rsatest a no-op when rsa null support is used
798- put all man pages into <section>ssl instead of <section>
799- break the m2crypto modules into a separate package
800
801* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
802- use BN_LLONG on s390
803
804* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
805- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
806
807* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
808- move c_rehash to the perl subpackage, because it's a perl script now
809
810* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
811- update to 0.9.6
812- enable MD2
813- use the libcrypto.so and libssl.so targets to build shared libs with
814- bump the soversion to 1 because we're no longer compatible with any of
815  the various 0.9.5a packages circulating around, which provide lib*.so.0
816
817* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
818- change hobble-openssl for disabling MD2 again
819
820* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
821- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
822  bytes or so, causing EVP_DigestInit() to zero out stack variables in
823  apps built against a version of the library without it
824
825* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
826- disable some inline assembly, which on x86 is Pentium-specific
827- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
828
829* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
830- fix s390 patch
831
832* Fri Dec 8 2000 Than Ngo <than@redhat.com>
833- added support s390
834
835* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
836- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
837- add the CA.pl man page to the perl subpackage
838
839* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
840- always build with -mcpu=ev5 on alpha
841
842* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
843- add a symlink from cert.pem to ca-bundle.crt
844
845* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
846- add a ca-bundle file for packages like Samba to reference for CA certificates
847
848* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
849- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
850
851* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
852- add unzip as a buildprereq (#17662)
853- update m2crypto to 0.05-snap4
854
855* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
856- fix some issues in building when it's not installed
857
858* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
859- make sure the headers we include are the ones we built with (aaaaarrgh!)
860
861* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
862- add Richard Henderson's patch for BN on ia64
863- clean up the changelog
864
865* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
866- fix the building of python modules without openssl-devel already installed
867
868* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
869- byte-compile python extensions without the build-root
870- adjust the makefile to not remove temporary files (like .key files when
871  building .csr files) by marking them as .PRECIOUS
872
873* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
874- break out python extensions into a subpackage
875
876* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
877- tweak the makefile some more
878
879* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
880- disable MD2 support
881
882* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
883- disable MDC2 support
884
885* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
886- tweak the disabling of RC5, IDEA support
887- tweak the makefile
888
889* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
890- strip binaries and libraries
891- rework certificate makefile to have the right parts for Apache
892
893* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
894- use %%{_perl} instead of /usr/bin/perl
895- disable alpha until it passes its own test suite
896
897* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
898- move the passwd.1 man page out of the passwd package's way
899
900* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
901- update to 0.9.5a, modified for U.S.
902- add perl as a build-time requirement
903- move certificate makefile to another package
904- disable RC5, IDEA, RSA support
905- remove optimizations for now
906
907* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
908- Bero told me to move the Makefile into this package
909
910* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
911- add lib*.so symlinks to link dynamically against shared libs
912
913* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
914- update to 0.9.5
915- run ldconfig directly in post/postun
916- add FAQ
917
918* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
919- Fix build on non-x86 platforms
920
921* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
922- move /usr/share/ssl/* from -devel to main package
923
924* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
925- inital packaging
926- changes from base:
927  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
928  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.