source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 12211

Revision 12211, 31.0 KB checked in by tomop, 5 years ago (diff)

openssl-1.1.1d-1

Line 
1%bcond_with fips
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}}
5%define version 1.1.1d
6%define release 1%{_dist_release}
7# 1.0.0 soversion = 10
8# 1.1.0 soversion = 1.1 (same as upstream although presence of some symbols
9#                        depends on build configuration options)
10%define soversion 1.1
11
12Summary: Secure Sockets Layer Toolkit
13Name: openssl
14Version: %{version}
15Release: %{release}
16# We have to remove certain patented algorithms from the openssl source
17# tarball with the hobble-openssl script which is included below.
18# The original openssl upstream tarball cannot be shipped in the .src.rpm.
19Source: openssl-%{version}-hobbled.tar.xz
20Source1: hobble-openssl
21Source2: Makefile.certificate
22Source6: make-dummy-cert
23Source7: renew-dummy-cert
24Source9: opensslconf-new.h
25Source10: opensslconf-new-warning.h
26Source11: README.FIPS
27Source12: ec_curve.c
28Source13: ectest.c
29
30# Build changes
31Patch1: openssl-1.1.1-build.patch
32Patch2: openssl-1.1.0-defaults.patch
33Patch3: openssl-1.1.0-no-html.patch
34Patch4: openssl-1.1.1-man-rename.patch
35# Bug fixes
36Patch21: openssl-1.1.0-issuer-hash.patch
37# Functionality changes
38Patch31: openssl-1.1.1-conf-paths.patch
39Patch32: openssl-1.1.1-version-add-engines.patch
40Patch33: openssl-1.1.1-apps-dgst.patch
41Patch36: openssl-1.1.1-no-brainpool.patch
42Patch37: openssl-1.1.1-ec-curves.patch
43Patch38: openssl-1.1.1-no-weak-verify.patch
44Patch40: openssl-1.1.1-disable-ssl3.patch
45Patch41: openssl-1.1.1-system-cipherlist.patch
46Patch42: openssl-1.1.1-fips.patch
47Patch43: openssl-1.1.1-ignore-bound.patch
48Patch44: openssl-1.1.1-version-override.patch
49Patch45: openssl-1.1.1-weak-ciphers.patch
50Patch46: openssl-1.1.1-seclevel.patch
51Patch48: openssl-1.1.1-fips-post-rand.patch
52Patch49: openssl-1.1.1-evp-kdf.patch
53Patch50: openssl-1.1.1-ssh-kdf.patch
54# Backported fixes including security fixes
55Patch51: openssl-1.1.1-upstream-sync.patch
56Patch52: openssl-1.1.1-s390x-update.patch
57Patch53: openssl-1.1.1-fips-crng-test.patch
58Patch54: openssl-1.1.1-regression-fixes.patch
59Patch100: BIO_f_zlib.patch
60
61# security fix
62# nothing ;-)
63
64License: BSDish
65Group: System Environment/Libraries
66URL: http://www.openssl.org/
67
68BuildRoot: %{_tmppath}/%{name}-%{version}-root
69BuildRequires: perl, sed
70BuildRequires: zlib-devel, krb5-devel
71BuildRequires: lksctp-tools-devel
72
73Requires: mktemp
74Requires: ca-certificates
75
76Vendor: Project Vine
77Distribution: Vine Linux
78Packager: daisuke, iwamoto
79
80%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
81
82%description
83The OpenSSL certificate management tool and the shared libraries that
84provide various cryptographic algorithms and protocols.
85
86%package devel
87Summary: OpenSSL libraries and development headers.
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: krb5-devel
91
92%description devel
93The static libraries and include files needed to compile apps
94with support for various the cryptographic algorithms and protocols
95supported by OpenSSL.
96
97Patches for many networking apps can be found at:
98ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
99
100%package static
101Summary:  Libraries for static linking of applications which will use OpenSSL
102Group: Development/Libraries
103Requires: %{name}-devel = %{version}-%{release}
104
105%description static
106OpenSSL is a toolkit for supporting cryptography. The openssl-static
107package contains static libraries needed for static linking of
108applications which support various cryptographic algorithms and
109protocols.
110
111%package perl
112Summary: OpenSSL scripts which require Perl.
113Group: Applications/Internet
114Requires: %{name} = %{version}-%{release}
115Requires: perl
116
117%description perl
118Perl scripts provided with OpenSSL for converting certificates and keys
119from other formats to those used by OpenSSL.
120
121## to build compat32 for x86_64 architecture support
122%package -n compat32-%{name}
123Summary: Secure Sockets Layer Toolkit
124Group: System Environment/Libraries
125Requires: %{name} = %{version}-%{release}
126%description -n compat32-%{name}
127The OpenSSL certificate management tool and the shared libraries that
128provide various cryptographic algorithms and protocols.
129
130%package -n compat32-%{name}-devel
131Summary: OpenSSL libraries and development headers.
132Group: Development/Libraries
133Requires: compat32-%{name} = %{version}-%{release}
134Requires: compat32-krb5-devel
135%description -n compat32-%{name}-devel
136The static libraries and include files needed to compile apps
137with support for various the cryptographic algorithms and protocols
138supported by OpenSSL.
139
140%prep
141%setup -q -n %{name}-%{version}
142
143# The hobble_openssl is called here redundantly, just to be sure.
144# The tarball has already the sources removed.
145%{SOURCE1} > /dev/null
146
147cp %{SOURCE12} crypto/ec/
148cp %{SOURCE13} test/
149
150%patch1 -p1 -b .build   %{?_rawbuild}
151%patch2 -p1 -b .defaults
152%patch3 -p1 -b .no-html  %{?_rawbuild}
153%patch4 -p1 -b .man-rename
154
155%patch21 -p1 -b .issuer-hash
156
157%patch31 -p1 -b .conf-paths
158%patch32 -p1 -b .version-add-engines
159%patch33 -p1 -b .dgst
160%patch36 -p1 -b .no-brainpool
161%patch37 -p1 -b .curves
162%patch38 -p1 -b .no-weak-verify
163%patch40 -p1 -b .disable-ssl3
164%patch41 -p1 -b .system-cipherlist
165%if %{with fips}
166%patch42 -p1 -b .fips
167%endif
168%patch43 -p1 -b .ignore-bound
169%if %{with fips}
170%patch44 -p1 -b .version-override
171%endif
172%patch45 -p1 -b .weak-ciphers
173%if %{with fips}
174%patch46 -p1 -b .seclevel
175%patch49 -p1 -b .evp-kdf
176%patch50 -p1 -b .ssh-kdf
177%patch51 -p1 -b .upstream-sync
178%endif
179%patch52 -p1 -b .s390x-update
180%if %{with fips}
181%patch53 -p1 -b .crng-test
182%endif
183%patch54 -p1 -b .regression
184
185%patch100 -p1 -b .BIO_f_zlib
186
187# security fix
188# nothing ;-)
189
190%build
191# Figure out which flags we want to use.
192# default
193sslarch=%{_os}-%{_target_cpu}
194#
195%ifarch %ix86
196sslarch=linux-elf
197if ! echo %{_target} | grep -q i686 ; then
198   sslflags="no-asm 386"
199fi
200%endif
201%ifarch x86_64
202sslflags=enable-ec_nistp_64_gcc_128
203%endif
204
205# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
206# marked as not requiring an executable stack.
207# Also add -DPURIFY to make using valgrind with openssl easier as we do not
208# want to depend on the uninitialized memory as a source of entropy anyway.
209RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack -DPURIFY $RPM_LD_FLAGS"
210
211export HASHBANGPERL=/usr/bin/perl
212
213perl -pi -e 's|/engines-|/%{name}/engines-|' ./Configurations/unix-Makefile.tmpl
214
215# ia64, x86_64, ppc are OK by default
216# Configure the build tree.  Override OpenSSL defaults with known-good defaults
217# usable on all platforms.  The Configure script already knows to use -fPIC and
218# RPM_OPT_FLAGS, so we can skip specifiying them here.
219./Configure \
220        --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
221        --system-ciphers-file=%{_sysconfdir}/crypto-policies/back-ends/openssl.config \
222        zlib enable-camellia enable-seed enable-rfc3779 enable-sctp \
223        enable-cms enable-md2 enable-rc5 enable-ssl3 enable-ssl3-method \
224        enable-weak-ssl-ciphers \
225        no-mdc2 no-ec2m no-sm2 no-sm4 \
226        shared  ${sslarch} $RPM_OPT_FLAGS '-DDEVRANDOM="\"/dev/urandom\""'
227
228# Do not run this in a production package the FIPS symbols must be patched-in
229#util/mkdef.pl crypto update
230
231make all
232
233%if %{with fips}
234# Overwrite FIPS README
235cp -f %{SOURCE11} .
236%endif
237
238# Clean up the .pc files
239for i in libcrypto.pc libssl.pc openssl.pc ; do
240  sed -i '/^Libs.private:/{s/-L[^ ]* //;s/-Wl[^ ]* //}' $i
241done
242
243%check
244# Verify that what was compiled actually works.
245
246# Hack - either enable SCTP AUTH chunks in kernel or disable sctp for check
247(sysctl net.sctp.addip_enable=1 && sysctl net.sctp.auth_enable=1) || \
248(echo 'Failed to enable SCTP AUTH chunks, disabling SCTP for tests...' &&
249 sed '/"zlib-dynamic" => "default",/a\ \ "sctp" => "default",' configdata.pm > configdata.pm.new && \
250 touch -r configdata.pm configdata.pm.new && \
251 mv -f configdata.pm.new configdata.pm)
252
253# We must revert patch31 before tests otherwise they will fail
254patch -p1 -R < %{PATCH31}
255
256# drop a recipe includes tests for brainpool curves (not supported by openssl-hobbled).
257rm -f test/recipes/80-test_ssl_new.t
258
259
260LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
261export LD_LIBRARY_PATH
262OPENSSL_ENABLE_MD5_VERIFY=
263export OPENSSL_ENABLE_MD5_VERIFY
264OPENSSL_SYSTEM_CIPHERS_OVERRIDE=xyz_nonexistent_file
265export OPENSSL_SYSTEM_CIPHERS_OVERRIDE
266make test
267
268
269# Add generation of HMAC checksum of the final stripped library
270%define __spec_install_post \
271    %{?__debug_package:%{__debug_install_post}} \
272    %{__arch_install_post} \
273    %{__os_install_post} \
274%{nil}
275
276%define __provides_exclude_from %{_libdir}/openssl
277
278%install
279[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
280# Install OpenSSL.
281install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl,%{_pkgdocdir}}
282make DESTDIR=$RPM_BUILD_ROOT install
283mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
284rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
285for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
286        chmod 755 ${lib}
287        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT/%{_libdir}/`basename ${lib} .%{version}`
288        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
289done
290
291# Install a makefile for generating keys and self-signed certs, and a script
292# for generating them on the fly.
293mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
294install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_pkgdocdir}/Makefile.certificate
295install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/make-dummy-cert
296install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_bindir}/renew-dummy-cert
297
298# Move runable perl scripts to bindir
299mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/*.pl $RPM_BUILD_ROOT%{_bindir}
300mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/tsget $RPM_BUILD_ROOT%{_bindir}
301
302# Rename man pages so that they don't conflict with other system man pages.
303pushd $RPM_BUILD_ROOT%{_mandir}
304ln -s -f config.5 man5/openssl.cnf.5
305for manpage in man*/* ; do
306        if [ -L ${manpage} ]; then
307                TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
308                ln -snf ${TARGET}ssl ${manpage}ssl
309                rm -f ${manpage}
310        else
311                mv ${manpage} ${manpage}ssl
312        fi
313done
314for conflict in passwd rand ; do
315        rename ${conflict} ssl${conflict} man*/${conflict}*
316# Fix dangling symlinks
317        manpage=man1/openssl-${conflict}.*
318        if [ -L ${manpage} ] ; then
319                ln -snf ssl${conflict}.1ssl ${manpage}
320        fi
321done
322popd
323
324mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
325mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
326mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
327mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
328mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
329
330# Ensure the config file timestamps are identical across builds to avoid
331# mulitlib conflicts and unnecessary renames on upgrade
332touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
333touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf
334
335rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf.dist
336rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf.dist
337
338# Determine which arch opensslconf.h is going to try to #include.
339basearch=%{_arch}
340%ifarch %{ix86}
341basearch=i386
342%endif
343
344# Next step of gradual disablement of SSL3.
345# Make SSL3 disappear to newly built dependencies.
346sed -i '/^\#ifndef OPENSSL_NO_SSL_TRACE/i\
347#ifndef OPENSSL_NO_SSL3\
348# define OPENSSL_NO_SSL3\
349#endif' $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
350
351%ifarch %{multilib_arches}
352# Do an opensslconf.h switcheroo to avoid file conflicts on systems where you
353# can have both a 32- and 64-bit version of the library, and they each need
354# their own correct-but-different versions of opensslconf.h to be usable.
355install -m644 %{SOURCE10} \
356        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
357cat $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h >> \
358        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
359install -m644 %{SOURCE9} \
360        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
361%endif
362LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
363export LD_LIBRARY_PATH
364
365
366%clean
367[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
368
369%files
370%defattr(-,root,root)
371%{!?_licensedir:%global license %%doc}
372%license LICENSE
373%doc FAQ NEWS README
374%if %{with fips}
375%doc README.FIPS
376%endif
377%{_pkgdocdir}/Makefile.certificate
378%dir %{_sysconfdir}/pki/tls
379%dir %{_sysconfdir}/pki/tls/certs
380%dir %{_sysconfdir}/pki/tls/misc
381%dir %{_sysconfdir}/pki/tls/private
382%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
383%config(noreplace) %{_sysconfdir}/pki/tls/ct_log_list.cnf
384
385%{_bindir}/make-dummy-cert
386%{_bindir}/renew-dummy-cert
387%{_bindir}/openssl
388%attr(0755,root,root) /%{_lib}/*.so.*
389%attr(0755,root,root) %{_libdir}/%{name}/engines-%{soversion}
390%dir %{_mandir}/man1*
391%{_mandir}/man1*/*
392%dir %{_mandir}/man5*
393%{_mandir}/man5*/*
394%dir %{_mandir}/man7*
395%{_mandir}/man7*/*
396
397%files devel
398%defattr(-,root,root)
399%{_prefix}/include/openssl
400%exclude %{_libdir}/lib*.a
401%attr(0755,root,root) %{_libdir}/*.so
402%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
403%dir %{_mandir}/man3*
404%{_mandir}/man3*/*
405
406%files static
407%defattr(-,root,root)
408%attr(0644,root,root) %{_libdir}/*.a
409
410%files perl
411%defattr(-,root,root)
412%{_bindir}/c_rehash
413%{_bindir}/*.pl
414%{_bindir}/tsget
415%{_mandir}/man1*/*.pl*
416%{_mandir}/man1*/c_rehash*
417%{_mandir}/man1*/tsget*
418%{_mandir}/man1*/openssl-tsget*
419%dir %{_sysconfdir}/pki/CA
420%dir %{_sysconfdir}/pki/CA/private
421%dir %{_sysconfdir}/pki/CA/certs
422%dir %{_sysconfdir}/pki/CA/crl
423%dir %{_sysconfdir}/pki/CA/newcerts
424
425## to build compat32 for x86_64 architecture support
426%if %{build_compat32}
427%files -n compat32-%{name}
428%defattr(-,root,root)
429%attr(0755,root,root) /%{_lib}/*.so.*
430
431%files -n compat32-%{name}-devel
432%defattr(-,root,root)
433%exclude %{_libdir}/lib*.a
434%attr(0755,root,root) %{_libdir}/*.so
435%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
436%endif
437
438%post -p /sbin/ldconfig
439
440%postun -p /sbin/ldconfig
441
442%post -n compat32-%{name} -p /sbin/ldconfig
443
444%postun -n compat32-%{name} -p /sbin/ldconfig
445
446%changelog
447* Fri Sep 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1d-1
448- new upstream release.
449- updated Source12 and 13.
450- updated all patches.
451- imported Patch100 from upstream.
452
453* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1c-1
454- new upstream release.
455- updated Patch37 and 41.
456- imported Patch52-54 from rawhide.
457
458* Mon May 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-2
459- fixed openssl.cnf
460
461* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-1
462- new upstream release.
463- imported Patch36 from rawhide.
464- updated Patch32.
465
466* Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1a-1
467- new upstream release.
468- updated Patch2.
469- dropped Patch36 and 46: fixed in upstream.
470
471* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-2
472- fixed symlinks.
473
474* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
475- new upstream release (newest LTS version).
476- imported fedora stuff (except FIPS).
477
478* Sun Apr  1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
479- new upstream release with security fixes
480
481* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
482- new upstream release with security fixes
483
484* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
485- new upstream release with security fixes
486
487* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
488- new upstream release with security fixes
489
490* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
491- new upstream release with security fixes
492
493* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
494- new upstream release 1.0.2 with security fixes
495- Patch2 is merged into Patch0
496
497* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
498- new upstream release with security fixes
499
500* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
501- new upstream release with security fixes
502
503* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
504- new upstream release
505
506* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
507- merged into Vine6
508  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
509  - new upstream release with security fixes 
510  - update Patch2,5
511
512* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
513- new upstream release with security fixes 
514
515* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
516- new upstream release with security fixes
517- add patch8 from fc21 (fix perl find.pl)
518
519* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
520- new upstream release with security fixes.
521
522* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
523- new upstream release with security fixes
524
525* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
526- new upstream release with security fixes
527
528* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
529- move root CA bundle to ca-certificates package
530
531* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
532- update to 1.0.1e
533  - 1.0.1d has major regressions from 1.0.1c
534
535* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
536- remove tsget script to delete dependency perl(WWW::Curl::Easy)
537 - openssl-perl package contains it in docdir
538
539* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
540- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
541- fixed %%files
542
543* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
544- update to 1.0.1c
545- enable configure options:
546  enable-camellia enable-seed enable-tlsext enable-rfc3779
547  enable-cms enable-md2
548- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
549- generate a table with the compile settings before configure
550
551* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
552- new upstream release with security fix (CVE-2012-0050)
553
554* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
555- new upstream release with security fix
556  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
557
558* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
559- new upstream release with security fix (CVE-2011-3207, 3210)
560
561* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
562- rebuild with krb5-libs 1.8
563
564* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
565- new upstream release with security fix
566
567* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
568- use upstream openssl.pc instead of vine original one (SOURCE6)
569
570* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
571- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
572
573* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
574- add R: krb5-devel into devel pkg
575- add R: compat32-krb5-devel into compat32-devel pkg
576
577* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
578- new upstream release 1.0.0x
579- separate static libs into static package
580- change configure options
581- change so version 10
582- add tsget into perl package
583- update all patches
584
585* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
586- fix changelog typo...
587
588* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
589- new upstream release with security fix (CVE-2010-4180)
590
591* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
592- new upstream release with security fix (CVE-2010-3864)
593- drop patches included in new release
594- update patch4
595
596* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
597- add patch12 for fix CVE-2009-3555 (renegotiation)
598
599* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
600- add patch11 for fix CVE-2009-4355 (memory leak)
601
602* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
603- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
604
605* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
606- removed unnecessary %%if %{build_compat32} statements
607- removed lib*.a from devel package
608
609* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
610- new upstream release with security fix (CVE-2000-0590,0591,0789)
611
612* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
613- new upstream release with security fix (CVE-2008-5077)
614
615* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
616- new upstream release
617
618* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
619- new upstream release
620- new versioning policy
621
622* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
623- new upstream release
624- drop patch10,20 which is merged in upstream
625
626* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
627- add security patch in advance for CVE-2007-5135
628  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
629  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
630
631* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
632- add security patch for CVE-2007-3108
633  (http://openssl.org/news/patch-CVE-2007-3108.txt)
634
635* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
636- new upstream release
637
638* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
639- update (fix) openssl.pc <BTS:437>
640
641* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
642- new upstream release (with security fix)
643
644* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
645- new upstream release
646- add patch2 to use RPM_OPT macro
647
648* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
649- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
650
651* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
652- added compat32-* packages for x86_64 architecture support
653- added openssl-0.9.7i.Configure-compat32.patch
654- changed '/lib' to '/%{_lib}'
655
656* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
657- new upstream release
658
659* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
660- rebuild on VineSeed
661
662* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
663- added a security patch from Gentoo.
664  - Patch1: openssl-0.9.7c-tempfile.patch
665
666* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
667- sslarch for ppc was missing... added.
668
669* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
670- use sslarch=linux-alpha-gcc instead of alpha-gcc
671
672* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
673- new upstream version
674- clean up of spec file
675        -- removed old patches
676
677* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
678- new upstream release
679- SECURITY fix.
680  - http://www.openssl.org/news/secadv_20040317.txt
681
682* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
683- new upstream release
684- [Security fix]
685  - Vulnerabilities in ASN.1 parsing
686    http://www.openssl.org/news/secadv_20030930.txt
687- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
688
689* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
690- add openssl.pc for pkgconfig
691
692* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
693- New upstream version
694- dropped patch10, 11
695        -- merged upstream version
696
697* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
698- rebuild for VineSeed
699
700* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
701- [Security Fix]
702  - Timing-based attacks on RSA keys
703    http://www.openssl.org/news/secadv_20030317.txt
704  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
705    http://www.openssl.org/news/secadv_20030317.txt
706
707* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
708- new upstream release 0.9.6i
709- [Security Fix]
710- build for Vine Linux 2.6 errata
711
712* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
713- new upstream release 0.9.6h
714
715* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
716- new upstream release 0.9.6g
717
718* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
719- SECURITY: CAN-2002-0659 fixed
720  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
721    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
722    - update asn patch to fix accidental reversal of a logic check
723    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
724    - update asn patch to reduce chance that compiler optimization will remove
725      one of the added tests
726    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
727    - rebuild
728    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
729    - add patch to fix ASN.1 vulnerabilities
730
731* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
732- rename spec file name
733- SECURITY: CA-2002-23 fixed
734  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
735    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
736    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
737
738* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
739- added ${PATH} in LD_LIBRARY_PATH
740- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
741 
742* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
743- remove --no-<cipher>
744
745* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
746- add Patch10 for mipsel shared ( Configure )
747
748* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
749- build for Vine Linux
750- use openssl-engine-0.9.6b.tar.gz
751
752* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
753- update to 0.9.6b
754
755* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
756- move .so symlinks back to %%{_libdir}
757
758* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
759- move shared libraries to /lib (#38410)
760
761* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
762- switch to engine code base
763
764* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
765- add a script for creating dummy certificates
766- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
767
768* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
769- add s390x support
770
771* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
772- change two memcpy() calls to memmove()
773- don't define L_ENDIAN on alpha
774
775* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
776- make subpackages depend on the main package
777
778* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
779- adjust the hobble script to not disturb symlinks in include/ (fix from
780  Joe Orton)
781
782* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
783- drop the m2crypo patch we weren't using
784
785* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
786- configure using "shared" as well
787
788* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
789- update to 0.9.6a
790- use the build-shared target to build shared libraries
791- bump the soversion to 2 because we're no longer compatible with
792  our 0.9.5a packages or our 0.9.6 packages
793- drop the patch for making rsatest a no-op when rsa null support is used
794- put all man pages into <section>ssl instead of <section>
795- break the m2crypto modules into a separate package
796
797* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
798- use BN_LLONG on s390
799
800* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
801- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
802
803* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
804- move c_rehash to the perl subpackage, because it's a perl script now
805
806* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
807- update to 0.9.6
808- enable MD2
809- use the libcrypto.so and libssl.so targets to build shared libs with
810- bump the soversion to 1 because we're no longer compatible with any of
811  the various 0.9.5a packages circulating around, which provide lib*.so.0
812
813* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
814- change hobble-openssl for disabling MD2 again
815
816* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
817- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
818  bytes or so, causing EVP_DigestInit() to zero out stack variables in
819  apps built against a version of the library without it
820
821* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
822- disable some inline assembly, which on x86 is Pentium-specific
823- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
824
825* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
826- fix s390 patch
827
828* Fri Dec 8 2000 Than Ngo <than@redhat.com>
829- added support s390
830
831* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
832- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
833- add the CA.pl man page to the perl subpackage
834
835* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
836- always build with -mcpu=ev5 on alpha
837
838* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
839- add a symlink from cert.pem to ca-bundle.crt
840
841* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
842- add a ca-bundle file for packages like Samba to reference for CA certificates
843
844* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
845- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
846
847* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
848- add unzip as a buildprereq (#17662)
849- update m2crypto to 0.05-snap4
850
851* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
852- fix some issues in building when it's not installed
853
854* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
855- make sure the headers we include are the ones we built with (aaaaarrgh!)
856
857* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
858- add Richard Henderson's patch for BN on ia64
859- clean up the changelog
860
861* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
862- fix the building of python modules without openssl-devel already installed
863
864* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
865- byte-compile python extensions without the build-root
866- adjust the makefile to not remove temporary files (like .key files when
867  building .csr files) by marking them as .PRECIOUS
868
869* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
870- break out python extensions into a subpackage
871
872* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
873- tweak the makefile some more
874
875* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
876- disable MD2 support
877
878* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
879- disable MDC2 support
880
881* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
882- tweak the disabling of RC5, IDEA support
883- tweak the makefile
884
885* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
886- strip binaries and libraries
887- rework certificate makefile to have the right parts for Apache
888
889* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
890- use %%{_perl} instead of /usr/bin/perl
891- disable alpha until it passes its own test suite
892
893* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
894- move the passwd.1 man page out of the passwd package's way
895
896* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
897- update to 0.9.5a, modified for U.S.
898- add perl as a build-time requirement
899- move certificate makefile to another package
900- disable RC5, IDEA, RSA support
901- remove optimizations for now
902
903* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
904- Bero told me to move the Makefile into this package
905
906* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
907- add lib*.so symlinks to link dynamically against shared libs
908
909* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
910- update to 0.9.5
911- run ldconfig directly in post/postun
912- add FAQ
913
914* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
915- Fix build on non-x86 platforms
916
917* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
918- move /usr/share/ssl/* from -devel to main package
919
920* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
921- inital packaging
922- changes from base:
923  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
924  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.