source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 12121

Revision 12121, 30.7 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%bcond_with fips
2
3%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
4%{!?_pkgdocdir:%global _pkgdocdir %{_docdir}}
5%define version 1.1.1c
6%define release 1%{_dist_release}
7# 1.0.0 soversion = 10
8# 1.1.0 soversion = 1.1 (same as upstream although presence of some symbols
9#                        depends on build configuration options)
10%define soversion 1.1
11
12Summary: Secure Sockets Layer Toolkit
13Name: openssl
14Version: %{version}
15Release: %{release}
16# We have to remove certain patented algorithms from the openssl source
17# tarball with the hobble-openssl script which is included below.
18# The original openssl upstream tarball cannot be shipped in the .src.rpm.
19Source: openssl-%{version}-hobbled.tar.xz
20Source1: hobble-openssl
21Source2: Makefile.certificate
22Source6: make-dummy-cert
23Source7: renew-dummy-cert
24Source9: opensslconf-new.h
25Source10: opensslconf-new-warning.h
26Source11: README.FIPS
27Source12: ec_curve.c
28Source13: ectest.c
29
30# Build changes
31Patch1: openssl-1.1.1-build.patch
32Patch2: openssl-1.1.0-defaults.patch
33Patch3: openssl-1.1.0-no-html.patch
34Patch4: openssl-1.1.1-man-rename.patch
35# Bug fixes
36Patch21: openssl-1.1.0-issuer-hash.patch
37# Functionality changes
38Patch31: openssl-1.1.1-conf-paths.patch
39Patch32: openssl-1.1.1-version-add-engines.patch
40Patch33: openssl-1.1.1-apps-dgst.patch
41Patch36: openssl-1.1.1-no-brainpool.patch
42Patch37: openssl-1.1.1-ec-curves.patch
43Patch38: openssl-1.1.1-no-weak-verify.patch
44Patch40: openssl-1.1.1-disable-ssl3.patch
45Patch41: openssl-1.1.1-system-cipherlist.patch
46Patch42: openssl-1.1.1-fips.patch
47Patch43: openssl-1.1.1-ignore-bound.patch
48Patch44: openssl-1.1.1-version-override.patch
49Patch45: openssl-1.1.1-weak-ciphers.patch
50Patch46: openssl-1.1.1-seclevel.patch
51Patch48: openssl-1.1.1-fips-post-rand.patch
52Patch49: openssl-1.1.1-evp-kdf.patch
53Patch50: openssl-1.1.1-ssh-kdf.patch
54# Backported fixes including security fixes
55Patch51: openssl-1.1.1-upstream-sync.patch
56Patch52: openssl-1.1.1-s390x-update.patch
57Patch53: openssl-1.1.1-fips-crng-test.patch
58Patch54: openssl-1.1.1-regression-fixes.patch
59
60# security fix
61# nothing ;-)
62
63License: BSDish
64Group: System Environment/Libraries
65URL: http://www.openssl.org/
66
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68BuildRequires: perl, sed
69BuildRequires: zlib-devel, krb5-devel
70BuildRequires: lksctp-tools-devel
71
72Requires: mktemp
73Requires: ca-certificates
74
75Vendor: Project Vine
76Distribution: Vine Linux
77Packager: daisuke, iwamoto
78
79%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
80
81%description
82The OpenSSL certificate management tool and the shared libraries that
83provide various cryptographic algorithms and protocols.
84
85%package devel
86Summary: OpenSSL libraries and development headers.
87Group: Development/Libraries
88Requires: %{name} = %{version}-%{release}
89Requires: krb5-devel
90
91%description devel
92The static libraries and include files needed to compile apps
93with support for various the cryptographic algorithms and protocols
94supported by OpenSSL.
95
96Patches for many networking apps can be found at:
97ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
98
99%package static
100Summary:  Libraries for static linking of applications which will use OpenSSL
101Group: Development/Libraries
102Requires: %{name}-devel = %{version}-%{release}
103
104%description static
105OpenSSL is a toolkit for supporting cryptography. The openssl-static
106package contains static libraries needed for static linking of
107applications which support various cryptographic algorithms and
108protocols.
109
110%package perl
111Summary: OpenSSL scripts which require Perl.
112Group: Applications/Internet
113Requires: %{name} = %{version}-%{release}
114Requires: perl
115
116%description perl
117Perl scripts provided with OpenSSL for converting certificates and keys
118from other formats to those used by OpenSSL.
119
120## to build compat32 for x86_64 architecture support
121%package -n compat32-%{name}
122Summary: Secure Sockets Layer Toolkit
123Group: System Environment/Libraries
124Requires: %{name} = %{version}-%{release}
125%description -n compat32-%{name}
126The OpenSSL certificate management tool and the shared libraries that
127provide various cryptographic algorithms and protocols.
128
129%package -n compat32-%{name}-devel
130Summary: OpenSSL libraries and development headers.
131Group: Development/Libraries
132Requires: compat32-%{name} = %{version}-%{release}
133Requires: compat32-krb5-devel
134%description -n compat32-%{name}-devel
135The static libraries and include files needed to compile apps
136with support for various the cryptographic algorithms and protocols
137supported by OpenSSL.
138
139%prep
140%setup -q -n %{name}-%{version}
141
142# The hobble_openssl is called here redundantly, just to be sure.
143# The tarball has already the sources removed.
144%{SOURCE1} > /dev/null
145
146cp %{SOURCE12} crypto/ec/
147cp %{SOURCE13} test/
148
149%patch1 -p1 -b .build   %{?_rawbuild}
150%patch2 -p1 -b .defaults
151%patch3 -p1 -b .no-html  %{?_rawbuild}
152%patch4 -p1 -b .man-rename
153
154%patch21 -p1 -b .issuer-hash
155
156%patch31 -p1 -b .conf-paths
157%patch32 -p1 -b .version-add-engines
158%patch33 -p1 -b .dgst
159%patch36 -p1 -b .no-brainpool
160%patch37 -p1 -b .curves
161%patch38 -p1 -b .no-weak-verify
162%patch40 -p1 -b .disable-ssl3
163%patch41 -p1 -b .system-cipherlist
164%if %{with fips}
165%patch42 -p1 -b .fips
166%endif
167%patch43 -p1 -b .ignore-bound
168%if %{with fips}
169%patch44 -p1 -b .version-override
170%endif
171%patch45 -p1 -b .weak-ciphers
172%if %{with fips}
173%patch46 -p1 -b .seclevel
174%patch49 -p1 -b .evp-kdf
175%patch50 -p1 -b .ssh-kdf
176%patch51 -p1 -b .upstream-sync
177%endif
178%patch52 -p1 -b .s390x-update
179%if %{with fips}
180%patch53 -p1 -b .crng-test
181%endif
182%patch54 -p1 -b .regression
183
184# security fix
185# nothing ;-)
186
187%build
188# Figure out which flags we want to use.
189# default
190sslarch=%{_os}-%{_target_cpu}
191#
192%ifarch %ix86
193sslarch=linux-elf
194if ! echo %{_target} | grep -q i686 ; then
195   sslflags="no-asm 386"
196fi
197%endif
198%ifarch x86_64
199sslflags=enable-ec_nistp_64_gcc_128
200%endif
201
202# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
203# marked as not requiring an executable stack.
204# Also add -DPURIFY to make using valgrind with openssl easier as we do not
205# want to depend on the uninitialized memory as a source of entropy anyway.
206RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack -DPURIFY $RPM_LD_FLAGS"
207
208export HASHBANGPERL=/usr/bin/perl
209
210perl -pi -e 's|/engines-|/%{name}/engines-|' ./Configurations/unix-Makefile.tmpl
211
212# ia64, x86_64, ppc are OK by default
213# Configure the build tree.  Override OpenSSL defaults with known-good defaults
214# usable on all platforms.  The Configure script already knows to use -fPIC and
215# RPM_OPT_FLAGS, so we can skip specifiying them here.
216./Configure \
217        --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
218        --system-ciphers-file=%{_sysconfdir}/crypto-policies/back-ends/openssl.config \
219        zlib enable-camellia enable-seed enable-rfc3779 enable-sctp \
220        enable-cms enable-md2 enable-rc5 enable-ssl3 enable-ssl3-method \
221        enable-weak-ssl-ciphers \
222        no-mdc2 no-ec2m no-sm2 no-sm4 \
223        shared  ${sslarch} $RPM_OPT_FLAGS '-DDEVRANDOM="\"/dev/urandom\""'
224
225# Do not run this in a production package the FIPS symbols must be patched-in
226#util/mkdef.pl crypto update
227
228make all
229
230%if %{with fips}
231# Overwrite FIPS README
232cp -f %{SOURCE11} .
233%endif
234
235# Clean up the .pc files
236for i in libcrypto.pc libssl.pc openssl.pc ; do
237  sed -i '/^Libs.private:/{s/-L[^ ]* //;s/-Wl[^ ]* //}' $i
238done
239
240%check
241# Verify that what was compiled actually works.
242
243# Hack - either enable SCTP AUTH chunks in kernel or disable sctp for check
244(sysctl net.sctp.addip_enable=1 && sysctl net.sctp.auth_enable=1) || \
245(echo 'Failed to enable SCTP AUTH chunks, disabling SCTP for tests...' &&
246 sed '/"zlib-dynamic" => "default",/a\ \ "sctp" => "default",' configdata.pm > configdata.pm.new && \
247 touch -r configdata.pm configdata.pm.new && \
248 mv -f configdata.pm.new configdata.pm)
249
250# We must revert patch31 before tests otherwise they will fail
251patch -p1 -R < %{PATCH31}
252
253# drop a recipe includes tests for brainpool curves (not supported by openssl-hobbled).
254rm -f test/recipes/80-test_ssl_new.t
255
256
257LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
258export LD_LIBRARY_PATH
259OPENSSL_ENABLE_MD5_VERIFY=
260export OPENSSL_ENABLE_MD5_VERIFY
261OPENSSL_SYSTEM_CIPHERS_OVERRIDE=xyz_nonexistent_file
262export OPENSSL_SYSTEM_CIPHERS_OVERRIDE
263make test
264
265
266# Add generation of HMAC checksum of the final stripped library
267%define __spec_install_post \
268    %{?__debug_package:%{__debug_install_post}} \
269    %{__arch_install_post} \
270    %{__os_install_post} \
271%{nil}
272
273%define __provides_exclude_from %{_libdir}/openssl
274
275%install
276[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
277# Install OpenSSL.
278install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl,%{_pkgdocdir}}
279make DESTDIR=$RPM_BUILD_ROOT install
280mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
281rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
282for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
283        chmod 755 ${lib}
284        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT/%{_libdir}/`basename ${lib} .%{version}`
285        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
286done
287
288# Install a makefile for generating keys and self-signed certs, and a script
289# for generating them on the fly.
290mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
291install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_pkgdocdir}/Makefile.certificate
292install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/make-dummy-cert
293install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_bindir}/renew-dummy-cert
294
295# Move runable perl scripts to bindir
296mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/*.pl $RPM_BUILD_ROOT%{_bindir}
297mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/tsget $RPM_BUILD_ROOT%{_bindir}
298
299# Rename man pages so that they don't conflict with other system man pages.
300pushd $RPM_BUILD_ROOT%{_mandir}
301ln -s -f config.5 man5/openssl.cnf.5
302for manpage in man*/* ; do
303        if [ -L ${manpage} ]; then
304                TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
305                ln -snf ${TARGET}ssl ${manpage}ssl
306                rm -f ${manpage}
307        else
308                mv ${manpage} ${manpage}ssl
309        fi
310done
311for conflict in passwd rand ; do
312        rename ${conflict} ssl${conflict} man*/${conflict}*
313# Fix dangling symlinks
314        manpage=man1/openssl-${conflict}.*
315        if [ -L ${manpage} ] ; then
316                ln -snf ssl${conflict}.1ssl ${manpage}
317        fi
318done
319popd
320
321mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
322mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
323mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
324mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
325mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
326
327# Ensure the config file timestamps are identical across builds to avoid
328# mulitlib conflicts and unnecessary renames on upgrade
329touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
330touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf
331
332rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf.dist
333rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf.dist
334
335# Determine which arch opensslconf.h is going to try to #include.
336basearch=%{_arch}
337%ifarch %{ix86}
338basearch=i386
339%endif
340
341# Next step of gradual disablement of SSL3.
342# Make SSL3 disappear to newly built dependencies.
343sed -i '/^\#ifndef OPENSSL_NO_SSL_TRACE/i\
344#ifndef OPENSSL_NO_SSL3\
345# define OPENSSL_NO_SSL3\
346#endif' $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
347
348%ifarch %{multilib_arches}
349# Do an opensslconf.h switcheroo to avoid file conflicts on systems where you
350# can have both a 32- and 64-bit version of the library, and they each need
351# their own correct-but-different versions of opensslconf.h to be usable.
352install -m644 %{SOURCE10} \
353        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
354cat $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h >> \
355        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
356install -m644 %{SOURCE9} \
357        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
358%endif
359LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
360export LD_LIBRARY_PATH
361
362
363%clean
364[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
365
366%files
367%defattr(-,root,root)
368%{!?_licensedir:%global license %%doc}
369%license LICENSE
370%doc FAQ NEWS README
371%if %{with fips}
372%doc README.FIPS
373%endif
374%{_pkgdocdir}/Makefile.certificate
375%dir %{_sysconfdir}/pki/tls
376%dir %{_sysconfdir}/pki/tls/certs
377%dir %{_sysconfdir}/pki/tls/misc
378%dir %{_sysconfdir}/pki/tls/private
379%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
380%config(noreplace) %{_sysconfdir}/pki/tls/ct_log_list.cnf
381
382%{_bindir}/make-dummy-cert
383%{_bindir}/renew-dummy-cert
384%{_bindir}/openssl
385%attr(0755,root,root) /%{_lib}/*.so.*
386%attr(0755,root,root) %{_libdir}/%{name}/engines-%{soversion}
387%dir %{_mandir}/man1*
388%{_mandir}/man1*/*
389%dir %{_mandir}/man5*
390%{_mandir}/man5*/*
391%dir %{_mandir}/man7*
392%{_mandir}/man7*/*
393
394%files devel
395%defattr(-,root,root)
396%{_prefix}/include/openssl
397%exclude %{_libdir}/lib*.a
398%attr(0755,root,root) %{_libdir}/*.so
399%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
400%dir %{_mandir}/man3*
401%{_mandir}/man3*/*
402
403%files static
404%defattr(-,root,root)
405%attr(0644,root,root) %{_libdir}/*.a
406
407%files perl
408%defattr(-,root,root)
409%{_bindir}/c_rehash
410%{_bindir}/*.pl
411%{_bindir}/tsget
412%{_mandir}/man1*/*.pl*
413%{_mandir}/man1*/c_rehash*
414%{_mandir}/man1*/tsget*
415%{_mandir}/man1*/openssl-tsget*
416%dir %{_sysconfdir}/pki/CA
417%dir %{_sysconfdir}/pki/CA/private
418%dir %{_sysconfdir}/pki/CA/certs
419%dir %{_sysconfdir}/pki/CA/crl
420%dir %{_sysconfdir}/pki/CA/newcerts
421
422## to build compat32 for x86_64 architecture support
423%if %{build_compat32}
424%files -n compat32-%{name}
425%defattr(-,root,root)
426%attr(0755,root,root) /%{_lib}/*.so.*
427
428%files -n compat32-%{name}-devel
429%defattr(-,root,root)
430%exclude %{_libdir}/lib*.a
431%attr(0755,root,root) %{_libdir}/*.so
432%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
433%endif
434
435%post -p /sbin/ldconfig
436
437%postun -p /sbin/ldconfig
438
439%post -n compat32-%{name} -p /sbin/ldconfig
440
441%postun -n compat32-%{name} -p /sbin/ldconfig
442
443%changelog
444* Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1c-1
445- new upstream release.
446- updated Patch37 and 41.
447- imported Patch52-54 from rawhide.
448
449* Mon May 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-2
450- fixed openssl.cnf
451
452* Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1b-1
453- new upstream release.
454- imported Patch36 from rawhide.
455- updated Patch32.
456
457* Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1a-1
458- new upstream release.
459- updated Patch2.
460- dropped Patch36 and 46: fixed in upstream.
461
462* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-2
463- fixed symlinks.
464
465* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
466- new upstream release (newest LTS version).
467- imported fedora stuff (except FIPS).
468
469* Sun Apr  1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
470- new upstream release with security fixes
471
472* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
473- new upstream release with security fixes
474
475* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
476- new upstream release with security fixes
477
478* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
479- new upstream release with security fixes
480
481* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
482- new upstream release with security fixes
483
484* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
485- new upstream release 1.0.2 with security fixes
486- Patch2 is merged into Patch0
487
488* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
489- new upstream release with security fixes
490
491* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
492- new upstream release with security fixes
493
494* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
495- new upstream release
496
497* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
498- merged into Vine6
499  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
500  - new upstream release with security fixes 
501  - update Patch2,5
502
503* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
504- new upstream release with security fixes 
505
506* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
507- new upstream release with security fixes
508- add patch8 from fc21 (fix perl find.pl)
509
510* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
511- new upstream release with security fixes.
512
513* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
514- new upstream release with security fixes
515
516* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
517- new upstream release with security fixes
518
519* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
520- move root CA bundle to ca-certificates package
521
522* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
523- update to 1.0.1e
524  - 1.0.1d has major regressions from 1.0.1c
525
526* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
527- remove tsget script to delete dependency perl(WWW::Curl::Easy)
528 - openssl-perl package contains it in docdir
529
530* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
531- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
532- fixed %%files
533
534* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
535- update to 1.0.1c
536- enable configure options:
537  enable-camellia enable-seed enable-tlsext enable-rfc3779
538  enable-cms enable-md2
539- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
540- generate a table with the compile settings before configure
541
542* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
543- new upstream release with security fix (CVE-2012-0050)
544
545* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
546- new upstream release with security fix
547  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
548
549* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
550- new upstream release with security fix (CVE-2011-3207, 3210)
551
552* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
553- rebuild with krb5-libs 1.8
554
555* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
556- new upstream release with security fix
557
558* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
559- use upstream openssl.pc instead of vine original one (SOURCE6)
560
561* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
562- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
563
564* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
565- add R: krb5-devel into devel pkg
566- add R: compat32-krb5-devel into compat32-devel pkg
567
568* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
569- new upstream release 1.0.0x
570- separate static libs into static package
571- change configure options
572- change so version 10
573- add tsget into perl package
574- update all patches
575
576* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
577- fix changelog typo...
578
579* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
580- new upstream release with security fix (CVE-2010-4180)
581
582* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
583- new upstream release with security fix (CVE-2010-3864)
584- drop patches included in new release
585- update patch4
586
587* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
588- add patch12 for fix CVE-2009-3555 (renegotiation)
589
590* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
591- add patch11 for fix CVE-2009-4355 (memory leak)
592
593* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
594- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
595
596* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
597- removed unnecessary %%if %{build_compat32} statements
598- removed lib*.a from devel package
599
600* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
601- new upstream release with security fix (CVE-2000-0590,0591,0789)
602
603* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
604- new upstream release with security fix (CVE-2008-5077)
605
606* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
607- new upstream release
608
609* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
610- new upstream release
611- new versioning policy
612
613* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
614- new upstream release
615- drop patch10,20 which is merged in upstream
616
617* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
618- add security patch in advance for CVE-2007-5135
619  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
620  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
621
622* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
623- add security patch for CVE-2007-3108
624  (http://openssl.org/news/patch-CVE-2007-3108.txt)
625
626* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
627- new upstream release
628
629* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
630- update (fix) openssl.pc <BTS:437>
631
632* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
633- new upstream release (with security fix)
634
635* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
636- new upstream release
637- add patch2 to use RPM_OPT macro
638
639* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
640- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
641
642* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
643- added compat32-* packages for x86_64 architecture support
644- added openssl-0.9.7i.Configure-compat32.patch
645- changed '/lib' to '/%{_lib}'
646
647* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
648- new upstream release
649
650* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
651- rebuild on VineSeed
652
653* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
654- added a security patch from Gentoo.
655  - Patch1: openssl-0.9.7c-tempfile.patch
656
657* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
658- sslarch for ppc was missing... added.
659
660* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
661- use sslarch=linux-alpha-gcc instead of alpha-gcc
662
663* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
664- new upstream version
665- clean up of spec file
666        -- removed old patches
667
668* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
669- new upstream release
670- SECURITY fix.
671  - http://www.openssl.org/news/secadv_20040317.txt
672
673* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
674- new upstream release
675- [Security fix]
676  - Vulnerabilities in ASN.1 parsing
677    http://www.openssl.org/news/secadv_20030930.txt
678- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
679
680* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
681- add openssl.pc for pkgconfig
682
683* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
684- New upstream version
685- dropped patch10, 11
686        -- merged upstream version
687
688* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
689- rebuild for VineSeed
690
691* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
692- [Security Fix]
693  - Timing-based attacks on RSA keys
694    http://www.openssl.org/news/secadv_20030317.txt
695  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
696    http://www.openssl.org/news/secadv_20030317.txt
697
698* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
699- new upstream release 0.9.6i
700- [Security Fix]
701- build for Vine Linux 2.6 errata
702
703* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
704- new upstream release 0.9.6h
705
706* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
707- new upstream release 0.9.6g
708
709* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
710- SECURITY: CAN-2002-0659 fixed
711  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
712    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
713    - update asn patch to fix accidental reversal of a logic check
714    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
715    - update asn patch to reduce chance that compiler optimization will remove
716      one of the added tests
717    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
718    - rebuild
719    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
720    - add patch to fix ASN.1 vulnerabilities
721
722* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
723- rename spec file name
724- SECURITY: CA-2002-23 fixed
725  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
726    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
727    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
728
729* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
730- added ${PATH} in LD_LIBRARY_PATH
731- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
732 
733* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
734- remove --no-<cipher>
735
736* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
737- add Patch10 for mipsel shared ( Configure )
738
739* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
740- build for Vine Linux
741- use openssl-engine-0.9.6b.tar.gz
742
743* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
744- update to 0.9.6b
745
746* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
747- move .so symlinks back to %%{_libdir}
748
749* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
750- move shared libraries to /lib (#38410)
751
752* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
753- switch to engine code base
754
755* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
756- add a script for creating dummy certificates
757- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
758
759* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
760- add s390x support
761
762* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
763- change two memcpy() calls to memmove()
764- don't define L_ENDIAN on alpha
765
766* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
767- make subpackages depend on the main package
768
769* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
770- adjust the hobble script to not disturb symlinks in include/ (fix from
771  Joe Orton)
772
773* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
774- drop the m2crypo patch we weren't using
775
776* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
777- configure using "shared" as well
778
779* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
780- update to 0.9.6a
781- use the build-shared target to build shared libraries
782- bump the soversion to 2 because we're no longer compatible with
783  our 0.9.5a packages or our 0.9.6 packages
784- drop the patch for making rsatest a no-op when rsa null support is used
785- put all man pages into <section>ssl instead of <section>
786- break the m2crypto modules into a separate package
787
788* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
789- use BN_LLONG on s390
790
791* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
792- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
793
794* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
795- move c_rehash to the perl subpackage, because it's a perl script now
796
797* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
798- update to 0.9.6
799- enable MD2
800- use the libcrypto.so and libssl.so targets to build shared libs with
801- bump the soversion to 1 because we're no longer compatible with any of
802  the various 0.9.5a packages circulating around, which provide lib*.so.0
803
804* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
805- change hobble-openssl for disabling MD2 again
806
807* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
808- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
809  bytes or so, causing EVP_DigestInit() to zero out stack variables in
810  apps built against a version of the library without it
811
812* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
813- disable some inline assembly, which on x86 is Pentium-specific
814- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
815
816* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
817- fix s390 patch
818
819* Fri Dec 8 2000 Than Ngo <than@redhat.com>
820- added support s390
821
822* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
823- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
824- add the CA.pl man page to the perl subpackage
825
826* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
827- always build with -mcpu=ev5 on alpha
828
829* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
830- add a symlink from cert.pem to ca-bundle.crt
831
832* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
833- add a ca-bundle file for packages like Samba to reference for CA certificates
834
835* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
836- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
837
838* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
839- add unzip as a buildprereq (#17662)
840- update m2crypto to 0.05-snap4
841
842* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
843- fix some issues in building when it's not installed
844
845* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
846- make sure the headers we include are the ones we built with (aaaaarrgh!)
847
848* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
849- add Richard Henderson's patch for BN on ia64
850- clean up the changelog
851
852* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
853- fix the building of python modules without openssl-devel already installed
854
855* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
856- byte-compile python extensions without the build-root
857- adjust the makefile to not remove temporary files (like .key files when
858  building .csr files) by marking them as .PRECIOUS
859
860* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
861- break out python extensions into a subpackage
862
863* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
864- tweak the makefile some more
865
866* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
867- disable MD2 support
868
869* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
870- disable MDC2 support
871
872* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
873- tweak the disabling of RC5, IDEA support
874- tweak the makefile
875
876* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
877- strip binaries and libraries
878- rework certificate makefile to have the right parts for Apache
879
880* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
881- use %%{_perl} instead of /usr/bin/perl
882- disable alpha until it passes its own test suite
883
884* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
885- move the passwd.1 man page out of the passwd package's way
886
887* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
888- update to 0.9.5a, modified for U.S.
889- add perl as a build-time requirement
890- move certificate makefile to another package
891- disable RC5, IDEA, RSA support
892- remove optimizations for now
893
894* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
895- Bero told me to move the Makefile into this package
896
897* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
898- add lib*.so symlinks to link dynamically against shared libs
899
900* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
901- update to 0.9.5
902- run ldconfig directly in post/postun
903- add FAQ
904
905* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
906- Fix build on non-x86 platforms
907
908* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
909- move /usr/share/ssl/* from -devel to main package
910
911* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
912- inital packaging
913- changes from base:
914  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
915  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.