source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 11830

Revision 11830, 29.4 KB checked in by tomop, 6 years ago (diff)

openssl-1.1.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%{!?_pkgdocdir:%define _pkgdocdir %{_docdir}}
3%define version 1.1.1
4%define release 2%{_dist_release}
5# 1.0.0 soversion = 10
6# 1.1.0 soversion = 1.1 (same as upstream although presence of some symbols
7#                        depends on build configuration options)
8%define soversion 1.1
9
10Summary: Secure Sockets Layer Toolkit
11Name: openssl
12Version: %{version}
13Release: %{release}
14# We have to remove certain patented algorithms from the openssl source
15# tarball with the hobble-openssl script which is included below.
16# The original openssl upstream tarball cannot be shipped in the .src.rpm.
17Source: openssl-%{version}-hobbled.tar.xz
18Source1: hobble-openssl
19Source2: Makefile.certificate
20Source6: make-dummy-cert
21Source7: renew-dummy-cert
22Source9: opensslconf-new.h
23Source10: opensslconf-new-warning.h
24#Source11: README.FIPS
25Source12: ec_curve.c
26Source13: ectest.c
27
28# Build changes
29Patch1: openssl-1.1.1-build.patch
30Patch2: openssl-1.1.0-defaults.patch
31Patch3: openssl-1.1.0-no-html.patch
32Patch4: openssl-1.1.1-man-rename.patch
33# Bug fixes
34Patch21: openssl-1.1.0-issuer-hash.patch
35# Functionality changes
36Patch31: openssl-1.1.1-conf-paths.patch
37Patch32: openssl-1.1.1-version-add-engines.patch
38Patch33: openssl-1.1.0-apps-dgst.patch
39Patch36: openssl-1.1.1-secure-getenv.patch
40Patch37: openssl-1.1.1-ec-curves.patch
41Patch38: openssl-1.1.0-no-weak-verify.patch
42Patch40: openssl-1.1.1-disable-ssl3.patch
43Patch41: openssl-1.1.1-system-cipherlist.patch
44#Patch42: openssl-1.1.1-fips.patch
45Patch43: openssl-1.1.1-ignore-bound.patch
46#Patch44: openssl-1.1.1-version-override.patch
47Patch45: openssl-1.1.1-weak-ciphers.patch
48Patch46: openssl-1.1.1-seclevel.patch
49
50# security fix
51# nothing ;-)
52
53License: BSDish
54Group: System Environment/Libraries
55URL: http://www.openssl.org/
56
57BuildRoot: %{_tmppath}/%{name}-%{version}-root
58BuildRequires: perl, sed
59BuildRequires: zlib-devel, krb5-devel
60BuildRequires: lksctp-tools-devel
61
62Requires: mktemp
63Requires: ca-certificates
64
65Vendor: Project Vine
66Distribution: Vine Linux
67Packager: daisuke, iwamoto
68
69%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
70
71%description
72The OpenSSL certificate management tool and the shared libraries that
73provide various cryptographic algorithms and protocols.
74
75%package devel
76Summary: OpenSSL libraries and development headers.
77Group: Development/Libraries
78Requires: %{name} = %{version}-%{release}
79Requires: krb5-devel
80
81%description devel
82The static libraries and include files needed to compile apps
83with support for various the cryptographic algorithms and protocols
84supported by OpenSSL.
85
86Patches for many networking apps can be found at:
87ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
88
89%package static
90Summary:  Libraries for static linking of applications which will use OpenSSL
91Group: Development/Libraries
92Requires: %{name}-devel = %{version}-%{release}
93
94%description static
95OpenSSL is a toolkit for supporting cryptography. The openssl-static
96package contains static libraries needed for static linking of
97applications which support various cryptographic algorithms and
98protocols.
99
100%package perl
101Summary: OpenSSL scripts which require Perl.
102Group: Applications/Internet
103Requires: %{name} = %{version}-%{release}
104Requires: perl
105Requires: perl-WWW-Curl
106
107%description perl
108Perl scripts provided with OpenSSL for converting certificates and keys
109from other formats to those used by OpenSSL.
110
111## to build compat32 for x86_64 architecture support
112%package -n compat32-%{name}
113Summary: Secure Sockets Layer Toolkit
114Group: System Environment/Libraries
115Requires: %{name} = %{version}-%{release}
116%description -n compat32-%{name}
117The OpenSSL certificate management tool and the shared libraries that
118provide various cryptographic algorithms and protocols.
119
120%package -n compat32-%{name}-devel
121Summary: OpenSSL libraries and development headers.
122Group: Development/Libraries
123Requires: compat32-%{name} = %{version}-%{release}
124Requires: compat32-krb5-devel
125%description -n compat32-%{name}-devel
126The static libraries and include files needed to compile apps
127with support for various the cryptographic algorithms and protocols
128supported by OpenSSL.
129
130%prep
131%setup -q -n %{name}-%{version}
132
133# The hobble_openssl is called here redundantly, just to be sure.
134# The tarball has already the sources removed.
135%{SOURCE1} > /dev/null
136
137cp %{SOURCE12} crypto/ec/
138cp %{SOURCE13} test/
139
140%patch1 -p1 -b .build   %{?_rawbuild}
141%patch2 -p1 -b .defaults
142%patch3 -p1 -b .no-html  %{?_rawbuild}
143%patch4 -p1 -b .man-rename
144
145%patch21 -p1 -b .issuer-hash
146
147%patch31 -p1 -b .conf-paths
148%patch32 -p1 -b .version-add-engines
149%patch33 -p1 -b .dgst
150%patch36 -p1 -b .secure-getenv
151%patch37 -p1 -b .curves
152%patch38 -p1 -b .no-weak-verify
153%patch40 -p1 -b .disable-ssl3
154%patch41 -p1 -b .system-cipherlist
155#patch42 -p1 -b .fips
156%patch43 -p1 -b .ignore-bound
157#patch44 -p1 -b .version-override
158%patch45 -p1 -b .weak-ciphers
159%patch46 -p1 -b .seclevel
160
161# security fix
162# nothing ;-)
163
164%build
165# Figure out which flags we want to use.
166# default
167sslarch=%{_os}-%{_target_cpu}
168#
169%ifarch %ix86
170sslarch=linux-elf
171if ! echo %{_target} | grep -q i686 ; then
172   sslflags="no-asm 386"
173fi
174%endif
175%ifarch x86_64
176sslflags=enable-ec_nistp_64_gcc_128
177%endif
178
179# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
180# marked as not requiring an executable stack.
181# Also add -DPURIFY to make using valgrind with openssl easier as we do not
182# want to depend on the uninitialized memory as a source of entropy anyway.
183RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack -DPURIFY $RPM_LD_FLAGS"
184
185export HASHBANGPERL=/usr/bin/perl
186
187perl -pi -e 's|/engines-|/%{name}/engines-|' ./Configurations/unix-Makefile.tmpl
188
189# ia64, x86_64, ppc are OK by default
190# Configure the build tree.  Override OpenSSL defaults with known-good defaults
191# usable on all platforms.  The Configure script already knows to use -fPIC and
192# RPM_OPT_FLAGS, so we can skip specifiying them here.
193./Configure \
194        --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
195        --system-ciphers-file=%{_sysconfdir}/crypto-policies/back-ends/openssl.config \
196        zlib enable-camellia enable-seed enable-rfc3779 enable-sctp \
197        enable-cms enable-md2 enable-rc5 enable-ssl3 enable-ssl3-method \
198        enable-weak-ssl-ciphers \
199        no-mdc2 no-ec2m no-sm2 no-sm4 \
200        shared  ${sslarch} $RPM_OPT_FLAGS '-DDEVRANDOM="\"/dev/urandom\""'
201
202# Do not run this in a production package the FIPS symbols must be patched-in
203#util/mkdef.pl crypto update
204
205make all
206
207# Clean up the .pc files
208for i in libcrypto.pc libssl.pc openssl.pc ; do
209  sed -i '/^Libs.private:/{s/-L[^ ]* //;s/-Wl[^ ]* //}' $i
210done
211
212%check
213# Verify that what was compiled actually works.
214
215# Hack - either enable SCTP AUTH chunks in kernel or disable sctp for check
216(sysctl net.sctp.addip_enable=1 && sysctl net.sctp.auth_enable=1) || \
217(echo 'Failed to enable SCTP AUTH chunks, disabling SCTP for tests...' &&
218 sed '/"zlib-dynamic" => "default",/a\ \ "sctp" => "default",' configdata.pm > configdata.pm.new && \
219 touch -r configdata.pm configdata.pm.new && \
220 mv -f configdata.pm.new configdata.pm)
221
222# We must revert patch31 before tests otherwise they will fail
223patch -p1 -R < %{PATCH31}
224
225LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
226export LD_LIBRARY_PATH
227OPENSSL_ENABLE_MD5_VERIFY=
228export OPENSSL_ENABLE_MD5_VERIFY
229OPENSSL_SYSTEM_CIPHERS_OVERRIDE=xyz_nonexistent_file
230export OPENSSL_SYSTEM_CIPHERS_OVERRIDE
231make test
232
233# Add generation of HMAC checksum of the final stripped library
234%define __spec_install_post \
235    %{?__debug_package:%{__debug_install_post}} \
236    %{__arch_install_post} \
237    %{__os_install_post} \
238%{nil}
239
240%define __provides_exclude_from %{_libdir}/openssl
241
242%install
243[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
244# Install OpenSSL.
245install -d $RPM_BUILD_ROOT{/%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl,%{_pkgdocdir}}
246make DESTDIR=$RPM_BUILD_ROOT install
247mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
248rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
249for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
250        chmod 755 ${lib}
251        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT/%{_libdir}/`basename ${lib} .%{version}`
252        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
253done
254
255# Install a makefile for generating keys and self-signed certs, and a script
256# for generating them on the fly.
257mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
258install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_pkgdocdir}/Makefile.certificate
259install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_bindir}/make-dummy-cert
260install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_bindir}/renew-dummy-cert
261
262# Move runable perl scripts to bindir
263mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/*.pl $RPM_BUILD_ROOT%{_bindir}
264mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc/tsget $RPM_BUILD_ROOT%{_bindir}
265
266# Rename man pages so that they don't conflict with other system man pages.
267pushd $RPM_BUILD_ROOT%{_mandir}
268ln -s -f config.5 man5/openssl.cnf.5
269for manpage in man*/* ; do
270        if [ -L ${manpage} ]; then
271                TARGET=`ls -l ${manpage} | awk '{ print $NF }'`
272                ln -snf ${TARGET}ssl ${manpage}ssl
273                rm -f ${manpage}
274        else
275                mv ${manpage} ${manpage}ssl
276        fi
277done
278for conflict in passwd rand ; do
279        rename ${conflict} ssl${conflict} man*/${conflict}*
280# Fix dangling symlinks
281        manpage=man1/openssl-${conflict}.*
282        if [ -L ${manpage} ] ; then
283                ln -snf ssl${conflict}.1ssl ${manpage}
284        fi
285done
286popd
287
288mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
289mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
290mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
291mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
292mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
293
294# Ensure the config file timestamps are identical across builds to avoid
295# mulitlib conflicts and unnecessary renames on upgrade
296touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
297touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf
298
299rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf.dist
300rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/ct_log_list.cnf.dist
301
302# Determine which arch opensslconf.h is going to try to #include.
303basearch=%{_arch}
304%ifarch %{ix86}
305basearch=i386
306%endif
307
308# Next step of gradual disablement of SSL3.
309# Make SSL3 disappear to newly built dependencies.
310sed -i '/^\#ifndef OPENSSL_NO_SSL_TRACE/i\
311#ifndef OPENSSL_NO_SSL3\
312# define OPENSSL_NO_SSL3\
313#endif' $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
314
315%ifarch %{multilib_arches}
316# Do an opensslconf.h switcheroo to avoid file conflicts on systems where you
317# can have both a 32- and 64-bit version of the library, and they each need
318# their own correct-but-different versions of opensslconf.h to be usable.
319install -m644 %{SOURCE10} \
320        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
321cat $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h >> \
322        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf-${basearch}.h
323install -m644 %{SOURCE9} \
324        $RPM_BUILD_ROOT/%{_prefix}/include/openssl/opensslconf.h
325%endif
326LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
327export LD_LIBRARY_PATH
328
329
330%clean
331[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
332
333%files
334%defattr(-,root,root)
335%{!?_licensedir:%global license %%doc}
336%license LICENSE
337%doc FAQ NEWS README
338%{_pkgdocdir}/Makefile.certificate
339%dir %{_sysconfdir}/pki/tls
340%dir %{_sysconfdir}/pki/tls/certs
341%dir %{_sysconfdir}/pki/tls/misc
342%dir %{_sysconfdir}/pki/tls/private
343%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
344%config(noreplace) %{_sysconfdir}/pki/tls/ct_log_list.cnf
345
346%{_bindir}/make-dummy-cert
347%{_bindir}/renew-dummy-cert
348%{_bindir}/openssl
349%attr(0755,root,root) /%{_lib}/*.so.*
350/%{_lib}/*.so.%{soversion}
351%attr(0755,root,root) %{_libdir}/%{name}/engines-%{soversion}
352%dir %{_mandir}/man1*
353%{_mandir}/man1*/*
354%dir %{_mandir}/man5*
355%{_mandir}/man5*/*
356%dir %{_mandir}/man7*
357%{_mandir}/man7*/*
358
359%files devel
360%defattr(-,root,root)
361%{_prefix}/include/openssl
362%exclude %{_libdir}/lib*.a
363%attr(0755,root,root) %{_libdir}/*.so
364%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
365%dir %{_mandir}/man3*
366%{_mandir}/man3*/*
367
368%files static
369%defattr(-,root,root)
370%attr(0644,root,root) %{_libdir}/*.a
371
372%files perl
373%defattr(-,root,root)
374%{_bindir}/c_rehash
375%{_bindir}/*.pl
376%{_bindir}/tsget
377%{_mandir}/man1*/*.pl*
378%{_mandir}/man1*/c_rehash*
379%{_mandir}/man1*/tsget*
380%{_mandir}/man1*/openssl-tsget*
381%dir %{_sysconfdir}/pki/CA
382%dir %{_sysconfdir}/pki/CA/private
383%dir %{_sysconfdir}/pki/CA/certs
384%dir %{_sysconfdir}/pki/CA/crl
385%dir %{_sysconfdir}/pki/CA/newcerts
386
387## to build compat32 for x86_64 architecture support
388%if %{build_compat32}
389%files -n compat32-%{name}
390%defattr(-,root,root)
391%attr(0755,root,root) /%{_lib}/*.so.*
392
393%files -n compat32-%{name}-devel
394%defattr(-,root,root)
395%exclude %{_libdir}/lib*.a
396%attr(0755,root,root) %{_libdir}/*.so
397%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
398%endif
399
400%post -p /sbin/ldconfig
401
402%postun -p /sbin/ldconfig
403
404%post -n compat32-%{name} -p /sbin/ldconfig
405
406%postun -n compat32-%{name} -p /sbin/ldconfig
407
408%changelog
409* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-2
410- fixed symlinks.
411
412* Thu Nov 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
413- new upstream release (newest LTS version).
414- imported fedora stuff (except FIPS).
415
416* Sun Apr  1 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2o-1
417- new upstream release with security fixes
418
419* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
420- new upstream release with security fixes
421
422* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
423- new upstream release with security fixes
424
425* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
426- new upstream release with security fixes
427
428* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
429- new upstream release with security fixes
430
431* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
432- new upstream release 1.0.2 with security fixes
433- Patch2 is merged into Patch0
434
435* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
436- new upstream release with security fixes
437
438* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
439- new upstream release with security fixes
440
441* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
442- new upstream release
443
444* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
445- merged into Vine6
446  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
447  - new upstream release with security fixes 
448  - update Patch2,5
449
450* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
451- new upstream release with security fixes 
452
453* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
454- new upstream release with security fixes
455- add patch8 from fc21 (fix perl find.pl)
456
457* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
458- new upstream release with security fixes.
459
460* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
461- new upstream release with security fixes
462
463* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
464- new upstream release with security fixes
465
466* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
467- move root CA bundle to ca-certificates package
468
469* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
470- update to 1.0.1e
471  - 1.0.1d has major regressions from 1.0.1c
472
473* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
474- remove tsget script to delete dependency perl(WWW::Curl::Easy)
475 - openssl-perl package contains it in docdir
476
477* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
478- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
479- fixed %%files
480
481* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
482- update to 1.0.1c
483- enable configure options:
484  enable-camellia enable-seed enable-tlsext enable-rfc3779
485  enable-cms enable-md2
486- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
487- generate a table with the compile settings before configure
488
489* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
490- new upstream release with security fix (CVE-2012-0050)
491
492* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
493- new upstream release with security fix
494  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
495
496* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
497- new upstream release with security fix (CVE-2011-3207, 3210)
498
499* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
500- rebuild with krb5-libs 1.8
501
502* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
503- new upstream release with security fix
504
505* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
506- use upstream openssl.pc instead of vine original one (SOURCE6)
507
508* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
509- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
510
511* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
512- add R: krb5-devel into devel pkg
513- add R: compat32-krb5-devel into compat32-devel pkg
514
515* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
516- new upstream release 1.0.0x
517- separate static libs into static package
518- change configure options
519- change so version 10
520- add tsget into perl package
521- update all patches
522
523* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
524- fix changelog typo...
525
526* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
527- new upstream release with security fix (CVE-2010-4180)
528
529* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
530- new upstream release with security fix (CVE-2010-3864)
531- drop patches included in new release
532- update patch4
533
534* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
535- add patch12 for fix CVE-2009-3555 (renegotiation)
536
537* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
538- add patch11 for fix CVE-2009-4355 (memory leak)
539
540* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
541- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
542
543* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
544- removed unnecessary %%if %{build_compat32} statements
545- removed lib*.a from devel package
546
547* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
548- new upstream release with security fix (CVE-2000-0590,0591,0789)
549
550* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
551- new upstream release with security fix (CVE-2008-5077)
552
553* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
554- new upstream release
555
556* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
557- new upstream release
558- new versioning policy
559
560* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
561- new upstream release
562- drop patch10,20 which is merged in upstream
563
564* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
565- add security patch in advance for CVE-2007-5135
566  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
567  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
568
569* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
570- add security patch for CVE-2007-3108
571  (http://openssl.org/news/patch-CVE-2007-3108.txt)
572
573* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
574- new upstream release
575
576* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
577- update (fix) openssl.pc <BTS:437>
578
579* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
580- new upstream release (with security fix)
581
582* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
583- new upstream release
584- add patch2 to use RPM_OPT macro
585
586* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
587- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
588
589* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
590- added compat32-* packages for x86_64 architecture support
591- added openssl-0.9.7i.Configure-compat32.patch
592- changed '/lib' to '/%{_lib}'
593
594* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
595- new upstream release
596
597* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
598- rebuild on VineSeed
599
600* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
601- added a security patch from Gentoo.
602  - Patch1: openssl-0.9.7c-tempfile.patch
603
604* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
605- sslarch for ppc was missing... added.
606
607* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
608- use sslarch=linux-alpha-gcc instead of alpha-gcc
609
610* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
611- new upstream version
612- clean up of spec file
613        -- removed old patches
614
615* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
616- new upstream release
617- SECURITY fix.
618  - http://www.openssl.org/news/secadv_20040317.txt
619
620* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
621- new upstream release
622- [Security fix]
623  - Vulnerabilities in ASN.1 parsing
624    http://www.openssl.org/news/secadv_20030930.txt
625- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
626
627* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
628- add openssl.pc for pkgconfig
629
630* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
631- New upstream version
632- dropped patch10, 11
633        -- merged upstream version
634
635* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
636- rebuild for VineSeed
637
638* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
639- [Security Fix]
640  - Timing-based attacks on RSA keys
641    http://www.openssl.org/news/secadv_20030317.txt
642  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
643    http://www.openssl.org/news/secadv_20030317.txt
644
645* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
646- new upstream release 0.9.6i
647- [Security Fix]
648- build for Vine Linux 2.6 errata
649
650* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
651- new upstream release 0.9.6h
652
653* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
654- new upstream release 0.9.6g
655
656* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
657- SECURITY: CAN-2002-0659 fixed
658  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
659    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
660    - update asn patch to fix accidental reversal of a logic check
661    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
662    - update asn patch to reduce chance that compiler optimization will remove
663      one of the added tests
664    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
665    - rebuild
666    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
667    - add patch to fix ASN.1 vulnerabilities
668
669* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
670- rename spec file name
671- SECURITY: CA-2002-23 fixed
672  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
673    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
674    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
675
676* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
677- added ${PATH} in LD_LIBRARY_PATH
678- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
679 
680* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
681- remove --no-<cipher>
682
683* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
684- add Patch10 for mipsel shared ( Configure )
685
686* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
687- build for Vine Linux
688- use openssl-engine-0.9.6b.tar.gz
689
690* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
691- update to 0.9.6b
692
693* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
694- move .so symlinks back to %%{_libdir}
695
696* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
697- move shared libraries to /lib (#38410)
698
699* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
700- switch to engine code base
701
702* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
703- add a script for creating dummy certificates
704- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
705
706* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
707- add s390x support
708
709* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
710- change two memcpy() calls to memmove()
711- don't define L_ENDIAN on alpha
712
713* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
714- make subpackages depend on the main package
715
716* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
717- adjust the hobble script to not disturb symlinks in include/ (fix from
718  Joe Orton)
719
720* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
721- drop the m2crypo patch we weren't using
722
723* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
724- configure using "shared" as well
725
726* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
727- update to 0.9.6a
728- use the build-shared target to build shared libraries
729- bump the soversion to 2 because we're no longer compatible with
730  our 0.9.5a packages or our 0.9.6 packages
731- drop the patch for making rsatest a no-op when rsa null support is used
732- put all man pages into <section>ssl instead of <section>
733- break the m2crypto modules into a separate package
734
735* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
736- use BN_LLONG on s390
737
738* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
739- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
740
741* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
742- move c_rehash to the perl subpackage, because it's a perl script now
743
744* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
745- update to 0.9.6
746- enable MD2
747- use the libcrypto.so and libssl.so targets to build shared libs with
748- bump the soversion to 1 because we're no longer compatible with any of
749  the various 0.9.5a packages circulating around, which provide lib*.so.0
750
751* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
752- change hobble-openssl for disabling MD2 again
753
754* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
755- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
756  bytes or so, causing EVP_DigestInit() to zero out stack variables in
757  apps built against a version of the library without it
758
759* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
760- disable some inline assembly, which on x86 is Pentium-specific
761- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
762
763* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
764- fix s390 patch
765
766* Fri Dec 8 2000 Than Ngo <than@redhat.com>
767- added support s390
768
769* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
770- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
771- add the CA.pl man page to the perl subpackage
772
773* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
774- always build with -mcpu=ev5 on alpha
775
776* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
777- add a symlink from cert.pem to ca-bundle.crt
778
779* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
780- add a ca-bundle file for packages like Samba to reference for CA certificates
781
782* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
783- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
784
785* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
786- add unzip as a buildprereq (#17662)
787- update m2crypto to 0.05-snap4
788
789* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
790- fix some issues in building when it's not installed
791
792* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
793- make sure the headers we include are the ones we built with (aaaaarrgh!)
794
795* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
796- add Richard Henderson's patch for BN on ia64
797- clean up the changelog
798
799* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
800- fix the building of python modules without openssl-devel already installed
801
802* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
803- byte-compile python extensions without the build-root
804- adjust the makefile to not remove temporary files (like .key files when
805  building .csr files) by marking them as .PRECIOUS
806
807* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
808- break out python extensions into a subpackage
809
810* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
811- tweak the makefile some more
812
813* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
814- disable MD2 support
815
816* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
817- disable MDC2 support
818
819* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
820- tweak the disabling of RC5, IDEA support
821- tweak the makefile
822
823* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
824- strip binaries and libraries
825- rework certificate makefile to have the right parts for Apache
826
827* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
828- use %%{_perl} instead of /usr/bin/perl
829- disable alpha until it passes its own test suite
830
831* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
832- move the passwd.1 man page out of the passwd package's way
833
834* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
835- update to 0.9.5a, modified for U.S.
836- add perl as a build-time requirement
837- move certificate makefile to another package
838- disable RC5, IDEA, RSA support
839- remove optimizations for now
840
841* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
842- Bero told me to move the Makefile into this package
843
844* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
845- add lib*.so symlinks to link dynamically against shared libs
846
847* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
848- update to 0.9.5
849- run ldconfig directly in post/postun
850- add FAQ
851
852* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
853- Fix build on non-x86 platforms
854
855* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
856- move /usr/share/ssl/* from -devel to main package
857
858* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
859- inital packaging
860- changes from base:
861  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
862  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.