source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 11408

Revision 11408, 26.5 KB checked in by iwamoto, 6 years ago (diff)

openssl: update to 1.0.2n

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.2n
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: ftp://ftp.openssl.org/source/openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source6: make-dummy-cert
13Source7: renew-dummy-cert
14
15# Patch0: openssl-1.0.2-soversion.patch
16# Patch2: openssl-1.0.1-rpm_opt.patch
17Patch0: openssl-1.0.2g-rpmbuild.patch
18Patch4: openssl-1.0.2g-enginesdir.patch
19Patch5: openssl-1.0.2a-version-add-engines.patch
20Patch8: openssl-1.0.1c-perlfind.patch
21
22# security fix
23# nothing ;-)
24
25License: BSDish
26Group: System Environment/Libraries
27URL: http://www.openssl.org/
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: perl, sed
31BuildRequires: zlib-devel, krb5-devel
32
33Requires: mktemp
34Requires: ca-certificates
35
36Vendor: Project Vine
37Distribution: Vine Linux
38Packager: daisuke, iwamoto
39
40%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
41
42%description
43The OpenSSL certificate management tool and the shared libraries that
44provide various cryptographic algorithms and protocols.
45
46%package devel
47Summary: OpenSSL libraries and development headers.
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: krb5-devel
51
52%description devel
53The static libraries and include files needed to compile apps
54with support for various the cryptographic algorithms and protocols
55supported by OpenSSL.
56
57Patches for many networking apps can be found at:
58ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
59
60%package static
61Summary:  Libraries for static linking of applications which will use OpenSSL
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64
65%description static
66OpenSSL is a toolkit for supporting cryptography. The openssl-static
67package contains static libraries needed for static linking of
68applications which support various cryptographic algorithms and
69protocols.
70
71%package perl
72Summary: OpenSSL scripts which require Perl.
73Group: Applications/Internet
74Requires: perl
75Requires: %{name} = %{version}-%{release}
76
77%description perl
78Perl scripts provided with OpenSSL for converting certificates and keys
79from other formats to those used by OpenSSL.
80
81## to build compat32 for x86_64 architecture support
82%package -n compat32-%{name}
83Summary: Secure Sockets Layer Toolkit
84Group: System Environment/Libraries
85Requires: %{name} = %{version}-%{release}
86%description -n compat32-%{name}
87The OpenSSL certificate management tool and the shared libraries that
88provide various cryptographic algorithms and protocols.
89
90%package -n compat32-%{name}-devel
91Summary: OpenSSL libraries and development headers.
92Group: Development/Libraries
93Requires: compat32-%{name} = %{version}-%{release}
94Requires: compat32-krb5-devel
95%description -n compat32-%{name}-devel
96The static libraries and include files needed to compile apps
97with support for various the cryptographic algorithms and protocols
98supported by OpenSSL.
99
100%prep
101%setup -q -n openssl-%{version}
102
103%patch0 -p1 -b .soversion
104%patch4 -p1 -b .enginesdir
105%patch5 -p1 -b .version-add-engines
106%patch8 -p1 -b .perlfind
107
108# security fix
109# nothing ;-)
110
111chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
112chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
113# chmod 644 doc/openssl_button.html doc/openssl_button.gif
114chmod 644 doc/ssleay.txt
115
116%build
117PATH=${PATH}:${PWD}/bin
118TOPDIR=${PWD}
119LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
120
121# Modify the various perl scripts to reference perl in the right location.
122perl util/perlpath.pl `dirname %{__perl}`
123
124# Generate a table with the compile settings for my perusal.
125touch Makefile
126make TABLE PERL=%{__perl}
127
128# Figure out which flags we want to use.
129# default
130sslarch=%{_os}-%{_target_cpu}
131#
132%ifarch %ix86
133sslarch=linux-elf
134if ! echo %{_target} | grep -q i686 ; then
135   sslflags="no-asm 386"
136fi
137%endif
138%ifarch sparcv9
139sslarch=linux-sparcv9
140sslflags=no-asm
141%endif
142%ifarch sparc64
143sslarch=linux64-sparcv9
144sslflags=no-asm
145%endif
146%ifarch alpha alphaev56 alphaev6 alphaev67
147sslarch=linux-alpha-gcc
148%endif
149%ifarch s390 sh3eb sh4eb
150sslarch="linux-generic32 -DB_ENDIAN"
151%endif
152%ifarch s390x
153sslarch="linux64-s390x"
154%endif
155%ifarch %{arm} sh3 sh4
156sslarch=linux-generic32
157%endif
158# ia64/x86_64/ppc\ppc64 are OK by default.
159
160# Configure the build tree.  Override OpenSSL defaults with known-good defaults
161# usable on all platforms.  The Configure script already knows to use -fPIC and
162# RPM_OPT_FLAGS, so we can skip specifiying them here.
163./Configure  \
164         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
165         zlib-dynamic enable-camellia enable-seed enable-tlsext \
166         enable-rfc3779 enable-cms enable-md2 \
167         --enginesdir=%{_libdir}/openssl/engines \
168         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
169         shared ${sslarch}
170
171# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
172# marked as not requiring an executable stack.
173RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
174make depend
175make all build-shared
176
177# Generate hashes for the included certs.
178LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
179export LD_LIBRARY_PATH
180make rehash build-shared
181
182# Verify that what was compiled actually works.
183make -C test apps tests
184
185# Relink the main binary to get it dynamically linked.
186rm apps/openssl
187make all build-shared
188
189%install
190[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
191# Install OpenSSL.
192install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
193make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
194install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
195# added for lib64
196# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
197mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
198# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
199mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
200mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
201rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
202rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
203for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
204        chmod 755 ${lib}
205        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
206        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
207done
208# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
209
210# Install a makefile for generating keys and self-signed certs, and a script
211# for generating them on the fly.
212mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
213install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
214install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
215install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
216
217# Make sure we actually include the headers we built against.
218for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
219        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
220                install -m644 include/openssl/`basename ${header}` ${header}
221        fi
222done
223
224# Rename man pages so that they don't conflict with system man pages.  We used
225# to change the file extensions, but that only prevents file conflicts.  The
226# man viewer still can't select either of the two unless we physically change
227# the directory.
228for section in 1 2 3 4 5 6 7 8 ; do
229        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
230                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
231                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
232        fi
233done
234
235# Pick a CA script.
236pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
237mv CA.sh CA
238popd
239
240mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
241mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
242mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
243mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
245
246# Ensure the openssl.cnf timestamp is identical across builds to avoid
247# mulitlib conflicts and unnecessary renames on upgrade
248touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
249
250%clean
251[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
252
253%files
254%defattr(-,root,root)
255%doc FAQ LICENSE CHANGES NEWS INSTALL README
256%doc doc/README doc/c-indentation.el doc/openssl.txt
257%doc doc/openssl_button.html doc/openssl_button.gif
258%doc doc/ssleay.txt
259
260%{_sysconfdir}/pki/tls/certs/make-dummy-cert
261%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
262%{_sysconfdir}/pki/tls/certs/Makefile
263%{_sysconfdir}/pki/tls/misc/CA
264%dir %{_sysconfdir}/pki/CA
265%dir %{_sysconfdir}/pki/CA/private
266%dir %{_sysconfdir}/pki/CA/certs
267%dir %{_sysconfdir}/pki/CA/crl
268%dir %{_sysconfdir}/pki/CA/newcerts
269%{_sysconfdir}/pki/tls/misc/c_*
270%dir %{_sysconfdir}/pki/tls
271%dir %{_sysconfdir}/pki/tls/certs
272%dir %{_sysconfdir}/pki/tls/misc
273%dir %{_sysconfdir}/pki/tls/private
274%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
275
276%attr(0755,root,root) %{_bindir}/openssl
277%attr(0755,root,root) /%{_lib}/*.so.*
278%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
279%attr(0755,root,root) %dir %{_mandir}/man1*
280%attr(0644,root,root) %{_mandir}/man1*/*
281%attr(0755,root,root) %dir %{_mandir}/man5*
282%attr(0644,root,root) %{_mandir}/man5*/*
283%attr(0755,root,root) %dir %{_mandir}/man7*
284%attr(0644,root,root) %{_mandir}/man7*/*
285
286%files devel
287%defattr(-,root,root)
288%{_prefix}/include/openssl
289%exclude %{_libdir}/lib*.a
290%attr(0755,root,root) %{_libdir}/*.so
291%attr(0755,root,root) %dir %{_mandir}/man3*
292%attr(0644,root,root) %{_mandir}/man3*/*
293%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
294
295%files static
296%defattr(-,root,root)
297%attr(0644,root,root) %{_libdir}/*.a
298
299%files perl
300%defattr(-,root,root)
301%attr(0755,root,root) %{_bindir}/c_rehash
302%attr(0755,root,root) %dir %{_mandir}/man1*
303%attr(0644,root,root) %{_mandir}/man1*/*.pl*
304%{_sysconfdir}/pki/tls/misc/*.pl
305#%{_sysconfdir}/pki/tls/misc/tsget
306%doc apps/tsget
307
308## to build compat32 for x86_64 architecture support
309%if %{build_compat32}
310%files -n compat32-%{name}
311%defattr(-,root,root)
312%attr(0755,root,root) /%{_lib}/*.so.*
313
314%files -n compat32-%{name}-devel
315%defattr(-,root,root)
316%exclude %{_libdir}/lib*.a
317%attr(0755,root,root) %{_libdir}/*.so
318%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
319%endif
320
321%post -p /sbin/ldconfig
322
323%postun -p /sbin/ldconfig
324
325%post -n compat32-%{name} -p /sbin/ldconfig
326
327%postun -n compat32-%{name} -p /sbin/ldconfig
328
329%changelog
330* Sun Jan 21 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2n-1
331- new upstream release with security fixes
332
333* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2m-1
334- new upstream release with security fixes
335
336* Sun Jan 29 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2k-1
337- new upstream release with security fixes
338
339* Thu May  5 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.0.2h-1
340- new upstream release with security fixes
341
342* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
343- new upstream release 1.0.2 with security fixes
344- Patch2 is merged into Patch0
345
346* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
347- new upstream release with security fixes
348
349* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
350- new upstream release with security fixes
351
352* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
353- new upstream release
354
355* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
356- merged into Vine6
357  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
358  - new upstream release with security fixes 
359  - update Patch2,5
360
361* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
362- new upstream release with security fixes 
363
364* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
365- new upstream release with security fixes
366- add patch8 from fc21 (fix perl find.pl)
367
368* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
369- new upstream release with security fixes.
370
371* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
372- new upstream release with security fixes
373
374* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
375- new upstream release with security fixes
376
377* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
378- move root CA bundle to ca-certificates package
379
380* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
381- update to 1.0.1e
382  - 1.0.1d has major regressions from 1.0.1c
383
384* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
385- remove tsget script to delete dependency perl(WWW::Curl::Easy)
386 - openssl-perl package contains it in docdir
387
388* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
389- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
390- fixed %%files
391
392* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
393- update to 1.0.1c
394- enable configure options:
395  enable-camellia enable-seed enable-tlsext enable-rfc3779
396  enable-cms enable-md2
397- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
398- generate a table with the compile settings before configure
399
400* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
401- new upstream release with security fix (CVE-2012-0050)
402
403* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
404- new upstream release with security fix
405  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
406
407* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
408- new upstream release with security fix (CVE-2011-3207, 3210)
409
410* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
411- rebuild with krb5-libs 1.8
412
413* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
414- new upstream release with security fix
415
416* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
417- use upstream openssl.pc instead of vine original one (SOURCE6)
418
419* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
420- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
421
422* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
423- add R: krb5-devel into devel pkg
424- add R: compat32-krb5-devel into compat32-devel pkg
425
426* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
427- new upstream release 1.0.0x
428- separate static libs into static package
429- change configure options
430- change so version 10
431- add tsget into perl package
432- update all patches
433
434* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
435- fix changelog typo...
436
437* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
438- new upstream release with security fix (CVE-2010-4180)
439
440* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
441- new upstream release with security fix (CVE-2010-3864)
442- drop patches included in new release
443- update patch4
444
445* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
446- add patch12 for fix CVE-2009-3555 (renegotiation)
447
448* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
449- add patch11 for fix CVE-2009-4355 (memory leak)
450
451* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
452- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
453
454* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
455- removed unnecessary %%if %{build_compat32} statements
456- removed lib*.a from devel package
457
458* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
459- new upstream release with security fix (CVE-2000-0590,0591,0789)
460
461* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
462- new upstream release with security fix (CVE-2008-5077)
463
464* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
465- new upstream release
466
467* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
468- new upstream release
469- new versioning policy
470
471* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
472- new upstream release
473- drop patch10,20 which is merged in upstream
474
475* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
476- add security patch in advance for CVE-2007-5135
477  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
478  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
479
480* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
481- add security patch for CVE-2007-3108
482  (http://openssl.org/news/patch-CVE-2007-3108.txt)
483
484* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
485- new upstream release
486
487* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
488- update (fix) openssl.pc <BTS:437>
489
490* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
491- new upstream release (with security fix)
492
493* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
494- new upstream release
495- add patch2 to use RPM_OPT macro
496
497* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
498- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
499
500* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
501- added compat32-* packages for x86_64 architecture support
502- added openssl-0.9.7i.Configure-compat32.patch
503- changed '/lib' to '/%{_lib}'
504
505* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
506- new upstream release
507
508* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
509- rebuild on VineSeed
510
511* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
512- added a security patch from Gentoo.
513  - Patch1: openssl-0.9.7c-tempfile.patch
514
515* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
516- sslarch for ppc was missing... added.
517
518* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
519- use sslarch=linux-alpha-gcc instead of alpha-gcc
520
521* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
522- new upstream version
523- clean up of spec file
524        -- removed old patches
525
526* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
527- new upstream release
528- SECURITY fix.
529  - http://www.openssl.org/news/secadv_20040317.txt
530
531* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
532- new upstream release
533- [Security fix]
534  - Vulnerabilities in ASN.1 parsing
535    http://www.openssl.org/news/secadv_20030930.txt
536- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
537
538* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
539- add openssl.pc for pkgconfig
540
541* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
542- New upstream version
543- dropped patch10, 11
544        -- merged upstream version
545
546* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
547- rebuild for VineSeed
548
549* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
550- [Security Fix]
551  - Timing-based attacks on RSA keys
552    http://www.openssl.org/news/secadv_20030317.txt
553  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
554    http://www.openssl.org/news/secadv_20030317.txt
555
556* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
557- new upstream release 0.9.6i
558- [Security Fix]
559- build for Vine Linux 2.6 errata
560
561* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
562- new upstream release 0.9.6h
563
564* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
565- new upstream release 0.9.6g
566
567* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
568- SECURITY: CAN-2002-0659 fixed
569  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
570    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
571    - update asn patch to fix accidental reversal of a logic check
572    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
573    - update asn patch to reduce chance that compiler optimization will remove
574      one of the added tests
575    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
576    - rebuild
577    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
578    - add patch to fix ASN.1 vulnerabilities
579
580* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
581- rename spec file name
582- SECURITY: CA-2002-23 fixed
583  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
584    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
585    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
586
587* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
588- added ${PATH} in LD_LIBRARY_PATH
589- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
590 
591* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
592- remove --no-<cipher>
593
594* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
595- add Patch10 for mipsel shared ( Configure )
596
597* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
598- build for Vine Linux
599- use openssl-engine-0.9.6b.tar.gz
600
601* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
602- update to 0.9.6b
603
604* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
605- move .so symlinks back to %%{_libdir}
606
607* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
608- move shared libraries to /lib (#38410)
609
610* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
611- switch to engine code base
612
613* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
614- add a script for creating dummy certificates
615- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
616
617* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
618- add s390x support
619
620* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
621- change two memcpy() calls to memmove()
622- don't define L_ENDIAN on alpha
623
624* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
625- make subpackages depend on the main package
626
627* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
628- adjust the hobble script to not disturb symlinks in include/ (fix from
629  Joe Orton)
630
631* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
632- drop the m2crypo patch we weren't using
633
634* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
635- configure using "shared" as well
636
637* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
638- update to 0.9.6a
639- use the build-shared target to build shared libraries
640- bump the soversion to 2 because we're no longer compatible with
641  our 0.9.5a packages or our 0.9.6 packages
642- drop the patch for making rsatest a no-op when rsa null support is used
643- put all man pages into <section>ssl instead of <section>
644- break the m2crypto modules into a separate package
645
646* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
647- use BN_LLONG on s390
648
649* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
650- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
651
652* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
653- move c_rehash to the perl subpackage, because it's a perl script now
654
655* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
656- update to 0.9.6
657- enable MD2
658- use the libcrypto.so and libssl.so targets to build shared libs with
659- bump the soversion to 1 because we're no longer compatible with any of
660  the various 0.9.5a packages circulating around, which provide lib*.so.0
661
662* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
663- change hobble-openssl for disabling MD2 again
664
665* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
666- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
667  bytes or so, causing EVP_DigestInit() to zero out stack variables in
668  apps built against a version of the library without it
669
670* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
671- disable some inline assembly, which on x86 is Pentium-specific
672- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
673
674* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
675- fix s390 patch
676
677* Fri Dec 8 2000 Than Ngo <than@redhat.com>
678- added support s390
679
680* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
681- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
682- add the CA.pl man page to the perl subpackage
683
684* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
685- always build with -mcpu=ev5 on alpha
686
687* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
688- add a symlink from cert.pem to ca-bundle.crt
689
690* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
691- add a ca-bundle file for packages like Samba to reference for CA certificates
692
693* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
694- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
695
696* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
697- add unzip as a buildprereq (#17662)
698- update m2crypto to 0.05-snap4
699
700* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
701- fix some issues in building when it's not installed
702
703* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
704- make sure the headers we include are the ones we built with (aaaaarrgh!)
705
706* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
707- add Richard Henderson's patch for BN on ia64
708- clean up the changelog
709
710* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
711- fix the building of python modules without openssl-devel already installed
712
713* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
714- byte-compile python extensions without the build-root
715- adjust the makefile to not remove temporary files (like .key files when
716  building .csr files) by marking them as .PRECIOUS
717
718* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
719- break out python extensions into a subpackage
720
721* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
722- tweak the makefile some more
723
724* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
725- disable MD2 support
726
727* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
728- disable MDC2 support
729
730* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
731- tweak the disabling of RC5, IDEA support
732- tweak the makefile
733
734* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
735- strip binaries and libraries
736- rework certificate makefile to have the right parts for Apache
737
738* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
739- use %%{_perl} instead of /usr/bin/perl
740- disable alpha until it passes its own test suite
741
742* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
743- move the passwd.1 man page out of the passwd package's way
744
745* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
746- update to 0.9.5a, modified for U.S.
747- add perl as a build-time requirement
748- move certificate makefile to another package
749- disable RC5, IDEA, RSA support
750- remove optimizations for now
751
752* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
753- Bero told me to move the Makefile into this package
754
755* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
756- add lib*.so symlinks to link dynamically against shared libs
757
758* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
759- update to 0.9.5
760- run ldconfig directly in post/postun
761- add FAQ
762
763* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
764- Fix build on non-x86 platforms
765
766* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
767- move /usr/share/ssl/* from -devel to main package
768
769* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
770- inital packaging
771- changes from base:
772  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
773  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.