source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 10063

Revision 10063, 26.0 KB checked in by iwamoto, 8 years ago (diff)

openssl: update to 1.0.2g with security fixes

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 10
3%define version 1.0.2g
4%define release 1%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source6: make-dummy-cert
13Source7: renew-dummy-cert
14
15# Patch0: openssl-1.0.2-soversion.patch
16# Patch2: openssl-1.0.1-rpm_opt.patch
17Patch0: openssl-1.0.2g-rpmbuild.patch
18Patch4: openssl-1.0.2g-enginesdir.patch
19Patch5: openssl-1.0.2a-version-add-engines.patch
20Patch8: openssl-1.0.1c-perlfind.patch
21
22# security fix
23# nothing ;-)
24
25License: BSDish
26Group: System Environment/Libraries
27URL: http://www.openssl.org/
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: perl, sed
31BuildRequires: zlib-devel, krb5-devel
32
33Requires: mktemp
34Requires: ca-certificates
35
36Vendor: Project Vine
37Distribution: Vine Linux
38Packager: daisuke, iwamoto
39
40%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
41
42%description
43The OpenSSL certificate management tool and the shared libraries that
44provide various cryptographic algorithms and protocols.
45
46%package devel
47Summary: OpenSSL libraries and development headers.
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: krb5-devel
51
52%description devel
53The static libraries and include files needed to compile apps
54with support for various the cryptographic algorithms and protocols
55supported by OpenSSL.
56
57Patches for many networking apps can be found at:
58ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
59
60%package static
61Summary:  Libraries for static linking of applications which will use OpenSSL
62Group: Development/Libraries
63Requires: %{name}-devel = %{version}-%{release}
64
65%description static
66OpenSSL is a toolkit for supporting cryptography. The openssl-static
67package contains static libraries needed for static linking of
68applications which support various cryptographic algorithms and
69protocols.
70
71%package perl
72Summary: OpenSSL scripts which require Perl.
73Group: Applications/Internet
74Requires: perl
75Requires: %{name} = %{version}-%{release}
76
77%description perl
78Perl scripts provided with OpenSSL for converting certificates and keys
79from other formats to those used by OpenSSL.
80
81## to build compat32 for x86_64 architecture support
82%package -n compat32-%{name}
83Summary: Secure Sockets Layer Toolkit
84Group: System Environment/Libraries
85Requires: %{name} = %{version}-%{release}
86%description -n compat32-%{name}
87The OpenSSL certificate management tool and the shared libraries that
88provide various cryptographic algorithms and protocols.
89
90%package -n compat32-%{name}-devel
91Summary: OpenSSL libraries and development headers.
92Group: Development/Libraries
93Requires: compat32-%{name} = %{version}-%{release}
94Requires: compat32-krb5-devel
95%description -n compat32-%{name}-devel
96The static libraries and include files needed to compile apps
97with support for various the cryptographic algorithms and protocols
98supported by OpenSSL.
99
100%prep
101%setup -q -n openssl-%{version}
102
103%patch0 -p1 -b .soversion
104%patch4 -p1 -b .enginesdir
105%patch5 -p1 -b .version-add-engines
106%patch8 -p1 -b .perlfind
107
108# security fix
109# nothing ;-)
110
111chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
112chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
113# chmod 644 doc/openssl_button.html doc/openssl_button.gif
114chmod 644 doc/ssleay.txt
115
116%build
117PATH=${PATH}:${PWD}/bin
118TOPDIR=${PWD}
119LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
120
121# Modify the various perl scripts to reference perl in the right location.
122perl util/perlpath.pl `dirname %{__perl}`
123
124# Generate a table with the compile settings for my perusal.
125touch Makefile
126make TABLE PERL=%{__perl}
127
128# Figure out which flags we want to use.
129# default
130sslarch=%{_os}-%{_target_cpu}
131#
132%ifarch %ix86
133sslarch=linux-elf
134if ! echo %{_target} | grep -q i686 ; then
135   sslflags="no-asm 386"
136fi
137%endif
138%ifarch sparcv9
139sslarch=linux-sparcv9
140sslflags=no-asm
141%endif
142%ifarch sparc64
143sslarch=linux64-sparcv9
144sslflags=no-asm
145%endif
146%ifarch alpha alphaev56 alphaev6 alphaev67
147sslarch=linux-alpha-gcc
148%endif
149%ifarch s390 sh3eb sh4eb
150sslarch="linux-generic32 -DB_ENDIAN"
151%endif
152%ifarch s390x
153sslarch="linux64-s390x"
154%endif
155%ifarch %{arm} sh3 sh4
156sslarch=linux-generic32
157%endif
158# ia64/x86_64/ppc\ppc64 are OK by default.
159
160# Configure the build tree.  Override OpenSSL defaults with known-good defaults
161# usable on all platforms.  The Configure script already knows to use -fPIC and
162# RPM_OPT_FLAGS, so we can skip specifiying them here.
163./Configure  \
164         --prefix=%{_prefix} --openssldir=%{_sysconfdir}/pki/tls ${sslflags} \
165         zlib-dynamic enable-camellia enable-seed enable-tlsext \
166         enable-rfc3779 enable-cms enable-md2 \
167         --enginesdir=%{_libdir}/openssl/engines \
168         --with-krb5-flavor=MIT --with-krb5-dir=/usr \
169         shared ${sslarch}
170
171# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
172# marked as not requiring an executable stack.
173RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
174make depend
175make all build-shared
176
177# Generate hashes for the included certs.
178LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
179export LD_LIBRARY_PATH
180make rehash build-shared
181
182# Verify that what was compiled actually works.
183make -C test apps tests
184
185# Relink the main binary to get it dynamically linked.
186rm apps/openssl
187make all build-shared
188
189%install
190[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
191# Install OpenSSL.
192install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
193make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
194install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
195# added for lib64
196# mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
197mv $RPM_BUILD_ROOT%{_libdir}/engines $RPM_BUILD_ROOT%{_libdir}/openssl
198# mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
199mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
200mv $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man/* $RPM_BUILD_ROOT%{_mandir}
201rmdir $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/man
202rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
203for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
204        chmod 755 ${lib}
205        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
206        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
207done
208# install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
209
210# Install a makefile for generating keys and self-signed certs, and a script
211# for generating them on the fly.
212mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs
213install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/Makefile
214install -m755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/make-dummy-cert
215install -m755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
216
217# Make sure we actually include the headers we built against.
218for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
219        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
220                install -m644 include/openssl/`basename ${header}` ${header}
221        fi
222done
223
224# Rename man pages so that they don't conflict with system man pages.  We used
225# to change the file extensions, but that only prevents file conflicts.  The
226# man viewer still can't select either of the two unless we physically change
227# the directory.
228for section in 1 2 3 4 5 6 7 8 ; do
229        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
230                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
231                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
232        fi
233done
234
235# Pick a CA script.
236pushd  $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/misc
237mv CA.sh CA
238popd
239
240mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA
241mkdir -m700 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/private
242mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/certs
243mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/crl
244mkdir -m755 $RPM_BUILD_ROOT%{_sysconfdir}/pki/CA/newcerts
245
246# Ensure the openssl.cnf timestamp is identical across builds to avoid
247# mulitlib conflicts and unnecessary renames on upgrade
248touch -r %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pki/tls/openssl.cnf
249
250%clean
251[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
252
253%files
254%defattr(-,root,root)
255%doc FAQ LICENSE CHANGES NEWS INSTALL README
256%doc doc/README doc/c-indentation.el doc/openssl.txt
257%doc doc/openssl_button.html doc/openssl_button.gif
258%doc doc/ssleay.txt
259
260%{_sysconfdir}/pki/tls/certs/make-dummy-cert
261%{_sysconfdir}/pki/tls/certs/renew-dummy-cert
262%{_sysconfdir}/pki/tls/certs/Makefile
263%{_sysconfdir}/pki/tls/misc/CA
264%dir %{_sysconfdir}/pki/CA
265%dir %{_sysconfdir}/pki/CA/private
266%dir %{_sysconfdir}/pki/CA/certs
267%dir %{_sysconfdir}/pki/CA/crl
268%dir %{_sysconfdir}/pki/CA/newcerts
269%{_sysconfdir}/pki/tls/misc/c_*
270%dir %{_sysconfdir}/pki/tls
271%dir %{_sysconfdir}/pki/tls/certs
272%dir %{_sysconfdir}/pki/tls/misc
273%dir %{_sysconfdir}/pki/tls/private
274%config(noreplace) %{_sysconfdir}/pki/tls/openssl.cnf
275
276%attr(0755,root,root) %{_bindir}/openssl
277%attr(0755,root,root) /%{_lib}/*.so.*
278%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
279%attr(0755,root,root) %dir %{_mandir}/man1*
280%attr(0644,root,root) %{_mandir}/man1*/*
281%attr(0755,root,root) %dir %{_mandir}/man5*
282%attr(0644,root,root) %{_mandir}/man5*/*
283%attr(0755,root,root) %dir %{_mandir}/man7*
284%attr(0644,root,root) %{_mandir}/man7*/*
285
286%files devel
287%defattr(-,root,root)
288%{_prefix}/include/openssl
289%exclude %{_libdir}/lib*.a
290%attr(0755,root,root) %{_libdir}/*.so
291%attr(0755,root,root) %dir %{_mandir}/man3*
292%attr(0644,root,root) %{_mandir}/man3*/*
293%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
294
295%files static
296%defattr(-,root,root)
297%attr(0644,root,root) %{_libdir}/*.a
298
299%files perl
300%defattr(-,root,root)
301%attr(0755,root,root) %{_bindir}/c_rehash
302%attr(0755,root,root) %dir %{_mandir}/man1*
303%attr(0644,root,root) %{_mandir}/man1*/*.pl*
304%{_sysconfdir}/pki/tls/misc/*.pl
305#%{_sysconfdir}/pki/tls/misc/tsget
306%doc apps/tsget
307
308## to build compat32 for x86_64 architecture support
309%if %{build_compat32}
310%files -n compat32-%{name}
311%defattr(-,root,root)
312%attr(0755,root,root) /%{_lib}/*.so.*
313
314%files -n compat32-%{name}-devel
315%defattr(-,root,root)
316%exclude %{_libdir}/lib*.a
317%attr(0755,root,root) %{_libdir}/*.so
318%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
319%endif
320
321%post -p /sbin/ldconfig
322
323%postun -p /sbin/ldconfig
324
325%post -n compat32-%{name} -p /sbin/ldconfig
326
327%postun -n compat32-%{name} -p /sbin/ldconfig
328
329%changelog
330* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.2g-1
331- new upstream release 1.0.2 with security fixes
332- Patch2 is merged into Patch0
333
334* Mon Dec 28 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1q-1
335- new upstream release with security fixes
336
337* Fri Jul 10 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1p-1
338- new upstream release with security fixes
339
340* Wed Jul  1 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1o-1
341- new upstream release
342
343* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.1m-1
344- merged into Vine6
345  * Fri Mar 20 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1m-1
346  - new upstream release with security fixes 
347  - update Patch2,5
348
349* Mon Jan 12 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1k-1
350- new upstream release with security fixes 
351
352* Mon Oct 20 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1j-1
353- new upstream release with security fixes
354- add patch8 from fc21 (fix perl find.pl)
355
356* Fri Jun 6 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.1h-1
357- new upstream release with security fixes.
358
359* Tue Apr  8 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1g-1
360- new upstream release with security fixes
361
362* Thu Jan  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.1f-1
363- new upstream release with security fixes
364
365* Tue Sep 24 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-2
366- move root CA bundle to ca-certificates package
367
368* Tue Feb 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1e-1
369- update to 1.0.1e
370  - 1.0.1d has major regressions from 1.0.1c
371
372* Sat Feb  9 2013 IWAI, Masaharu <iwai@alib.jp> 1.0.1d-2
373- remove tsget script to delete dependency perl(WWW::Curl::Easy)
374 - openssl-perl package contains it in docdir
375
376* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.0.1d-1
377- new upstream release with security fix (CVE-2012-2686, CVE-2013-0166, 0169)
378- fixed %%files
379
380* Tue May 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1c-1
381- update to 1.0.1c
382- enable configure options:
383  enable-camellia enable-seed enable-tlsext enable-rfc3779
384  enable-cms enable-md2
385- remove no-asm option from ai64/x86_64/ppc/ppc64/i686
386- generate a table with the compile settings before configure
387
388* Fri Jan 20 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0g-1
389- new upstream release with security fix (CVE-2012-0050)
390
391* Fri Jan  6 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0f-1
392- new upstream release with security fix
393  (CVE-2011-4108,09, CVE-2011-4576,77, CVE-2011-4619, CVE-2012-0027)
394
395* Wed Sep  7 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0e-1
396- new upstream release with security fix (CVE-2011-3207, 3210)
397
398* Sun Mar 20 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-2
399- rebuild with krb5-libs 1.8
400
401* Fri Feb 11 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0d-1
402- new upstream release with security fix
403
404* Sat Jan 15 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-4
405- use upstream openssl.pc instead of vine original one (SOURCE6)
406
407* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-3
408- move tsget to docs to delete dependency perl(WWW::Curl::Easy)
409
410* Sat Jan  1 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-2
411- add R: krb5-devel into devel pkg
412- add R: compat32-krb5-devel into compat32-devel pkg
413
414* Fri Dec 31 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.0c-1
415- new upstream release 1.0.0x
416- separate static libs into static package
417- change configure options
418- change so version 10
419- add tsget into perl package
420- update all patches
421
422* Thu Dec 30 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-2
423- fix changelog typo...
424
425* Tue Dec  7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8q-1
426- new upstream release with security fix (CVE-2010-4180)
427
428* Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
429- new upstream release with security fix (CVE-2010-3864)
430- drop patches included in new release
431- update patch4
432
433* Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
434- add patch12 for fix CVE-2009-3555 (renegotiation)
435
436* Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
437- add patch11 for fix CVE-2009-4355 (memory leak)
438
439* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
440- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
441
442* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
443- removed unnecessary %%if %{build_compat32} statements
444- removed lib*.a from devel package
445
446* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
447- new upstream release with security fix (CVE-2000-0590,0591,0789)
448
449* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
450- new upstream release with security fix (CVE-2008-5077)
451
452* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
453- new upstream release
454
455* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
456- new upstream release
457- new versioning policy
458
459* Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
460- new upstream release
461- drop patch10,20 which is merged in upstream
462
463* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
464- add security patch in advance for CVE-2007-5135
465  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
466  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
467
468* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
469- add security patch for CVE-2007-3108
470  (http://openssl.org/news/patch-CVE-2007-3108.txt)
471
472* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
473- new upstream release
474
475* Sun Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
476- update (fix) openssl.pc <BTS:437>
477
478* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
479- new upstream release (with security fix)
480
481* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
482- new upstream release
483- add patch2 to use RPM_OPT macro
484
485* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
486- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
487
488* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
489- added compat32-* packages for x86_64 architecture support
490- added openssl-0.9.7i.Configure-compat32.patch
491- changed '/lib' to '/%{_lib}'
492
493* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
494- new upstream release
495
496* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
497- rebuild on VineSeed
498
499* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
500- added a security patch from Gentoo.
501  - Patch1: openssl-0.9.7c-tempfile.patch
502
503* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
504- sslarch for ppc was missing... added.
505
506* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
507- use sslarch=linux-alpha-gcc instead of alpha-gcc
508
509* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
510- new upstream version
511- clean up of spec file
512        -- removed old patches
513
514* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
515- new upstream release
516- SECURITY fix.
517  - http://www.openssl.org/news/secadv_20040317.txt
518
519* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
520- new upstream release
521- [Security fix]
522  - Vulnerabilities in ASN.1 parsing
523    http://www.openssl.org/news/secadv_20030930.txt
524- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
525
526* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
527- add openssl.pc for pkgconfig
528
529* Tue Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
530- New upstream version
531- dropped patch10, 11
532        -- merged upstream version
533
534* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
535- rebuild for VineSeed
536
537* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
538- [Security Fix]
539  - Timing-based attacks on RSA keys
540    http://www.openssl.org/news/secadv_20030317.txt
541  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
542    http://www.openssl.org/news/secadv_20030317.txt
543
544* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
545- new upstream release 0.9.6i
546- [Security Fix]
547- build for Vine Linux 2.6 errata
548
549* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
550- new upstream release 0.9.6h
551
552* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
553- new upstream release 0.9.6g
554
555* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
556- SECURITY: CAN-2002-0659 fixed
557  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
558    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
559    - update asn patch to fix accidental reversal of a logic check
560    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
561    - update asn patch to reduce chance that compiler optimization will remove
562      one of the added tests
563    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
564    - rebuild
565    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
566    - add patch to fix ASN.1 vulnerabilities
567
568* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
569- rename spec file name
570- SECURITY: CA-2002-23 fixed
571  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
572    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
573    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
574
575* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
576- added ${PATH} in LD_LIBRARY_PATH
577- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
578 
579* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
580- remove --no-<cipher>
581
582* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
583- add Patch10 for mipsel shared ( Configure )
584
585* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
586- build for Vine Linux
587- use openssl-engine-0.9.6b.tar.gz
588
589* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
590- update to 0.9.6b
591
592* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
593- move .so symlinks back to %%{_libdir}
594
595* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
596- move shared libraries to /lib (#38410)
597
598* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
599- switch to engine code base
600
601* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
602- add a script for creating dummy certificates
603- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
604
605* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
606- add s390x support
607
608* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
609- change two memcpy() calls to memmove()
610- don't define L_ENDIAN on alpha
611
612* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
613- make subpackages depend on the main package
614
615* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
616- adjust the hobble script to not disturb symlinks in include/ (fix from
617  Joe Orton)
618
619* Thu Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
620- drop the m2crypo patch we weren't using
621
622* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
623- configure using "shared" as well
624
625* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
626- update to 0.9.6a
627- use the build-shared target to build shared libraries
628- bump the soversion to 2 because we're no longer compatible with
629  our 0.9.5a packages or our 0.9.6 packages
630- drop the patch for making rsatest a no-op when rsa null support is used
631- put all man pages into <section>ssl instead of <section>
632- break the m2crypto modules into a separate package
633
634* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
635- use BN_LLONG on s390
636
637* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
638- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
639
640* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
641- move c_rehash to the perl subpackage, because it's a perl script now
642
643* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
644- update to 0.9.6
645- enable MD2
646- use the libcrypto.so and libssl.so targets to build shared libs with
647- bump the soversion to 1 because we're no longer compatible with any of
648  the various 0.9.5a packages circulating around, which provide lib*.so.0
649
650* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
651- change hobble-openssl for disabling MD2 again
652
653* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
654- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
655  bytes or so, causing EVP_DigestInit() to zero out stack variables in
656  apps built against a version of the library without it
657
658* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
659- disable some inline assembly, which on x86 is Pentium-specific
660- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
661
662* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
663- fix s390 patch
664
665* Fri Dec 8 2000 Than Ngo <than@redhat.com>
666- added support s390
667
668* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
669- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
670- add the CA.pl man page to the perl subpackage
671
672* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
673- always build with -mcpu=ev5 on alpha
674
675* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
676- add a symlink from cert.pem to ca-bundle.crt
677
678* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
679- add a ca-bundle file for packages like Samba to reference for CA certificates
680
681* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
682- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
683
684* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
685- add unzip as a buildprereq (#17662)
686- update m2crypto to 0.05-snap4
687
688* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
689- fix some issues in building when it's not installed
690
691* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
692- make sure the headers we include are the ones we built with (aaaaarrgh!)
693
694* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
695- add Richard Henderson's patch for BN on ia64
696- clean up the changelog
697
698* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
699- fix the building of python modules without openssl-devel already installed
700
701* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
702- byte-compile python extensions without the build-root
703- adjust the makefile to not remove temporary files (like .key files when
704  building .csr files) by marking them as .PRECIOUS
705
706* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
707- break out python extensions into a subpackage
708
709* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
710- tweak the makefile some more
711
712* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
713- disable MD2 support
714
715* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
716- disable MDC2 support
717
718* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
719- tweak the disabling of RC5, IDEA support
720- tweak the makefile
721
722* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
723- strip binaries and libraries
724- rework certificate makefile to have the right parts for Apache
725
726* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
727- use %%{_perl} instead of /usr/bin/perl
728- disable alpha until it passes its own test suite
729
730* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
731- move the passwd.1 man page out of the passwd package's way
732
733* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
734- update to 0.9.5a, modified for U.S.
735- add perl as a build-time requirement
736- move certificate makefile to another package
737- disable RC5, IDEA, RSA support
738- remove optimizations for now
739
740* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
741- Bero told me to move the Makefile into this package
742
743* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
744- add lib*.so symlinks to link dynamically against shared libs
745
746* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
747- update to 0.9.5
748- run ldconfig directly in post/postun
749- add FAQ
750
751* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
752- Fix build on non-x86 platforms
753
754* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
755- move /usr/share/ssl/* from -devel to main package
756
757* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
758- inital packaging
759- changes from base:
760  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
761  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.