source: projects/specs/trunk/o/openssl/openssl-vl.spec @ 521

Revision 521, 20.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2%define soversion 6
3%define version 0.9.8k
4%define release 3%{_dist_release}
5
6Summary: Secure Sockets Layer Toolkit
7Name: openssl
8Version: %{version}
9Release: %{release}
10Source: openssl-%{version}.tar.gz
11Source2: Makefile.certificate
12Source3: ca-bundle.crt
13Source5: make-dummy-cert
14Source6: openssl-%{version}.pc
15Patch0: openssl-0.9.8b-soversion.patch
16Patch2: openssl-0.9.8e-rpm_opt.patch
17Patch4: openssl-0.9.8a-enginesdir.patch
18
19# security fix
20Patch10: openssl-0.9.8k-dtls-dos.patch
21
22License: BSDish
23Group: System Environment/Libraries
24URL: http://www.openssl.org/
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26BuildPreReq: perl, sed
27Requires: mktemp
28Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
29Vendor: Project Vine
30Distribution: Vine Linux
31
32%define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
33
34%description
35The OpenSSL certificate management tool and the shared libraries that
36provide various cryptographic algorithms and protocols.
37
38%package devel
39Summary: OpenSSL libraries and development headers.
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44The static libraries and include files needed to compile apps
45with support for various the cryptographic algorithms and protocols
46supported by OpenSSL.
47
48Patches for many networking apps can be found at:
49ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
50
51%package perl
52Summary: OpenSSL scripts which require Perl.
53Group: Applications/Internet
54Requires: perl
55Requires: %{name} = %{version}-%{release}
56
57%description perl
58Perl scripts provided with OpenSSL for converting certificates and keys
59from other formats to those used by OpenSSL.
60
61## to build compat32 for x86_64 architecture support
62%package -n compat32-%{name}
63Summary: Secure Sockets Layer Toolkit
64Group: System Environment/Libraries
65Requires: %{name} = %{version}-%{release}
66%description -n compat32-%{name}
67The OpenSSL certificate management tool and the shared libraries that
68provide various cryptographic algorithms and protocols.
69
70%package -n compat32-%{name}-devel
71Summary: OpenSSL libraries and development headers.
72Group: Development/Libraries
73Requires: compat32-%{name} = %{version}-%{release}
74%description -n compat32-%{name}-devel
75The static libraries and include files needed to compile apps
76with support for various the cryptographic algorithms and protocols
77supported by OpenSSL.
78
79%prep
80%setup -q -n openssl-%{version}
81%patch0 -p1 -b .soversion
82%patch2 -p1 -b .rpm_opt
83%patch4 -p1 -b .enginesdir
84
85# security fix
86%patch10 -p1 -b .dtls-dos
87
88chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
89chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
90chmod 644 doc/openssl_button.html doc/openssl_button.gif
91chmod 644 doc/ssleay.txt
92
93# Link the configuration header to the one we're going to make.
94ln -sf ../../crypto/opensslconf.h include/openssl/
95
96%build
97PATH=${PATH}:${PWD}/bin
98TOPDIR=${PWD}
99LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
100
101# Figure out which flags we want to use.  Can't use assembler because it's
102# not lowest-common-denominator in most cases.
103perl util/perlpath.pl `dirname %{__perl}`
104%ifarch %ix86
105sslarch=linux-elf
106sslflags="no-asm 386"
107%endif
108%ifarch ppc
109sslarch=linux-ppc
110sslflags=no-asm
111%endif
112%ifarch sparc
113sslarch=linux-sparcv9
114sslflags=no-asm
115%endif
116%ifarch ia64
117sslarch=linux-ia64
118sslflags=no-asm
119%endif
120%ifarch alpha
121sslarch=linux-alpha-gcc
122sslflags=no-asm
123%endif
124%ifarch s390
125sslarch=linux-s390
126%endif
127%ifarch s390x
128sslarch=linux-s390x
129%endif
130%ifarch mipsel
131sslarch=linux-mips
132sslflags=no-asm
133%endif
134## to build for x86_64 architecture support
135%ifarch x86_64
136sslarch=linux-x86_64
137sslflags=no-asm
138%endif
139
140# Configure the build tree.  Override OpenSSL defaults with known-good defaults
141# usable on all platforms.  The Configure script already knows to use -fPIC and
142# RPM_OPT_FLAGS, so we can skip specifiying them here.
143./Configure  \
144         --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
145         --enginesdir=%{_libdir}/openssl/engines \
146         shared ${sslarch}
147
148# Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
149# marked as not requiring an executable stack.
150RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
151make depend
152make all build-shared
153
154# Generate hashes for the included certs.
155LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
156export LD_LIBRARY_PATH
157make rehash build-shared
158
159# Verify that what was compiled actually works.
160make -C test apps tests
161
162# Relink the main binary to get it dynamically linked.
163rm apps/openssl
164make all build-shared
165
166%install
167[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
168# Install OpenSSL.
169install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
170make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
171install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
172# added for lib64
173mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
174mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
175mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
176mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
177rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
178rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
179for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
180        chmod 755 ${lib}
181        ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
182        ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
183done
184install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
185
186# Install a makefile for generating keys and self-signed certs, and a script
187# for generating them on the fly.
188mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
189install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
190install -m644 $RPM_SOURCE_DIR/make-dummy-cert      $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
191
192# Make sure we actually include the headers we built against.
193for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
194        if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
195                install -m644 include/openssl/`basename ${header}` ${header}
196        fi
197done
198
199# Rename man pages so that they don't conflict with system man pages.  We used
200# to change the file extensions, but that only prevents file conflicts.  The
201# man viewer still can't select either of the two unless we physically change
202# the directory.
203for section in 1 2 3 4 5 6 7 8 ; do
204        if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
205                mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
206                   $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
207        fi
208done
209
210# Pick a CA script.
211pushd  $RPM_BUILD_ROOT%{_datadir}/ssl/misc
212mv CA.sh CA
213popd
214
215# Install root CA stuffs.
216cat %{SOURCE3} > ca-bundle.crt
217install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
218ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
219
220# Fix libdir.
221#sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
222sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
223        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
224        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
225cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
226        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
227rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
228
229%clean
230[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
231
232%files
233%defattr(-,root,root)
234%doc FAQ LICENSE CHANGES NEWS INSTALL README
235%doc doc/README doc/c-indentation.el doc/openssl.txt
236%doc doc/openssl_button.html doc/openssl_button.gif
237%doc doc/ssleay.txt
238%dir %{_datadir}/ssl
239%{_datadir}/ssl/certs
240%{_datadir}/ssl/cert.pem
241%{_datadir}/ssl/misc/CA
242%{_datadir}/ssl/misc/c_*
243%{_datadir}/ssl/private
244
245%config(noreplace) %{_datadir}/ssl/openssl.cnf
246
247%attr(0755,root,root) %{_bindir}/openssl
248%attr(0755,root,root) /%{_lib}/*.so.*
249%attr(0755,root,root) %{_libdir}/openssl/engines/*.so
250%attr(0755,root,root) %dir %{_mandir}/man1*
251%attr(0644,root,root) %{_mandir}/man1*/*
252%attr(0755,root,root) %dir %{_mandir}/man5*
253%attr(0644,root,root) %{_mandir}/man5*/*
254%attr(0755,root,root) %dir %{_mandir}/man7*
255%attr(0644,root,root) %{_mandir}/man7*/*
256
257%files devel
258%defattr(-,root,root)
259%{_prefix}/include/openssl
260%exclude %{_libdir}/lib*.a
261%attr(0755,root,root) %{_libdir}/*.so
262%attr(0755,root,root) %dir %{_mandir}/man3*
263%attr(0644,root,root) %{_mandir}/man3*/*
264%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
265
266%files perl
267%defattr(-,root,root)
268%attr(0755,root,root) %{_bindir}/c_rehash
269%attr(0755,root,root) %dir %{_mandir}/man1*
270%attr(0644,root,root) %{_mandir}/man1*/*.pl*
271%{_datadir}/ssl/misc/*.pl
272
273## to build compat32 for x86_64 architecture support
274%if %{build_compat32}
275%files -n compat32-%{name}
276%defattr(-,root,root)
277%attr(0755,root,root) /%{_lib}/*.so.*
278
279%files -n compat32-%{name}-devel
280%defattr(-,root,root)
281%exclude %{_libdir}/lib*.a
282%attr(0755,root,root) %{_libdir}/*.so
283%attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
284%endif
285
286%post -p /sbin/ldconfig
287
288%postun -p /sbin/ldconfig
289
290%post -n compat32-%{name} -p /sbin/ldconfig
291
292%postun -n compat32-%{name} -p /sbin/ldconfig
293
294%changelog
295* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
296- add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
297
298* Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
299- removed unnecessary %%if %{build_compat32} statements
300- removed lib*.a from devel package
301
302* Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
303- new upstream release with security fix (CVE-2000-0590,0591,0789)
304
305* Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
306- new upstream release with security fix (CVE-2008-5077)
307
308* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
309- new upstream release
310
311* Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
312- new upstream release
313- new versioning policy
314
315* Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
316- new upstream release
317- drop patch10,20 which is merged in upstream
318
319* Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
320- add security patch in advance for CVE-2007-5135
321  http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
322  http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
323
324* Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
325- add security patch for CVE-2007-3108
326  (http://openssl.org/news/patch-CVE-2007-3108.txt)
327
328* Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
329- new upstream release
330
331* Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
332- update (fix) openssl.pc <BTS:437>
333
334* Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
335- new upstream release (with security fix)
336
337* Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
338- new upstream release
339- add patch2 to use RPM_OPT macro
340
341* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
342- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
343
344* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
345- added compat32-* packages for x86_64 architecture support
346- added openssl-0.9.7i.Configure-compat32.patch
347- changed '/lib' to '/%{_lib}'
348
349* Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
350- new upstream release
351
352* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
353- rebuild on VineSeed
354
355* Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
356- added a security patch from Gentoo.
357  - Patch1: openssl-0.9.7c-tempfile.patch
358
359* Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
360- sslarch for ppc was missing... added.
361
362* Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
363- use sslarch=linux-alpha-gcc instead of alpha-gcc
364
365* Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
366- new upstream version
367- clean up of spec file
368        -- removed old patches
369
370* Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
371- new upstream release
372- SECURITY fix.
373  - http://www.openssl.org/news/secadv_20040317.txt
374
375* Wed Oct  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
376- new upstream release
377- [Security fix]
378  - Vulnerabilities in ASN.1 parsing
379    http://www.openssl.org/news/secadv_20030930.txt
380- see %{_docdir}/%{name}-%{version}/CHANGES for other changes
381
382* Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
383- add openssl.pc for pkgconfig
384
385* Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
386- New upstream version
387- dropped patch10, 11
388        -- merged upstream version
389
390* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
391- rebuild for VineSeed
392
393* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
394- [Security Fix]
395  - Timing-based attacks on RSA keys
396    http://www.openssl.org/news/secadv_20030317.txt
397  - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
398    http://www.openssl.org/news/secadv_20030317.txt
399
400* Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
401- new upstream release 0.9.6i
402- [Security Fix]
403- build for Vine Linux 2.6 errata
404
405* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
406- new upstream release 0.9.6h
407
408* Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
409- new upstream release 0.9.6g
410
411* Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
412- SECURITY: CAN-2002-0659 fixed
413  - added Patch101 from RedHat 7.2 updates 0.9.6b-28
414    * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
415    - update asn patch to fix accidental reversal of a logic check
416    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
417    - update asn patch to reduce chance that compiler optimization will remove
418      one of the added tests
419    * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
420    - rebuild
421    * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
422    - add patch to fix ASN.1 vulnerabilities
423
424* Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
425- rename spec file name
426- SECURITY: CA-2002-23 fixed
427  - added Patch100 from RedHat 7.2 updates 0.9.6b-24
428    * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
429    - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
430
431* Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
432- added ${PATH} in LD_LIBRARY_PATH
433- added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
434 
435* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
436- remove --no-<cipher>
437
438* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
439- add Patch10 for mipsel shared ( Configure )
440
441* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
442- build for Vine Linux
443- use openssl-engine-0.9.6b.tar.gz
444
445* Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
446- update to 0.9.6b
447
448* Thu Jul  5 2001 Nalin Dahyabhai <nalin@redhat.com>
449- move .so symlinks back to %%{_libdir}
450
451* Tue Jul  3 2001 Nalin Dahyabhai <nalin@redhat.com>
452- move shared libraries to /lib (#38410)
453
454* Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
455- switch to engine code base
456
457* Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
458- add a script for creating dummy certificates
459- move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
460
461* Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
462- add s390x support
463
464* Fri Jun  1 2001 Nalin Dahyabhai <nalin@redhat.com>
465- change two memcpy() calls to memmove()
466- don't define L_ENDIAN on alpha
467
468* Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
469- make subpackages depend on the main package
470
471* Tue May  1 2001 Nalin Dahyabhai <nalin@redhat.com>
472- adjust the hobble script to not disturb symlinks in include/ (fix from
473  Joe Orton)
474
475* Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
476- drop the m2crypo patch we weren't using
477
478* Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
479- configure using "shared" as well
480
481* Sun Apr  8 2001 Nalin Dahyabhai <nalin@redhat.com>
482- update to 0.9.6a
483- use the build-shared target to build shared libraries
484- bump the soversion to 2 because we're no longer compatible with
485  our 0.9.5a packages or our 0.9.6 packages
486- drop the patch for making rsatest a no-op when rsa null support is used
487- put all man pages into <section>ssl instead of <section>
488- break the m2crypto modules into a separate package
489
490* Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
491- use BN_LLONG on s390
492
493* Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
494- fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
495
496* Sat Mar  3 2001 Nalin Dahyabhai <nalin@redhat.com>
497- move c_rehash to the perl subpackage, because it's a perl script now
498
499* Fri Mar  2 2001 Nalin Dahyabhai <nalin@redhat.com>
500- update to 0.9.6
501- enable MD2
502- use the libcrypto.so and libssl.so targets to build shared libs with
503- bump the soversion to 1 because we're no longer compatible with any of
504  the various 0.9.5a packages circulating around, which provide lib*.so.0
505
506* Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
507- change hobble-openssl for disabling MD2 again
508
509* Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
510- re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
511  bytes or so, causing EVP_DigestInit() to zero out stack variables in
512  apps built against a version of the library without it
513
514* Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
515- disable some inline assembly, which on x86 is Pentium-specific
516- re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
517
518* Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
519- fix s390 patch
520
521* Fri Dec 8 2000 Than Ngo <than@redhat.com>
522- added support s390
523
524* Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
525- remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
526- add the CA.pl man page to the perl subpackage
527
528* Thu Nov  2 2000 Nalin Dahyabhai <nalin@redhat.com>
529- always build with -mcpu=ev5 on alpha
530
531* Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
532- add a symlink from cert.pem to ca-bundle.crt
533
534* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
535- add a ca-bundle file for packages like Samba to reference for CA certificates
536
537* Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
538- remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
539
540* Mon Oct  2 2000 Nalin Dahyabhai <nalin@redhat.com>
541- add unzip as a buildprereq (#17662)
542- update m2crypto to 0.05-snap4
543
544* Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
545- fix some issues in building when it's not installed
546
547* Wed Sep  6 2000 Nalin Dahyabhai <nalin@redhat.com>
548- make sure the headers we include are the ones we built with (aaaaarrgh!)
549
550* Fri Sep  1 2000 Nalin Dahyabhai <nalin@redhat.com>
551- add Richard Henderson's patch for BN on ia64
552- clean up the changelog
553
554* Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
555- fix the building of python modules without openssl-devel already installed
556
557* Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
558- byte-compile python extensions without the build-root
559- adjust the makefile to not remove temporary files (like .key files when
560  building .csr files) by marking them as .PRECIOUS
561
562* Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
563- break out python extensions into a subpackage
564
565* Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
566- tweak the makefile some more
567
568* Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
569- disable MD2 support
570
571* Thu Jul  6 2000 Nalin Dahyabhai <nalin@redhat.com>
572- disable MDC2 support
573
574* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
575- tweak the disabling of RC5, IDEA support
576- tweak the makefile
577
578* Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
579- strip binaries and libraries
580- rework certificate makefile to have the right parts for Apache
581
582* Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
583- use %%{_perl} instead of /usr/bin/perl
584- disable alpha until it passes its own test suite
585
586* Fri Jun  9 2000 Nalin Dahyabhai <nalin@redhat.com>
587- move the passwd.1 man page out of the passwd package's way
588
589* Fri Jun  2 2000 Nalin Dahyabhai <nalin@redhat.com>
590- update to 0.9.5a, modified for U.S.
591- add perl as a build-time requirement
592- move certificate makefile to another package
593- disable RC5, IDEA, RSA support
594- remove optimizations for now
595
596* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
597- Bero told me to move the Makefile into this package
598
599* Wed Mar  1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
600- add lib*.so symlinks to link dynamically against shared libs
601
602* Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
603- update to 0.9.5
604- run ldconfig directly in post/postun
605- add FAQ
606
607* Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
608- Fix build on non-x86 platforms
609
610* Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
611- move /usr/share/ssl/* from -devel to main package
612
613* Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
614- inital packaging
615- changes from base:
616  - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
617  - handle RPM_OPT_FLAGS
Note: See TracBrowser for help on using the repository browser.