source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 7986

Revision 7986, 26.0 KB checked in by daisuke, 11 years ago (diff)

openssh: update to 6.4p1

Line 
1%define ver 6.4p1
2%define rel 1%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66
67Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
68
69Patch0: openssh-6.4p1-vine.patch
70Patch4: openssh-6.2p1-vendor.patch
71Patch12: openssh-selinux.patch
72Patch20: openssh-3.9p1-gssapimitm.patch
73Patch21: openssh-3.9p1-safe-stop.patch
74Patch24: openssh-5.7p1-fromto-remote.patch
75Patch26: openssh-5.2p1-pam-no-stack.patch
76# Patch27: openssh-5.1p1-log-in-chroot.patch
77Patch30: openssh-5.6p1-exit-deadlock.patch
78# Patch31: openssh-3.9p1-skip-used.patch
79Patch35: openssh-5.1p1-askpass-progress.patch
80
81# Vine Source
82Source100: sshd.init
83Source110: sshd.sysconfig
84
85# Vine Patch
86Patch100: openssh-norootlogin.patch
87
88License: BSD
89Group: Applications/Internet
90BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
91
92Obsoletes: ssh
93
94BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
95BuildRequires: util-linux
96BuildRequires: db4-devel
97BuildRequires: pam-devel
98BuildRequires: zlib-devel
99%if ! %{no_gnome_askpass}
100BuildRequires: libX11-devel
101BuildRequires: gtk2-devel
102%endif
103BuildRequires: xorg-x11-xauth
104BuildRequires: groff
105BuildRequires: libedit-devel
106
107Vendor: Project Vine
108Distribution: Vine Linux
109Packager: daisuke
110
111%package clients
112Summary: OpenSSH clients.
113Summary(ja): OpenSSH Secure Shell プロトコルクライアント
114Requires: openssh = %{version}-%{release}
115Group: Applications/Internet
116Obsoletes: ssh-clients
117Obsoletes: openssh-contrib
118
119%package server
120Summary: The OpenSSH server daemon.
121Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
122Group: System Environment/Daemons
123Obsoletes: ssh-server
124Requires(post): openssh = %{version}-%{release}
125Requires(post): chkconfig
126Requires(pre): shadow-utils
127Requires(post): initscripts >= 5.20
128Requires: pam
129
130%package askpass-gnome
131Summary: A passphrase dialog for OpenSSH, X, and GNOME.
132Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
133Group: Applications/Internet
134Requires: openssh = %{version}-%{release}
135Obsoletes: ssh-extras
136Obsoletes: openssh-askpass < 5.5p1-3vl6
137Provides: openssh-askpass = %{version}-%{release}
138
139%description
140SSH (Secure SHell) is a program for logging into and executing
141commands on a remote machine. SSH is intended to replace rlogin and
142rsh, and to provide secure encrypted communications between two
143untrusted hosts over an insecure network. X11 connections and
144arbitrary TCP/IP ports can also be forwarded over the secure channel.
145
146OpenSSH is OpenBSD's version of the last free version of SSH, bringing
147it up to date in terms of security and features, as well as removing
148all patented algorithms to separate libraries.
149
150This package includes the core files necessary for both the OpenSSH
151client and server. To make this package useful, you should also
152install openssh-clients, openssh-server, or both.
153
154#'
155%description -l ja
156OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
157Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
158するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
159ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
160可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
161な通信路の中を通すことができます。
162
163OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
164最新のセキュリティと機能を提供しています。またすべての特許がからむ
165アルゴリズムは分割したライブラリにわかれています。
166
167このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
168コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
169openssh-clients および/または openssh-server が必要です。
170
171%description clients
172OpenSSH is a free version of SSH (Secure SHell), a program for logging
173into and executing commands on a remote machine. This package includes
174the clients necessary to make encrypted connections to SSH servers.
175You'll also need to install the openssh package on OpenSSH clients.
176
177#'
178%description -l ja clients
179OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
180Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
181するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
182ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
183可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
184な通信路の中を通すことができます。
185
186OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
187最新のセキュリティと機能を提供しています。またすべての特許がからむ
188アルゴリズムは分割したライブラリにわかれています。
189
190このパッケージは OpenSSH をクライアントとして使用する場合に
191必要なものを含んでいます。
192
193
194%description server
195OpenSSH is a free version of SSH (Secure SHell), a program for logging
196into and executing commands on a remote machine. This package contains
197the secure shell daemon (sshd). The sshd daemon allows SSH clients to
198securely connect to your SSH server. You also need to have the openssh
199package installed.
200
201%description -l ja server
202OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
203Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
204するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
205ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
206可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
207な通信路の中を通すことができます。
208
209OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
210最新のセキュリティと機能を提供しています。またすべての特許がからむ
211アルゴリズムは分割したライブラリにわかれています。
212
213このパッケージは OpenSSH をサーバとして使用する場合に必要な
214デーモンなどを含んでいます。
215
216%description askpass-gnome
217OpenSSH is a free version of SSH (Secure SHell), a program for logging
218into and executing commands on a remote machine. This package contains
219an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
220environment.
221
222%description -l ja askpass-gnome
223OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
224Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
225するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
226ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
227可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
228な通信路の中を通すことができます。
229
230OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
231最新のセキュリティと機能を提供しています。またすべての特許がからむ
232アルゴリズムは分割したライブラリにわかれています。
233
234このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
235
236%prep
237
238%setup -q
239%patch0 -p1 -b .vine
240%patch4 -p1 -b .vendor
241
242%if %{WITH_SELINUX}
243#SELinux
244%patch12 -p1 -b .selinux
245%endif
246
247%patch21 -p1 -b .safe-stop
248%patch24 -p1 -b .fromto-remote
249%patch26 -p1 -b .stack
250# %patch27 -p1 -b .log-chroot
251%patch30 -p1 -b .exit-deadlock
252%patch35 -p1 -b .progress
253
254%patch100 -p1 -b .norootlogin
255
256autoreconf
257
258
259%build
260CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
261%if %{rescue}
262CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
263%endif
264%if %{pie}
265%ifarch s390 s390x sparc sparc64
266CFLAGS="$CFLAGS -fPIE"
267%else
268CFLAGS="$CFLAGS -fpie"
269%endif
270export CFLAGS
271LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
272%endif
273
274%configure \
275        --sysconfdir=%{_sysconfdir}/ssh \
276        --libexecdir=%{_libexecdir}/openssh \
277        --datadir=%{_datadir}/openssh \
278        --with-tcp-wrappers \
279        --with-default-path=/usr/local/bin:/bin:/usr/bin \
280        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
281        --with-privsep-path=%{_var}/empty/sshd \
282        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
283        --with-libedit \
284        --with-xauth=/usr/bin/xauth \
285%if %{scard}
286        --with-smartcard \
287%endif
288%if %{noip6}
289        --with-ipv4-default \
290%endif
291%if %{rescue}
292        --without-pam --with-md5-passwords
293%else
294        --with-pam
295%endif
296
297%if %{static_libcrypto}
298perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
299%endif
300
301make
302
303%if %{gtk2}
304        gtk2=yes
305%else
306        gtk2=no
307%endif
308
309%if ! %{no_gnome_askpass}
310pushd contrib
311if [ $gtk2 = yes ]; then
312        make gnome-ssh-askpass2
313        mv gnome-ssh-askpass2 gnome-ssh-askpass
314else
315        make gnome-ssh-askpass1
316        mv gnome-ssh-askpass1 gnome-ssh-askpass
317fi
318popd
319%endif
320
321%install
322rm -rf $RPM_BUILD_ROOT
323mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
324mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
325mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
326mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
327
328make install DESTDIR=$RPM_BUILD_ROOT
329
330touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
331install -d $RPM_BUILD_ROOT/etc/pam.d/
332install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
333install -d $RPM_BUILD_ROOT/etc/sysconfig/
334install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
335install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
336install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
337install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
338
339%if ! %{scard}
340        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
341%endif
342
343%if ! %{no_gnome_askpass}
344install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
345install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
346install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
347%endif
348
349%if %{no_gnome_askpass}
350rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
351%endif
352
353# for contrib package
354install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
355install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
356mv contrib/README contrib/README.contrib
357
358perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
359
360%clean
361rm -rf $RPM_BUILD_ROOT
362
363%triggerun server -- ssh-server
364if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
365        touch /var/run/sshd.restart
366fi
367
368%triggerun server -- openssh-server < 2.5.0p1
369# Count the number of HostKey and HostDsaKey statements we have.
370gawk    'BEGIN {IGNORECASE=1}
371         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
372         END {exit sawhostkey}' /etc/ssh/sshd_config
373# And if we only found one, we know the client was relying on the old default
374# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
375# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
376# one nullifies the default, which would have loaded both.
377if [ $? -eq 1 ] ; then
378        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
379        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
380fi
381
382%triggerpostun server -- ssh-server
383if [ "$1" != 0 ] ; then
384        /sbin/chkconfig --add sshd
385        if test -f /var/run/sshd.restart ; then
386                rm -f /var/run/sshd.restart
387                # /sbin/service sshd start > /dev/null 2>&1 || :
388                /sbin/service sshd start
389        fi
390fi
391
392%pre server
393%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
394%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
395        -g sshd -M -r sshd 2>/dev/null || :
396
397%post server
398/sbin/chkconfig --add sshd
399
400%postun server
401# /sbin/service sshd condrestart > /dev/null 2>&1 || :
402/sbin/service sshd condrestart
403exit 0
404
405%preun server
406if [ "$1" = 0 ]
407then
408        /sbin/service sshd stop > /dev/null 2>&1 || :
409        /sbin/chkconfig --del sshd
410fi
411
412%files
413%defattr(-,root,root)
414%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
415%attr(0755,root,root) %{_bindir}/scp
416%attr(0644,root,root) %{_mandir}/man1/scp.1*
417%attr(0755,root,root) %dir %{_sysconfdir}/ssh
418%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
419%attr(644,root,root) %{_mandir}/man5/moduli.5*
420%if ! %{rescue}
421%attr(0755,root,root) %{_bindir}/ssh-keygen
422%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
423%attr(0755,root,root) %dir %{_libexecdir}/openssh
424%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
425%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
426%endif
427%if %{scard}
428%attr(0755,root,root) %dir %{_datadir}/openssh
429%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
430%endif
431
432%files clients
433%defattr(-,root,root)
434%attr(0755,root,root) %{_bindir}/ssh
435%attr(0644,root,root) %{_mandir}/man1/ssh.1*
436%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
437%attr(0644,root,root) %{_mandir}/man1/slogin.1*
438%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
439%attr(-,root,root) %{_bindir}/slogin
440%if ! %{rescue}
441%attr(0755,root,root) %{_bindir}/ssh-agent
442%attr(0755,root,root) %{_bindir}/ssh-add
443%attr(0755,root,root) %{_bindir}/ssh-keyscan
444%attr(0755,root,root) %{_bindir}/sftp
445%attr(0755,root,root) %{_bindir}/ssh-copy-id
446%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
447%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
448%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
449%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
450%attr(0644,root,root) %{_mandir}/man1/sftp.1*
451%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
452%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
453%endif
454
455%if ! %{rescue}
456%files server
457%defattr(-,root,root)
458%dir %attr(0711,root,root) %{_var}/empty/sshd
459%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
460%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
461%attr(0755,root,root) %{_sbindir}/sshd
462%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
463%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
464%attr(0644,root,root) %{_mandir}/man8/sshd.8*
465%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
466%attr(0755,root,root) %dir %{_sysconfdir}/ssh
467%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
468%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
469%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
470%attr(0755,root,root) %config /etc/sysconfig/sshd
471%endif
472
473%if ! %{no_gnome_askpass}
474%files askpass-gnome
475%defattr(-,root,root)
476%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
477%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
478%endif
479
480
481%changelog
482* Tue Nov 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.4p1-1
483- update to 6.4p1
484
485* Mon May 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p2-1
486- update to 6.2p2
487
488* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p1-1
489- update to 6.2p1
490
491* Fri Nov  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.1p1-1
492- new upstream release
493- add -with-xauth option in configure
494- patch4, 30, 35 are updated from fc18
495
496* Mon May 07 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0p1-1
497- new upstream release
498
499* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9p1-1
500- new upstream release
501
502* Sun May  8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
503- new upstream release
504
505* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
506- add our own sshd.init based on fedora's sshd.init
507  - generate ECDSA host key.
508
509* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
510- new upstream release
511
512* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
513- new upstream release
514
515* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
516- new upstream release
517- obsolete contrib subpackage, move ssh-copy-id to client subpackage
518
519* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
520- rebuilt with openssl 1.0.0c
521
522* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
523- drop x11-askpass, add Obsoletes: openssh-askpass
524- add BR: groff
525- enable --with-libedit option, add BR: libedit-devel
526- remove unrecognized option '--with-rsh'
527
528* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
529- add BR: xorg-x11-xauth for X11 forwarding support
530
531* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
532- new upstream release
533- update patch0,2
534- drop patch3,22
535
536* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
537- new upstream release
538
539* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
540- new upstream release
541
542* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
543- rebuild with xorg-x11-7.3
544
545* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
546- new upstream release with security fix (CVE-2008-1483)
547- drop patch31 which is included in new release (This was for CVE-2008-1483)
548
549* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
550- new upstream release with security fix ("ForceCommand" Directive)
551- turn on daemon restart message
552- new versioning policy
553
554* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
555- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
556
557* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
558- new upstream release
559
560* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
561- build with -fpie/-pie by default.
562- enable ipv6 by default.
563
564* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
565- new upstream release
566
567* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
568- new upstream release
569
570* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
571- new upstream release
572
573* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
574- new upstream release
575
576* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
577- new upstream release
578- remove build6x stuff
579- remove libgnome-devel from BuildRequires
580- cleanup BuildRequires
581- drop Patch200, it is merged in upstream.
582- import patches(25-35) from FC-devel
583
584* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
585- SECURITY FIX: CVE-2006-0225
586  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
587- update BuildPreReq: s/XFree86-devel/XOrg-devel/
588- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
589  - When GNOME2 is used, using libgnome-devel
590  - add BuildPreReq: gtk2-devel for GNOME2
591
592* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
593- rebuild with gtk+-2.8 final
594
595* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
596- new upstream release
597- build with gtk+-2.7
598
599* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
600- new upstream release
601
602* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
603- cleanup obsolete patches and added patches from fedora
604
605* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
606- new upstream release
607
608* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
609- new upstream release
610
611* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
612- new upstream release
613
614* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
615- rebuild with openssl-0.9.7d
616
617* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
618- new upstream release
619
620* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
621- create contrib package
622
623* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
624- new upstream release
625- fix security issue: http://www.openssh.com/txt/sshpam.adv
626
627* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
628- new upstream release
629- fix security issue: http://www.openssh.com/txt/buffer.adv
630
631* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
632- new upstream release
633
634* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
635- rebuild with gtk2
636
637* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
638- new upstream release
639
640* Sun Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
641- rebuild with new tool chain
642
643* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
644- new upstream release
645- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
646
647* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
648- change some defines in spec files
649
650* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
651- add patch110 ( 3.4p1 does not include mmap-fallback patch )
652
653* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
654- new upstream release
655  - security fix
656- drop patch10
657
658* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
659- add patch from Solar Designer to make privsep work with a 2.2 kernel.
660
661* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
662- new upstream release
663- add {sshd,ssh}_config.5 manpages
664- add ssh-keysign
665
666* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
667- new upstream release
668
669* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
670- new upstream release
671- drop patch1
672
673* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
674- new upstream release
675- merged with rawhide release.
676- drop Patch101 (merged in upstream)
677
678* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
679- seurity patch for off-by-one bug
680
681* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
682- merged with Rawhide 3.0.2p1-2
683
684* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
685- updated to 3.0.2p1
686
687* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
688- updated to 3.0.1p1
689
690* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
691- updated to 3.0p1
692
693* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
694- add japanese summery and descriptions.
695- update x11-askpass 1.2.5
696
697* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
698- update to openssh-2.9.9p2
699
700* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
701- rebuilt with openssl-0.9.6b
702
703* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
704- do not Permit RootLogin
705
706* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
707- update to openssh-2.5.2p2
708
709* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
710- update to openssh-2.5.2p1
711
712* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
713- update to openssh-2.5.1p2
714
715* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
716- update to openssh-2.5.1p1
717
718* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
719- update to openssh-2.5.1p1
720
721* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
722- remove suid bit from ssh
723
724* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
725- moved man dir to /usr/share/man
726
727* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
728- fixed askpass's link in ssh-add
729- partially used rpmmacros
730
731* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
732- update to 2.3.0p1
733- update x11-askpass 1.0.3
734
735* Wed Oct 18 2000 Damien Miller <djm@mindrot.org>
736- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
737  Redhat 7.0 spec file
738
739* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
740- rebuild for Vine Linux
741
742* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
743- Use RPM configure macro
744* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
745- Some surgery to sshd.init (generate keys at runtime)
746- Cleanup of groups and removal of keygen calls
747* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
748- Make building of X11-askpass and gnome-askpass optional
749* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
750- Glob manpages to catch compressed files
751* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
752- Updated for new location
753- Updated for new gnome-ssh-askpass build
754* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
755- Added Jim Knoble's <jmknoble@pobox.com> askpass
756* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
757- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
758* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
759- Added 'Obsoletes' directives
760* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
761- Use make install
762- Subpackages
763* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
764- Added links for slogin
765- Fixed perms on manpages
766* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
767- Renamed init script
768* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
769- Back to old binary names
770* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
771- Use autoconf
772- New binary names
773* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
774- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
775
776
Note: See TracBrowser for help on using the repository browser.