source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 521

Revision 521, 26.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ver 5.2p1
2%define rel 1%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of x11-askpass? (1=yes 0=no)
15%define no_x11_askpass 0
16
17# Do we want to disable building of gnome-askpass? (1=yes 0=no)
18%define no_gnome_askpass 0
19
20# Use GTK2 for gnome-ssh-askpass
21%define gtk2 1
22
23# Build position-independent executables (requires toolchain support)?
24%define pie 1
25
26# Do we want to link against a static libcrypto? (1=yes 0=no)
27%define static_libcrypto 0
28
29# Do we want smartcard support (1=yes 0=no)
30%define scard 0
31
32# Disable IPv6 (avoids DNS hangs on some glibc versions)
33%define noip6 0
34
35# Do we want kerberos5 support (1=yes 0=no)
36%define kerberos5 0
37
38# Reserve options to override askpass settings with:
39# rpm -ba|--rebuild --define 'skip_xxx 1'
40%{?skip_x11_askpass:%define no_x11_askpass 1}
41%{?skip_gnome_askpass:%define no_gnome_askpass 1}
42
43# Options for static OpenSSL link:
44# rpm -ba|--rebuild --define "static_openssl 1"
45%{?static_openssl:%define static_libcrypto 1}
46
47# Options for Smartcard support: (needs libsectok and openssl-engine)
48# rpm -ba|--rebuild --define "smartcard 1"
49%{?smartcard:%define scard 1}
50
51# Option to disable ipv6
52# rpm -ba|--rebuild --define "noipv6 1"
53%{?noipv6:%define noip6 1}
54
55# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
56%define rescue 0
57%{?build_rescue:%define rescue 1}
58
59# Turn off some stuff for resuce builds
60%if %{rescue}
61%define kerberos5 0
62%endif
63
64Summary: The OpenSSH implementation of SSH.
65Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
66Name: openssh
67Version: %{ver}
68Release: %{rel}
69URL: http://www.openssh.com/portable.html
70Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
71Source1: http://www.pobox.com/~jmknoble/software/x11-ssh-askpass/x11-ssh-askpass-%{aversion}.tar.gz
72Patch0: openssh-5.2p1-vine.patch
73Patch2: openssh-3.8.1p1-skip-initial.patch
74Patch3: openssh-3.8.1p1-krb5-config.patch
75Patch4: openssh-5.2p1-vendor.patch
76Patch5: openssh-3.9p1-noinitlog.patch
77Patch12: openssh-selinux.patch
78Patch20: openssh-3.9p1-gssapimitm.patch
79Patch21: openssh-3.9p1-safe-stop.patch
80Patch22: openssh-3.9p1-askpass-keep-above.patch
81Patch24: openssh-4.3p1-fromto-remote.patch
82Patch26: openssh-5.2p1-pam-no-stack.patch
83Patch27: openssh-5.1p1-log-in-chroot.patch
84Patch30: openssh-4.0p1-exit-deadlock.patch
85# Patch31: openssh-3.9p1-skip-used.patch
86Patch35: openssh-4.2p1-askpass-progress.patch
87# Vine Patch
88Patch100: openssh-norootlogin.patch
89#Patch110: openssh-3.4p1-mmap-fallback.diff
90Patch120: openssh-4.7p1-sshd.init.patch
91
92License: BSD
93Group: Applications/Internet
94BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
95Obsoletes: ssh
96
97PreReq: initscripts >= 5.20
98BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
99BuildRequires: util-linux
100BuildRequires: db4-devel
101BuildRequires: pam-devel
102BuildRequires: zlib-devel
103%if ! %{no_x11_askpass}
104BuildRequires: libX11-devel, libSM-devel, libXt-devel, libICE-devel
105%endif
106%if ! %{no_gnome_askpass}
107BuildRequires: libX11-devel
108BuildRequires: gtk2-devel
109%endif
110
111Vendor: Project Vine
112Distribution: Vine Linux
113
114%package clients
115Summary: OpenSSH clients.
116Summary(ja): OpenSSH Secure Shell プロトコルクライアント
117Requires: openssh = %{version}-%{release}
118Group: Applications/Internet
119Obsoletes: ssh-clients
120
121%package server
122Summary: The OpenSSH server daemon.
123Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
124Group: System Environment/Daemons
125Obsoletes: ssh-server
126PreReq: openssh = %{version}-%{release}, chkconfig >= 0.9
127Requires: pam
128
129%package askpass
130Summary: A passphrase dialog for OpenSSH and X.
131Summary(ja): OpenSSH X11 パスフレーズ入力ダイアログ
132Group: Applications/Internet
133Requires: openssh = %{version}-%{release}
134Obsoletes: ssh-extras
135
136%package askpass-gnome
137Summary: A passphrase dialog for OpenSSH, X, and GNOME.
138Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
139Group: Applications/Internet
140Requires: openssh = %{version}-%{release}
141Obsoletes: ssh-extras
142
143%package contrib
144Summary: addons for OpenSSH
145Summary(ja): OpenSSH のためのアドオン
146Group: Applications/Internet
147Requires: openssh-clients = %{version}-%{release}
148
149%description
150SSH (Secure SHell) is a program for logging into and executing
151commands on a remote machine. SSH is intended to replace rlogin and
152rsh, and to provide secure encrypted communications between two
153untrusted hosts over an insecure network. X11 connections and
154arbitrary TCP/IP ports can also be forwarded over the secure channel.
155
156OpenSSH is OpenBSD's version of the last free version of SSH, bringing
157it up to date in terms of security and features, as well as removing
158all patented algorithms to separate libraries.
159
160This package includes the core files necessary for both the OpenSSH
161client and server. To make this package useful, you should also
162install openssh-clients, openssh-server, or both.
163
164#'
165%description -l ja
166OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
167Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
168するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
169ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
170可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
171な通信路の中を通すことができます。
172
173OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
174最新のセキュリティと機能を提供しています。またすべての特許がからむ
175アルゴリズムは分割したライブラリにわかれています。
176
177このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
178コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
179openssh-clients および/または openssh-server が必要です。
180
181%description clients
182OpenSSH is a free version of SSH (Secure SHell), a program for logging
183into and executing commands on a remote machine. This package includes
184the clients necessary to make encrypted connections to SSH servers.
185You'll also need to install the openssh package on OpenSSH clients.
186
187#'
188%description -l ja clients
189OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
190Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
191するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
192ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
193可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
194な通信路の中を通すことができます。
195
196OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
197最新のセキュリティと機能を提供しています。またすべての特許がからむ
198アルゴリズムは分割したライブラリにわかれています。
199
200このパッケージは OpenSSH をクライアントとして使用する場合に
201必要なものを含んでいます。
202
203
204%description server
205OpenSSH is a free version of SSH (Secure SHell), a program for logging
206into and executing commands on a remote machine. This package contains
207the secure shell daemon (sshd). The sshd daemon allows SSH clients to
208securely connect to your SSH server. You also need to have the openssh
209package installed.
210
211%description -l ja server
212OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
213Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
214するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
215ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
216可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
217な通信路の中を通すことができます。
218
219OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
220最新のセキュリティと機能を提供しています。またすべての特許がからむ
221アルゴリズムは分割したライブラリにわかれています。
222
223このパッケージは OpenSSH をサーバとして使用する場合に必要な
224デーモンなどを含んでいます。
225
226%description askpass
227OpenSSH is a free version of SSH (Secure SHell), a program for logging
228into and executing commands on a remote machine. This package contains
229an X11 passphrase dialog for OpenSSH.
230
231%description -l ja askpass
232OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
233Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
234するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
235ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
236可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
237な通信路の中を通すことができます。
238
239OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
240最新のセキュリティと機能を提供しています。またすべての特許がからむ
241アルゴリズムは分割したライブラリにわかれています。
242
243このパッケージは Jim Knoble <jmknoble@jmknoble.cx> による X11 上の
244パスフレーズ入力ダイアログを含んでいます。
245
246%description askpass-gnome
247OpenSSH is a free version of SSH (Secure SHell), a program for logging
248into and executing commands on a remote machine. This package contains
249an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
250environment.
251
252%description -l ja askpass-gnome
253OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
254Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
255するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
256ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
257可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
258な通信路の中を通すことができます。
259
260OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
261最新のセキュリティと機能を提供しています。またすべての特許がからむ
262アルゴリズムは分割したライブラリにわかれています。
263
264このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
265
266%description contrib
267addons for OpenSSH
268
269%description -l ja contrib
270OpenSSH のためのアドオン
271
272%prep
273
274%if ! %{no_x11_askpass}
275%setup -q -a 1
276%else
277%setup -q
278%endif
279%patch0 -p1 -b .vine
280%patch2 -p1 -b .skip-initial
281%patch3 -p1 -b .krb5-config
282%patch4 -p1 -b .vendor
283%patch5 -p1 -b .noinitlog
284
285%if %{WITH_SELINUX}
286#SELinux
287%patch12 -p1 -b .selinux
288%endif
289
290#%patch20 -p0 -b .gssapimitm
291%patch21 -p1 -b .safe-stop
292%patch22 -p1 -b .keep-above
293%patch24 -p1 -b .fromto-remote
294%patch26 -p1 -b .stack
295%patch27 -p1 -b .log-chroot
296%patch30 -p1 -b .exit-deadlock
297# %patch31 -p1 -b .skip-used
298%patch35 -p1 -b .progress
299
300%patch100 -p1 -b .norootlogin
301%patch120 -p1 -b .localtime
302
303autoreconf
304
305
306%build
307CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
308%if %{rescue}
309CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
310%endif
311%if %{pie}
312%ifarch s390 s390x sparc sparc64
313CFLAGS="$CFLAGS -fPIE"
314%else
315CFLAGS="$CFLAGS -fpie"
316%endif
317export CFLAGS
318LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
319%endif
320
321%configure \
322        --sysconfdir=%{_sysconfdir}/ssh \
323        --libexecdir=%{_libexecdir}/openssh \
324        --datadir=%{_datadir}/openssh \
325        --with-tcp-wrappers \
326        --with-rsh=%{_bindir}/rsh \
327        --with-default-path=/usr/local/bin:/bin:/usr/bin \
328        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
329        --with-privsep-path=%{_var}/empty/sshd \
330        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
331%if %{scard}
332        --with-smartcard \
333%endif
334%if %{noip6}
335        --with-ipv4-default \
336%endif
337%if %{rescue}
338        --without-pam --with-md5-passwords
339%else
340        --with-pam
341%endif
342
343%if %{static_libcrypto}
344perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
345%endif
346
347make
348
349%if ! %{no_x11_askpass}
350pushd x11-ssh-askpass-%{aversion}
351%configure --libexecdir=%{_libexecdir}/openssh
352xmkmf -a
353make
354popd
355%endif
356
357%if %{gtk2}
358        gtk2=yes
359%else
360        gtk2=no
361%endif
362
363%if ! %{no_gnome_askpass}
364pushd contrib
365if [ $gtk2 = yes ]; then
366        make gnome-ssh-askpass2
367        mv gnome-ssh-askpass2 gnome-ssh-askpass
368else
369        make gnome-ssh-askpass1
370        mv gnome-ssh-askpass1 gnome-ssh-askpass
371fi
372popd
373%endif
374
375%install
376rm -rf $RPM_BUILD_ROOT
377mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
378mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
379mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
380mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
381
382make install DESTDIR=$RPM_BUILD_ROOT
383
384touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
385install -d $RPM_BUILD_ROOT/etc/pam.d/
386install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
387install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
388install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
389install -m755 contrib/redhat/sshd.init $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
390
391%if ! %{no_x11_askpass}
392install -s x11-ssh-askpass-%{aversion}/x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/x11-ssh-askpass
393ln -s x11-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/ssh-askpass
394%endif
395
396%if ! %{scard}
397        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
398%endif
399
400%if ! %{no_gnome_askpass}
401install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
402install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
403install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
404%endif
405
406%if %{no_gnome_askpass}
407rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
408%endif
409
410# for contrib package
411install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
412install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
413mv contrib/README contrib/README.contrib
414
415perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
416
417%clean
418rm -rf $RPM_BUILD_ROOT
419
420%triggerun server -- ssh-server
421if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
422        touch /var/run/sshd.restart
423fi
424
425%triggerun server -- openssh-server < 2.5.0p1
426# Count the number of HostKey and HostDsaKey statements we have.
427gawk    'BEGIN {IGNORECASE=1}
428         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
429         END {exit sawhostkey}' /etc/ssh/sshd_config
430# And if we only found one, we know the client was relying on the old default
431# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
432# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
433# one nullifies the default, which would have loaded both.
434if [ $? -eq 1 ] ; then
435        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
436        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
437fi
438
439%triggerpostun server -- ssh-server
440if [ "$1" != 0 ] ; then
441        /sbin/chkconfig --add sshd
442        if test -f /var/run/sshd.restart ; then
443                rm -f /var/run/sshd.restart
444                # /sbin/service sshd start > /dev/null 2>&1 || :
445                /sbin/service sshd start
446        fi
447fi
448
449%pre server
450%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
451%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
452        -g sshd -M -r sshd 2>/dev/null || :
453
454%post server
455/sbin/chkconfig --add sshd
456
457%postun server
458# /sbin/service sshd condrestart > /dev/null 2>&1 || :
459/sbin/service sshd condrestart
460
461%preun server
462if [ "$1" = 0 ]
463then
464        /sbin/service sshd stop > /dev/null 2>&1 || :
465        /sbin/chkconfig --del sshd
466fi
467
468%files
469%defattr(-,root,root)
470%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
471%attr(0755,root,root) %{_bindir}/scp
472%attr(0644,root,root) %{_mandir}/man1/scp.1*
473%attr(0755,root,root) %dir %{_sysconfdir}/ssh
474%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
475%attr(644,root,root) %{_mandir}/man5/moduli.5*
476%if ! %{rescue}
477%attr(0755,root,root) %{_bindir}/ssh-keygen
478%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
479%attr(0755,root,root) %dir %{_libexecdir}/openssh
480%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
481%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
482%endif
483%if %{scard}
484%attr(0755,root,root) %dir %{_datadir}/openssh
485%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
486%endif
487
488%files clients
489%defattr(-,root,root)
490%attr(0755,root,root) %{_bindir}/ssh
491%attr(0644,root,root) %{_mandir}/man1/ssh.1*
492%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
493%attr(0644,root,root) %{_mandir}/man1/slogin.1*
494%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
495%attr(-,root,root) %{_bindir}/slogin
496%if ! %{rescue}
497%attr(0755,root,root) %{_bindir}/ssh-agent
498%attr(0755,root,root) %{_bindir}/ssh-add
499%attr(0755,root,root) %{_bindir}/ssh-keyscan
500%attr(0755,root,root) %{_bindir}/sftp
501%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
502%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
503%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
504%attr(0644,root,root) %{_mandir}/man1/sftp.1*
505%endif
506
507%if ! %{rescue}
508%files server
509%defattr(-,root,root)
510%dir %attr(0711,root,root) %{_var}/empty/sshd
511%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
512%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
513%attr(0755,root,root) %{_sbindir}/sshd
514%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
515%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
516%attr(0644,root,root) %{_mandir}/man8/sshd.8*
517%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
518%attr(0755,root,root) %dir %{_sysconfdir}/ssh
519%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
520%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
521%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
522%endif
523
524%if ! %{no_x11_askpass}
525%files askpass
526%defattr(-,root,root)
527%doc x11-ssh-askpass-%{aversion}/README
528%doc x11-ssh-askpass-%{aversion}/ChangeLog
529%doc x11-ssh-askpass-%{aversion}/SshAskpass*.ad
530%attr(0755,root,root) %{_libexecdir}/openssh/ssh-askpass
531%attr(0755,root,root) %{_libexecdir}/openssh/x11-ssh-askpass
532%endif
533
534%if ! %{no_gnome_askpass}
535%files askpass-gnome
536%defattr(-,root,root)
537%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
538%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
539%endif
540
541%files contrib
542%defattr(-,root,root)
543%doc contrib/README.contrib
544%{_bindir}/ssh-copy-id
545%{_mandir}/man1/ssh-copy-id.1*
546
547%changelog
548* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
549- new upstream release
550
551* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
552- new upstream release
553
554* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
555- rebuild with xorg-x11-7.3
556
557* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
558- new upstream release with security fix (CVE-2008-1483)
559- drop patch31 which is included in new release (This was for CVE-2008-1483)
560
561* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
562- new upstream release with security fix ("ForceCommand" Directive)
563- turn on daemon restart message
564- new versioning policy
565
566* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
567- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
568
569* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
570- new upstream release
571
572* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
573- build with -fpie/-pie by default.
574- enable ipv6 by default.
575
576* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
577- new upstream release
578
579* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
580- new upstream release
581
582* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
583- new upstream release
584
585* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
586- new upstream release
587
588* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
589- new upstream release
590- remove build6x stuff
591- remove libgnome-devel from BuildRequires
592- cleanup BuildRequires
593- drop Patch200, it is merged in upstream.
594- import patches(25-35) from FC-devel
595
596* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
597- SECURITY FIX: CVE-2006-0225
598  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
599- update BuildPreReq: s/XFree86-devel/XOrg-devel/
600- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
601  - When GNOME2 is used, using libgnome-devel
602  - add BuildPreReq: gtk2-devel for GNOME2
603
604* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
605- rebuild with gtk+-2.8 final
606
607* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
608- new upstream release
609- build with gtk+-2.7
610
611* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
612- new upstream release
613
614* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
615- cleanup obsolete patches and added patches from fedora
616
617* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
618- new upstream release
619
620* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
621- new upstream release
622
623* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
624- new upstream release
625
626* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
627- rebuild with openssl-0.9.7d
628
629* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
630- new upstream release
631
632* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
633- create contrib package
634
635* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
636- new upstream release
637- fix security issue: http://www.openssh.com/txt/sshpam.adv
638
639* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
640- new upstream release
641- fix security issue: http://www.openssh.com/txt/buffer.adv
642
643* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
644- new upstream release
645
646* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
647- rebuild with gtk2
648
649* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
650- new upstream release
651
652* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
653- rebuild with new tool chain
654
655* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
656- new upstream release
657- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
658
659* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
660- change some defines in spec files
661
662* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
663- add patch110 ( 3.4p1 does not include mmap-fallback patch )
664
665* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
666- new upstream release
667  - security fix
668- drop patch10
669
670* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
671- add patch from Solar Designer to make privsep work with a 2.2 kernel.
672
673* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
674- new upstream release
675- add {sshd,ssh}_config.5 manpages
676- add ssh-keysign
677
678* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
679- new upstream release
680
681* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
682- new upstream release
683- drop patch1
684
685* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
686- new upstream release
687- merged with rawhide release.
688- drop Patch101 (merged in upstream)
689
690* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
691- seurity patch for off-by-one bug
692
693* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
694- merged with Rawhide 3.0.2p1-2
695
696* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
697- updated to 3.0.2p1
698
699* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
700- updated to 3.0.1p1
701
702* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
703- updated to 3.0p1
704
705* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
706- add japanese summery and descriptions.
707- update x11-askpass 1.2.5
708
709* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
710- update to openssh-2.9.9p2
711
712* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
713- rebuilt with openssl-0.9.6b
714
715* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
716- do not Permit RootLogin
717
718* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
719- update to openssh-2.5.2p2
720
721* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
722- update to openssh-2.5.2p1
723
724* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
725- update to openssh-2.5.1p2
726
727* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
728- update to openssh-2.5.1p1
729
730* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
731- update to openssh-2.5.1p1
732
733* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
734- remove suid bit from ssh
735
736* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
737- moved man dir to /usr/share/man
738
739* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
740- fixed askpass's link in ssh-add
741- partially used rpmmacros
742
743* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
744- update to 2.3.0p1
745- update x11-askpass 1.0.3
746
747* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
748- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
749  Redhat 7.0 spec file
750
751* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
752- rebuild for Vine Linux
753
754* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
755- Use RPM configure macro
756* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
757- Some surgery to sshd.init (generate keys at runtime)
758- Cleanup of groups and removal of keygen calls
759* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
760- Make building of X11-askpass and gnome-askpass optional
761* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
762- Glob manpages to catch compressed files
763* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
764- Updated for new location
765- Updated for new gnome-ssh-askpass build
766* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
767- Added Jim Knoble's <jmknoble@pobox.com> askpass
768* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
769- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
770* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
771- Added 'Obsoletes' directives
772* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
773- Use make install
774- Subpackages
775* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
776- Added links for slogin
777- Fixed perms on manpages
778* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
779- Renamed init script
780* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
781- Back to old binary names
782* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
783- Use autoconf
784- New binary names
785* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
786- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
787
Note: See TracBrowser for help on using the repository browser.