source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 12502

Revision 12502, 29.9 KB checked in by tomop, 3 years ago (diff)

updated 8 packages

firefox-78.3.1-1

libpq-13.0-1

nodejs-12.18.4-1

openssh-8.4p1-1

php74-7.4.11-1

postgresql-13.0-1

rspamd-2.6-1

thunderbird-68.12.1-1

Line 
1%bcond_with systemd
2
3# SELinux
4%define WITH_SELINUX 0
5
6# OpenSSH privilege separation requires a user & group ID
7%define sshd_uid    74
8%define sshd_gid    74
9
10# Do we want to disable building of gnome-askpass? (1=yes 0=no)
11%define no_gnome_askpass 0
12
13# Use GTK3 for gnome-ssh-askpass
14%define gtk3 1
15
16# Build position-independent executables (requires toolchain support)?
17%define pie 1
18
19# Do we want to link against a static libcrypto? (1=yes 0=no)
20%define static_libcrypto 0
21
22# Do we want smartcard support (1=yes 0=no)
23%define scard 0
24
25# Disable IPv6 (avoids DNS hangs on some glibc versions)
26%define noip6 0
27
28# Do we want kerberos5 support (1=yes 0=no)
29%define kerberos5 0
30
31# Reserve options to override askpass settings with:
32# rpm -ba|--rebuild --define 'skip_xxx 1'
33%{?skip_gnome_askpass:%define no_gnome_askpass 1}
34
35# Options for static OpenSSL link:
36# rpm -ba|--rebuild --define "static_openssl 1"
37%{?static_openssl:%define static_libcrypto 1}
38
39# Options for Smartcard support: (needs libsectok and openssl-engine)
40# rpm -ba|--rebuild --define "smartcard 1"
41%{?smartcard:%define scard 1}
42
43# Option to disable ipv6
44# rpm -ba|--rebuild --define "noipv6 1"
45%{?noipv6:%define noip6 1}
46
47# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
48%define rescue 0
49%{?build_rescue:%define rescue 1}
50
51# Turn off some stuff for resuce builds
52%if %{rescue}
53%define kerberos5 0
54%endif
55
56Summary: The OpenSSH implementation of SSH.
57Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
58Name: openssh
59Version: 8.4p1
60Release: 1%{_dist_release}%{?with_systemd:.systemd}
61Group: network
62Vendor: Project Vine
63Distribution: Vine Linux
64Packager: daisuke
65
66License: BSD
67URL: https://www.openssh.com/portable.html
68Source0: https://cdn.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
69# files for systemd
70Source9: sshd@.service
71Source10: sshd.socket
72Source11: sshd.service
73Source12: sshd-keygen@.service
74Source13: sshd-keygen
75Source14: sshd.tmpfiles
76Source15: sshd-keygen.target
77
78Patch0: openssh-8.4p1-vine.patch
79#Patch4: openssh-8.0p1-vendor.patch
80# Patch12: openssh-selinux.patch
81# Patch20: openssh-3.9p1-gssapimitm.patch
82Patch21: openssh-7.6p1-safe-stop.patch
83Patch24: openssh-7.6p1-fromto-remote.patch
84Patch26: openssh-5.2p1-pam-no-stack.patch
85# Patch27: openssh-5.1p1-log-in-chroot.patch
86# Patch30: openssh-5.6p1-exit-deadlock.patch
87# Patch31: openssh-3.9p1-skip-used.patch
88Patch35: openssh-8.2p1-askpass-progress-gtk3.patch
89
90# Help systemd to track the running service
91Patch948: openssh-7.4p1-systemd.patch
92
93# Vine Source
94Source100: sshd.init.vine
95Source110: sshd.sysconfig.vine
96
97BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
98
99Obsoletes: ssh
100
101BuildRequires: perl, openssl-devel
102BuildRequires: util-linux
103%if "%{_dist_release}" >= "vl7"
104BuildRequires: libdb-devel
105%else
106BuildRequires: db4-devel
107%endif
108BuildRequires: pam-devel
109BuildRequires: zlib-devel
110%if ! %{no_gnome_askpass}
111BuildRequires: libX11-devel
112BuildRequires: gtk3-devel
113%endif
114BuildRequires: xorg-x11-xauth
115BuildRequires: groff
116BuildRequires: libedit-devel
117%if %{with systemd}
118BuildRequires: systemd-devel
119%endif
120
121%description
122SSH (Secure SHell) is a program for logging into and executing
123commands on a remote machine. SSH is intended to replace rlogin and
124rsh, and to provide secure encrypted communications between two
125untrusted hosts over an insecure network. X11 connections and
126arbitrary TCP/IP ports can also be forwarded over the secure channel.
127
128OpenSSH is OpenBSD's version of the last free version of SSH, bringing
129it up to date in terms of security and features, as well as removing
130all patented algorithms to separate libraries.
131
132This package includes the core files necessary for both the OpenSSH
133client and server. To make this package useful, you should also
134install openssh-clients, openssh-server, or both.
135
136#'
137%description -l ja
138OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
139Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
140するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
141ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
142可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
143な通信路の中を通すことができます。
144
145OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
146最新のセキュリティと機能を提供しています。またすべての特許がからむ
147アルゴリズムは分割したライブラリにわかれています。
148
149このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
150コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
151openssh-clients および/または openssh-server が必要です。
152
153
154%package clients
155Summary: OpenSSH clients.
156Summary(ja): OpenSSH Secure Shell プロトコルクライアント
157Requires: openssh = %{version}-%{release}
158Group: network
159Obsoletes: ssh-clients
160Obsoletes: openssh-contrib
161
162%description clients
163OpenSSH is a free version of SSH (Secure SHell), a program for logging
164into and executing commands on a remote machine. This package includes
165the clients necessary to make encrypted connections to SSH servers.
166You'll also need to install the openssh package on OpenSSH clients.
167
168#'
169%description -l ja clients
170OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
171Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
172するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
173ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
174可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
175な通信路の中を通すことができます。
176
177OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
178最新のセキュリティと機能を提供しています。またすべての特許がからむ
179アルゴリズムは分割したライブラリにわかれています。
180
181このパッケージは OpenSSH をクライアントとして使用する場合に
182必要なものを含んでいます。
183
184
185%package server
186Summary: The OpenSSH server daemon.
187Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
188Group: servers
189Obsoletes: ssh-server
190Requires(post): openssh = %{version}-%{release}
191Requires(post): chkconfig
192Requires(pre): shadow-utils
193Requires(post): initscripts >= 5.20
194Requires: pam
195
196%description server
197OpenSSH is a free version of SSH (Secure SHell), a program for logging
198into and executing commands on a remote machine. This package contains
199the secure shell daemon (sshd). The sshd daemon allows SSH clients to
200securely connect to your SSH server. You also need to have the openssh
201package installed.
202
203%description -l ja server
204OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
205Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
206するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
207ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
208可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
209な通信路の中を通すことができます。
210
211OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
212最新のセキュリティと機能を提供しています。またすべての特許がからむ
213アルゴリズムは分割したライブラリにわかれています。
214
215このパッケージは OpenSSH をサーバとして使用する場合に必要な
216デーモンなどを含んでいます。
217
218
219%package askpass-gnome
220Summary: A passphrase dialog for OpenSSH, X, and GNOME.
221Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
222Group: network
223Requires: openssh = %{version}-%{release}
224Obsoletes: ssh-extras
225Obsoletes: openssh-askpass < 5.5p1-3vl6
226Provides: openssh-askpass = %{version}-%{release}
227
228%description askpass-gnome
229OpenSSH is a free version of SSH (Secure SHell), a program for logging
230into and executing commands on a remote machine. This package contains
231an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
232environment.
233
234%description -l ja askpass-gnome
235OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
236Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
237するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
238ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
239可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
240な通信路の中を通すことができます。
241
242OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
243最新のセキュリティと機能を提供しています。またすべての特許がからむ
244アルゴリズムは分割したライブラリにわかれています。
245
246このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
247
248
249%debug_package
250
251
252%prep
253%setup -q
254%patch0 -p1 -b .vine
255#patch4 -p1 -b .vendor
256
257%if %{WITH_SELINUX}
258#SELinux
259#%patch12 -p1 -b .selinux
260%endif
261
262%patch21 -p1 -b .safe-stop
263%patch24 -p1 -b .fromto-remote
264%patch26 -p1 -b .stack
265# %patch27 -p1 -b .log-chroot
266# %patch30 -p1 -b .exit-deadlock
267# %patch35 -p1 -b .progress
268
269%if %{with systemd}
270%patch948 -p1
271%endif
272
273autoreconf
274
275
276%build
277CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
278%if %{rescue}
279CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
280%endif
281%if %{pie}
282%ifarch s390 s390x sparc sparc64
283CFLAGS="$CFLAGS -fPIE"
284%else
285CFLAGS="$CFLAGS -fpie"
286%endif
287export CFLAGS
288LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
289%endif
290
291%configure \
292        --sysconfdir=%{_sysconfdir}/ssh \
293        --libexecdir=%{_libexecdir}/openssh \
294        --datadir=%{_datadir}/openssh \
295        --with-tcp-wrappers \
296        --with-default-path=/usr/local/bin:/bin:/usr/bin \
297        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
298        --with-privsep-path=%{_var}/empty/sshd \
299        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
300        --with-libedit \
301        --with-xauth=/usr/bin/xauth \
302%if %{scard}
303        --with-smartcard \
304%endif
305%if %{noip6}
306        --with-ipv4-default \
307%endif
308%if %{rescue}
309        --without-pam --with-md5-passwords \
310%else
311        --with-pam \
312%endif
313%if %{with systemd}
314        --with-systemd \
315%endif
316        %{nil}
317
318%if %{static_libcrypto}
319perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
320%endif
321
322make
323
324%if %{gtk3}
325        gtk3=yes
326%else
327        gtk3=no
328%endif
329
330%if ! %{no_gnome_askpass}
331pushd contrib
332if [ $gtk3 = yes ]; then
333        make gnome-ssh-askpass3
334        mv gnome-ssh-askpass3 gnome-ssh-askpass
335else
336        make gnome-ssh-askpass2
337        mv gnome-ssh-askpass2 gnome-ssh-askpass
338fi
339popd
340%endif
341
342%install
343rm -rf $RPM_BUILD_ROOT
344mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
345mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
346mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
347mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
348
349make install DESTDIR=$RPM_BUILD_ROOT
350
351touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
352install -d $RPM_BUILD_ROOT/etc/pam.d/
353install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
354install -d $RPM_BUILD_ROOT/etc/sysconfig/
355install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
356install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
357install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
358
359%if %{with systemd}
360install -d -m755 $RPM_BUILD_ROOT/%{_unitdir}
361install -m644 %{SOURCE9} $RPM_BUILD_ROOT/%{_unitdir}/sshd@.service
362install -m644 %{SOURCE10} $RPM_BUILD_ROOT/%{_unitdir}/sshd.socket
363install -m644 %{SOURCE11} $RPM_BUILD_ROOT/%{_unitdir}/sshd.service
364install -m644 %{SOURCE12} $RPM_BUILD_ROOT/%{_unitdir}/sshd-keygen@.service
365install -m644 %{SOURCE15} $RPM_BUILD_ROOT/%{_unitdir}/sshd-keygen.target
366install -m744 %{SOURCE13} $RPM_BUILD_ROOT/%{_libexecdir}/openssh/sshd-keygen
367install -m755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}/
368install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1/
369install -m644 -D %{SOURCE14} $RPM_BUILD_ROOT%{_tmpfilesdir}/%{name}.conf
370%else
371install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
372%endif
373
374%if ! %{scard}
375        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
376%endif
377
378%if ! %{no_gnome_askpass}
379install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
380install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
381install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
382%endif
383
384%if %{no_gnome_askpass}
385rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
386%endif
387
388# for contrib package
389install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
390install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
391mv contrib/README contrib/README.contrib
392
393perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
394
395%clean
396rm -rf $RPM_BUILD_ROOT
397
398%triggerun server -- ssh-server
399if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
400        touch /var/run/sshd.restart
401fi
402
403%triggerun server -- openssh-server < 2.5.0p1
404# Count the number of HostKey and HostDsaKey statements we have.
405gawk    'BEGIN {IGNORECASE=1}
406         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
407         END {exit sawhostkey}' /etc/ssh/sshd_config
408# And if we only found one, we know the client was relying on the old default
409# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
410# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
411# one nullifies the default, which would have loaded both.
412if [ $? -eq 1 ] ; then
413        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
414        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
415fi
416
417%triggerpostun server -- ssh-server
418if [ "$1" != 0 ] ; then
419        /sbin/chkconfig --add sshd
420        if test -f /var/run/sshd.restart ; then
421                rm -f /var/run/sshd.restart
422                # /sbin/service sshd start > /dev/null 2>&1 || :
423                /sbin/service sshd start
424        fi
425fi
426
427%if %{with systemd}
428%pre
429getent group ssh_keys >/dev/null || groupadd -r ssh_keys || :
430%endif
431
432%pre server
433%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
434%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
435        -g sshd -M -r sshd 2>/dev/null || :
436
437%post server
438%if %{with systemd}
439%systemd_post sshd.service sshd.socket
440%else
441/sbin/chkconfig --add sshd
442%endif
443
444%postun server
445%if %{with systemd}
446%systemd_postun_with_restart sshd.service
447%else
448# /sbin/service sshd condrestart > /dev/null 2>&1 || :
449/sbin/service sshd condrestart
450exit 0
451%endif
452
453%preun server
454%if %{with systemd}
455%systemd_preun sshd.service sshd.socket
456%else
457if [ "$1" = 0 -o -x /bin/systemctl ]; then
458        /sbin/service sshd stop > /dev/null 2>&1 || :
459        /sbin/chkconfig --del sshd
460%endif
461fi
462
463
464%files
465%defattr(-,root,root)
466%license LICENCE
467%doc CREDITS ChangeLog INSTALL OVERVIEW PROTOCOL* README* TODO
468%attr(0755,root,root) %dir %{_sysconfdir}/ssh
469%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
470%attr(644,root,root) %{_mandir}/man5/moduli.5*
471%if ! %{rescue}
472%attr(0755,root,root) %{_bindir}/ssh-keygen
473%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
474%attr(0755,root,root) %dir %{_libexecdir}/openssh
475%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
476%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
477%endif
478%if %{scard}
479%attr(0755,root,root) %dir %{_datadir}/openssh
480%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
481%endif
482
483%files clients
484%defattr(-,root,root)
485%attr(0755,root,root) %{_bindir}/scp
486%attr(0755,root,root) %{_bindir}/ssh
487%attr(0644,root,root) %{_mandir}/man1/scp.1*
488%attr(0644,root,root) %{_mandir}/man1/ssh.1*
489%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
490# %attr(0644,root,root) %{_mandir}/man1/slogin.1*
491%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
492# %attr(-,root,root) %{_bindir}/slogin
493%if ! %{rescue}
494%attr(0755,root,root) %{_bindir}/ssh-agent
495%attr(0755,root,root) %{_bindir}/ssh-add
496%attr(0755,root,root) %{_bindir}/ssh-keyscan
497%attr(0755,root,root) %{_bindir}/sftp
498%attr(0755,root,root) %{_bindir}/ssh-copy-id
499%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
500%attr(0755,root,root) %{_libexecdir}/openssh/ssh-sk-helper
501%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
502%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
503%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
504%attr(0644,root,root) %{_mandir}/man1/sftp.1*
505%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
506%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
507%attr(0644,root,root) %{_mandir}/man8/ssh-sk-helper.8*
508%endif
509
510%if ! %{rescue}
511%files server
512%defattr(-,root,root)
513%dir %attr(0711,root,root) %{_var}/empty/sshd
514%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
515%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
516%attr(0755,root,root) %{_sbindir}/sshd
517%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
518%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
519%attr(0644,root,root) %{_mandir}/man8/sshd.8*
520%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
521%attr(0755,root,root) %dir %{_sysconfdir}/ssh
522%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
523%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
524%attr(0755,root,root) %config /etc/sysconfig/sshd
525%if %{with systemd}
526%attr(0755,root,root) %{_libexecdir}/openssh/sshd-keygen
527%attr(0644,root,root) %{_unitdir}/sshd.service
528%attr(0644,root,root) %{_unitdir}/sshd@.service
529%attr(0644,root,root) %{_unitdir}/sshd.socket
530%attr(0644,root,root) %{_unitdir}/sshd-keygen@.service
531%attr(0644,root,root) %{_unitdir}/sshd-keygen.target
532%attr(0644,root,root) %{_tmpfilesdir}/openssh.conf
533%else
534%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
535%endif
536%endif
537
538%if ! %{no_gnome_askpass}
539%files askpass-gnome
540%defattr(-,root,root)
541%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
542%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
543%endif
544
545
546%changelog
547* Wed Oct 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4p1-1
548- new upstream release.
549- updated Patch0.
550- disabled Patch35.
551
552* Wed May 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.3p1-1
553- new upstream release.
554
555* Thu Apr 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2p1-2
556- added systemd support (disabled as default).
557
558* Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2p1-1
559- new upstream release.
560- updated Patch35.
561
562* Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1p1-1
563- new upstream release.
564
565* Sat Jun 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0p1-1
566- new upstream release.
567- moved scp to openssh-clients.
568- changed "PasswordAuthentication" to "no" as default.
569- dropped Patch4.
570- updated Patch35 to use GTK+3 for gnome-ssh-askpass.
571
572* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.9p1-1
573- new upstream release.
574- updated Patch4.
575
576* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.6p1-1
577- new upstream release.
578- update patch0,4,21,24
579- update patch35 from fc26
580- drop patch12,20,30
581
582* Fri Aug  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.2p2-2
583- disabled rsa1 hostkey generation.
584
585* Sat Jul 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.2p2-1
586- new upstream release.
587
588* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.2p1-1
589- new upstream release
590- built with openssl 1.0.2g
591- drop slogin command and manual, this is upstream change.
592
593* Sun Jan 17 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p2-1
594- update to 7.1p2
595
596* Mon Dec 28 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p1-1
597- update to 7.1p1
598- remove patch100 to use default value "prohibit-password" for PermitRootLogin
599
600* Tue Oct 14 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.7p1-1
601- update to 6.7p1
602- fix sshd.init
603
604* Thu Aug 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.6p1-1
605- update to 6.6p1
606- remove BR: sharutils
607- add BR: libdb-devel instead of db4-devel
608
609* Tue Feb 04 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 6.5p1-1
610- update to 6.5p1
611- update sshd_config
612  - generate ED25519 host key.
613
614* Tue Nov 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.4p1-1
615- update to 6.4p1
616
617* Mon May 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p2-1
618- update to 6.2p2
619
620* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p1-1
621- update to 6.2p1
622
623* Fri Nov  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.1p1-1
624- new upstream release
625- add -with-xauth option in configure
626- patch4, 30, 35 are updated from fc18
627
628* Mon May 07 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0p1-1
629- new upstream release
630
631* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9p1-1
632- new upstream release
633
634* Sun May  8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
635- new upstream release
636
637* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
638- add our own sshd.init based on fedora's sshd.init
639  - generate ECDSA host key.
640
641* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
642- new upstream release
643
644* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
645- new upstream release
646
647* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
648- new upstream release
649- obsolete contrib subpackage, move ssh-copy-id to client subpackage
650
651* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
652- rebuilt with openssl 1.0.0c
653
654* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
655- drop x11-askpass, add Obsoletes: openssh-askpass
656- add BR: groff
657- enable --with-libedit option, add BR: libedit-devel
658- remove unrecognized option '--with-rsh'
659
660* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
661- add BR: xorg-x11-xauth for X11 forwarding support
662
663* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
664- new upstream release
665- update patch0,2
666- drop patch3,22
667
668* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
669- new upstream release
670
671* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
672- new upstream release
673
674* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
675- rebuild with xorg-x11-7.3
676
677* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
678- new upstream release with security fix (CVE-2008-1483)
679- drop patch31 which is included in new release (This was for CVE-2008-1483)
680
681* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
682- new upstream release with security fix ("ForceCommand" Directive)
683- turn on daemon restart message
684- new versioning policy
685
686* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
687- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
688
689* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
690- new upstream release
691
692* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
693- build with -fpie/-pie by default.
694- enable ipv6 by default.
695
696* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
697- new upstream release
698
699* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
700- new upstream release
701
702* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
703- new upstream release
704
705* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
706- new upstream release
707
708* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
709- new upstream release
710- remove build6x stuff
711- remove libgnome-devel from BuildRequires
712- cleanup BuildRequires
713- drop Patch200, it is merged in upstream.
714- import patches(25-35) from FC-devel
715
716* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
717- SECURITY FIX: CVE-2006-0225
718  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
719- update BuildPreReq: s/XFree86-devel/XOrg-devel/
720- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
721  - When GNOME2 is used, using libgnome-devel
722  - add BuildPreReq: gtk2-devel for GNOME2
723
724* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
725- rebuild with gtk+-2.8 final
726
727* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
728- new upstream release
729- build with gtk+-2.7
730
731* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
732- new upstream release
733
734* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
735- cleanup obsolete patches and added patches from fedora
736
737* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
738- new upstream release
739
740* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
741- new upstream release
742
743* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
744- new upstream release
745
746* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
747- rebuild with openssl-0.9.7d
748
749* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
750- new upstream release
751
752* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
753- create contrib package
754
755* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
756- new upstream release
757- fix security issue: http://www.openssh.com/txt/sshpam.adv
758
759* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
760- new upstream release
761- fix security issue: http://www.openssh.com/txt/buffer.adv
762
763* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
764- new upstream release
765
766* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
767- rebuild with gtk2
768
769* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
770- new upstream release
771
772* Sun Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
773- rebuild with new tool chain
774
775* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
776- new upstream release
777- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
778
779* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
780- change some defines in spec files
781
782* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
783- add patch110 ( 3.4p1 does not include mmap-fallback patch )
784
785* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
786- new upstream release
787  - security fix
788- drop patch10
789
790* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
791- add patch from Solar Designer to make privsep work with a 2.2 kernel.
792
793* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
794- new upstream release
795- add {sshd,ssh}_config.5 manpages
796- add ssh-keysign
797
798* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
799- new upstream release
800
801* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
802- new upstream release
803- drop patch1
804
805* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
806- new upstream release
807- merged with rawhide release.
808- drop Patch101 (merged in upstream)
809
810* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
811- seurity patch for off-by-one bug
812
813* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
814- merged with Rawhide 3.0.2p1-2
815
816* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
817- updated to 3.0.2p1
818
819* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
820- updated to 3.0.1p1
821
822* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
823- updated to 3.0p1
824
825* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
826- add japanese summery and descriptions.
827- update x11-askpass 1.2.5
828
829* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
830- update to openssh-2.9.9p2
831
832* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
833- rebuilt with openssl-0.9.6b
834
835* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
836- do not Permit RootLogin
837
838* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
839- update to openssh-2.5.2p2
840
841* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
842- update to openssh-2.5.2p1
843
844* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
845- update to openssh-2.5.1p2
846
847* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
848- update to openssh-2.5.1p1
849
850* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
851- update to openssh-2.5.1p1
852
853* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
854- remove suid bit from ssh
855
856* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
857- moved man dir to /usr/share/man
858
859* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
860- fixed askpass's link in ssh-add
861- partially used rpmmacros
862
863* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
864- update to 2.3.0p1
865- update x11-askpass 1.0.3
866
867* Wed Oct 18 2000 Damien Miller <djm@mindrot.org>
868- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
869  Redhat 7.0 spec file
870
871* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
872- rebuild for Vine Linux
873
874* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
875- Use RPM configure macro
876* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
877- Some surgery to sshd.init (generate keys at runtime)
878- Cleanup of groups and removal of keygen calls
879* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
880- Make building of X11-askpass and gnome-askpass optional
881* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
882- Glob manpages to catch compressed files
883* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
884- Updated for new location
885- Updated for new gnome-ssh-askpass build
886* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
887- Added Jim Knoble's <jmknoble@pobox.com> askpass
888* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
889- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
890* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
891- Added 'Obsoletes' directives
892* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
893- Use make install
894- Subpackages
895* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
896- Added links for slogin
897- Fixed perms on manpages
898* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
899- Renamed init script
900* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
901- Back to old binary names
902* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
903- Use autoconf
904- New binary names
905* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
906- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
907
908
Note: See TracBrowser for help on using the repository browser.