source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 12413

Revision 12413, 29.8 KB checked in by tomop, 4 years ago (diff)

updated 6 packages

cyrus-sasl-2.1.27-2

dnsmasq-2.81-1

freerdp-2.1.1-1

glib2-2.64.3-1

libmariadb-3.1.8-1

openssh-8.3p1-1

Line 
1%bcond_with systemd
2
3# SELinux
4%define WITH_SELINUX 0
5
6# OpenSSH privilege separation requires a user & group ID
7%define sshd_uid    74
8%define sshd_gid    74
9
10# Do we want to disable building of gnome-askpass? (1=yes 0=no)
11%define no_gnome_askpass 0
12
13# Use GTK3 for gnome-ssh-askpass
14%define gtk3 1
15
16# Build position-independent executables (requires toolchain support)?
17%define pie 1
18
19# Do we want to link against a static libcrypto? (1=yes 0=no)
20%define static_libcrypto 0
21
22# Do we want smartcard support (1=yes 0=no)
23%define scard 0
24
25# Disable IPv6 (avoids DNS hangs on some glibc versions)
26%define noip6 0
27
28# Do we want kerberos5 support (1=yes 0=no)
29%define kerberos5 0
30
31# Reserve options to override askpass settings with:
32# rpm -ba|--rebuild --define 'skip_xxx 1'
33%{?skip_gnome_askpass:%define no_gnome_askpass 1}
34
35# Options for static OpenSSL link:
36# rpm -ba|--rebuild --define "static_openssl 1"
37%{?static_openssl:%define static_libcrypto 1}
38
39# Options for Smartcard support: (needs libsectok and openssl-engine)
40# rpm -ba|--rebuild --define "smartcard 1"
41%{?smartcard:%define scard 1}
42
43# Option to disable ipv6
44# rpm -ba|--rebuild --define "noipv6 1"
45%{?noipv6:%define noip6 1}
46
47# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
48%define rescue 0
49%{?build_rescue:%define rescue 1}
50
51# Turn off some stuff for resuce builds
52%if %{rescue}
53%define kerberos5 0
54%endif
55
56Summary: The OpenSSH implementation of SSH.
57Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
58Name: openssh
59Version: 8.3p1
60Release: 1%{_dist_release}%{?with_systemd:.systemd}
61Group: Applications/Internet
62Vendor: Project Vine
63Distribution: Vine Linux
64Packager: daisuke
65
66License: BSD
67URL: https://www.openssh.com/portable.html
68Source0: https://cdn.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
69# files for systemd
70Source9: sshd@.service
71Source10: sshd.socket
72Source11: sshd.service
73Source12: sshd-keygen@.service
74Source13: sshd-keygen
75Source14: sshd.tmpfiles
76Source15: sshd-keygen.target
77
78Patch0: openssh-7.6p1-vine.patch
79#Patch4: openssh-8.0p1-vendor.patch
80# Patch12: openssh-selinux.patch
81# Patch20: openssh-3.9p1-gssapimitm.patch
82Patch21: openssh-7.6p1-safe-stop.patch
83Patch24: openssh-7.6p1-fromto-remote.patch
84Patch26: openssh-5.2p1-pam-no-stack.patch
85# Patch27: openssh-5.1p1-log-in-chroot.patch
86# Patch30: openssh-5.6p1-exit-deadlock.patch
87# Patch31: openssh-3.9p1-skip-used.patch
88Patch35: openssh-8.2p1-askpass-progress-gtk3.patch
89
90# Help systemd to track the running service
91Patch948: openssh-7.4p1-systemd.patch
92
93# Vine Source
94Source100: sshd.init.vine
95Source110: sshd.sysconfig.vine
96
97BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
98
99Obsoletes: ssh
100
101BuildRequires: perl, openssl-devel
102BuildRequires: util-linux
103%if "%{_dist_release}" >= "vl7"
104BuildRequires: libdb-devel
105%else
106BuildRequires: db4-devel
107%endif
108BuildRequires: pam-devel
109BuildRequires: zlib-devel
110%if ! %{no_gnome_askpass}
111BuildRequires: libX11-devel
112BuildRequires: gtk3-devel
113%endif
114BuildRequires: xorg-x11-xauth
115BuildRequires: groff
116BuildRequires: libedit-devel
117%if %{with systemd}
118BuildRequires: systemd-devel
119%endif
120
121
122%package clients
123Summary: OpenSSH clients.
124Summary(ja): OpenSSH Secure Shell プロトコルクライアント
125Requires: openssh = %{version}-%{release}
126Group: Applications/Internet
127Obsoletes: ssh-clients
128Obsoletes: openssh-contrib
129
130%package server
131Summary: The OpenSSH server daemon.
132Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
133Group: System Environment/Daemons
134Obsoletes: ssh-server
135Requires(post): openssh = %{version}-%{release}
136Requires(post): chkconfig
137Requires(pre): shadow-utils
138Requires(post): initscripts >= 5.20
139Requires: pam
140
141%package askpass-gnome
142Summary: A passphrase dialog for OpenSSH, X, and GNOME.
143Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
144Group: Applications/Internet
145Requires: openssh = %{version}-%{release}
146Obsoletes: ssh-extras
147Obsoletes: openssh-askpass < 5.5p1-3vl6
148Provides: openssh-askpass = %{version}-%{release}
149
150%description
151SSH (Secure SHell) is a program for logging into and executing
152commands on a remote machine. SSH is intended to replace rlogin and
153rsh, and to provide secure encrypted communications between two
154untrusted hosts over an insecure network. X11 connections and
155arbitrary TCP/IP ports can also be forwarded over the secure channel.
156
157OpenSSH is OpenBSD's version of the last free version of SSH, bringing
158it up to date in terms of security and features, as well as removing
159all patented algorithms to separate libraries.
160
161This package includes the core files necessary for both the OpenSSH
162client and server. To make this package useful, you should also
163install openssh-clients, openssh-server, or both.
164
165#'
166%description -l ja
167OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
168Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
169するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
170ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
171可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
172な通信路の中を通すことができます。
173
174OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
175最新のセキュリティと機能を提供しています。またすべての特許がからむ
176アルゴリズムは分割したライブラリにわかれています。
177
178このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
179コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
180openssh-clients および/または openssh-server が必要です。
181
182%description clients
183OpenSSH is a free version of SSH (Secure SHell), a program for logging
184into and executing commands on a remote machine. This package includes
185the clients necessary to make encrypted connections to SSH servers.
186You'll also need to install the openssh package on OpenSSH clients.
187
188#'
189%description -l ja clients
190OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
191Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
192するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
193ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
194可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
195な通信路の中を通すことができます。
196
197OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
198最新のセキュリティと機能を提供しています。またすべての特許がからむ
199アルゴリズムは分割したライブラリにわかれています。
200
201このパッケージは OpenSSH をクライアントとして使用する場合に
202必要なものを含んでいます。
203
204
205%description server
206OpenSSH is a free version of SSH (Secure SHell), a program for logging
207into and executing commands on a remote machine. This package contains
208the secure shell daemon (sshd). The sshd daemon allows SSH clients to
209securely connect to your SSH server. You also need to have the openssh
210package installed.
211
212%description -l ja server
213OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
214Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
215するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
216ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
217可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
218な通信路の中を通すことができます。
219
220OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
221最新のセキュリティと機能を提供しています。またすべての特許がからむ
222アルゴリズムは分割したライブラリにわかれています。
223
224このパッケージは OpenSSH をサーバとして使用する場合に必要な
225デーモンなどを含んでいます。
226
227%description askpass-gnome
228OpenSSH is a free version of SSH (Secure SHell), a program for logging
229into and executing commands on a remote machine. This package contains
230an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
231environment.
232
233%description -l ja askpass-gnome
234OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
235Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
236するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
237ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
238可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
239な通信路の中を通すことができます。
240
241OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
242最新のセキュリティと機能を提供しています。またすべての特許がからむ
243アルゴリズムは分割したライブラリにわかれています。
244
245このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
246
247
248%prep
249%setup -q
250%patch0 -p1 -b .vine
251#patch4 -p1 -b .vendor
252
253%if %{WITH_SELINUX}
254#SELinux
255#%patch12 -p1 -b .selinux
256%endif
257
258%patch21 -p1 -b .safe-stop
259%patch24 -p1 -b .fromto-remote
260%patch26 -p1 -b .stack
261# %patch27 -p1 -b .log-chroot
262# %patch30 -p1 -b .exit-deadlock
263%patch35 -p1 -b .progress
264
265%if %{with systemd}
266%patch948 -p1
267%endif
268
269autoreconf
270
271
272%build
273CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
274%if %{rescue}
275CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
276%endif
277%if %{pie}
278%ifarch s390 s390x sparc sparc64
279CFLAGS="$CFLAGS -fPIE"
280%else
281CFLAGS="$CFLAGS -fpie"
282%endif
283export CFLAGS
284LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
285%endif
286
287%configure \
288        --sysconfdir=%{_sysconfdir}/ssh \
289        --libexecdir=%{_libexecdir}/openssh \
290        --datadir=%{_datadir}/openssh \
291        --with-tcp-wrappers \
292        --with-default-path=/usr/local/bin:/bin:/usr/bin \
293        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
294        --with-privsep-path=%{_var}/empty/sshd \
295        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
296        --with-libedit \
297        --with-xauth=/usr/bin/xauth \
298%if %{scard}
299        --with-smartcard \
300%endif
301%if %{noip6}
302        --with-ipv4-default \
303%endif
304%if %{rescue}
305        --without-pam --with-md5-passwords \
306%else
307        --with-pam \
308%endif
309%if %{with systemd}
310        --with-systemd \
311%endif
312        %{nil}
313
314%if %{static_libcrypto}
315perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
316%endif
317
318make
319
320%if %{gtk3}
321        gtk3=yes
322%else
323        gtk3=no
324%endif
325
326%if ! %{no_gnome_askpass}
327pushd contrib
328if [ $gtk3 = yes ]; then
329        make gnome-ssh-askpass3
330        mv gnome-ssh-askpass3 gnome-ssh-askpass
331else
332        make gnome-ssh-askpass2
333        mv gnome-ssh-askpass2 gnome-ssh-askpass
334fi
335popd
336%endif
337
338%install
339rm -rf $RPM_BUILD_ROOT
340mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
341mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
342mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
343mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
344
345make install DESTDIR=$RPM_BUILD_ROOT
346
347touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
348install -d $RPM_BUILD_ROOT/etc/pam.d/
349install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
350install -d $RPM_BUILD_ROOT/etc/sysconfig/
351install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
352install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
353install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
354
355%if %{with systemd}
356install -d -m755 $RPM_BUILD_ROOT/%{_unitdir}
357install -m644 %{SOURCE9} $RPM_BUILD_ROOT/%{_unitdir}/sshd@.service
358install -m644 %{SOURCE10} $RPM_BUILD_ROOT/%{_unitdir}/sshd.socket
359install -m644 %{SOURCE11} $RPM_BUILD_ROOT/%{_unitdir}/sshd.service
360install -m644 %{SOURCE12} $RPM_BUILD_ROOT/%{_unitdir}/sshd-keygen@.service
361install -m644 %{SOURCE15} $RPM_BUILD_ROOT/%{_unitdir}/sshd-keygen.target
362install -m744 %{SOURCE13} $RPM_BUILD_ROOT/%{_libexecdir}/openssh/sshd-keygen
363install -m755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}/
364install contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1/
365install -m644 -D %{SOURCE14} $RPM_BUILD_ROOT%{_tmpfilesdir}/%{name}.conf
366%else
367install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
368%endif
369
370%if ! %{scard}
371        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
372%endif
373
374%if ! %{no_gnome_askpass}
375install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
376install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
377install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
378%endif
379
380%if %{no_gnome_askpass}
381rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
382%endif
383
384# for contrib package
385install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
386install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
387mv contrib/README contrib/README.contrib
388
389perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
390
391%clean
392rm -rf $RPM_BUILD_ROOT
393
394%triggerun server -- ssh-server
395if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
396        touch /var/run/sshd.restart
397fi
398
399%triggerun server -- openssh-server < 2.5.0p1
400# Count the number of HostKey and HostDsaKey statements we have.
401gawk    'BEGIN {IGNORECASE=1}
402         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
403         END {exit sawhostkey}' /etc/ssh/sshd_config
404# And if we only found one, we know the client was relying on the old default
405# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
406# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
407# one nullifies the default, which would have loaded both.
408if [ $? -eq 1 ] ; then
409        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
410        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
411fi
412
413%triggerpostun server -- ssh-server
414if [ "$1" != 0 ] ; then
415        /sbin/chkconfig --add sshd
416        if test -f /var/run/sshd.restart ; then
417                rm -f /var/run/sshd.restart
418                # /sbin/service sshd start > /dev/null 2>&1 || :
419                /sbin/service sshd start
420        fi
421fi
422
423%if %{with systemd}
424%pre
425getent group ssh_keys >/dev/null || groupadd -r ssh_keys || :
426%endif
427
428%pre server
429%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
430%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
431        -g sshd -M -r sshd 2>/dev/null || :
432
433%post server
434%if %{with systemd}
435%systemd_post sshd.service sshd.socket
436%else
437/sbin/chkconfig --add sshd
438%endif
439
440%postun server
441%if %{with systemd}
442%systemd_postun_with_restart sshd.service
443%else
444# /sbin/service sshd condrestart > /dev/null 2>&1 || :
445/sbin/service sshd condrestart
446exit 0
447%endif
448
449%preun server
450%if %{with systemd}
451%systemd_preun sshd.service sshd.socket
452%else
453if [ "$1" = 0 -o -x /bin/systemctl ]; then
454        /sbin/service sshd stop > /dev/null 2>&1 || :
455        /sbin/chkconfig --del sshd
456%endif
457fi
458
459
460%files
461%defattr(-,root,root)
462%license LICENCE
463%doc CREDITS ChangeLog INSTALL OVERVIEW PROTOCOL* README* TODO
464%attr(0755,root,root) %dir %{_sysconfdir}/ssh
465%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
466%attr(644,root,root) %{_mandir}/man5/moduli.5*
467%if ! %{rescue}
468%attr(0755,root,root) %{_bindir}/ssh-keygen
469%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
470%attr(0755,root,root) %dir %{_libexecdir}/openssh
471%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
472%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
473%endif
474%if %{scard}
475%attr(0755,root,root) %dir %{_datadir}/openssh
476%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
477%endif
478
479%files clients
480%defattr(-,root,root)
481%attr(0755,root,root) %{_bindir}/scp
482%attr(0755,root,root) %{_bindir}/ssh
483%attr(0644,root,root) %{_mandir}/man1/scp.1*
484%attr(0644,root,root) %{_mandir}/man1/ssh.1*
485%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
486# %attr(0644,root,root) %{_mandir}/man1/slogin.1*
487%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
488# %attr(-,root,root) %{_bindir}/slogin
489%if ! %{rescue}
490%attr(0755,root,root) %{_bindir}/ssh-agent
491%attr(0755,root,root) %{_bindir}/ssh-add
492%attr(0755,root,root) %{_bindir}/ssh-keyscan
493%attr(0755,root,root) %{_bindir}/sftp
494%attr(0755,root,root) %{_bindir}/ssh-copy-id
495%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
496%attr(0755,root,root) %{_libexecdir}/openssh/ssh-sk-helper
497%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
498%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
499%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
500%attr(0644,root,root) %{_mandir}/man1/sftp.1*
501%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
502%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
503%attr(0644,root,root) %{_mandir}/man8/ssh-sk-helper.8*
504%endif
505
506%if ! %{rescue}
507%files server
508%defattr(-,root,root)
509%dir %attr(0711,root,root) %{_var}/empty/sshd
510%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
511%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
512%attr(0755,root,root) %{_sbindir}/sshd
513%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
514%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
515%attr(0644,root,root) %{_mandir}/man8/sshd.8*
516%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
517%attr(0755,root,root) %dir %{_sysconfdir}/ssh
518%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
519%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
520%attr(0755,root,root) %config /etc/sysconfig/sshd
521%if %{with systemd}
522%attr(0755,root,root) %{_libexecdir}/openssh/sshd-keygen
523%attr(0644,root,root) %{_unitdir}/sshd.service
524%attr(0644,root,root) %{_unitdir}/sshd@.service
525%attr(0644,root,root) %{_unitdir}/sshd.socket
526%attr(0644,root,root) %{_unitdir}/sshd-keygen@.service
527%attr(0644,root,root) %{_unitdir}/sshd-keygen.target
528%attr(0644,root,root) %{_tmpfilesdir}/openssh.conf
529%else
530%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
531%endif
532%endif
533
534%if ! %{no_gnome_askpass}
535%files askpass-gnome
536%defattr(-,root,root)
537%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
538%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
539%endif
540
541
542%changelog
543* Wed May 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.3p1-1
544- new upstream release.
545
546* Thu Apr 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2p1-2
547- added systemd support (disabled as default).
548
549* Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2p1-1
550- new upstream release.
551- updated Patch35.
552
553* Thu Oct 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1p1-1
554- new upstream release.
555
556* Sat Jun 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0p1-1
557- new upstream release.
558- moved scp to openssh-clients.
559- changed "PasswordAuthentication" to "no" as default.
560- dropped Patch4.
561- updated Patch35 to use GTK+3 for gnome-ssh-askpass.
562
563* Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.9p1-1
564- new upstream release.
565- updated Patch4.
566
567* Wed Nov 15 2017 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.6p1-1
568- new upstream release.
569- update patch0,4,21,24
570- update patch35 from fc26
571- drop patch12,20,30
572
573* Fri Aug  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.2p2-2
574- disabled rsa1 hostkey generation.
575
576* Sat Jul 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.2p2-1
577- new upstream release.
578
579* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.2p1-1
580- new upstream release
581- built with openssl 1.0.2g
582- drop slogin command and manual, this is upstream change.
583
584* Sun Jan 17 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p2-1
585- update to 7.1p2
586
587* Mon Dec 28 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p1-1
588- update to 7.1p1
589- remove patch100 to use default value "prohibit-password" for PermitRootLogin
590
591* Tue Oct 14 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.7p1-1
592- update to 6.7p1
593- fix sshd.init
594
595* Thu Aug 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.6p1-1
596- update to 6.6p1
597- remove BR: sharutils
598- add BR: libdb-devel instead of db4-devel
599
600* Tue Feb 04 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 6.5p1-1
601- update to 6.5p1
602- update sshd_config
603  - generate ED25519 host key.
604
605* Tue Nov 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.4p1-1
606- update to 6.4p1
607
608* Mon May 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p2-1
609- update to 6.2p2
610
611* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p1-1
612- update to 6.2p1
613
614* Fri Nov  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.1p1-1
615- new upstream release
616- add -with-xauth option in configure
617- patch4, 30, 35 are updated from fc18
618
619* Mon May 07 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0p1-1
620- new upstream release
621
622* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9p1-1
623- new upstream release
624
625* Sun May  8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
626- new upstream release
627
628* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
629- add our own sshd.init based on fedora's sshd.init
630  - generate ECDSA host key.
631
632* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
633- new upstream release
634
635* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
636- new upstream release
637
638* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
639- new upstream release
640- obsolete contrib subpackage, move ssh-copy-id to client subpackage
641
642* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
643- rebuilt with openssl 1.0.0c
644
645* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
646- drop x11-askpass, add Obsoletes: openssh-askpass
647- add BR: groff
648- enable --with-libedit option, add BR: libedit-devel
649- remove unrecognized option '--with-rsh'
650
651* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
652- add BR: xorg-x11-xauth for X11 forwarding support
653
654* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
655- new upstream release
656- update patch0,2
657- drop patch3,22
658
659* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
660- new upstream release
661
662* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
663- new upstream release
664
665* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
666- rebuild with xorg-x11-7.3
667
668* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
669- new upstream release with security fix (CVE-2008-1483)
670- drop patch31 which is included in new release (This was for CVE-2008-1483)
671
672* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
673- new upstream release with security fix ("ForceCommand" Directive)
674- turn on daemon restart message
675- new versioning policy
676
677* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
678- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
679
680* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
681- new upstream release
682
683* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
684- build with -fpie/-pie by default.
685- enable ipv6 by default.
686
687* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
688- new upstream release
689
690* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
691- new upstream release
692
693* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
694- new upstream release
695
696* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
697- new upstream release
698
699* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
700- new upstream release
701- remove build6x stuff
702- remove libgnome-devel from BuildRequires
703- cleanup BuildRequires
704- drop Patch200, it is merged in upstream.
705- import patches(25-35) from FC-devel
706
707* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
708- SECURITY FIX: CVE-2006-0225
709  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
710- update BuildPreReq: s/XFree86-devel/XOrg-devel/
711- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
712  - When GNOME2 is used, using libgnome-devel
713  - add BuildPreReq: gtk2-devel for GNOME2
714
715* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
716- rebuild with gtk+-2.8 final
717
718* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
719- new upstream release
720- build with gtk+-2.7
721
722* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
723- new upstream release
724
725* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
726- cleanup obsolete patches and added patches from fedora
727
728* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
729- new upstream release
730
731* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
732- new upstream release
733
734* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
735- new upstream release
736
737* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
738- rebuild with openssl-0.9.7d
739
740* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
741- new upstream release
742
743* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
744- create contrib package
745
746* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
747- new upstream release
748- fix security issue: http://www.openssh.com/txt/sshpam.adv
749
750* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
751- new upstream release
752- fix security issue: http://www.openssh.com/txt/buffer.adv
753
754* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
755- new upstream release
756
757* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
758- rebuild with gtk2
759
760* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
761- new upstream release
762
763* Sun Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
764- rebuild with new tool chain
765
766* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
767- new upstream release
768- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
769
770* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
771- change some defines in spec files
772
773* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
774- add patch110 ( 3.4p1 does not include mmap-fallback patch )
775
776* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
777- new upstream release
778  - security fix
779- drop patch10
780
781* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
782- add patch from Solar Designer to make privsep work with a 2.2 kernel.
783
784* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
785- new upstream release
786- add {sshd,ssh}_config.5 manpages
787- add ssh-keysign
788
789* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
790- new upstream release
791
792* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
793- new upstream release
794- drop patch1
795
796* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
797- new upstream release
798- merged with rawhide release.
799- drop Patch101 (merged in upstream)
800
801* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
802- seurity patch for off-by-one bug
803
804* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
805- merged with Rawhide 3.0.2p1-2
806
807* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
808- updated to 3.0.2p1
809
810* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
811- updated to 3.0.1p1
812
813* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
814- updated to 3.0p1
815
816* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
817- add japanese summery and descriptions.
818- update x11-askpass 1.2.5
819
820* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
821- update to openssh-2.9.9p2
822
823* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
824- rebuilt with openssl-0.9.6b
825
826* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
827- do not Permit RootLogin
828
829* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
830- update to openssh-2.5.2p2
831
832* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
833- update to openssh-2.5.2p1
834
835* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
836- update to openssh-2.5.1p2
837
838* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
839- update to openssh-2.5.1p1
840
841* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
842- update to openssh-2.5.1p1
843
844* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
845- remove suid bit from ssh
846
847* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
848- moved man dir to /usr/share/man
849
850* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
851- fixed askpass's link in ssh-add
852- partially used rpmmacros
853
854* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
855- update to 2.3.0p1
856- update x11-askpass 1.0.3
857
858* Wed Oct 18 2000 Damien Miller <djm@mindrot.org>
859- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
860  Redhat 7.0 spec file
861
862* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
863- rebuild for Vine Linux
864
865* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
866- Use RPM configure macro
867* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
868- Some surgery to sshd.init (generate keys at runtime)
869- Cleanup of groups and removal of keygen calls
870* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
871- Make building of X11-askpass and gnome-askpass optional
872* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
873- Glob manpages to catch compressed files
874* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
875- Updated for new location
876- Updated for new gnome-ssh-askpass build
877* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
878- Added Jim Knoble's <jmknoble@pobox.com> askpass
879* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
880- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
881* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
882- Added 'Obsoletes' directives
883* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
884- Use make install
885- Subpackages
886* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
887- Added links for slogin
888- Fixed perms on manpages
889* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
890- Renamed init script
891* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
892- Back to old binary names
893* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
894- Use autoconf
895- New binary names
896* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
897- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
898
899
Note: See TracBrowser for help on using the repository browser.