source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 10064

Revision 10064, 26.8 KB checked in by iwamoto, 8 years ago (diff)

openssh: update to 7.2p1 and built with openssl 1.0.2g

Line 
1%define ver 7.2p1
2%define rel 1%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66
67Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
68
69Patch0: openssh-6.4p1-vine.patch
70Patch4: openssh-7.0p1-vendor.patch
71Patch12: openssh-selinux.patch
72Patch20: openssh-3.9p1-gssapimitm.patch
73Patch21: openssh-3.9p1-safe-stop.patch
74Patch24: openssh-5.7p1-fromto-remote.patch
75Patch26: openssh-5.2p1-pam-no-stack.patch
76# Patch27: openssh-5.1p1-log-in-chroot.patch
77Patch30: openssh-5.6p1-exit-deadlock.patch
78# Patch31: openssh-3.9p1-skip-used.patch
79Patch35: openssh-5.1p1-askpass-progress.patch
80
81# Vine Source
82Source100: sshd.init.vine
83Source110: sshd.sysconfig.vine
84
85License: BSD
86Group: Applications/Internet
87BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
88
89Obsoletes: ssh
90
91BuildRequires: perl, openssl-devel, tcp_wrappers
92BuildRequires: util-linux
93%if "%{_dist_release}" >= "vl7"
94BuildRequires: libdb-devel
95%else
96BuildRequires: db4-devel
97%endif
98BuildRequires: pam-devel
99BuildRequires: zlib-devel
100%if ! %{no_gnome_askpass}
101BuildRequires: libX11-devel
102BuildRequires: gtk2-devel
103%endif
104BuildRequires: xorg-x11-xauth
105BuildRequires: groff
106BuildRequires: libedit-devel
107
108Vendor: Project Vine
109Distribution: Vine Linux
110Packager: daisuke
111
112%package clients
113Summary: OpenSSH clients.
114Summary(ja): OpenSSH Secure Shell プロトコルクライアント
115Requires: openssh = %{version}-%{release}
116Group: Applications/Internet
117Obsoletes: ssh-clients
118Obsoletes: openssh-contrib
119
120%package server
121Summary: The OpenSSH server daemon.
122Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
123Group: System Environment/Daemons
124Obsoletes: ssh-server
125Requires(post): openssh = %{version}-%{release}
126Requires(post): chkconfig
127Requires(pre): shadow-utils
128Requires(post): initscripts >= 5.20
129Requires: pam
130
131%package askpass-gnome
132Summary: A passphrase dialog for OpenSSH, X, and GNOME.
133Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
134Group: Applications/Internet
135Requires: openssh = %{version}-%{release}
136Obsoletes: ssh-extras
137Obsoletes: openssh-askpass < 5.5p1-3vl6
138Provides: openssh-askpass = %{version}-%{release}
139
140%description
141SSH (Secure SHell) is a program for logging into and executing
142commands on a remote machine. SSH is intended to replace rlogin and
143rsh, and to provide secure encrypted communications between two
144untrusted hosts over an insecure network. X11 connections and
145arbitrary TCP/IP ports can also be forwarded over the secure channel.
146
147OpenSSH is OpenBSD's version of the last free version of SSH, bringing
148it up to date in terms of security and features, as well as removing
149all patented algorithms to separate libraries.
150
151This package includes the core files necessary for both the OpenSSH
152client and server. To make this package useful, you should also
153install openssh-clients, openssh-server, or both.
154
155#'
156%description -l ja
157OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
158Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
159するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
160ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
161可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
162な通信路の中を通すことができます。
163
164OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
165最新のセキュリティと機能を提供しています。またすべての特許がからむ
166アルゴリズムは分割したライブラリにわかれています。
167
168このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
169コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
170openssh-clients および/または openssh-server が必要です。
171
172%description clients
173OpenSSH is a free version of SSH (Secure SHell), a program for logging
174into and executing commands on a remote machine. This package includes
175the clients necessary to make encrypted connections to SSH servers.
176You'll also need to install the openssh package on OpenSSH clients.
177
178#'
179%description -l ja clients
180OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
181Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
182するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
183ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
184可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
185な通信路の中を通すことができます。
186
187OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
188最新のセキュリティと機能を提供しています。またすべての特許がからむ
189アルゴリズムは分割したライブラリにわかれています。
190
191このパッケージは OpenSSH をクライアントとして使用する場合に
192必要なものを含んでいます。
193
194
195%description server
196OpenSSH is a free version of SSH (Secure SHell), a program for logging
197into and executing commands on a remote machine. This package contains
198the secure shell daemon (sshd). The sshd daemon allows SSH clients to
199securely connect to your SSH server. You also need to have the openssh
200package installed.
201
202%description -l ja server
203OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
204Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
205するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
206ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
207可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
208な通信路の中を通すことができます。
209
210OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
211最新のセキュリティと機能を提供しています。またすべての特許がからむ
212アルゴリズムは分割したライブラリにわかれています。
213
214このパッケージは OpenSSH をサーバとして使用する場合に必要な
215デーモンなどを含んでいます。
216
217%description askpass-gnome
218OpenSSH is a free version of SSH (Secure SHell), a program for logging
219into and executing commands on a remote machine. This package contains
220an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
221environment.
222
223%description -l ja askpass-gnome
224OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
225Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
226するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
227ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
228可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
229な通信路の中を通すことができます。
230
231OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
232最新のセキュリティと機能を提供しています。またすべての特許がからむ
233アルゴリズムは分割したライブラリにわかれています。
234
235このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
236
237%prep
238
239%setup -q
240%patch0 -p1 -b .vine
241%patch4 -p1 -b .vendor
242
243%if %{WITH_SELINUX}
244#SELinux
245%patch12 -p1 -b .selinux
246%endif
247
248%patch21 -p1 -b .safe-stop
249%patch24 -p1 -b .fromto-remote
250%patch26 -p1 -b .stack
251# %patch27 -p1 -b .log-chroot
252%patch30 -p1 -b .exit-deadlock
253%patch35 -p1 -b .progress
254
255autoreconf
256
257
258%build
259CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
260%if %{rescue}
261CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
262%endif
263%if %{pie}
264%ifarch s390 s390x sparc sparc64
265CFLAGS="$CFLAGS -fPIE"
266%else
267CFLAGS="$CFLAGS -fpie"
268%endif
269export CFLAGS
270LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
271%endif
272
273%configure \
274        --sysconfdir=%{_sysconfdir}/ssh \
275        --libexecdir=%{_libexecdir}/openssh \
276        --datadir=%{_datadir}/openssh \
277        --with-tcp-wrappers \
278        --with-default-path=/usr/local/bin:/bin:/usr/bin \
279        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
280        --with-privsep-path=%{_var}/empty/sshd \
281        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
282        --with-libedit \
283        --with-xauth=/usr/bin/xauth \
284%if %{scard}
285        --with-smartcard \
286%endif
287%if %{noip6}
288        --with-ipv4-default \
289%endif
290%if %{rescue}
291        --without-pam --with-md5-passwords
292%else
293        --with-pam
294%endif
295
296%if %{static_libcrypto}
297perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
298%endif
299
300make
301
302%if %{gtk2}
303        gtk2=yes
304%else
305        gtk2=no
306%endif
307
308%if ! %{no_gnome_askpass}
309pushd contrib
310if [ $gtk2 = yes ]; then
311        make gnome-ssh-askpass2
312        mv gnome-ssh-askpass2 gnome-ssh-askpass
313else
314        make gnome-ssh-askpass1
315        mv gnome-ssh-askpass1 gnome-ssh-askpass
316fi
317popd
318%endif
319
320%install
321rm -rf $RPM_BUILD_ROOT
322mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
323mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
324mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
325mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
326
327make install DESTDIR=$RPM_BUILD_ROOT
328
329touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
330install -d $RPM_BUILD_ROOT/etc/pam.d/
331install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
332install -d $RPM_BUILD_ROOT/etc/sysconfig/
333install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
334install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
335install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
336install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
337
338%if ! %{scard}
339        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
340%endif
341
342%if ! %{no_gnome_askpass}
343install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
344install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
345install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
346%endif
347
348%if %{no_gnome_askpass}
349rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
350%endif
351
352# for contrib package
353install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
354install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
355mv contrib/README contrib/README.contrib
356
357perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
358
359%clean
360rm -rf $RPM_BUILD_ROOT
361
362%triggerun server -- ssh-server
363if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
364        touch /var/run/sshd.restart
365fi
366
367%triggerun server -- openssh-server < 2.5.0p1
368# Count the number of HostKey and HostDsaKey statements we have.
369gawk    'BEGIN {IGNORECASE=1}
370         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
371         END {exit sawhostkey}' /etc/ssh/sshd_config
372# And if we only found one, we know the client was relying on the old default
373# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
374# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
375# one nullifies the default, which would have loaded both.
376if [ $? -eq 1 ] ; then
377        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
378        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
379fi
380
381%triggerpostun server -- ssh-server
382if [ "$1" != 0 ] ; then
383        /sbin/chkconfig --add sshd
384        if test -f /var/run/sshd.restart ; then
385                rm -f /var/run/sshd.restart
386                # /sbin/service sshd start > /dev/null 2>&1 || :
387                /sbin/service sshd start
388        fi
389fi
390
391%pre server
392%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
393%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
394        -g sshd -M -r sshd 2>/dev/null || :
395
396%post server
397/sbin/chkconfig --add sshd
398
399%postun server
400# /sbin/service sshd condrestart > /dev/null 2>&1 || :
401/sbin/service sshd condrestart
402exit 0
403
404%preun server
405if [ "$1" = 0 ]
406then
407        /sbin/service sshd stop > /dev/null 2>&1 || :
408        /sbin/chkconfig --del sshd
409fi
410
411%files
412%defattr(-,root,root)
413%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
414%attr(0755,root,root) %{_bindir}/scp
415%attr(0644,root,root) %{_mandir}/man1/scp.1*
416%attr(0755,root,root) %dir %{_sysconfdir}/ssh
417%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
418%attr(644,root,root) %{_mandir}/man5/moduli.5*
419%if ! %{rescue}
420%attr(0755,root,root) %{_bindir}/ssh-keygen
421%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
422%attr(0755,root,root) %dir %{_libexecdir}/openssh
423%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
424%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
425%endif
426%if %{scard}
427%attr(0755,root,root) %dir %{_datadir}/openssh
428%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
429%endif
430
431%files clients
432%defattr(-,root,root)
433%attr(0755,root,root) %{_bindir}/ssh
434%attr(0644,root,root) %{_mandir}/man1/ssh.1*
435%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
436# %attr(0644,root,root) %{_mandir}/man1/slogin.1*
437%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
438# %attr(-,root,root) %{_bindir}/slogin
439%if ! %{rescue}
440%attr(0755,root,root) %{_bindir}/ssh-agent
441%attr(0755,root,root) %{_bindir}/ssh-add
442%attr(0755,root,root) %{_bindir}/ssh-keyscan
443%attr(0755,root,root) %{_bindir}/sftp
444%attr(0755,root,root) %{_bindir}/ssh-copy-id
445%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
446%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
447%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
448%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
449%attr(0644,root,root) %{_mandir}/man1/sftp.1*
450%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
451%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
452%endif
453
454%if ! %{rescue}
455%files server
456%defattr(-,root,root)
457%dir %attr(0711,root,root) %{_var}/empty/sshd
458%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
459%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
460%attr(0755,root,root) %{_sbindir}/sshd
461%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
462%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
463%attr(0644,root,root) %{_mandir}/man8/sshd.8*
464%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
465%attr(0755,root,root) %dir %{_sysconfdir}/ssh
466%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
467%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
468%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
469%attr(0755,root,root) %config /etc/sysconfig/sshd
470%endif
471
472%if ! %{no_gnome_askpass}
473%files askpass-gnome
474%defattr(-,root,root)
475%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
476%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
477%endif
478
479
480%changelog
481* Wed Mar  9 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.2p1-1
482- new upstream release
483- built with openssl 1.0.2g
484- drop slogin command and manual, this is upstream change.
485
486* Sun Jan 17 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p2-1
487- update to 7.1p2
488
489* Mon Dec 28 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 7.1p1-1
490- update to 7.1p1
491- remove patch100 to use default value "prohibit-password" for PermitRootLogin
492
493* Tue Oct 14 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.7p1-1
494- update to 6.7p1
495- fix sshd.init
496
497* Thu Aug 07 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 6.6p1-1
498- update to 6.6p1
499- remove BR: sharutils
500- add BR: libdb-devel instead of db4-devel
501
502* Tue Feb 04 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 6.5p1-1
503- update to 6.5p1
504- update sshd_config
505  - generate ED25519 host key.
506
507* Tue Nov 12 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.4p1-1
508- update to 6.4p1
509
510* Mon May 20 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p2-1
511- update to 6.2p2
512
513* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2p1-1
514- update to 6.2p1
515
516* Fri Nov  2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 6.1p1-1
517- new upstream release
518- add -with-xauth option in configure
519- patch4, 30, 35 are updated from fc18
520
521* Mon May 07 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 6.0p1-1
522- new upstream release
523
524* Tue Mar 06 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 5.9p1-1
525- new upstream release
526
527* Sun May  8 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.8p2-1
528- new upstream release
529
530* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
531- add our own sshd.init based on fedora's sshd.init
532  - generate ECDSA host key.
533
534* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
535- new upstream release
536
537* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
538- new upstream release
539
540* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
541- new upstream release
542- obsolete contrib subpackage, move ssh-copy-id to client subpackage
543
544* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
545- rebuilt with openssl 1.0.0c
546
547* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
548- drop x11-askpass, add Obsoletes: openssh-askpass
549- add BR: groff
550- enable --with-libedit option, add BR: libedit-devel
551- remove unrecognized option '--with-rsh'
552
553* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
554- add BR: xorg-x11-xauth for X11 forwarding support
555
556* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
557- new upstream release
558- update patch0,2
559- drop patch3,22
560
561* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
562- new upstream release
563
564* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
565- new upstream release
566
567* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
568- rebuild with xorg-x11-7.3
569
570* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
571- new upstream release with security fix (CVE-2008-1483)
572- drop patch31 which is included in new release (This was for CVE-2008-1483)
573
574* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
575- new upstream release with security fix ("ForceCommand" Directive)
576- turn on daemon restart message
577- new versioning policy
578
579* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
580- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
581
582* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
583- new upstream release
584
585* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
586- build with -fpie/-pie by default.
587- enable ipv6 by default.
588
589* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
590- new upstream release
591
592* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
593- new upstream release
594
595* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
596- new upstream release
597
598* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
599- new upstream release
600
601* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
602- new upstream release
603- remove build6x stuff
604- remove libgnome-devel from BuildRequires
605- cleanup BuildRequires
606- drop Patch200, it is merged in upstream.
607- import patches(25-35) from FC-devel
608
609* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
610- SECURITY FIX: CVE-2006-0225
611  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
612- update BuildPreReq: s/XFree86-devel/XOrg-devel/
613- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
614  - When GNOME2 is used, using libgnome-devel
615  - add BuildPreReq: gtk2-devel for GNOME2
616
617* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
618- rebuild with gtk+-2.8 final
619
620* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
621- new upstream release
622- build with gtk+-2.7
623
624* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
625- new upstream release
626
627* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
628- cleanup obsolete patches and added patches from fedora
629
630* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
631- new upstream release
632
633* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
634- new upstream release
635
636* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
637- new upstream release
638
639* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
640- rebuild with openssl-0.9.7d
641
642* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
643- new upstream release
644
645* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
646- create contrib package
647
648* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
649- new upstream release
650- fix security issue: http://www.openssh.com/txt/sshpam.adv
651
652* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
653- new upstream release
654- fix security issue: http://www.openssh.com/txt/buffer.adv
655
656* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
657- new upstream release
658
659* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
660- rebuild with gtk2
661
662* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
663- new upstream release
664
665* Sun Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
666- rebuild with new tool chain
667
668* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
669- new upstream release
670- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
671
672* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
673- change some defines in spec files
674
675* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
676- add patch110 ( 3.4p1 does not include mmap-fallback patch )
677
678* Thu Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
679- new upstream release
680  - security fix
681- drop patch10
682
683* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
684- add patch from Solar Designer to make privsep work with a 2.2 kernel.
685
686* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
687- new upstream release
688- add {sshd,ssh}_config.5 manpages
689- add ssh-keysign
690
691* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
692- new upstream release
693
694* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
695- new upstream release
696- drop patch1
697
698* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
699- new upstream release
700- merged with rawhide release.
701- drop Patch101 (merged in upstream)
702
703* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
704- seurity patch for off-by-one bug
705
706* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
707- merged with Rawhide 3.0.2p1-2
708
709* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
710- updated to 3.0.2p1
711
712* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
713- updated to 3.0.1p1
714
715* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
716- updated to 3.0p1
717
718* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
719- add japanese summery and descriptions.
720- update x11-askpass 1.2.5
721
722* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
723- update to openssh-2.9.9p2
724
725* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
726- rebuilt with openssl-0.9.6b
727
728* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
729- do not Permit RootLogin
730
731* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
732- update to openssh-2.5.2p2
733
734* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
735- update to openssh-2.5.2p1
736
737* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
738- update to openssh-2.5.1p2
739
740* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
741- update to openssh-2.5.1p1
742
743* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
744- update to openssh-2.5.1p1
745
746* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
747- remove suid bit from ssh
748
749* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
750- moved man dir to /usr/share/man
751
752* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
753- fixed askpass's link in ssh-add
754- partially used rpmmacros
755
756* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
757- update to 2.3.0p1
758- update x11-askpass 1.0.3
759
760* Wed Oct 18 2000 Damien Miller <djm@mindrot.org>
761- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
762  Redhat 7.0 spec file
763
764* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
765- rebuild for Vine Linux
766
767* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
768- Use RPM configure macro
769* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
770- Some surgery to sshd.init (generate keys at runtime)
771- Cleanup of groups and removal of keygen calls
772* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
773- Make building of X11-askpass and gnome-askpass optional
774* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
775- Glob manpages to catch compressed files
776* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
777- Updated for new location
778- Updated for new gnome-ssh-askpass build
779* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
780- Added Jim Knoble's <jmknoble@pobox.com> askpass
781* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
782- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
783* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
784- Added 'Obsoletes' directives
785* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
786- Use make install
787- Subpackages
788* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
789- Added links for slogin
790- Fixed perms on manpages
791* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
792- Renamed init script
793* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
794- Back to old binary names
795* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
796- Use autoconf
797- New binary names
798* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
799- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
800
801
Note: See TracBrowser for help on using the repository browser.