source: projects/specs/trunk/o/openssh/openssh-vl.spec @ 3587

Revision 3587, 25.3 KB checked in by daisuke, 13 years ago (diff)

openssh: update sshd.init

Line 
1%define ver 5.8p1
2%define rel 2%{_dist_release}
3
4# SELinux
5%define WITH_SELINUX 0
6
7# OpenSSH privilege separation requires a user & group ID
8%define sshd_uid    74
9%define sshd_gid    74
10
11# Version of ssh-askpass
12%define aversion 1.2.4.1
13
14# Do we want to disable building of gnome-askpass? (1=yes 0=no)
15%define no_gnome_askpass 0
16
17# Use GTK2 for gnome-ssh-askpass
18%define gtk2 1
19
20# Build position-independent executables (requires toolchain support)?
21%define pie 1
22
23# Do we want to link against a static libcrypto? (1=yes 0=no)
24%define static_libcrypto 0
25
26# Do we want smartcard support (1=yes 0=no)
27%define scard 0
28
29# Disable IPv6 (avoids DNS hangs on some glibc versions)
30%define noip6 0
31
32# Do we want kerberos5 support (1=yes 0=no)
33%define kerberos5 0
34
35# Reserve options to override askpass settings with:
36# rpm -ba|--rebuild --define 'skip_xxx 1'
37%{?skip_gnome_askpass:%define no_gnome_askpass 1}
38
39# Options for static OpenSSL link:
40# rpm -ba|--rebuild --define "static_openssl 1"
41%{?static_openssl:%define static_libcrypto 1}
42
43# Options for Smartcard support: (needs libsectok and openssl-engine)
44# rpm -ba|--rebuild --define "smartcard 1"
45%{?smartcard:%define scard 1}
46
47# Option to disable ipv6
48# rpm -ba|--rebuild --define "noipv6 1"
49%{?noipv6:%define noip6 1}
50
51# Is this a build for the rescue CD (without PAM)? (1=yes 0=no)
52%define rescue 0
53%{?build_rescue:%define rescue 1}
54
55# Turn off some stuff for resuce builds
56%if %{rescue}
57%define kerberos5 0
58%endif
59
60Summary: The OpenSSH implementation of SSH.
61Summary(ja): OpenSSH - フリーの Secure Shell (SSH) の実装
62Name: openssh
63Version: %{ver}
64Release: %{rel}
65URL: http://www.openssh.com/portable.html
66
67Source0: ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-%{version}.tar.gz
68
69Patch0: openssh-5.5p1-vine.patch
70Patch4: openssh-5.2p1-vendor.patch
71Patch12: openssh-selinux.patch
72Patch20: openssh-3.9p1-gssapimitm.patch
73Patch21: openssh-3.9p1-safe-stop.patch
74Patch24: openssh-5.7p1-fromto-remote.patch
75Patch26: openssh-5.2p1-pam-no-stack.patch
76Patch27: openssh-5.1p1-log-in-chroot.patch
77Patch30: openssh-4.0p1-exit-deadlock.patch
78# Patch31: openssh-3.9p1-skip-used.patch
79Patch35: openssh-4.2p1-askpass-progress.patch
80
81# Vine Source
82Source100: sshd.init
83Source110: sshd.sysconfig
84
85# Vine Patch
86Patch100: openssh-norootlogin.patch
87
88License: BSD
89Group: Applications/Internet
90BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
91
92Obsoletes: ssh
93
94BuildRequires: perl, openssl-devel, sharutils, tcp_wrappers
95BuildRequires: util-linux
96BuildRequires: db4-devel
97BuildRequires: pam-devel
98BuildRequires: zlib-devel
99%if ! %{no_gnome_askpass}
100BuildRequires: libX11-devel
101BuildRequires: gtk2-devel
102%endif
103BuildRequires: xorg-x11-xauth
104BuildRequires: groff
105BuildRequires: libedit-devel
106
107Vendor: Project Vine
108Distribution: Vine Linux
109Packager: daisuke
110
111%package clients
112Summary: OpenSSH clients.
113Summary(ja): OpenSSH Secure Shell プロトコルクライアント
114Requires: openssh = %{version}-%{release}
115Group: Applications/Internet
116Obsoletes: ssh-clients
117Obsoletes: openssh-contrib
118
119%package server
120Summary: The OpenSSH server daemon.
121Summary(ja): OpenSSH Secure Shell プロトコルサーバ (sshd)
122Group: System Environment/Daemons
123Obsoletes: ssh-server
124Requires(post): openssh = %{version}-%{release}
125Requires(post): chkconfig
126Requires(pre): shadow-utils
127Requires(post): initscripts >= 5.20
128Requires: pam
129
130%package askpass-gnome
131Summary: A passphrase dialog for OpenSSH, X, and GNOME.
132Summary(ja): OpenSSH GNOME パスフレーズ入力ダイアログ
133Group: Applications/Internet
134Requires: openssh = %{version}-%{release}
135Obsoletes: ssh-extras
136Obsoletes: openssh-askpass < 5.5p1-3vl6
137Provides: openssh-askpass = %{version}-%{release}
138
139%description
140SSH (Secure SHell) is a program for logging into and executing
141commands on a remote machine. SSH is intended to replace rlogin and
142rsh, and to provide secure encrypted communications between two
143untrusted hosts over an insecure network. X11 connections and
144arbitrary TCP/IP ports can also be forwarded over the secure channel.
145
146OpenSSH is OpenBSD's version of the last free version of SSH, bringing
147it up to date in terms of security and features, as well as removing
148all patented algorithms to separate libraries.
149
150This package includes the core files necessary for both the OpenSSH
151client and server. To make this package useful, you should also
152install openssh-clients, openssh-server, or both.
153
154#'
155%description -l ja
156OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
157Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
158するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
159ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
160可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
161な通信路の中を通すことができます。
162
163OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
164最新のセキュリティと機能を提供しています。またすべての特許がからむ
165アルゴリズムは分割したライブラリにわかれています。
166
167このパッケージは OpenSSH のクライアントとサーバの両方で必要とされる
168コアのファイルを含んでいます。実際に使用するにはこのパッケージの他に
169openssh-clients および/または openssh-server が必要です。
170
171%description clients
172OpenSSH is a free version of SSH (Secure SHell), a program for logging
173into and executing commands on a remote machine. This package includes
174the clients necessary to make encrypted connections to SSH servers.
175You'll also need to install the openssh package on OpenSSH clients.
176
177#'
178%description -l ja clients
179OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
180Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
181するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
182ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
183可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
184な通信路の中を通すことができます。
185
186OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
187最新のセキュリティと機能を提供しています。またすべての特許がからむ
188アルゴリズムは分割したライブラリにわかれています。
189
190このパッケージは OpenSSH をクライアントとして使用する場合に
191必要なものを含んでいます。
192
193
194%description server
195OpenSSH is a free version of SSH (Secure SHell), a program for logging
196into and executing commands on a remote machine. This package contains
197the secure shell daemon (sshd). The sshd daemon allows SSH clients to
198securely connect to your SSH server. You also need to have the openssh
199package installed.
200
201%description -l ja server
202OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
203Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
204するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
205ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
206可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
207な通信路の中を通すことができます。
208
209OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
210最新のセキュリティと機能を提供しています。またすべての特許がからむ
211アルゴリズムは分割したライブラリにわかれています。
212
213このパッケージは OpenSSH をサーバとして使用する場合に必要な
214デーモンなどを含んでいます。
215
216%description askpass-gnome
217OpenSSH is a free version of SSH (Secure SHell), a program for logging
218into and executing commands on a remote machine. This package contains
219an X11 passphrase dialog for OpenSSH and the GNOME GUI desktop
220environment.
221
222%description -l ja askpass-gnome
223OpenSSH は、ネットワーク接続ツールである SSH プロトコル実装の フリー版 です。
224Ssh はリモートマシンへログインしたり、リモートマシンでコマンドを実行したり
225するためのプログラムです。rlogin や rsh を置き換えるもので、二つの信頼でき
226ないホスト間の信頼できない通信路でセキュアで暗号化された通信を行うことが
227可能にします。X11 のコネクションやあらゆる TCP/IP のポートもまた、セキュア
228な通信路の中を通すことができます。
229
230OpenSSH は OpenBSD による最後のフリーのバージョンの再実装で、
231最新のセキュリティと機能を提供しています。またすべての特許がからむ
232アルゴリズムは分割したライブラリにわかれています。
233
234このパッケージは GNOME 用のパスフレーズ入力ダイアログを含んでいます。
235
236%prep
237
238%setup -q
239%patch0 -p1 -b .vine
240%patch4 -p1 -b .vendor
241
242%if %{WITH_SELINUX}
243#SELinux
244%patch12 -p1 -b .selinux
245%endif
246
247%patch21 -p1 -b .safe-stop
248%patch24 -p1 -b .fromto-remote
249%patch26 -p1 -b .stack
250%patch27 -p1 -b .log-chroot
251%patch30 -p1 -b .exit-deadlock
252%patch35 -p1 -b .progress
253
254%patch100 -p1 -b .norootlogin
255
256autoreconf
257
258
259%build
260CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
261%if %{rescue}
262CFLAGS="$RPM_OPT_FLAGS -Os"; export CFLAGS
263%endif
264%if %{pie}
265%ifarch s390 s390x sparc sparc64
266CFLAGS="$CFLAGS -fPIE"
267%else
268CFLAGS="$CFLAGS -fpie"
269%endif
270export CFLAGS
271LDFLAGS="$LDFLAGS -pie"; export LDFLAGS
272%endif
273
274%configure \
275        --sysconfdir=%{_sysconfdir}/ssh \
276        --libexecdir=%{_libexecdir}/openssh \
277        --datadir=%{_datadir}/openssh \
278        --with-tcp-wrappers \
279        --with-default-path=/usr/local/bin:/bin:/usr/bin \
280        --with-superuser-path=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin \
281        --with-privsep-path=%{_var}/empty/sshd \
282        --enable-vendor-patchlevel="VL-%{version}-%{release}" \
283        --with-libedit \
284%if %{scard}
285        --with-smartcard \
286%endif
287%if %{noip6}
288        --with-ipv4-default \
289%endif
290%if %{rescue}
291        --without-pam --with-md5-passwords
292%else
293        --with-pam
294%endif
295
296%if %{static_libcrypto}
297perl -pi -e "s|-lcrypto|%{_libdir}/libcrypto.a|g" Makefile
298%endif
299
300make
301
302%if %{gtk2}
303        gtk2=yes
304%else
305        gtk2=no
306%endif
307
308%if ! %{no_gnome_askpass}
309pushd contrib
310if [ $gtk2 = yes ]; then
311        make gnome-ssh-askpass2
312        mv gnome-ssh-askpass2 gnome-ssh-askpass
313else
314        make gnome-ssh-askpass1
315        mv gnome-ssh-askpass1 gnome-ssh-askpass
316fi
317popd
318%endif
319
320%install
321rm -rf $RPM_BUILD_ROOT
322mkdir -p -m755 $RPM_BUILD_ROOT%{_sysconfdir}/ssh
323mkdir -p -m755 $RPM_BUILD_ROOT%{_libexecdir}/openssh
324mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd
325mkdir -p -m755 $RPM_BUILD_ROOT%{_var}/empty/sshd/etc
326
327make install DESTDIR=$RPM_BUILD_ROOT
328
329touch $RPM_BUILD_ROOT%{_var}/empty/sshd/etc/localtime
330install -d $RPM_BUILD_ROOT/etc/pam.d/
331install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
332install -d $RPM_BUILD_ROOT/etc/sysconfig/
333install -d $RPM_BUILD_ROOT%{_libexecdir}/openssh
334install -m644 contrib/redhat/sshd.pam     $RPM_BUILD_ROOT/etc/pam.d/sshd
335install -m755 %{SOURCE100} $RPM_BUILD_ROOT/etc/rc.d/init.d/sshd
336install -m644 %{SOURCE110} $RPM_BUILD_ROOT/etc/sysconfig/sshd
337
338%if ! %{scard}
339        rm -f $RPM_BUILD_ROOT%{_datadir}/openssh/Ssh.bin
340%endif
341
342%if ! %{no_gnome_askpass}
343install -s contrib/gnome-ssh-askpass $RPM_BUILD_ROOT%{_libexecdir}/openssh/gnome-ssh-askpass
344install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
345install -m 755 contrib/redhat/gnome-ssh-askpass.{sh,csh} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/
346%endif
347
348%if %{no_gnome_askpass}
349rm -f $RPM_BUILD_ROOT/etc/profile.d/gnome-ssh-askpass.*
350%endif
351
352# for contrib package
353install -m 0755 contrib/ssh-copy-id $RPM_BUILD_ROOT%{_bindir}
354install -m 0644 contrib/ssh-copy-id.1 $RPM_BUILD_ROOT%{_mandir}/man1
355mv contrib/README contrib/README.contrib
356
357perl -pi -e "s|$RPM_BUILD_ROOT||g" $RPM_BUILD_ROOT%{_mandir}/man*/*
358
359%clean
360rm -rf $RPM_BUILD_ROOT
361
362%triggerun server -- ssh-server
363if [ "$1" != 0 -a -r /var/run/sshd.pid ] ; then
364        touch /var/run/sshd.restart
365fi
366
367%triggerun server -- openssh-server < 2.5.0p1
368# Count the number of HostKey and HostDsaKey statements we have.
369gawk    'BEGIN {IGNORECASE=1}
370         /^hostkey/ || /^hostdsakey/ {sawhostkey = sawhostkey + 1}
371         END {exit sawhostkey}' /etc/ssh/sshd_config
372# And if we only found one, we know the client was relying on the old default
373# behavior, which loaded the the SSH2 DSA host key when HostDsaKey wasn't
374# specified.  Now that HostKey is used for both SSH1 and SSH2 keys, specifying
375# one nullifies the default, which would have loaded both.
376if [ $? -eq 1 ] ; then
377        echo HostKey /etc/ssh/ssh_host_rsa_key >> /etc/ssh/sshd_config
378        echo HostKey /etc/ssh/ssh_host_dsa_key >> /etc/ssh/sshd_config
379fi
380
381%triggerpostun server -- ssh-server
382if [ "$1" != 0 ] ; then
383        /sbin/chkconfig --add sshd
384        if test -f /var/run/sshd.restart ; then
385                rm -f /var/run/sshd.restart
386                # /sbin/service sshd start > /dev/null 2>&1 || :
387                /sbin/service sshd start
388        fi
389fi
390
391%pre server
392%{_sbindir}/groupadd -r -g %{sshd_gid} sshd 2>/dev/null || :
393%{_sbindir}/useradd -d /var/empty/sshd -s /bin/false -u %{sshd_uid} \
394        -g sshd -M -r sshd 2>/dev/null || :
395
396%post server
397/sbin/chkconfig --add sshd
398
399%postun server
400# /sbin/service sshd condrestart > /dev/null 2>&1 || :
401/sbin/service sshd condrestart
402exit 0
403
404%preun server
405if [ "$1" = 0 ]
406then
407        /sbin/service sshd stop > /dev/null 2>&1 || :
408        /sbin/chkconfig --del sshd
409fi
410
411%files
412%defattr(-,root,root)
413%doc CREDITS ChangeLog INSTALL LICENCE OVERVIEW README* RFC* TODO WARNING*
414%attr(0755,root,root) %{_bindir}/scp
415%attr(0644,root,root) %{_mandir}/man1/scp.1*
416%attr(0755,root,root) %dir %{_sysconfdir}/ssh
417%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/moduli
418%attr(644,root,root) %{_mandir}/man5/moduli.5*
419%if ! %{rescue}
420%attr(0755,root,root) %{_bindir}/ssh-keygen
421%attr(0644,root,root) %{_mandir}/man1/ssh-keygen.1*
422%attr(0755,root,root) %dir %{_libexecdir}/openssh
423%attr(4711,root,root) %{_libexecdir}/openssh/ssh-keysign
424%attr(0644,root,root) %{_mandir}/man8/ssh-keysign.8*
425%endif
426%if %{scard}
427%attr(0755,root,root) %dir %{_datadir}/openssh
428%attr(0644,root,root) %{_datadir}/openssh/Ssh.bin
429%endif
430
431%files clients
432%defattr(-,root,root)
433%attr(0755,root,root) %{_bindir}/ssh
434%attr(0644,root,root) %{_mandir}/man1/ssh.1*
435%attr(0644,root,root) %{_mandir}/man5/ssh_config.5*
436%attr(0644,root,root) %{_mandir}/man1/slogin.1*
437%attr(0644,root,root) %config(noreplace) %{_sysconfdir}/ssh/ssh_config
438%attr(-,root,root) %{_bindir}/slogin
439%if ! %{rescue}
440%attr(0755,root,root) %{_bindir}/ssh-agent
441%attr(0755,root,root) %{_bindir}/ssh-add
442%attr(0755,root,root) %{_bindir}/ssh-keyscan
443%attr(0755,root,root) %{_bindir}/sftp
444%attr(0755,root,root) %{_bindir}/ssh-copy-id
445%attr(0755,root,root) %{_libexecdir}/openssh/ssh-pkcs11-helper
446%attr(0644,root,root) %{_mandir}/man1/ssh-agent.1*
447%attr(0644,root,root) %{_mandir}/man1/ssh-add.1*
448%attr(0644,root,root) %{_mandir}/man1/ssh-keyscan.1*
449%attr(0644,root,root) %{_mandir}/man1/sftp.1*
450%attr(0644,root,root) %{_mandir}/man1/ssh-copy-id.1*
451%attr(0644,root,root) %{_mandir}/man8/ssh-pkcs11-helper.8*
452%endif
453
454%if ! %{rescue}
455%files server
456%defattr(-,root,root)
457%dir %attr(0711,root,root) %{_var}/empty/sshd
458%dir %attr(0755,root,root) %{_var}/empty/sshd/etc
459%ghost %verify(not md5 size mtime) %{_var}/empty/sshd/etc/localtime
460%attr(0755,root,root) %{_sbindir}/sshd
461%attr(0755,root,root) %{_libexecdir}/openssh/sftp-server
462%attr(0644,root,root) %{_mandir}/man5/sshd_config.5*
463%attr(0644,root,root) %{_mandir}/man8/sshd.8*
464%attr(0644,root,root) %{_mandir}/man8/sftp-server.8*
465%attr(0755,root,root) %dir %{_sysconfdir}/ssh
466%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/ssh/sshd_config
467%attr(0600,root,root) %config(noreplace) /etc/pam.d/sshd
468%attr(0755,root,root) %config /etc/rc.d/init.d/sshd
469%attr(0755,root,root) %config /etc/sysconfig/sshd
470%endif
471
472%if ! %{no_gnome_askpass}
473%files askpass-gnome
474%defattr(-,root,root)
475%attr(0755,root,root) %config %{_sysconfdir}/profile.d/gnome-ssh-askpass.*
476%attr(0755,root,root) %{_libexecdir}/openssh/gnome-ssh-askpass
477%endif
478
479
480%changelog
481* Tue Apr 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-2
482- add our own sshd.init based on fedora's sshd.init
483  - generate ECDSA host key.
484
485* Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.8p1-1
486- new upstream release
487
488* Tue Jan 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.7p1-1
489- new upstream release
490
491* Mon Jan 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 5.6p1-1
492- new upstream release
493- obsolete contrib subpackage, move ssh-copy-id to client subpackage
494
495* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.5p1-4
496- rebuilt with openssl 1.0.0c
497
498* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-3
499- drop x11-askpass, add Obsoletes: openssh-askpass
500- add BR: groff
501- enable --with-libedit option, add BR: libedit-devel
502- remove unrecognized option '--with-rsh'
503
504* Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-2
505- add BR: xorg-x11-xauth for X11 forwarding support
506
507* Thu Apr 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.5p1-1
508- new upstream release
509- update patch0,2
510- drop patch3,22
511
512* Tue Feb 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2p1-1
513- new upstream release
514
515* Tue Jul 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1p1-1
516- new upstream release
517
518* Thu May 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.0p1-2
519- rebuild with xorg-x11-7.3
520
521* Fri Apr 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 5.0p1-1
522- new upstream release with security fix (CVE-2008-1483)
523- drop patch31 which is included in new release (This was for CVE-2008-1483)
524
525* Tue Apr 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.9p1-1
526- new upstream release with security fix ("ForceCommand" Directive)
527- turn on daemon restart message
528- new versioning policy
529
530* Mon Nov 26 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.7p1-0vl2
531- add /var/empty/sshd/etc/localtime to fix secure log bad timestamps
532
533* Tue Nov 13 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.7p1-0vl1
534- new upstream release
535
536* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl2
537- build with -fpie/-pie by default.
538- enable ipv6 by default.
539
540* Fri May 04 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.6p1-0vl1
541- new upstream release
542
543* Wed Nov 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.5p1-0vl1
544- new upstream release
545
546* Fri Sep 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.4p1-0vl1
547- new upstream release
548
549* Thu Jul 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p2-0vl1
550- new upstream release
551
552* Mon Apr 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3p1-0vl1
553- new upstream release
554- remove build6x stuff
555- remove libgnome-devel from BuildRequires
556- cleanup BuildRequires
557- drop Patch200, it is merged in upstream.
558- import patches(25-35) from FC-devel
559
560* Mon Apr 10 2006 IWAI, Masaharu <iwai@alib.jp> 4.2p1-0vl3
561- SECURITY FIX: CVE-2006-0225
562  - add scp no system patch ( Patch200 ): from Fedora Core 4 4.2p1-fc4.10
563- update BuildPreReq: s/XFree86-devel/XOrg-devel/
564- fix BuildPreReq for GNOME: gnome-libs-devel ( GNOME1 ) was always used
565  - When GNOME2 is used, using libgnome-devel
566  - add BuildPreReq: gtk2-devel for GNOME2
567
568* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl2
569- rebuild with gtk+-2.8 final
570
571* Sun Sep  4 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2p1-0vl1
572- new upstream release
573- build with gtk+-2.7
574
575* Sun May 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.1p1-0vl1
576- new upstream release
577
578* Fri Apr 01 2005 KOBAYASHI Taizo <tkoba@vinelinux.org> 4.0p1-0vl2
579- cleanup obsolete patches and added patches from fedora
580
581* Wed Mar 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0p1-0vl1
582- new upstream release
583
584* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.9pl1-0vl1
585- new upstream release
586
587* Wed Apr 21 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8.1p1-0vl1
588- new upstream release
589
590* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl2
591- rebuild with openssl-0.9.7d
592
593* Fri Feb 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.8p1-0vl1
594- new upstream release
595
596* Thu Oct  2 2003 IWAI, Masaharu <iwai@alib.jp> 3.7.1p2-0vl2
597- create contrib package
598
599* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p2-0vl1
600- new upstream release
601- fix security issue: http://www.openssh.com/txt/sshpam.adv
602
603* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7.1p1-0vl1
604- new upstream release
605- fix security issue: http://www.openssh.com/txt/buffer.adv
606
607* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.7p1-0vl1
608- new upstream release
609
610* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1.1
611- rebuild with gtk2
612
613* Thu May  1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 3.6.1p2-0vl1
614- new upstream release
615
616* Sat Apr 13 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.5p1-0vl2
617- rebuild with new tool chain
618
619* Tue Oct 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5p1-0vl1
620- new upstream release
621- merge with upstream spec (drop anonymous mmap patch, suid of ssh)
622
623* Tue Aug 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl3
624- change some defines in spec files
625
626* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl2
627- add patch110 ( 3.4p1 does not include mmap-fallback patch )
628
629* Wed Jun 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.4p1-0vl1
630- new upstream release
631  - security fix
632- drop patch10
633
634* Wed Jun 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl2
635- add patch from Solar Designer to make privsep work with a 2.2 kernel.
636
637* Sun Jun 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3p1-0vl1
638- new upstream release
639- add {sshd,ssh}_config.5 manpages
640- add ssh-keysign
641
642* Sun May 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.3p1-0vl1
643- new upstream release
644
645* Sat May 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.2.2p1-0vl1
646- new upstream release
647- drop patch1
648
649* Fri Mar 08 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1p1-2vl1
650- new upstream release
651- merged with rawhide release.
652- drop Patch101 (merged in upstream)
653
654* Fri Mar 08 2002 Toru Sagami <sagami@vinelinux.org> 3.0.2p1-2vl2
655- seurity patch for off-by-one bug
656
657* Wed Jan 30 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.2p-2vl1
658- merged with Rawhide 3.0.2p1-2
659
660* Sun Dec 02 2001 Toru Sagami <sagami@vinelinux.org>
661- updated to 3.0.2p1
662
663* Mon Nov 19 2001 Toru Sagami <sagami@vinelinux.org>
664- updated to 3.0.1p1
665
666* Thu Nov 08 2001 Toru Sagami <sagami@vinelinux.org> 3.0p1-0vl0
667- updated to 3.0p1
668
669* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl2
670- add japanese summery and descriptions.
671- update x11-askpass 1.2.5
672
673* Sun Sep 30 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.9p2-0vl1
674- update to openssh-2.9.9p2
675
676* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org> 2.5.2p2-0vl3
677- rebuilt with openssl-0.9.6b
678
679* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 2.5.2p2-0vl2
680- do not Permit RootLogin
681
682* Tue Mar 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p2-0vl1
683- update to openssh-2.5.2p2
684
685* Wed Mar 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.2p1-0vl1
686- update to openssh-2.5.2p1
687
688* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
689- update to openssh-2.5.1p2
690
691* Thu Mar 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p2-0vl1
692- update to openssh-2.5.1p1
693
694* Wed Feb 21 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1p1-0vl1
695- update to openssh-2.5.1p1
696
697* Thu Dec 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl4
698- remove suid bit from ssh
699
700* Tue Dec 19 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl3
701- moved man dir to /usr/share/man
702
703* Wed Dec 06 2000 Satoshi MACHINO <machino@vinelinux.org> 2.3.0p1-0vl2
704- fixed askpass's link in ssh-add
705- partially used rpmmacros
706
707* Fri Nov 10 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0p1-0vl1
708- update to 2.3.0p1
709- update x11-askpass 1.0.3
710
711* Mon Oct 18 2000 Damien Miller <djm@mindrot.org>
712- Merge some of Nalin Dahyabhai <nalin@redhat.com> changes from the
713  Redhat 7.0 spec file
714
715* Sat Oct 14 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0p2-2vl1
716- rebuild for Vine Linux
717
718* Tue Sep 05 2000 Damien Miller <djm@mindrot.org>
719- Use RPM configure macro
720* Tue Aug 08 2000 Damien Miller <djm@mindrot.org>
721- Some surgery to sshd.init (generate keys at runtime)
722- Cleanup of groups and removal of keygen calls
723* Wed Jul 12 2000 Damien Miller <djm@mindrot.org>
724- Make building of X11-askpass and gnome-askpass optional
725* Mon Jun 12 2000 Damien Miller <djm@mindrot.org>
726- Glob manpages to catch compressed files
727* Wed Mar 15 2000 Damien Miller <djm@ibs.com.au>
728- Updated for new location
729- Updated for new gnome-ssh-askpass build
730* Sun Dec 26 1999 Damien Miller <djm@mindrot.org>
731- Added Jim Knoble's <jmknoble@pobox.com> askpass
732* Mon Nov 15 1999 Damien Miller <djm@mindrot.org>
733- Split subpackages further based on patch from jim knoble <jmknoble@pobox.com>
734* Sat Nov 13 1999 Damien Miller <djm@mindrot.org>
735- Added 'Obsoletes' directives
736* Tue Nov 09 1999 Damien Miller <djm@ibs.com.au>
737- Use make install
738- Subpackages
739* Mon Nov 08 1999 Damien Miller <djm@ibs.com.au>
740- Added links for slogin
741- Fixed perms on manpages
742* Sat Oct 30 1999 Damien Miller <djm@ibs.com.au>
743- Renamed init script
744* Fri Oct 29 1999 Damien Miller <djm@ibs.com.au>
745- Back to old binary names
746* Thu Oct 28 1999 Damien Miller <djm@ibs.com.au>
747- Use autoconf
748- New binary names
749* Wed Oct 27 1999 Damien Miller <djm@ibs.com.au>
750- Initial RPMification, based on Jan "Yenya" Kasprzak's <kas@fi.muni.cz> spec.
751
Note: See TracBrowser for help on using the repository browser.