source: projects/specs/trunk/o/opensp/opensp-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: SGML and XML parser
2Summary(ja): SGML, XML パーサ
3Name: opensp
4Version: 1.5.2
5Release: 6%{?_dist_release}
6URL: http://openjade.sourceforge.net/
7Source: http://download.sourceforge.net/openjade/OpenSP-%{version}.tar.gz
8Patch0: opensp-multilib.patch
9Patch1: opensp-nodeids.patch
10Patch2: opensp-sigsegv.patch
11License: BSD
12Group: Applications/Text
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: xmlto, jadetex
16Requires: sgml-common >= 0.5
17
18%description
19OpenSP is an implementation of the ISO/IEC 8879:1986 standard SGML
20(Standard Generalized Markup Language). OpenSP is based on James
21Clark's SP implementation of SGML. OpenSP is a command-line
22application and a set of components, including a generic API.
23
24%package devel
25Summary: Files for developing applications that use OpenSP
26Group: Development/Libraries
27Requires: %{name} = %{version}-%{release}
28
29%description devel
30Header files and libtool library for developing applications that use OpenSP.
31
32
33%prep
34%setup -q -n OpenSP-%{version}
35%patch0 -p1 -b .multilib
36%patch1 -p1 -b .nodeids
37%patch2 -p1 -b .sigsegv
38
39%build
40%configure --disable-dependency-tracking --disable-static --enable-http \
41 --enable-default-catalog=%{_sysconfdir}/sgml/catalog \
42 --enable-default-search-path=%{_datadir}/sgml:%{_datadir}/xml
43make %{?_smp_mflags}
44
45%install
46rm -rf $RPM_BUILD_ROOT
47
48make install DESTDIR=$RPM_BUILD_ROOT
49
50# Fix up libtool libraries
51find $RPM_BUILD_ROOT -name '*.la' | \
52  xargs perl -p -i -e "s|-L$RPM_BUILD_DIR[\w/.-]*||g"
53
54# oMy, othis ois osilly.
55for file in nsgmls sgmlnorm spam spent sx ; do
56   ln -s o$file $RPM_BUILD_ROOT%{_bindir}/$file
57   echo ".so man1/o${file}.1" > $RPM_BUILD_ROOT%{_mandir}/man1/${file}.1
58done
59
60#
61# Rename sx to sgml2xml.
62mv $RPM_BUILD_ROOT%{_bindir}/sx $RPM_BUILD_ROOT%{_bindir}/sgml2xml
63mv $RPM_BUILD_ROOT%{_mandir}/man1/{sx,sgml2xml}.1
64
65#
66# Clean out (installed) redundant copies of the docs and DTDs.
67rm -rf $RPM_BUILD_ROOT%{_docdir}/OpenSP
68rm -rf $RPM_BUILD_ROOT%{_datadir}/OpenSP
69
70%find_lang sp5
71
72## remove unuse files
73rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
74
75
76%check
77make check || : # failures as of 1.5.2pre1 :(
78
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83
84%post -p /sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88
89%files -f sp5.lang
90%defattr(-,root,root)
91%doc doc/*.htm
92%doc docsrc/releasenotes.html
93%doc AUTHORS BUGS COPYING ChangeLog NEWS README
94%doc pubtext/opensp-implied.dcl
95%{_bindir}/*
96%{_libdir}/libosp.so.*
97%{_mandir}/man1/*.1*
98
99%files devel
100%defattr(-,root,root)
101%{_includedir}/OpenSP/
102%{_libdir}/libosp.so
103#%{_libdir}/libosp.la
104
105
106%changelog
107* Fri Feb 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.2-6
108- rebuilt with new toolchain
109
110* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.5.2-5vl5
111- removed *.la
112- spec in utf-8
113
114* Sun May 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.2-4vl5
115- added Patch1 and 2 from Fedora
116  * Thu Jun 21 2007 Ondrej Vasik <ovasik@redhat.com>
117  - fixed SIGSEGV (bug #245104)
118  * Mon Feb 12 2007 Tim Waugh <twaugh@redhat.com>
119  - Give IDs to nodes in the release notes source to prevent releasenotes.html
120    having multilib conflicts (bug #228320).
121
122* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-3vl1
123- based on FC6 1.5.2-3.1, built on new toolchain
124
125* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-3.1
126- rebuild
127
128* Tue Jun 13 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-3
129- Fixed multilib fix (bug #194702).
130
131* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-2
132- Fixed multilib devel conflicts (bug #192741).
133
134* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-1.2
135- bump again for double-long bug on ppc(64)
136
137* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-1.1
138- rebuilt for new gcc4.1 snapshot and glibc changes
139
140* Thu Jan  5 2006 Tim Waugh <twaugh@redhat.com>  1.5.2-1
141- 1.5.2.
142
143* Tue Dec 14 2005 Tim Waugh <twaugh@redhat.com>  1.5.1-2
144- Backported patch from 1.5.2pre1 to fix ArcEngine crash.
145
146* Tue Dec 13 2005 Tim Waugh <twaugh@redhat.com>  1.5.1-1
147- Back down to 1.5.1 for now.
148- Fixes for GCC4.1.
149
150* Sun Dec  4 2005 Ville Skytt辰 <ville.skytta at iki.fi> - 1.5.2-0.1.pre1
151- Fix build dependencies.
152- Require exact version of main package in -devel.
153- Build with dependency tracking disabled.
154- Add %%{_datadir}/xml to default search path.
155- Run test suite during build.
156- Add URL tag.
157- Use %%find_lang.
158- Cosmetic improvements.
159
160* Tue Nov 29 2005 Terje Bless <link@pobox.com> 1.5.2-0.pre1
161- New package OpenSP.
162
Note: See TracBrowser for help on using the repository browser.