source: projects/specs/trunk/o/opensp/opensp-vl.spec @ 10529

Revision 10529, 5.1 KB checked in by tomop, 8 years ago (diff)

opensp-1.5.2-10

Line 
1Summary: SGML and XML parser
2Summary(ja): SGML, XML パーサ
3Name: opensp
4Version: 1.5.2
5Release: 10%{?_dist_release}
6
7License: MIT
8Group: Applications/Text
9URL: http://openjade.sourceforge.net/
10
11Source: http://download.sourceforge.net/openjade/OpenSP-%{version}.tar.gz
12Patch0: opensp-multilib.patch
13Patch1: opensp-nodeids.patch
14Patch2: opensp-sigsegv.patch
15Patch3: opensp-manpage.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18#BuildRequires: jadetex
19BuildRequires: xmlto
20Requires: sgml-common >= 0.5
21
22Vendor: Project Vine
23Distribution: Vine Linux
24
25%description
26OpenSP is an implementation of the ISO/IEC 8879:1986 standard SGML
27(Standard Generalized Markup Language). OpenSP is based on James
28Clark's SP implementation of SGML. OpenSP is a command-line
29application and a set of components, including a generic API.
30
31%package devel
32Summary: Files for developing applications that use OpenSP
33Summary(ja): OpenSP を用いるアプリケーションの開発に必要なファイル
34Group: Development/Libraries
35Requires: %{name} = %{version}-%{release}
36
37%description devel
38Header files and libtool library for developing applications that use OpenSP.
39
40
41%prep
42%setup -q -n OpenSP-%{version}
43%patch0 -p1 -b .multilib
44%patch1 -p1 -b .nodeids
45%patch2 -p1 -b .sigsegv
46%patch3 -p1 -b .manpage
47# convert files to UTF-8
48iconv -f latin1 -t utf8 ChangeLog -o ChangeLog.tmp
49mv -f ChangeLog.tmp ChangeLog
50
51%build
52%configure --disable-dependency-tracking --disable-static --enable-http \
53 --enable-default-catalog=%{_sysconfdir}/sgml/catalog \
54 --enable-default-search-path=%{_datadir}/sgml:%{_datadir}/xml
55
56# specify --skip-validation option
57make %{?_smp_mflags} XMLTO="%{_bindir}/xmlto --skip-validation"
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62make install DESTDIR=$RPM_BUILD_ROOT
63
64# Get rid of libtool libraries
65rm $RPM_BUILD_ROOT%{_libdir}/*.la
66
67# oMy, othis ois osilly.
68for file in nsgmls sgmlnorm spam spent sx ; do
69   ln -s o$file $RPM_BUILD_ROOT%{_bindir}/$file
70   echo ".so man1/o${file}.1" > $RPM_BUILD_ROOT%{_mandir}/man1/${file}.1
71done
72
73#
74# Rename sx to sgml2xml.
75mv $RPM_BUILD_ROOT%{_bindir}/sx $RPM_BUILD_ROOT%{_bindir}/sgml2xml
76mv $RPM_BUILD_ROOT%{_mandir}/man1/{sx,sgml2xml}.1
77
78#
79# Clean out (installed) redundant copies of the docs and DTDs.
80rm -rf $RPM_BUILD_ROOT%{_docdir}/OpenSP
81rm -rf $RPM_BUILD_ROOT%{_datadir}/OpenSP
82
83%find_lang sp5
84
85
86%check
87make check || : # failures as of 1.5.2pre1 :(
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96
97%files -f sp5.lang
98%defattr(-,root,root)
99%doc doc/*.htm
100%doc docsrc/releasenotes.html
101%doc AUTHORS BUGS COPYING ChangeLog NEWS README
102%doc pubtext/opensp-implied.dcl
103%{_bindir}/*
104%{_libdir}/libosp.so.*
105%{_mandir}/man1/*.1*
106
107%files devel
108%defattr(-,root,root)
109%{_includedir}/OpenSP/
110%{_libdir}/libosp.so
111
112
113%changelog
114* Mon Jul  4 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-10
115- rebuilt with new toolchain.
116
117* Mon Nov  3 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.5.2-9
118- converted doc files to UTF
119- added XMLTO option to build on current xmlto
120- added Patch3 from FC
121  * Thu Aug 15 2013 Ondrej Vasik <ovasik@redhat.com> - 1.5.2-18
122  - fix the inconsistency between man page and help (#854941)
123
124* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.2-8
125- rebuild with VineSeed environment
126
127* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 1.5.2-7
128- rebuilt with rpm-4.8.1-3
129
130* Fri Feb 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.2-6
131- rebuilt with new toolchain
132
133* Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 1.5.2-5vl5
134- removed *.la
135- spec in utf-8
136
137* Sun May 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.5.2-4vl5
138- added Patch1 and 2 from Fedora
139  * Thu Jun 21 2007 Ondrej Vasik <ovasik@redhat.com>
140  - fixed SIGSEGV (bug #245104)
141  * Mon Feb 12 2007 Tim Waugh <twaugh@redhat.com>
142  - Give IDs to nodes in the release notes source to prevent releasenotes.html
143    having multilib conflicts (bug #228320).
144
145* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.5.2-3vl1
146- based on FC6 1.5.2-3.1, built on new toolchain
147
148* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-3.1
149- rebuild
150
151* Tue Jun 13 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-3
152- Fixed multilib fix (bug #194702).
153
154* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 1.5.2-2
155- Fixed multilib devel conflicts (bug #192741).
156
157* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-1.2
158- bump again for double-long bug on ppc(64)
159
160* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.5.2-1.1
161- rebuilt for new gcc4.1 snapshot and glibc changes
162
163* Thu Jan  5 2006 Tim Waugh <twaugh@redhat.com>  1.5.2-1
164- 1.5.2.
165
166* Wed Dec 14 2005 Tim Waugh <twaugh@redhat.com>  1.5.1-2
167- Backported patch from 1.5.2pre1 to fix ArcEngine crash.
168
169* Tue Dec 13 2005 Tim Waugh <twaugh@redhat.com>  1.5.1-1
170- Back down to 1.5.1 for now.
171- Fixes for GCC4.1.
172
173* Sun Dec  4 2005 Ville Skytt辰 <ville.skytta at iki.fi> - 1.5.2-0.1.pre1
174- Fix build dependencies.
175- Require exact version of main package in -devel.
176- Build with dependency tracking disabled.
177- Add %%{_datadir}/xml to default search path.
178- Run test suite during build.
179- Add URL tag.
180- Use %%find_lang.
181- Cosmetic improvements.
182
183* Tue Nov 29 2005 Terje Bless <link@pobox.com> 1.5.2-0.pre1
184- New package OpenSP.
185
Note: See TracBrowser for help on using the repository browser.