source: projects/specs/trunk/o/opensource-cobol/opensource-cobol-vl.spec @ 12058

Revision 12058, 3.4 KB checked in by ara_t, 5 years ago (diff)

opensource-cobol: update to 1.5.2J

Line 
1%define pkg_name    opensource-cobol
2%define pkg_version 1.5.2J
3%define pkg_release 1%{?_dist_release}
4
5Summary: An open-source COBOL compiler
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPLv2
11Group:   Development/Languages
12URL:     https://www.osscons.jp/
13Source0: %{name}-%{version}-utf8.tar.gz
14
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16
17%if %{?_dist_release} == "vl6"
18BuildRequires: db4-devel
19%else
20BuildRequires: libdb-devel
21%endif
22BuildRequires: gmp-devel
23BuildRequires: ncurses-devel
24
25BuildRequires: texinfo
26BuildRequires: texlive-common
27%if %{?_dist_release} == "vl6"
28BuildRequires: texlive-collection-texinfo
29%endif
30%if %{?_dist_release} >= "vl7"
31BuildRequires: texlive-collection-plaingeneric
32BuildRequires: texlive-collection-fontsrecommended
33%endif
34
35Requires: ncurses-devel
36%if %{?_dist_release} == "vl6"
37Requires: db4-devel
38%else
39Requires: libdb-devel
40%endif
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: ara_t
45
46
47%description
48"opensource COBOL" is open-source COBOL compiler,
49an extension of the Japan-specific features.
50"opensource COBOL" translates COBOL program to C code
51and compiles it using GCC or CL.
52
53It was forked from OpenCOBOL in 2012.
54See also OpenCOBOL project.
55    http://www.opencobol.org/
56    http://sourceforge.net/projects/open-cobol/
57
58%description -l ja
59opensource COBOLは、オーペンソースのCOBOLコンパイラであり、
60COBOLプログラムをC言語のコードに翻訳し、GCCあるいはCLを用いて
61コンパイルします。
62
63opensource COBOLは、オープンCOBOLソリューション部会によって
64OpenCOBOLに日本特有のビジネス環境に即したカスタマイズ、
65メンテナンスを加えたものです。
66
67
68%prep
69%{__rm} -rf ${RPM_BUILD_ROOT}
70%setup -q -n %{name}-%{version}-utf8
71
72%build
73%{configure} \
74 --enable-utf8 \
75 --disable-static
76
77%{__make} %{?_smp_mflags}
78%{__make} pdf html
79
80%check
81%{__make} check
82
83%install
84%{make_install}
85%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
86%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
87
88%clean
89%{__rm} -rf ${RPM_BUILD_ROOT}
90
91%post
92%{_syssbindir}/install-info %{_infodir}/open-cobol.info.gz \
93 %{_infodir}/dir 2>/dev/null
94%{_syssbindir}/ldconfig
95
96%preun
97if [ $1 = 0 ]; then
98    %{_syssbindir}/install-info --delete %{_infodir}/open-cobol.info.gz \
99     %{_infodir}/dir 2>/dev/null
100fi
101
102%postun -p %{_syssbindir}/ldconfig
103
104
105%files
106%defattr(-,root,root)
107%doc AUTHORS ChangeLog COPYING* NEWS README THANKS TODO
108%doc texi/open-cobol.pdf
109%doc texi/open-cobol.html/
110%{_bindir}/
111%{_includedir}/libcob.h
112%{_includedir}/libcob
113%{_libdir}/libcob.so*
114%{_datadir}/locale/
115%{_datadir}/%{name}-%{version}
116%{_infodir}/*.info.gz
117
118
119%changelog
120* Sun Apr 21 2019 Toshiaki Ara <ara_t@384.jp> 1.5.2J-1
121- new upstream release
122- change to BuildRequires: texlive-collection-plaingeneric
123
124* Mon Dec 12 2016 Toshiaki Ara <ara_t@384.jp> 1.5.1J-1
125- new upstream release
126
127* Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-3
128- change Group to Development/Languages
129
130* Fri Jul 29 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-2
131- change Requires: ncurses to ncurses-devel
132- change Requires: db4/libdb to db4-devel/libdb-devel
133- add export CFLAGS="%{optflags} -std=gnu89" for VineSeed (gcc-5)
134
135* Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-1
136- update to 1.5.0J
137- delete BuildRequires: texlive-collection-lang*
138
139* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-2
140- rebuild under texlive 2016 pretest
141- add BuildRequires
142
143* Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-1
144- new package
145
Note: See TracBrowser for help on using the repository browser.