source: projects/specs/trunk/o/opensource-cobol/opensource-cobol-vl.spec @ 10843

Revision 10843, 3.4 KB checked in by ara_t, 7 years ago (diff)

opensource-cobol: update to 1.5.1J

Line 
1%define pkg_name    opensource-cobol
2%define pkg_version 1.5.1J
3%define pkg_release 1%{?_dist_release}
4
5Summary: An open-source COBOL compiler
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: GPLv2
11Group:   Development/Languages
12URL:     https://www.osscons.jp/
13Source0: %{name}-%{version}-utf8.tar.gz
14
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16
17%if %{?_dist_release} == "vl6"
18BuildRequires: db4-devel
19%else
20BuildRequires: libdb-devel
21%endif
22BuildRequires: gmp-devel
23BuildRequires: ncurses-devel
24
25BuildRequires: texinfo
26BuildRequires: texlive-common
27%if %{?_dist_release} == "vl6"
28BuildRequires: texlive-collection-texinfo
29%else
30BuildRequires: texlive-collection-plainextra
31BuildRequires: texlive-collection-fontsrecommended
32%endif
33
34Requires: ncurses-devel
35%if %{?_dist_release} == "vl6"
36Requires: db4-devel
37%else
38Requires: libdb-devel
39%endif
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: ara_t
44
45
46%description
47"opensource COBOL" is open-source COBOL compiler,
48an extension of the Japan-specific features.
49"opensource COBOL" translates COBOL program to C code
50and compiles it using GCC or CL.
51
52It was forked from OpenCOBOL in 2012.
53See also OpenCOBOL project.
54    http://www.opencobol.org/
55    http://sourceforge.net/projects/open-cobol/
56
57%description -l ja
58opensource COBOLは、オーペンソースのCOBOLコンパイラであり、
59COBOLプログラムをC言語のコードに翻訳し、GCCあるいはCLを用いて
60コンパイルします。
61
62opensource COBOLは、オープンCOBOLソリューション部会によって
63OpenCOBOLに日本特有のビジネス環境に即したカスタマイズ、
64メンテナンスを加えたものです。
65
66
67%prep
68%{__rm} -rf ${RPM_BUILD_ROOT}
69%setup -q -n %{name}-%{version}-utf8
70
71%build
72# %if %{?_dist_release} >= "vl7"
73# export CFLAGS="%{optflags} -std=gnu89"
74# %endif
75%{configure} \
76 --enable-utf8 \
77 --disable-static
78
79%{__make} %{?_smp_mflags}
80%{__make} pdf html
81
82%check
83%{__make} check
84
85%install
86%{make_install}
87%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
88%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
89
90%clean
91%{__rm} -rf ${RPM_BUILD_ROOT}
92
93%post
94%{_syssbindir}/install-info %{_infodir}/open-cobol.info.gz \
95 %{_infodir}/dir 2>/dev/null
96%{_syssbindir}/ldconfig
97
98%preun
99if [ $1 = 0 ]; then
100    %{_syssbindir}/install-info --delete %{_infodir}/open-cobol.info.gz \
101     %{_infodir}/dir 2>/dev/null
102fi
103
104%postun -p %{_syssbindir}/ldconfig
105
106
107%files
108%defattr(-,root,root)
109%doc AUTHORS ChangeLog COPYING* NEWS README THANKS TODO
110%doc texi/open-cobol.pdf
111%doc texi/open-cobol.html/
112%{_bindir}/
113%{_includedir}/libcob.h
114%{_includedir}/libcob
115%{_libdir}/libcob.so*
116%{_datadir}/locale/
117%{_datadir}/%{name}-%{version}
118%{_infodir}/*.info.gz
119
120
121%changelog
122* Mon Dec 12 2016 Toshiaki Ara <ara_t@384.jp> 1.5.1J-1
123- new upstream release
124
125* Sun Nov 06 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-3
126- change Group to Development/Languages
127
128* Fri Jul 29 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-2
129- change Requires: ncurses to ncurses-devel
130- change Requires: db4/libdb to db4-devel/libdb-devel
131- add export CFLAGS="%{optflags} -std=gnu89" for VineSeed (gcc-5)
132
133* Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 1.5.0J-1
134- update to 1.5.0J
135- delete BuildRequires: texlive-collection-lang*
136
137* Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-2
138- rebuild under texlive 2016 pretest
139- add BuildRequires
140
141* Fri May 13 2016 Toshiaki Ara <ara_t@384.jp> 1.4.0J-1
142- new package
143
Note: See TracBrowser for help on using the repository browser.