source: projects/specs/trunk/o/opensoap/opensoap-vl.spec @ 521

Revision 521, 8.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# -*- mode: rpm-spec; -*-
2
3%define version_major  1.0
4%define version_relext 0.20031201
5
6%define version_package 1.0-20031201
7
8## for apache2
9%define _with_cgi_bin /var/www/cgi-bin
10## for apache1
11#define _with_cgi_bin /home/httpd/cgi-bin
12
13%define _sysconfdir /etc/opensoap
14%define _with_servicesdir /usr/lib/opensoap
15
16%define _localstatedir /var/opensoap
17# may need to be modified like /var/{log,spool,run}/opensoap
18
19Summary: SOAP-based middleware for XML Web Services applications.
20Summary(ja): XML Web¥µ¡¼¥Ó¥¹¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¸þ¤±SOAP¥Ù¡¼¥¹¥ß¥É¥ë¥¦¥§¥¢¡£
21Name: opensoap
22Version: 2.0.1
23Release: 0vl1
24Epoch: 1
25Group: System Environment/Libraries
26Source: http://www.opensoap.jp/download/%{name}-%{version}.tar.gz
27Patch0: opensoap-2.0.1-protected.patch
28
29License: BSD
30URL: http://www.opensoap.jp/
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32#Patch: %{name}-%{version_package}.patch
33
34BuildRequires: libxml2-devel openssl-devel apache2-devel
35Requires: libxml2 openssl
36
37%description
38OpenSOAP provides an environment for XML Web Services.
39API libraries to use SOAP (Simple Object Access Protocol) and the
40server for service applications are provided.  Also Transaction and
41Security functions are implemented.
42This main package includes shared libraries for executing OpenSOAP
43application software, and such basic tools as Soaping client/service
44and Transaction service.
45
46%description -l ja
47OpenSOAP¤ÏXML Web¥µ¡¼¥Ó¥¹¤Î¤¿¤á¤Î´Ä¶­¤òÄ󶡤·¤Þ¤¹¡£SOAP (Simple Object
48Access Protocol)¤òÍøÍѤ¹¤ë¤¿¤á¤ÎAPI¥é¥¤¥Ö¥é¥ê¤È¡¢¥µ¡¼¥Ó¥¹¥¢¥×¥ê¥±¡¼¥·¥ç
49¥ó±¿ÍѤΤ¿¤á¤Î¥µ¡¼¥Ð¤òÄ󶡤·¡¢¥È¥é¥ó¥¶¥¯¥·¥ç¥ó¤ä¥»¥­¥å¥ê¥Æ¥£¤Îµ¡Ç½¤ò»ý¤Ã
50¤Æ¤¤¤Þ¤¹¡£
51¤³¤ÎËÜÂΥѥ屡¼¥¸¤Ë¤Ï¡¢OpenSOAP¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¥½¥Õ¥È¼Â¹Ô»þ¤ËɬÍפÊ
52¶¦Í­¥é¥¤¥Ö¥é¥ê¡¢µÚ¤Ó¡¢´ðËܥġ¼¥ë¤Ç¤¢¤ëSoaping¥¯¥é¥¤¥¢¥ó¥È/¥µ¡¼¥Ó¥¹¡¢
53Transaction¥µ¡¼¥Ó¥¹¤¬´Þ¤Þ¤ì¤Þ¤¹¡£
54
55%package devel
56Summary: Libraries, include files to develop OpenSOAP applications.
57Summary(ja): OpenSOAP¥¢¥×¥ê¥±¡¼¥·¥ç¥ó³«È¯¤Î¤¿¤á¤Î¥é¥¤¥Ö¥é¥ê¤È¥Ø¥Ã¥À¥Õ¥¡¥¤¥ë¡£
58Group: Development/Libraries
59Requires: %{name} = %{epoch}:%{version}-%{release}
60
61%description devel
62Libraries, include-header files and documentation which can be used to
63develop software based on SOAP for Web Services, and to compile the
64source code for OpenSOAP application programs.
65
66%description devel -l ja
67¤³¤Î¥é¥¤¥Ö¥é¥ê¤È¥Ø¥Ã¥À¥Õ¥¡¥¤¥ë¡¢µÚ¤Ó¥É¥­¥å¥á¥ó¥ÈÎà¤òÍøÍѤ¹¤ë¤³¤È¤Ç¡¢
68Web¥µ¡¼¥Ó¥¹¤Î¤¿¤á¤ÎSOAPÄÌ¿®¤òÍøÍѤ¹¤ë¥½¥Õ¥È¥¦¥§¥¢¤ò³«È¯¤·¤¿¤ê¡¢Æþ¼ê¤·
69¤¿OpenSOAP¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¤Î¥½¡¼¥¹¥³¡¼¥É¤ò¥³¥ó¥Ñ¥¤¥ëµÚ¤Ó¥ê¥ó¥¯¤¹¤ë¤³¤È
70¤¬²Äǽ¤È¤Ê¤ê¤Þ¤¹¡£
71
72%package server
73Summary: Server for the original OpenSOAP functions.
74Summary(ja): OpenSOAPÆȼ«¤Îµ¡Ç½¤ò¼Â¸½¤¹¤ë¤¿¤á¤Î¥µ¡¼¥Ð¡£
75Group: System Environment/Daemons
76Requires: %{name} = %{epoch}:%{version}-%{release}
77Provides: mod_opensoap = %{version}-%{release}
78
79%description server
80The OpenSOAP Server supports operations for Web Service systems and
81provides practical functions, such as asynchronous client connections
82for non-real time processing, message forwarding for searching valid
83services and passing through firewalls, and signing messages for
84security validation.
85
86%description server -l ja
87OpenSOAP¥µ¡¼¥Ð¤Ï¡¢Â絬ÌϤÊWeb¥µ¡¼¥Ó¥¹¥·¥¹¥Æ¥à¤Î±¿ÍѤò¥µ¥Ý¡¼¥È¤·¤Þ¤¹¡£
88¥µ¡¼¥Ó¥¹¤ÎÈó¥ê¥¢¥ë¥¿¥¤¥à½èÍý¤ËÂбþ¤¹¤ëÈóƱ´ü¥¯¥é¥¤¥¢¥ó¥ÈÀܳµ¡Ç½¡¢¥µ¡¼¥Ó
89¥¹¤Îõº÷¤ä¥Õ¥¡¥¤¥¢¥¦¥©¡¼¥ë±Û¤¨¤ò¼Â¸½¤¹¤ë¥µ¡¼¥Ð´Ö¥á¥Ã¥»¡¼¥¸Å¾Á÷µ¡Ç½¡¢¥á¥Ã
90¥»¡¼¥¸¤Ø¤Î½ð̾¤Ê¤É¤ò¹Ô¤¦¥»¥­¥å¥ê¥Æ¥£µ¡Ç½¤¬´Þ¤Þ¤ì¤Æ¤¤¤Þ¤¹¡£
91
92%package samples
93Summary: Sample application programs of OpenSOAP.
94Summary(ja): OpenSOAP¤Î¥µ¥ó¥×¥ë¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¥×¥í¥°¥é¥à¡£
95Group: Applications/Networking
96Requires: %{name} = %{epoch}:%{version}-%{release}
97
98%description samples
99This is a collection of simple sample application programs using
100OpenSOAP.  Please try them if you just want to use OpenSOAP.  If you
101are interested in developing application programs, please also refer
102to the source codes.
103
104%description samples -l ja
105OpenSOAP¥¢¥×¥ê¥±¡¼¥·¥ç¥ó¤Î´Êñ¤Ê¥µ¥ó¥×¥ë¤Î´ó¤»½¸¤á¤Ç¤¹¡£
106OpenSOAP¤ò¤È¤ê¤¢¤¨¤º»È¤Ã¤Æ¤ß¤¿¤¤¾ì¹ç¤Ë¡¢À§È󤪻²¼¤µ¤¤¡£¥¢¥×¥ê¥±¡¼¥·¥ç
107¥ó¥×¥í¥°¥é¥à³«È¯¤Ë¶½Ì£¤Î¤¢¤ëÊý¤Ï¡¢¥½¡¼¥¹¥³¡¼¥É¤â¤´Í÷²¼¤µ¤¤¡£
108
109%prep
110%setup -q
111%patch0 -p1 -b .protected
112
113%build
114%configure --sysconfdir=%{_sysconfdir} --with-servicesdir=%{_with_servicesdir} --with-cgi-bin=%{_with_cgi_bin} --localstatedir=%{_localstatedir} --with-ssl-include=/usr/include
115
116## doc files to be copied
117cp -pr doc docs
118find docs -name 'Makefile*' -exec rm {} \;
119rm -rf docs/api/*/Doxyfile
120rm -rf docs/api/*/text/
121cp -pr samples docs/
122
123make
124
125%install
126rm -rf $RPM_BUILD_ROOT
127LIBRARY_PATH="$RPM_BUILD_ROOT"%{_libdir} make DESTDIR="$RPM_BUILD_ROOT" install
128# samples
129make DESTDIR="$RPM_BUILD_ROOT" install-samples
130
131# install SYSV init stuff
132mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
133install -m755 etc/init.d/opensoap.redhat \
134        $RPM_BUILD_ROOT/etc/rc.d/init.d/opensoap
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post server
140# Register the opensoap service
141/sbin/chkconfig --add opensoap
142
143%preun server
144if [ $1 = 0 ]; then
145#       %{_sbindir}/opensoap-server-ctl stop || exit 0
146        /sbin/service opensoap stop
147        /sbin/chkconfig --del opensoap
148fi
149
150%post -p /sbin/ldconfig
151%postun -p /sbin/ldconfig
152
153%files
154%defattr(-,root,root)
155%{_bindir}/soaping
156%{_libdir}/libFileLib.so.*
157%{_libdir}/libOpenSOAPClient.so.*
158%{_libdir}/libOpenSOAPInterface.so.*
159%{_libdir}/libOpenSOAPService.so.*
160%{_libdir}/libOpenSOAPSecurity.so.*
161%{_libdir}/libSharedLib.so.*
162%{_libdir}/libTraceLib.so.*
163%{_with_cgi_bin}/TransactionService.cgi
164%{_with_cgi_bin}/SoapingService.cgi
165%{_with_servicesdir}/Soaping
166%{_with_servicesdir}/Transaction
167%{_localstatedir}/services/Transaction
168%{_mandir}/man1/*
169%{_mandir}/ja/man1/*
170%doc INSTALL INSTALL.ujis README README.ujis LICENSE
171%doc HISTORY HISTORY.ujis TODO TODO.ujis
172%doc docs/tools
173
174%files devel
175%defattr(-,root,root)
176%{_includedir}/OpenSOAP
177%{_libdir}/libFileLib.so
178%{_libdir}/libOpenSOAPClient.so
179%{_libdir}/libOpenSOAPInterface.so
180%{_libdir}/libOpenSOAPService.so
181%{_libdir}/libOpenSOAPSecurity.so
182%{_libdir}/libSharedLib.so
183%{_libdir}/libTraceLib.so
184%{_libdir}/libFileLib.*a
185%{_libdir}/libOpenSOAPClient.*a
186%{_libdir}/libOpenSOAPInterface.*a
187%{_libdir}/libOpenSOAPService.*a
188%{_libdir}/libOpenSOAPSecurity.*a
189%{_libdir}/libSharedLib.*a
190%{_libdir}/libTraceLib.*a
191%doc docs/api/en
192%doc docs/api/ja
193
194%files server
195%defattr(-,root,root)
196%{_sbindir}/*
197%{_libdir}/libOpenSOAPServer.*
198#{_libdir}/libHTTPMessage.*
199%{_libdir}/libSOAPMessage.*
200%{_libdir}/libconnection.*
201%{_libdir}/apache2/modules/mod_opensoap.so
202%config %{_sysconfdir}/server.conf
203%config %{_sysconfdir}/privKey.pem
204%config %{_sysconfdir}/pubKey.pem
205%{_sysconfdir}/*pem.default
206%{_sysconfdir}/ssml/Soaping.ssml
207%{_sysconfdir}/ssml/Transaction.ssml
208%{_with_cgi_bin}/soapInterface.cgi
209%{_mandir}/man8/*
210%{_mandir}/ja/man8/*
211%doc docs/server/*
212%config /etc/rc.d/init.d/opensoap
213
214%files samples
215%defattr(-,root,root)
216
217%doc docs/samples/*
218%{_with_cgi_bin}/*Calc*
219%{_with_cgi_bin}/Hello*
220%{_with_cgi_bin}/GetCertService.cgi
221%{_with_cgi_bin}/*Shopping*
222%{_with_cgi_bin}/TransactionApp.cgi
223%{_with_cgi_bin}/TransactionHtml
224%{_with_cgi_bin}/TransactionABankService.cgi
225%{_with_cgi_bin}/Echo*
226%{_with_servicesdir}/*Calc*
227%{_with_servicesdir}/*Hello*
228%{_with_servicesdir}/GetCert
229%{_with_servicesdir}/*Shopping*
230%{_with_servicesdir}/TransactionABank
231%{_with_servicesdir}/Echo
232%{_bindir}/*Calc*
233%{_bindir}/*Hello*
234%{_bindir}/GetCertClient
235%{_bindir}/registCA
236# %{_bindir}/genrsakey
237# %{_bindir}/secEnv
238%{_bindir}/*Shopping*
239%{_bindir}/TransactionClient
240%{_bindir}/EchoClient
241%{_sysconfdir}/ssml/*Calc*
242%{_sysconfdir}/ssml/GetCert.ssml
243%{_sysconfdir}/ssml/*Hello*
244%{_sysconfdir}/ssml/*Shopping*
245%{_sysconfdir}/ssml/TransactionABank.ssml
246%{_sysconfdir}/ssml/Echo.ssml
247%{_localstatedir}/services/CalcAsync
248%{_localstatedir}/services/GetCert
249%{_localstatedir}/services/ShoppingSec
250
251%changelog
252* Wed Oct 03 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.1-0vl1
253- updated to 2.0.1
254- added Patch0 based on Bugzilla
255
256* Mon Dec 01 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0-0.20031201
257- added /usr/kerberos/include to avoid ssl compilation errors on RedHat9
258
259* Wed Sep 03 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0-0.20030903
260- specify LIBRARY_PATH for make install
261
262* Fri May 30 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0-0.20030530
263- added init script
264- added Epoch because versioning was confusing
265- added man/ja/
266- build opensoap-samples properly
267
268* Sat Mar  1 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0_20030228-2
269- added %defattr
270- removed Vendor
271- corrected _with_cgi_bin (bug of define ?)
272
273* Thu Feb 28 2003 Nobuhito OKADA <okada@opensoap.jp> 1.0_20030228-1
274- Released as the first version.
Note: See TracBrowser for help on using the repository browser.