source: projects/specs/trunk/o/openobex/openobex-vl.spec @ 521

Revision 521, 7.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Library for using OBEX
2Summary(ja): OBEXを利用するためのオープンライブラリです
3Name: openobex
4Version: 1.3
5Release: 14%{?_dist_release}
6License: GPLv2+
7Group: System Environment/Libraries
8URL: http://openobex.sourceforge.net
9Source: http://downloads.sourceforge.net/openobex/openobex-%{version}.tar.gz
10
11Patch0: openobex-apps-flush.patch
12Patch1: openobex-1.3-push.patch
13Patch2: openobex-1.3-autoconf.patch
14Patch3: openobex-1.3-ipv6.patch
15Patch4: openobex-1.3-utf.patch
16Patch5: openobex-1.3-ircp.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19#----------------------------------------------------------------------------
20
21BuildRequires: autoconf >= 2.57
22BuildRequires: bluez-libs-devel
23BuildRequires: sed, libusb-devel
24BuildRequires: automake, autoconf, libtool
25ExcludeArch: s390 s390x
26
27#----------------------------------------------------------------------------
28%description
29OBEX (OBject EXchange) is a protocol usually used by various mobile
30devices to exchange all kind of objects like files, pictures, calendar
31entries (vCal) and business cards (vCard).  This package contains the
32Open OBEX shared C library.
33
34%description -l ja
35OBEX(OBject EXchange) は様々なモバイル機器での、ファイル、写真、カレンダー
36エントリー(vCal) 、そして名刺(vCard)のような、すべての種類のオブジェクトを
37交換するために通常使用されているプロトコルです。
38このパッケージには、Open OBEX のC言語共有ライブラリが含まれています。
39
40
41#----------------------------------------------------------------------------
42%package devel
43Summary: Files for development of applications which will use OBEX
44Summary(ja): OBEX アプリ開発用ライブラリとヘッダーファイル
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47Requires: bluez-libs-devel libusb-devel pkgconfig
48
49%description devel
50Header files for development of applications which use OpenOBEX.
51
52%description devel -l ja
53
54Open OBEX を使用するアプリケーションを開発するためのヘッダーファイル類
55(devel パッケージ)
56
57#----------------------------------------------------------------------------
58%package apps
59Summary: Applications for using OBEX
60Summary(ja): OBEX を使ったアプリケーション
61Group: System Environment/Libraries
62
63
64%description apps
65Open OBEX Applications to exchange all kind of objects like files, pictures,
66calendar entries (vCal) and business cards (vCard) using the OBEX protocol.
67
68%description apps -l ja
69Open OBEX アプリケーションは OBEX プロトコルを使用して、ファイル、写真、
70カレンダーエントリー(vCal) 、そして名刺(vCard)のような、すべての種類の
71オブジェクトを交換します。
72
73
74#----------------------------------------------------------------------------
75%prep
76%setup -q
77%patch0 -p1 -b .flush
78%patch1 -p1 -b .push
79%patch2 -p1 -b .ipv6
80%patch3 -p1 -b .autoconf
81%patch4 -p1 -b .utf
82%patch5 -p1 -b .ircp
83autoreconf --install --force
84
85%build
86%configure --disable-static --enable-apps --enable-usb --disable-dependency-tracking
87make %{?_smp_mflags}
88# make -C doc %{?_smp_mflags}
89
90#----------------------------------------------------------------------------
91%install
92rm -rf $RPM_BUILD_ROOT
93make install DESTDIR=$RPM_BUILD_ROOT
94# we do not want .la files
95rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100#----------------------------------------------------------------------------
101%post -p /sbin/ldconfig
102
103%postun -p /sbin/ldconfig
104
105#----------------------------------------------------------------------------
106%files
107%defattr(-, root, root)
108%doc AUTHORS COPYING COPYING.LIB ChangeLog README
109%{_libdir}/libopenobex*.so.*
110
111%files devel
112%defattr(-, root, root)
113%doc AUTHORS COPYING COPYING.LIB ChangeLog README
114%{_libdir}/libopenobex*.so
115%{_datadir}/aclocal/openobex.m4
116%dir %{_includedir}/openobex
117%{_includedir}/openobex/*.h
118%{_libdir}/pkgconfig/openobex.pc
119
120%files apps
121%defattr(-, root, root)
122%{_bindir}/irobex_palm3
123%{_bindir}/irxfer
124%{_bindir}/ircp
125%{_bindir}/obex_tcp
126%{_bindir}/obex_test
127%{_bindir}/obex_push
128%{_mandir}/man1/obex_push.1*
129
130#----------------------------------------------------------------------------
131# Maintainers: babasaki@mindgear.org
132#
133#----------------------------------------------------------------------------
134%changelog
135* Fri Oct 24 2008 Seiichirou Babasaki 1.3-14
136- added "# Maintainers: " comments.
137- changed UTF-8 encode at bluez-gnome.vs.spec
138- Updated specfile
139
140* Fri Jun 13 2008 Seiichirou Babasaki 1.3-13
141- Updated specfile
142- LOGS - 1.3-12
143- improved utf(non ascii) support
144- Resolves: #430128
145- LOGS - 1.3-11
146- Autorebuild for GCC 4.3
147- LOGS - 1.3-10
148- Spec file cleanup
149- LOGS - 1.3-9
150- Spec file cleanup
151- Fixed wrong lib path in autoconf
152
153* Wed Jan 16 2008 Seiichirou Babasaki 1.3-8vl1
154- Import oponobex - Packager: Babasaki
155- Updated specfile
156
157#----------------------------------------------------------------------------
158* Tue Sep 18 2007 Jiri Moskovcak <jmoskovcak@redhat.com> 1.3-8
159- Changed sources in specfile URL to point to the right location
160
161* Fri Aug 24 2007 Jiri Moskovcak <jmoskovc@redhat.com> 1.3-7
162- Added ipv6 support
163- Resolves: #198396
164
165* Wed Aug 22 2007 Harald Hoyer <harald@redhat.com> - 1.3-6
166- changed license tag
167
168* Fri Mar 23 2007 Harald Hoyer <harald@redhat.com> - 1.3-5
169- specfile cleanup
170
171* Wed Feb  7 2007 Harald Hoyer <harald@redhat.com> - 1.3-4
172- readded obex_push
173
174* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3-3.1
175- rebuild
176
177* Tue Jun 27 2006 Harald Hoyer <harald@redhat.com> - 1.3-3
178- removed more patches
179
180* Tue Jun 27 2006 Harald Hoyer <harald@redhat.com> - 1.3-2
181- added more build requirements
182- built now with enable-usb
183
184* Fri Jun 16 2006 Harald Hoyer <harald@redhat.com> - 1.3-1
185- version 1.3
186
187* Tue Jun 13 2006 Harald Hoyer <harald@redhat.com> - 1.2-2
188- more build requirements
189
190* Tue Jun 13 2006 Harald Hoyer <harald@redhat.com> - 1.2-1
191- version 1.2
192
193* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> 1.1-1
194- version 1.1
195
196* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
197- bump again for double-long bug on ppc(64)
198
199* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
200- rebuilt for new gcc4.1 snapshot and glibc changes
201
202* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
203- rebuilt
204
205* Mon May 02 2005 Harald Hoyer <harald@redhat.com> 1.0.1-4
206- added `OBEX_ServerAccept' to the exported symbols (bug rh#146353)
207
208* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
209- rebuilt
210
211* Wed Feb 09 2005 Harald Hoyer <harald@redhat.com>
212- rebuilt
213
214* Mon Sep 13 2004 Harald Hoyer <harald@redhat.de> 1.0.1-1
215- version 1.0.1
216
217* Tue Jun 22 2004 Alan Cox <alan@redhat.com>
218- removed now unneeded glib requirement
219
220* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
221- rebuilt
222
223* Mon Apr 19 2004 David Woodhouse <dwmw2@redhat.com> 1.0.0-5
224- import for for #121271 from openobex CVS tree
225
226* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
227- rebuilt
228
229* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
230- rebuilt
231
232* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
233- rebuilt
234
235* Wed Jun  4 2003 Harald Hoyer <harald@redhat.de> 1.0.0-2
236- excludeArch s390 s390x
237
238* Wed Jun  4 2003 Harald Hoyer <harald@redhat.de> 1.0.0-1
239- redhatified specfile
240- bump to version 1.0.0
241
242* Thu May 18 2000 Pontus Fuchs <pontus.fuchs@tactel.se>
243- Initial RPM
Note: See TracBrowser for help on using the repository browser.