source: projects/specs/trunk/o/openobex/openobex-vl.spec @ 9078

Revision 9078, 8.3 KB checked in by inagaki, 9 years ago (diff)

2014-11-11 Ryoichi INAGAKI <ryo1@…>

  • libbtctl: added patch
  • obex-data-server, obexftp, openobex: updated


Line 
1%global udevdir /lib/udev
2
3Summary: Library for using OBEX
4Summary(ja): OBEX を利用するためのライブラリ
5Name: openobex
6Version: 1.7.1
7Release: 1%{?_dist_release}
8License: GPLv2+ and LGPLv2+
9Group: System Environment/Libraries
10URL: http://openobex.sourceforge.net
11
12Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}-Source.tar.gz
13Patch0:  openobex-apps-flush.patch
14Patch1:  openobex-1.7-obex_push.patch
15Patch2:  openobex-1.7-udev_rule.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  bluez-libs-devel
19BuildRequires:  cmake
20BuildRequires:  docbook-style-xsl
21BuildRequires:  doxygen
22BuildRequires:  libusb1-devel
23BuildRequires:  libxslt
24BuildRequires:  sed
25ExcludeArch:    s390 s390x
26
27#----------------------------------------------------------------------------
28%description
29OBEX (OBject EXchange) is a protocol usually used by various mobile
30devices to exchange all kind of objects like files, pictures, calendar
31entries (vCal) and business cards (vCard).  This package contains the
32Open OBEX shared C library.
33
34%description -l ja
35OBEX(OBject EXchange) は様々なモバイル機器での、ファイル、写真、カレンダーエントリー(vCal) 、そして名刺(vCard)のような、すべての種類のオブジェクトを交換するために通常使用されているプロトコルです。
36このパッケージには、Open OBEX のC言語共有ライブラリが含まれています。
37
38
39#----------------------------------------------------------------------------
40%package devel
41Summary: Files for development of applications which will use OBEX
42Summary(ja): OBEX アプリ開発用ライブラリとヘッダーファイル
43Group: Development/Libraries
44Requires: %{name} = %{version}-%{release}
45Requires: bluez-libs-devel
46Requires: libusb1-devel
47Requires: pkgconfig
48
49%description devel
50Header files for development of applications which use OpenOBEX.
51
52%description devel -l ja
53Open OBEX を使用するアプリケーションを開発するためのヘッダーファイル等です。
54
55#----------------------------------------------------------------------------
56%package apps
57Summary: Applications for using OBEX
58Summary(ja): OBEX を使ったアプリケーション
59Group: Applications/Communications
60
61%description apps
62Open OBEX Applications to exchange all kind of objects like files, pictures,
63calendar entries (vCal) and business cards (vCard) using the OBEX protocol.
64
65%description apps -l ja
66Open OBEX アプリケーションは OBEX プロトコルを使用して、ファイル、写真、カレンダーエントリー(vCal) 、そして名刺(vCard)のような、すべての種類のオブジェクトを交換します。
67
68#----------------------------------------------------------------------------
69%prep
70%setup -q -n openobex-%{version}-Source
71%patch0 -p1 -b .flush
72%patch1 -p1 -b .push
73%patch2 -p1 -b .udev
74
75%build
76%cmake \
77    -DCMAKE_SKIP_RPATH=YES \
78    -DCMAKE_VERBOSE_MAKEFILE=YES \
79    -DCMAKE_INSTALL_UDEVRULESDIR=%{udevdir}/rules.d \
80
81make %{?_smp_mflags}
82make openobex-apps %{?_smp_mflags}
83
84#----------------------------------------------------------------------------
85%install
86rm -rf $RPM_BUILD_ROOT
87make install DESTDIR=$RPM_BUILD_ROOT
88# we do not want .la files
89rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
90# don't ship obex_test program, that is for testing purposes only
91# and has some problems (multiple buffer overflows etc.)
92rm -f $RPM_BUILD_ROOT%{_bindir}/obex_test
93rm -f $RPM_BUILD_ROOT%{_mandir}/man1/obex_test.1*
94
95# HTML doc
96rm -rf _docs_to_include
97mkdir -p _docs_to_include
98mv $RPM_BUILD_ROOT%{_docdir}/%{name}/html _docs_to_include
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104
105%postun -p /sbin/ldconfig
106
107%files
108%defattr(-, root, root)
109%doc AUTHORS COPYING COPYING.LIB ChangeLog README
110%{_sbindir}/obex-check-device
111%{_libdir}/libopenobex*.so.*
112%{udevdir}/rules.d/60-openobex.rules
113
114%files devel
115%defattr(-, root, root)
116%doc AUTHORS COPYING COPYING.LIB ChangeLog README
117%doc _docs_to_include/html
118%dir %{_includedir}/%{name}
119%{_includedir}/%{name}/*.h
120%{_libdir}/libopenobex*.so
121%{_libdir}/pkgconfig/openobex.pc
122%{_libdir}/cmake/OpenObex-%{version}
123
124%files apps
125%defattr(-, root, root)
126%{_bindir}/irobex_palm3
127%{_bindir}/irxfer
128%{_bindir}/ircp
129%{_bindir}/obex_find
130%{_bindir}/obex_tcp
131%{_bindir}/obex_push
132%{_mandir}/man1/irobex_palm3.1*
133%{_mandir}/man1/irxfer.1*
134%{_mandir}/man1/ircp.1*
135%{_mandir}/man1/obex_tcp.1*
136%{_mandir}/man1/obex_find.1*
137%{_mandir}/man1/obex_push.1*
138
139#----------------------------------------------------------------------------
140# Maintainers: babasaki@mindgear.org
141#
142#----------------------------------------------------------------------------
143%changelog
144* Tue Nov 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.7.1-1
145- updated to 1.7,1
146- added Patch1 and Patch2 from fc
147  * Wed Oct 01 2014 Tomas Hozza <thozza@redhat.com> - 1.7.1-5
148  - Fix udev rule to not use plugdev group (#1136580)
149  * Thu Jan 09 2014 Tomas Hozza <thozza@redhat.com> - 1.7.1-2
150  - Distribute Cmake config files
151
152* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-3
153- rebuild with VineSeed environment
154
155* Thu Sep 30 2010 Shu KONNO <owa@bg.wakwak.com> 1.5-2
156- rebuilt with rpm-4.8.1 for pkg-config
157
158* Sun May 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5-1
159- new upstream release
160- drop Patch1, Patch2, Patch3, Patch4, Patch5
161
162* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3-15
163- for <BTS:847>
164  - fixed %postun section
165  - changed apps Group to Applications/Accessories
166
167* Fri Oct 24 2008 Seiichirou Babasaki 1.3-14
168- added "# Maintainers: " comments.
169- changed UTF-8 encode at bluez-gnome.vs.spec
170- Updated specfile
171
172* Fri Jun 13 2008 Seiichirou Babasaki 1.3-13
173- Updated specfile
174- LOGS - 1.3-12
175- improved utf(non ascii) support
176- Resolves: #430128
177- LOGS - 1.3-11
178- Autorebuild for GCC 4.3
179- LOGS - 1.3-10
180- Spec file cleanup
181- LOGS - 1.3-9
182- Spec file cleanup
183- Fixed wrong lib path in autoconf
184
185* Wed Jan 16 2008 Seiichirou Babasaki 1.3-8vl1
186- Import oponobex - Packager: Babasaki
187- Updated specfile
188
189#----------------------------------------------------------------------------
190* Tue Sep 18 2007 Jiri Moskovcak <jmoskovcak@redhat.com> 1.3-8
191- Changed sources in specfile URL to point to the right location
192
193* Fri Aug 24 2007 Jiri Moskovcak <jmoskovc@redhat.com> 1.3-7
194- Added ipv6 support
195- Resolves: #198396
196
197* Wed Aug 22 2007 Harald Hoyer <harald@redhat.com> - 1.3-6
198- changed license tag
199
200* Fri Mar 23 2007 Harald Hoyer <harald@redhat.com> - 1.3-5
201- specfile cleanup
202
203* Wed Feb  7 2007 Harald Hoyer <harald@redhat.com> - 1.3-4
204- readded obex_push
205
206* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3-3.1
207- rebuild
208
209* Tue Jun 27 2006 Harald Hoyer <harald@redhat.com> - 1.3-3
210- removed more patches
211
212* Tue Jun 27 2006 Harald Hoyer <harald@redhat.com> - 1.3-2
213- added more build requirements
214- built now with enable-usb
215
216* Fri Jun 16 2006 Harald Hoyer <harald@redhat.com> - 1.3-1
217- version 1.3
218
219* Tue Jun 13 2006 Harald Hoyer <harald@redhat.com> - 1.2-2
220- more build requirements
221
222* Tue Jun 13 2006 Harald Hoyer <harald@redhat.com> - 1.2-1
223- version 1.2
224
225* Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> 1.1-1
226- version 1.1
227
228* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2.1
229- bump again for double-long bug on ppc(64)
230
231* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.1-4.2
232- rebuilt for new gcc4.1 snapshot and glibc changes
233
234* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
235- rebuilt
236
237* Mon May 02 2005 Harald Hoyer <harald@redhat.com> 1.0.1-4
238- added `OBEX_ServerAccept' to the exported symbols (bug rh#146353)
239
240* Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
241- rebuilt
242
243* Wed Feb 09 2005 Harald Hoyer <harald@redhat.com>
244- rebuilt
245
246* Mon Sep 13 2004 Harald Hoyer <harald@redhat.de> 1.0.1-1
247- version 1.0.1
248
249* Tue Jun 22 2004 Alan Cox <alan@redhat.com>
250- removed now unneeded glib requirement
251
252* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
253- rebuilt
254
255* Mon Apr 19 2004 David Woodhouse <dwmw2@redhat.com> 1.0.0-5
256- import for for #121271 from openobex CVS tree
257
258* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
259- rebuilt
260
261* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
262- rebuilt
263
264* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
265- rebuilt
266
267* Wed Jun  4 2003 Harald Hoyer <harald@redhat.de> 1.0.0-2
268- excludeArch s390 s390x
269
270* Wed Jun  4 2003 Harald Hoyer <harald@redhat.de> 1.0.0-1
271- redhatified specfile
272- bump to version 1.0.0
273
274* Thu May 18 2000 Pontus Fuchs <pontus.fuchs@tactel.se>
275- Initial RPM
Note: See TracBrowser for help on using the repository browser.