source: projects/specs/trunk/o/openlibm/openlibm-vl.spec @ 11766

Revision 11766, 4.6 KB checked in by ara_t, 6 years ago (diff)

openlibm: update to 0.6.0

Line 
1%define pkg_name    openlibm
2%define pkg_version 0.6.0
3%define pkg_release 1%{?_dist_release}
4
5Summary: High quality system independent, open source libm
6Name:    %{pkg_name}
7Version: %{pkg_version}
8Release: %{pkg_release}
9
10License: BSD and MIT and ISC and Public Domain
11Group:   System Environment/Libraries
12URL:     https://github.com/JuliaLang/openlibm/
13
14Source0: %{name}-%{version}.tar.gz
15
16
17%description
18OpenLIBM is an effort to have a high quality standalone LIBM library.
19It is meant to be used standalone in applications and programming language
20implementations. The OpenLIBM code derives from the FreeBSD msun implementation,
21which in turn derives from FDLIBM 5.3. As a result, it has a number of fixes
22and updates that have accumulated over the years in msun, and also optimized
23assembly versions of many functions.
24
25%package devel
26Summary:  High quality system independent, open source libm
27Group:    Development/Libraries
28Requires: %{name} = %{version}-%{release}
29
30%description devel
31Contains header files for developing applications that use the %{name}
32library.
33
34
35%prep
36%{__rm} -rf ${RPM_BUILD_ROOT}
37%setup -q
38
39# File under the Apple Public Source License Version 1.1
40%{__rm} -f test/ieeetestnew.c
41# File under the Apple Public Source License Version 2.0
42%{__rm} -f i387/osx_asm.h
43
44%build
45%{__make} %{?_smp_mflags} FFLAGS="%{optflags}" CFLAGS="%{optflags}"
46
47%install
48%{makeinstall}
49
50%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/libopenlibm.a
51
52%check
53%{__make} test
54
55%clean
56%{__rm} -rf ${RPM_BUILD_ROOT}
57
58%post -p %{_syssbindir}/ldconfig
59
60%postun -p %{_syssbindir}/ldconfig
61
62
63%files
64%doc LICENSE.md README.md
65%{_libdir}/libopenlibm.so.2*
66
67%files devel
68%{_libdir}/libopenlibm.so
69%{_libdir}/pkgconfig/openlibm.pc
70%{_includedir}/openlibm/
71
72
73%changelog
74* Mon Aug 13 2018 Toshiaki Ara <ara_t@384.jp> 0.6.0-1
75- update to 0.6.0
76
77* Wed Jun 13 2018 Toshiaki Ara <ara_t@384.jp> 0.5.5-1
78- initial build for Vine Linux
79
80* Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-6
81- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
82
83* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-5
84- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
85
86* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-4
87- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
88
89* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-3
90- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
91
92* Tue Aug 23 2016 Dan Horák <dan[at]danny.cz> 0.5.3-2
93- set ExclusiveArch to arches where openlibm has been ported
94
95* Sat Aug 13 2016 Peter Robinson <pbrobinson@fedoraproject.org> 0.5.3-1
96- Update to 0.5.3 (aarch64 support)
97
98* Tue Mar 8 2016 Milan Bouchet-Valat <nalimilan@club.fr> - 0.5.0-1
99- New upstream release (bumping SONAME).
100- Remove ExclusiveArch since PPC is now supported (and passes the tests).
101- Enable tests on i686.
102- Remove custom code for computing ARCH, which is now correctly detected.
103
104* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.4.1-3
105- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
106
107* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-2
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
109
110* Sun Feb 1 2015 Milan Bouchet-Valat <nalimilan@club.fr> - 0.4.1-1
111- New upstream release.
112- Run tests on architectures where they are supposed to work thanks to new fixes.
113
114* Sat Oct 25 2014 Peter Robinson <pbrobinson@fedoraproject.org> 0.4-3
115- Fix build on armv7hl
116
117* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4-2
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
119
120* Sun Jul 27 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 0.4-1
121- New upstream release.
122- Fix path of two files to remove.
123
124* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-7
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
126
127* Sun May 4 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 0.3-6
128- Disable tests for now.
129
130* Thu May 1 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 0.3-5
131- Add tests.
132
133* Tue Apr 29 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 0.3-4
134- Add ISC to list of licenses.
135- Add bug reference about the failing tests.
136
137* Mon Apr 21 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 0.3-3
138- Use Group System Environment/Libraries for base package.
139
140* Sun Apr 20 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 0.3-2
141- Put libopenlibm.so.0 in base package instead of in -devel.
142
143* Sat Apr 19 2014 Milan Bouchet-Valat <nalimilan@club.fr> - 0.3-1
144- Initial version.
Note: See TracBrowser for help on using the repository browser.