source: projects/specs/trunk/o/openjpeg/openjpeg-vl.spec @ 521

Revision 521, 2.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: JPEG 2000 codec library
2Summary(ja): JPEG 2000 コーデックライブラリ
3Name:    openjpeg
4Version: 1.2
5Release: 1%{?_dist_release}
6Group:     System Environment/Libraries
7License:   BSD
8URL:       http://www.openjpeg.org/
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11Source0: %{name}_v1_2.tar.gz
12Patch1: %{name}-1.2-fix_build.patch
13Patch2: %{name}-1.2-dyn_link_binaries.patch
14Patch3: %{name}-1.2-upstream_fixes.patch
15Patch4: %{name}-1.2-lib64.patch
16
17%description
18The OpenJPEG library is an open-source JPEG 2000 codec written in C language.
19It has been developed in order to promote the use of JPEG 2000, the new
20still-image compression standard from the Joint Photographic Experts Group
21(JPEG).
22
23%package  devel
24Summary:  Development files for openjpeg
25Group:    Development/Libraries
26Requires: openjpeg = %{version}-%{release}
27
28%description devel
29The openjpeg-devel package contains libraries and header files for
30developing applications that use openjpeg.
31
32%prep
33%setup -q -n trunk
34%patch1 -p1
35%patch2 -p1
36%patch3 -p1
37if [ "lib64" = %{_lib} ]; then
38%patch4 -p1
39fi
40find . -type f|xargs chmod 644
41
42%build
43%ifarch i686
44make COMPILERFLAGS="%{optflags} -ffast-math -fPIC \
45                    -march=i686 -O3 -fasynchronous-unwind-tables \
46                    -ftree-vectorize -ftree-vectorizer-verbose=5" \
47     LIBRARIES="-lm" \
48     %{?_smp_mflags}
49%else
50make COMPILERFLAGS="%{optflags} -ffast-math -fPIC" \
51     LIBRARIES="-lm" \
52     %{?_smp_mflags}
53%endif
54
55%install
56rm -rf %{buildroot}
57make install DESTDIR=%{buildroot} LIBDIR=%{_libdir} INCDIR=%{_includedir}
58
59%clean
60rm -rf %{buildroot}
61
62%post -p /sbin/ldconfig
63
64%postun -p /sbin/ldconfig
65
66%files
67%defattr(-,root,root,-)
68%{_libdir}/libopenjpeg.so.*
69
70%files devel
71%defattr(-,root,root,-)
72%doc ChangeLog
73%{_includedir}/openjpeg.h
74%{_libdir}/libopenjpeg.so
75%{_libdir}/libopenjpeg.a
76
77%changelog
78* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.2-1vl5
79- applied new versioning policy, spec in utf-8
80
81* Sun Jul 29 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.2-0vl2
82- added lib64 patch for x86_64 architecture
83
84* Wed Jun 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2-0vl1
85- new upstream release
86
87* Sun Apr 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-0vl1
88- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.