source: projects/specs/trunk/o/openjade/openjade-vl.spec @ 521

Revision 521, 11.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A DSSSL implementation.
2Name: openjade
3Version: 1.3.2
4Release: 29%{?_dist_release}
5Source: http://download.sourceforge.net/openjade/openjade-%{version}.tar.gz
6Patch0: openjade-ppc64.patch
7Patch1: openjade-1.3.1-nsl.patch
8Patch2: openjade-deplibs.patch
9Patch3: openjade-nola.patch
10License: BSD
11Group: Applications/Text
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14Obsoletes: openjade-devel < 1.3.2-17
15Obsoletes: jade
16Provides: jade
17Requires(post): sgml-common >= 0.5
18Requires(preun): sgml-common >= 0.5
19
20BuildRequires: opensp-devel
21
22
23%description
24OpenJade is an implementation of the ISO/IEC 10179:1996 standard DSSSL
25(Document Style Semantics and Specification Language). OpenJade is
26based on James Clark's Jade implementation of DSSSL. OpenJade is a
27command-line application and a set of components. The DSSSL engine
28inputs an SGML or XML document and can output a variety of formats:
29XML, RTF, TeX, MIF (FrameMaker), SGML, or XML.
30
31
32%prep
33%setup -q
34%patch0 -p1
35%patch1 -p1
36%patch2 -p1 -b .deplibs
37%patch3 -p1 -b .nola
38
39%build
40%configure --disable-static --datadir=%{_datadir}/sgml/%{name}-%{version} \
41        --enable-splibdir=%{_libdir}
42make
43
44%install
45rm -rf $RPM_BUILD_ROOT
46
47make install install-man DESTDIR=$RPM_BUILD_ROOT
48
49# Fix up libtool libraries
50find $RPM_BUILD_ROOT -name '*.la' | \
51  xargs perl -p -i -e "s|-L$RPM_BUILD_DIR[\w/.-]*||g"
52
53# oMy, othis ois osilly.
54ln -s openjade $RPM_BUILD_ROOT/%{_prefix}/bin/jade
55echo ".so man1/openjade.1" > $RPM_BUILD_ROOT/%{_mandir}/man1/jade.1
56
57# install jade/jade $RPM_BUILD_ROOT/%{_prefix}/bin/jade
58cp dsssl/catalog $RPM_BUILD_ROOT/%{_datadir}/sgml/%{name}-%{version}/
59cp dsssl/{dsssl,style-sheet,fot}.dtd $RPM_BUILD_ROOT/%{_datadir}/sgml/%{name}-%{version}/
60
61# add unversioned/versioned catalog and symlink
62mkdir -p $RPM_BUILD_ROOT/etc/sgml
63cd $RPM_BUILD_ROOT/etc/sgml
64touch %{name}-%{version}-%{release}.soc
65ln -s %{name}-%{version}-%{release}.soc %{name}.soc
66cd -
67
68
69%clean
70rm -rf $RPM_BUILD_ROOT
71
72%post
73/sbin/ldconfig
74/usr/bin/install-catalog --add /etc/sgml/%{name}-%{version}-%{release}.soc \
75    %{_datadir}/sgml/%{name}-%{version}/catalog >/dev/null 2>/dev/null || :
76 
77%preun
78/usr/bin/install-catalog --remove /etc/sgml/%{name}-%{version}-%{release}.soc \
79    %{_datadir}/sgml/%{name}-%{version}/catalog >/dev/null 2>/dev/null || :
80
81%postun -p /sbin/ldconfig
82
83%files
84%defattr(-,root,root)
85%doc jadedoc/* dsssl/README.jadetex
86%doc README COPYING VERSION
87%ghost /etc/sgml/%{name}-%{version}-%{release}.soc
88/etc/sgml/%{name}.soc
89%{_bindir}/*
90%{_libdir}/*.so
91%{_libdir}/*.so.*
92%{_mandir}/*/*
93%{_datadir}/sgml/%{name}-%{version}
94%exclude %{_libdir}/*.la
95
96
97%changelog
98* Fri Feb 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.2-29
99- updated Patch3 based on FC
100- added Patch4 from FC
101  * Thu Sep 25 2008 Ondrej Vasik <ovasik@redhat.com> 1.3.2-32
102  - do not require OpenSP libosp.la file for build(#485114)
103
104* Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.3.2-28
105- applied new versioning policy
106- used Requires(post,preun)
107
108* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-27vl1
109- based on FC6 1.3.2-27 (opensp into separate package, no openjade-devel)
110- built with new toolchain
111- previous Vine changelogs were as follows:
112
113  - Sat Aug 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.2-9vl2
114  - skip libtoolize (cannot build if not so)
115  - use %%{_sysconfdir}, %%{_datadir} instead of /etc, /usr/share
116  - rename README, COPYING to *.{openjade,opensp}
117
118  - Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-9vl1
119  - add Patch12 to build with gcc33
120  - add Patch13 to not link with libnsl
121
122  - Mon May 05 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.2-2vl2
123  - sorry, rebuilt without openjade-1.3.1-10vl2
124
125- Wed Apr 30 2003 IWAI Masaharu <iwai@alib.jp> 1.3.2-2vl1
126- sync rawhide-1.3.2-2
127
128* Mon Jul 17 2006 Tim Waugh <twaugh@redhat.com> 1.3.2-27
129- Rebuilt.
130
131* Mon Jul 10 2006 Tim Waugh <twaugh@redhat.com> 1.3.2-26
132- Fix dependent libs for libogrove (bug #198232).
133
134* Mon Jun 26 2006 Florian La Roche <laroche@redhat.com> 1.3.2-25
135- add redirection to /dev/null for preun
136
137* Tue Jun 13 2006 Tim Waugh <twaugh@redhat.com> 1.3.2-24
138- Rebuild against opensp.
139
140* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.3.2-23.2
141- bump again for double-long bug on ppc(64)
142
143* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.3.2-23.1
144- rebuilt for new gcc4.1 snapshot and glibc changes
145
146* Fri Jan  6 2006 Tim Waugh <twaugh@redhat.com> 1.3.2-23
147- Rebuild against new opensp.
148
149* Mon Dec 19 2005 Tim Waugh <twaugh@redhat.com> 1.3.2-22
150- Fix SOC files.
151- Quieten scriptlets.
152
153* Mon Dec 19 2005 Tim Waugh <twaugh@redhat.com> 1.3.2-21
154- Fix location of catalog.
155
156* Tue Dec 13 2005 Tim Waugh <twaugh@redhat.com> 1.3.2-20
157- Use --enable-splibdir to prevent ambiguity.
158- Move 'install-catalog --remove' to %%preun section (bug #60409).
159
160* Thu Dec  8 2005 Terje Bless <link@pobox.com> - 1.3.2-19
161- Drop -devel subpackage.
162
163* Sun Dec  4 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.3.2-18
164- Really BuildRequire opensp-devel.
165- Clean up unneeded build dependencies and configure options.
166- Drop dependency on docbook-dtds.
167- Fix %%post(un) syntax and catalog installation.
168
169* Wed Nov 30 2005 Terje Bless <link@pobox.com> 1.3.2-17
170- Split opensp out into its own package.
171- BuildRequire OpenSP-devel, Require OpenSP.
172- Drop openjade-1.3.1-manpage.patch (it patches opensp, not openjade, and is
173  obsolete with external opensp).
174
175* Tue Mar  1 2005 Tim Waugh <twaugh@redhat.com> 1.3.2-16
176- Rebuilt for new GCC.
177
178* Wed Feb  9 2005 Tim Waugh <twaugh@redhat.com> 1.3.2-15
179- Rebuilt.
180
181* Tue Oct  5 2004 Tim Waugh <twaugh@redhat.com> 1.3.2-14
182- Build requires gettext-devel (bug #134672).
183
184* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
185- rebuilt
186
187* Fri Mar 19 2004 Tim Waugh <twaugh@redhat.com> 1.3.2-11.2
188- Rebuilt.
189
190* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
191- rebuilt
192
193* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
194- rebuilt
195
196* Sat Jan 31 2004 Tim Waugh <twaugh@redhat.com> 1.3.2-10
197- More C++ fixes (for GCC 3.4).
198
199* Thu Dec  4 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-9
200- No longer need httphost patch.
201
202* Mon Oct 20 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-8
203- Rebuilt.
204
205* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de> 1.3.2-7
206- do not link against -lnsl
207
208* Thu Aug  7 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-6
209- Rebootstrap to create a libtool that actually works.
210
211* Wed Aug  6 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-5
212- Rebuilt.
213
214* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 1.3.2-4
215- rebuilt
216
217* Thu May 22 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-3
218- Fixes for GCC 3.3.
219- Use --parents for %doc.
220
221* Tue Mar 18 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-2
222- Provide sgml2xml man page (bug #83759).
223- Add devel subpackage.
224
225* Fri Mar 14 2003 Tim Waugh <twaugh@redhat.com> 1.3.2-1
226- OpenSP 1.5, openjade 1.3.2.
227- Renumber patches.
228
229* Thu Feb 13 2003 Elliot Lee <sopwith@redhat.com> 1.3.1-13
230- Add openjade-ppc64.patch
231
232* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
233- rebuilt
234
235* Tue Jan  7 2003 Jeff Johnson <jbj@redhat.com> 1.3.1-11
236- don't include -debuginfo files in package.
237
238* Thu Dec 12 2002 Tim Waugh <twaugh@redhat.com>
239- Fix typo in description (bug #79395).
240
241* Mon Nov  4 2002 Tim Waugh <twaugh@redhat.com> 1.3.1-10
242- Fix DTD retrieval from virtual hosts (bug #77137).
243
244* Sat Aug 10 2002 Elliot Lee <sopwith@redhat.com>
245- rebuilt with gcc-3.2 (we hope)
246
247* Mon Jul 22 2002 Tim Powers <timp@redhat.com> 1.3.1-8
248- rebuild using gcc-3.2-0.1
249
250* Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.3.1-7
251- automated rebuild
252
253* Thu Jun 13 2002 Tim Waugh <twaugh@redhat.com> 1.3.1-6
254- Fix sgmlnorm(1) man page (bug #64136).
255- Fix %%files list (bug #64323).
256
257* Thu May 23 2002 Tim Powers <timp@redhat.com> 1.3.1-5
258- automated rebuild
259
260* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.3.1-4
261- Avoid bad triggers.
262
263* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.3.1-3
264- Rebuild in new environment.
265
266* Mon Jan 28 2002 Tim Waugh <twaugh@redhat.com> 1.3.1-2
267- Ship man pages.
268
269* Mon Jan 28 2002 Tim Waugh <twaugh@redhat.com> 1.3.1-1
270- 1.3.1.
271- Patches no longer needed: decl, strdup, foo, size_t, 31525, indev,
272  ligature, twosidestartonright.
273- Updated lt patch.
274
275* Mon Jan 14 2002 Tim Waugh <twaugh@redhat.com> 1.3-22
276- Enable build on GCC 3.0 onwards.
277- Run libtoolize.
278
279* Fri Nov  2 2001 Tim Waugh <twaugh@redhat.com> 1.3-21
280- Enable HTTP support.  Now a DocBook XML document can be processed by
281  either xsltproc or openjade.
282
283* Tue Oct 30 2001 Tim Waugh <twaugh@redhat.com> 1.3-20
284- Apply twosidestartonright patch from Ian Castle.
285
286* Thu Oct 11 2001 Tim Waugh <twaugh@redhat.com> 1.3-19
287- s/Copyright:/License:/
288- Use %%{_tmppath}.
289- Fix up libtool libraries (bug #46212).
290
291* Wed Sep 12 2001 Tim Powers <timp@redhat.com> 1.3-18
292- rebuild with new gcc and binutils
293
294* Fri Jun 15 2001 Tim Waugh <twaugh@redhat.com> 1.3-17
295- Apply patch from CVS to break up unintentional ligatures (bugs #11497,
296  #11779)
297
298* Mon Jun  4 2001 Tim Waugh <twaugh@redhat.com> 1.3-16
299- Apply the iNdev openjade-1.3.patch patch.
300
301* Tue May 29 2001 Tim Waugh <twaugh@redhat.com> 1.3-15
302- ldconfig (bug #32824).
303- Fix up some libtool problems.
304
305* Fri Apr 27 2001 Bill Nottingham <notting@redhat.com> 1.3-14
306- rebuild for C++ exception handling on ia64
307- build with optimization on ia64
308
309* Tue Mar 13 2001 Tim Waugh <twaugh@redhat.com>
310- Avoid creating bogus TeX output for section headings containing
311  special characters (#bug 31525).
312
313* Mon Jan 22 2001 Florian La Roche <Florian.LaRoche@redhat.de>
314- Apply original autoconf patch to s390 s390x only. This patch can
315  be deleted once s390* uses a current compiler.
316
317* Thu Jan 19 2001 Tim Waugh <twaugh@redhat.com>
318- Don't conflict with stylesheets; require sgml-common >= 0.5 instead.
319- Revert autoconf change, as it's still broken.
320
321* Wed Jan 17 2001 Florian La Roche <Florian.LaRoche@redhat.de>
322- fix this autoconf macro to work on all archs :-)
323
324* Wed Jan 17 2001 Florian La Roche <Florian.LaRoche@redhat.de>
325- apply patch from Fritz Elfert <felfert@to.com>
326        - removed explicit stripping
327        - Added autoconf macro for correctly recognizing if size_t
328          is unsigned int
329
330* Tue Jan 16 2001 Tim Waugh <twaugh@redhat.com>
331- Default catalog file is /etc/sgml/catalog.
332
333* Mon Jan 08 2001 Tim Waugh <twaugh@redhat.com>
334- Conflict with stylesheets (new-trials location changes).
335- /usr/lib/sgml -> /usr/share/sgml/%%{name}-%%{version}.
336- Remove %%post and %%postun.
337
338* Wed Oct 18 2000 Matt Wilson <msw@redhat.com>
339- rebuilt against g++-2.96-60, fixes jade on alpha
340
341* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
342- automatic rebuild
343
344* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
345- Rebuild with new C++
346
347* Wed May 31 2000 Matt Wilson <msw@redhat.com>
348- fix several C++ build problems (declarations)
349- build against new libstdc++
350
351* Wed May 17 2000 Matt Wilson <msw@redhat.com>
352- build with -O0 on alpha
353- fix -j testing
354
355* Thu May  5 2000 Bill Nottingham <notting@redhat.com>
356- openjade is maintained, and actually builds. Let's try that.
357
358* Thu Mar  9 2000 Bill Nottingham <notting@redhat.com>
359- this package is way too huge. strip *everything*
360
361* Mon Feb 21 2000 Matt Wilson <msw@redhat.com>
362- build with CXXFLAGS="-O2 -ggdb" to work around segfault on alpha
363
364* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
365- strip binaries
366
367* Wed Jan  5 2000 Bill Nottingham <notting@redhat.com>
368- sanitize spec file some
369
370* Tue Aug 17 1999 Tim Powers <timp@redhat.com>
371- fixed conflict problem with sgml-tools
372
373* Sat Jul 17 1999 Tim Powers <timp@redhat.com>
374- changed buildroot path to /var/tmp
375- rebuilt for 6.1
376
377* Fri Apr 23 1999 Michael K. Johnson <johnsonm@redhat.com>
378- quiet scripts
379
380* Thu Apr 23 1999 Owen Taylor <otaylor@redhat.com>
381- Made requires for sgml-common into prereq
Note: See TracBrowser for help on using the repository browser.