source: projects/specs/trunk/o/openhpi/openhpi-vl.spec @ 5849

Revision 5849, 10.6 KB checked in by Takemikaduchi, 12 years ago (diff)

net-snmp-5.7.1

Line 
1Summary: Hardware Platform Interface library and tools
2Summary(ja): ハードウエアプラットフォームインタフェースライブラリおよびツール
3Name: openhpi
4Version: 3.0.0
5Release: 1%{?_dist_release}
6License: BSD
7Group: System Environment/Base
8URL: http://www.openhpi.org
9Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
10Source1: %{name}.initd
11Source2: %{name}.sysconfig
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildRequires: sysfsutils-devel, net-snmp-devel, OpenIPMI-devel, glib2-devel
14BuildRequires: libtool-ltdl-devel, openssl-devel, ncurses-devel
15BuildRequires: libxml2-devel, docbook-utils, libuuid-devel
16Requires(post): chkconfig
17Requires(preun): chkconfig
18Requires(preun): initscripts
19
20%description
21OpenHPI is an open source project created with the intent of providing an
22implementation of the SA Forum's Hardware Platform Interface (HPI). HPI
23provides an abstracted interface to managing computer hardware, typically for
24chassis and rack based servers. HPI includes resource modeling; access to and
25control over sensor, control, watchdog, and inventory data associated with
26resources; abstracted System Event Log interfaces; hardware events and alerts;
27and a managed hot swap interface.
28
29OpenHPI provides a modular mechanism for adding new hardware and device support
30easily. Many plug-ins exist in the OpenHPI source tree to provide access to
31various types of hardware. This includes, but is not limited to, IPMI based
32servers, Blade Center, and machines which export data via sysfs.
33
34
35%package libs
36Group: System Environment/Libraries
37Summary: The system libraries for the OpenHPI project
38Summary(ja): OpenHPI のシステムライブラリ
39Obsoletes: %{name} < 2.10.2-1
40
41%description libs
42The system libraries for the OpenHPI project.
43
44
45%package devel
46Group: Development/Libraries
47Summary: The development environment for the OpenHPI project
48Summary(ja): OpenHPIの開発環境
49Requires: %{name}-libs = %{version}-%{release}
50Requires: glib2-devel, pkgconfig
51
52%description devel
53The development libraries and header files for the OpenHPI project.
54
55
56%prep
57%setup -q
58
59# fix permissions
60chmod a-x plugins/simulator/*.[ch]
61chmod a-x clients/*.[ch]
62
63
64%build
65export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
66%configure --disable-static
67
68# Don't use rpath!
69sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
70sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
71
72make %{?_smp_mflags}
73
74
75%install
76mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
77mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
78mkdir -p $RPM_BUILD_ROOT%{_initddir}
79mkdir -p -m1777 $RPM_BUILD_ROOT%{_var}/lib/%{name}
80make install DESTDIR=$RPM_BUILD_ROOT
81
82rm -f $RPM_BUILD_ROOT%{_sysconfdir}/init.d/openhpid
83install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/openhpid
84install -p -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/openhpid
85
86rm -rf $RPM_BUILD_ROOT/%{_libdir}/*.la
87rm -rf $RPM_BUILD_ROOT/%{_libdir}/%{name}/*.la
88
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93
94%post
95/sbin/chkconfig --add openhpid
96
97%preun
98if [ $1 = 0 ] ; then
99    /sbin/service openhpid stop >/dev/null 2>&1
100    /sbin/chkconfig --del openhpid
101fi
102
103%postun
104if [ "$1" -ge "1" ] ; then
105    /sbin/service openhpid condrestart >/dev/null 2>&1
106fi
107
108%post libs -p /sbin/ldconfig
109
110%postun libs -p /sbin/ldconfig
111
112
113%files
114%defattr(-,root,root,-)
115%doc COPYING README README.daemon openhpi.conf.example
116%dir %{_sysconfdir}/%{name}
117%config(noreplace) %{_sysconfdir}/%{name}/%{name}.conf
118%config(noreplace) %{_sysconfdir}/%{name}/%{name}client.conf
119%config(noreplace) %{_sysconfdir}/openhpi/simulation.data
120%{_initddir}/openhpid
121%config(noreplace) %{_sysconfdir}/sysconfig/openhpid
122%attr(1777,root,root) %{_var}/lib/%{name}
123%{_bindir}/*
124%{_sbindir}/*
125%{_libdir}/%{name}
126%{_mandir}/man1/*
127%{_mandir}/man7/*
128%{_mandir}/man8/*
129
130%files libs
131%defattr(-,root,root,-)
132%{_libdir}/*.so.*
133
134%files devel
135%defattr(-,root,root,-)
136%doc COPYING
137%{_libdir}/*.so
138%{_includedir}/%{name}
139%{_libdir}/pkgconfig/*.pc
140
141
142%changelog
143* Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0.0-1
144- new upstream release
145- remove Patch0
146
147* Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.14.1-2
148- rebuild with openssl-1.0.0d
149
150* Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
151- initial build for Vine Linux
152
153* Wed Feb 24 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-3
154- update initscript (#521648, #521830)
155
156* Fri Jan 15 2010 Dan Horák <dan[at]danny.cz> - 2.14.1-2
157- added fix for inconsistent SaHpi.h
158
159* Wed Nov 25 2009 Dan Horák <dan[at]danny.cz> - 2.14.1-1
160- updated to bug fix release 2.14.1
161
162* Fri Oct  9 2009 Dan Horák <dan[at]danny.cz> - 2.14.0-6
163- rebuilt with net-snmp 5.5
164
165* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.14.0-5
166- rebuilt with new openssl
167
168* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.14.0-4
169- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
170
171* Wed Jul 14 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-3
172- add BR: libuuid-devel
173
174* Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-2
175- use upstream default config
176- libtoolize/autoreconf is not needed
177
178* Fri Apr 17 2009 Dan Horak <dan[at]danny.cz> - 2.14.0-1
179- update to 2.14.0
180
181* Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-2
182- fix ppc/ppc64 builds
183
184* Wed Feb 25 2009 Dan Horak <dan[at]danny.cz> - 2.13.3-1
185- update to 2.13.3
186
187* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.13.1-3
188- rebuild with new openssl
189
190* Tue Nov 25 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-2
191- shorten Summary
192
193* Thu Nov 20 2008 Dan Horak <dan[at]danny.cz> - 2.13.1-1
194- update to 2.13.1
195
196* Mon Nov 17 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-2
197- rebuild for new libtool
198
199* Sat Jul 26 2008 Dan Horak <dan[at]danny.cz> - 2.12.0-1
200- update to 2.12.0
201
202* Thu Jun 27 2008 Dan Horak <dan[at]danny.cz> - 2.11.3-1
203- update to 2.11.3
204
205* Thu Apr 18 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-2
206- enable the sysfs plugin
207- add missing R: for -devel subpackage
208
209* Thu Mar 13 2008 Dan Horak <dan[at]danny.cz> - 2.10.2-1
210- update to 2.10.2
211- spec file and patch cleanup
212
213* Thu Feb 28 2008 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-3
214- Removed incorrect patch for IBM BC snmp_bc plugin
215- Fixed GCC 4.3 rebuild problems
216
217* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.10.1-2
218- Autorebuild for GCC 4.3
219
220* Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.10.1-1
221- Updated to openhpi-2.10.1
222- Bump release and rebuild due to new openssl
223
224* Thu Aug 23 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-5
225- Bump release and rebuild because of PPC issues
226- Fix rebuild problems due to new glibc open macro
227
228* Fri Jul 20 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-4
229- Fix for hpipower segfaulting when using -b option out of range (#247279)
230
231* Tue Jul 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-3
232- Fixed a bug where the snmp_bc plugin didn't work in IBM BC (#247280)
233
234* Mon Jun 04 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-2.fc7
235- Fixed missing e2fsprogs-devel and openssl-devel build requires
236
237* Fri Mar 30 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.1-1.fc7
238- Update to openhpi-2.8.1
239
240* Thu Feb 08 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-3.fc7
241- Fixed some silly bugs in the specfile
242
243* Wed Feb 07 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-2.fc7
244- Bump and rebuild.
245
246* Tue Feb 06 2007 Phil Knirsch <pknirsch@redhat.com> - 2.8.0-1.fc7
247- Update to openhpi-2.8.0
248
249* Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-7.fc7
250- Rebuilt due to new net-snmp-5.4
251- Small specfile updates
252
253* Fri Sep 29 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-6
254- Fixed file conflicts for openhpi-switcher (#205226)
255
256* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.1-5.1
257- rebuild
258
259* Mon Jul 10 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-5
260- Had to disable sysfs support due to new libsysfs and incompatible API.
261- Added missing ncurses-devel buildrequires
262
263* Wed Jun 07 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-4
264- Rebuilt with final memset patch
265- Added missing pkgconfig buildprereq (#191935)
266
267* Fri May 26 2006 Radek Vokal <rvokal@redhat.com> - 2.4.1-2
268- rebuilt for new libnetsnmp and net-snmp-config changes
269
270* Wed May 24 2006 Phil Knirsch <pknirsch@redhat.com> - 2.4.1-1
271- Fixed buggy use of memset throughout the code
272- Made the package build and install properly
273
274* Fri May 19 2006 Phil Knirsch <pknirsch@redhat.com>
275- Added missing glib2-devel build prereq (#191935)
276- Update to latest stable version openhpi-2.4.1
277
278* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.2
279- bump again for double-long bug on ppc(64)
280
281* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.1-4.1
282- rebuilt for new gcc4.1 snapshot and glibc changes
283
284* Mon Jan  9 2006 Peter Jones <pjones@redhat.com> 2.2.1-4
285- Don't use -Werror, it doesn't build with that on ppc64 currently.
286
287* Mon Jan 06 2006 Jesse Keating <jkeating@redhat.com> 2.2.1-3
288- Fix to not use stict-aliasing.
289
290* Wed Jan 04 2006 Radek Vokal <rvokal@redhat.com> 2.2.1-2
291- Rebuilt against new libnetsnmp
292
293* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
294- rebuilt
295
296* Fri Nov 11 2005 Phil Knirsch <pknirsch@redhat.com> 2.2.1-1
297- Update to stable openhpi-2.2.1
298
299* Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-5
300- Rebuilt to link against latest openssl lib.
301
302* Mon Nov 07 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-4
303- Added the openhpi config file
304- Added missing /var/lib/openhpi dir with proper rights
305- Added a few missing BuildPreReqs
306
307* Thu Nov 03 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-3
308- Rebuild against new net-snmp libs
309
310* Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 2.0.3-1
311- Moved the pkgconfig files to the devel package (#152507)
312- Update to openhpi-2.0.3
313- Had to manually disable ipmi support for now until openhpi builds correctly
314  against it again
315- Dropped net-snmp-config patch, not needed anymore
316
317* Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-5
318- Fixed gcc4 rebuild problems
319
320* Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-4
321- bump release and rebuild with gcc 4
322
323* Mon Feb 14 2005 Phil Knirsch <pknirsch@redhat.com> 1.9.2-3
324- Rebuilt for new rpm-4.4
325
326* Mon Dec 20 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.2-2
327- Fixed overflow in plugins/sysfs/sysfs2hpi.c
328- Fixed rebuild problem with latest net-snmp
329- Removed is_simulator patch, not needed anymore
330
331* Fri Nov 26 2004 Florian La Roche <laroche@redhat.com> 1.9.2-1
332- update to 1.9.2
333
334* Tue Nov 02 2004 Phil Knirsch <pknirsch@redhat.com> 1.9.1-1
335- Added proper BuildRequires
336- Drop ia64 for first build, something fishy with the compiler and warning.
337
338* Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
339- Initial version
340- Disable dummy plugin, doesn't compile
341- Fix missing () in snmp_bc_session.c
Note: See TracBrowser for help on using the repository browser.